Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mitsubishi Montero Sport

1373840424346

Comments

  • tripwesttripwest Posts: 1
    I have a '99 Montero sport and I have replaced the alternator 3 times in the past 18 months. I now have the same indicators lighting up (battery, brake) that I had when the alternator went out previously. I just replaced this last one a month ago. I have a new (6 months) battery What can be causing this?
  • labbe,

    Did you ever come across a viable fix for your constant brake light on problem. I'm interested in the fix as well for my 1999 Montero. I thought the problem would be with a maladjusted parking brake lever switch but when that didn't make the light go off I was stumped.

    I bought the vehicle this way but knew it wasn't a real problem. It is distracting though so I just wanted to know if you ever got an answer for this issue. Thanks.
  • kellerjkkellerjk Posts: 1
    I have the same problem on my 2001. 3 mechanics later, including a dealer, they cannot see anything wrong with the brakes or wheels. Let me know if you have had better luck.
  • scobaxscobax Posts: 1
    I have had a 1999 Montero Sport for almost 2 years now, its a real piece. About 4 months after I bought it I started having problems with the electrical system, then the following winter I had problems with the transmission. Currently it is sitting in my driveway not working. I had a stereo system taken out of it, and ever since that was done it hasnt started. The battery is fine (I had it tested), it stays charged. It will not even try to turn over. Ive checked the fuses and the look fine. I dont know if the relay to the starter is blown or what. Any advice??? I really need to get it fixed so I can get rid of it.
  • ajames58ajames58 Posts: 2
    I just got my Montero Sport out of shop for the same reason with 58000 miles on it. They thought that they resolved the problem, but got almost home, and Transmission started to act like it was going into neutral, this only seems to happen when going into overdrive. What did they replace on yours to resolve the problem. I am about to get rid of this thing if I can't get resoled soon.
    Thank you
  • i know maybe someone here has had this problem. My 2000 montero sport has a dash light flashing everytime i drive it.... i think it pertains to the 2x4....4x4 switch.....even when I have it on 2x4 the light flashes up with an anti-lock solid light right below it.....can someone tell me what I can do to take this off....thank you
  • I just noticed your message. Did you get rid or your Montero Sport? If not, they repalced the valve body on my transmission at approximately 36k miles. I am now at 52K and having all the same problems again. I am planning on getting rid of
    mine as well but have to hold on for another year.
  • Lloyds,
    I am having the exact same problem with my 2000 Sport. Was the dealer ever able to diagnose the problem?
  • Yes, I did get rid of the 2003 Montero Sport, Bought a Ford F-150 4wd. Couldn't take the chance that they couldn't fix Montero Sport. Let someone else deal with it. I babied that vehicle, Talked to Service Advisor at Mitsubiti dealer and he stated that he couldn't guarentee, that problem wouldn't come,back, so we traded it while it was under 60k mile warranty. It really sucks, because the thing was paid off, and wanted to keep it for a while and not to have any payments for awhile. Never again will I purchase Mitsubiti. They won't be in business very long. From what I hear they are really hurting, what a shame. Good luck, and trade soon!!! By the way 59950 miles and got $9500.
  • hey people i've been looking for a site for a long time where i can get questions answered about a mitsubishi montero sport. im 18 yrs old so im gonna have a lot of questions. i wanted to know what kind of parts could i buy for a montero sport to increase the car's peformance. it can be anything. i just dont know where to start. can u guys help me out.
  • hey i forgot to say that its a 2000 XLS 4wd
  • tidestertidester Posts: 10,110
    Hi, everyone. As you've probably noticed, we have been trying to refine the discussions into more narrowly focussed topics. Our objective is twofold. We want to make it easier for people seeking specific information about their vehicles to find it easily and without having to wade through hundreds or thousands of postings.

    To those ends, we will be shutting down the general make/model discussions and work exclusively with specific issues. This requires us to populate the make/model subsections with relevant, interesting and timely topics. Rather than having the hosts simply create boilerplate topics for each make/model, we feel that you, the owner, the make/model enthusiast and the prospective buyer can best judge what those topics should be.

    You can help by adding a discussion (it's easy!) or suggesting one here.

    To add a discussion, click on the last link in the "You are here" line at the top of this page. That will take you to the topic page for this make/model. Review the list of topics and click on the "Add discussion" link when you've decided what topic you'd like to add. Follow the directions and you're done! Feel free to add more than one. Just avoid duplicating existing topics and try not to make it TOO specific!

    Your help and continued participation in the Forums is greatly appreciated! Thanks.
  • tidestertidester Posts: 10,110
    Please go to the group top level and create a discussion that fits your comments/questions or post in an existing discussion.

    Mitsubishi Montero/Montero Sport
  • tidestertidester Posts: 10,110
    Enjoy!

    tidester, host
  • Hi, I'm new to forum. Am looking for a reliable used car and love the way the M.S. looks. Have read a lot of bad things about '00,'01 but nothing, really good or bad about '02. Any help would be greatly appreciated. Am looking at XLS 4x4, leather seats, 3.5 liter V6. It has 39,000 miles on it. Thanks to everyone.
  • The battery in my Montero Sport has just been replaced and now my car radio no longer plays. Apparently, radio requires a "code/password" (which I do not have). The dealer has informed me that they must remove the radio to find the password to reactivate radio. My question, is -- isn't there a simpler way (less costly) to locate password? In June I shelled out $1,465 for a 60,000 mile check up (which was quite a shock, considering the car ran beautifully) -- so I'm trying to save all I can. Thank you.
  • steverstever YooperlandPosts: 40,016
    The person who replaced your battery should have plugged a 9 volt battery gizmo into the cigarette lighter/power post. That would have saved all your settings while the battery was being switched.

    Usually you have to take the radio out to get the serial number, and then the dealer (or places on the internet) will give you the code for that radio. You may be able to just ease the frame around the radio off with a butter knife and see the sticker on the radio with the serial number.

    Sometimes you can find the code in the owner's manual or on cards that came with the card. It should be a four digit number.

    Many dealers will give you the code for free if you tell them the radio serial number and the VIN of the car; if yours won't ask to speak to the manager (mention the price you paid for your last service!) or try another Mitsu dealer.

    btw, the Edmunds Maintenance Guide says that a 60,000 service should cost about $732. You may want to ask the dealer what else they did to justify the extra cost or visit your local consumer protection agency and complain.

    Good luck!

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • i had the same problem and i called around looked on the net and even purchased the unlock from ebay to no avail finally i called a local dealer and he said the same thing, get the number off the radio -so what i did was go down to the truck with a butter knife, pop off the trim then i looked inside and low and behold there was the serial number right in front i didnt have to pull the radio out or anything - i jotted the number down popped the trim back on and called the dealer back with the number he looked it up in the computer and gave me two codes then he told me to leave the truck turned on auxillary for 1 hr and the radio will come on once that happens to enter the code and i t worked like a charm.... i called several different dealers before i got someone who was nice enough to give me the info for free he said if i brought the car in it would be 75.00 to do this ....
  • Hi everyone, I recently purchased a used 2002 Montero Sport XLS 4x4 with the 3.5L engine with 46000 miles. When I start the vehicle on cold mornings I get a loud rattle sound comming from the engine. The sound stops after about a minute and I do not here it again until the next cold morning start. It seems to happen most when below 40 degrees overnight. Does anyone have an idea what this might be. I have heard fuel pumps make noise when cold but not like this. Any ideas would be appreciated.

    Thanks
    John
  • Bigeasyal,
    I have a quick question regarding the A/T Mode button. Whenever I push this button a light on my instrument panel appears and it says "hold" how do I make the All terrain mode engage?
Sign In or Register to comment.