Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Nissan Versa Engine Problems

123457

Comments

  • Funny you mention about Nissan being aware of certain problems.
    They count on a good percentage of customers being ignorant in automotive matters; they have a good idea what they can pass on.
    They would have quite a network in North America so getting statistics together is probably a challenge but also useful in determining their attitude.
    I have noticed quite a turnover in staff at the dealer where I got my versa a year ago.
  • gagalgagal Posts: 4
    Good luck with getting anything done! We ended up paying for all the repairs out of our own pocket. Once we got the engine replaced, we had to replace the transmission because Nissan has NEVER made the seal for the torque converter. I have called Nissan in Franklin, TN and left multiple messages for the "President" but they never call back.

    These cars have problems and are just a piece of junk!
  • My 2007 Nissan Versa has only 27,000 miles and was told that the fuel pump is faulty. Nissan is saying they are not aware of any history on faulty fuel pumps for their Versa. However, there appears to be a problem after reading all the posts here. Can any one provide advice?
  • Hi:
    Did you ever find out the problem. My 2007 Nissan Versa SL is having the same problem and it's pretty scary.

    Any response would be greatly appreciated.

    Best,
    Major
  • It is strange that you are getting this answer even when it regards engine noises.
    I have had a number of problems with my 2010 Nissan Versa with CVT, - the response I get from the service guys at the dealership is that these noises and things which I consider problems due to poor quality and assembly are normal.

    My Versa was made in Mexico. The Aquasalientes plant has production problems; however, it seems that Nissan wants to pass these problems onto their customers, and they just tell everyone that the noises are normal.
    It has become a mantra with them, and they obviously do not care about repeat customers.

    I will never buy a car from Nissan again, and I do jot recommend Nissan to anyone. Stay away from this manufacturer, - they do not know what they are doing.

    Can you imagine what will happen with the Leaf? Another tin can even cheaper than the Versa lemons. :lemon:
  • hbredhbred Posts: 1
    edited February 2012
    My 2008 Versa Sedan just quit running while driving it. Everything shut down so I had suddenly had no power to the wheels and steering and the car swerved violently as the engine quit. Lucky that I wasn't in an accident because it was a difficult maneuver to get to the side of the road safely in traffic.

    I had the vehicle towed into the Nissan dealer and was told that I had a catastrophic drive belt failure and that the AC compressor was completely destroyed and that there was debris in all of the filters, and that they would have to be replaced as well. I was also told that the engine could have been quite easily destroyed if I hadn't come to a stop as quickly as I did. The vehicle has 50,000 miles on it, so there is no warranty coverage. Price to repair quoted at $1,175-.

    I have a couple of questions:

    1. Is this a common, or at least well-known, problem with the drive belt?

    2. Is there a quality issue with the drive belt manufacturer?

    2. Doesn't this seem like a serious design flaw that a high-wear part like this could fail and cause a complete loss of drivability and wreak so much damage in the engine compartment?

    Thanks!
  • with less than 18,000 miles on our Versa, we were told the same thing -- its a catch all excuse for not wanting to deal with the situation - and no, they are not normal if you a sensible driver
  • My wife had the same problem 3 times -- the engine just shut down, they said nothing was wrong the first time, replaced the trans the 2nd time and on the 3rd time then replaced the ATC (computer for trans). We didn't keep that car long after that -- something was still not right as it made noises that weren't there before -- they blamed that on normal for that car --

    Instead of immediately paying, I would get a local TV consumer reporter to do a report and call Nissan directly -- this a problem even if they don't want to admit it
  • bruneau1bruneau1 Posts: 468
    If I were having serious problems with my Versa, I wouldn't be too happy either. But let's be aware that there are hundreds of thousands of Versas on the road and they continue to sell well. All brands have some serious problems sometime. My friend's Lexus has been in for repairs three times. and one problem never completely resolved.
  • busirisbusiris Posts: 3,490
    AFAIK, the Versa has a 3 year/36k mile bumper to bumper warranty, and a 5 year/60k drive train warranty. The CVT was later updated to a 10 year/120k warranty, retroactive back to at least 2008 (I think)..

    Not seeing your car, I cant say whether you would be covered or not.

    What you described is not normal as far as I can tell.

    Good luck!
  • cynortizcynortiz Posts: 1
    Several times when the road was wet my Nissan Versa also felt like the breaks locked up and I slid for a second. It is scary. I just bought this car used with 17,000 miles on it. It is a 2010. I am going to contact the dealer.
  • Managed to pry info out of dealer on what I thought was valve noise all along.
    They claim it's noisy injectors. Now Nissan is not promoting use of gas additives but int his case it makes sense to use. The vehicle was built in may and not sold till mid august. With todays fuel life in summer specially in Mexico I wonder about gumming and resulting sticking of components.
    Will keep posted.
  • monti2000monti2000 Posts: 13
    :lemon: On Christmas Eve, Dec. 24, 2011, my car would not start as it was - 15 degrees. The service man came, and gave me a boost, told me to run the car for 1 hour before turning it off.

    Naturally my host was waiting for us. We were late, and everyone was waiting for us.

    The battery continued to die throughout the holidays, and finally in early January 2012, I brought it to my dealership.

    They replaced the batter, and told me that I had to pay for a portion as the battery is not part of the drive train warranty, - even though I have paid an extra $1400 for the extended drive train package over 5 years.

    This car is most irritating, and the mileage is now about 1/3 of what is listed on the brochure.

    Even my service manager, has a Versa, and he admitted that his mileage is also the pits, and that there is nothing that the dealership can do.

    I told him that the dealership should have Nissan repair these cars. Clearly Aquasalientes in Mexico is building cars that should stay in Mexico. These vehicles are not meant for heavy North American winters.

    I am still having all of the other problems. Nissan's mantra is that these are normal. :lemon:

    Monti
  • jrudolph1jrudolph1 Posts: 1
    FINALLY! After MONTHS and at least FOUR VISITS to the Nissan Staunton Dealership in Staunton, Virginia - and them not being able to recreate or see the issue since it comes and goes - you have described EXACTLY the SAME PROBLEMS my 2008 Nissan has been going through. I am going to email this link to Corey, their Nissan Service Manager, as soon as I can reach him and get his email address. He will finally be glad to understand this very serious SAFETY problem I've been going through, but it has been so intermittent. It happened a few months ago and now THIS WEEK it is happening again. With this and the possible brake switch problem, maybe this is the fix! My car currently has just over 98k miles too. SEVERAL VISITS resulted in them not finding anything wrong, too. Nissan Corporate has heard from me too and their Techline has been useless so far - inability to even see the codes on the computer (I doubt the codes are coming up) but this is the Toyota acceleration problem in reverse. Imagine making a left turn on a busy highway and this happens - YES, happened to me again last night. Thanks for explaining this, it is EXACTLY my same issue!
  • As previously reported, it was noisy at times but intermittent.
    Managed to pry out of service manager that the injectors are noisy.
    Enquired about cause but they treated as a mystery like poor gas, dirty injectors, temperature etc.
    Since warmer weather, it has bee fine so suspect fuel temperature is the cause.
    It has bee over 25c for the last two months.
    Dealer still talks as they dont know!
    They won't test the injectors either. Will see next winter.
  • I have a 2007 Nissan Versa Sl Hatchback. I have had many issues with my Nissan and have taken it to the dealer over the years without any solution. My passenger airbag light blinks on and off all the time even when there is nobody in the passenger seat. They can not find any codes in the system so it has never been fixed. And, the problem started after they had to replace my 6 cd player out because it kept breaking on me. Just a couple of days ago I was pulling out of a parking lot and had no acceleration at all! Thankfully, no car was coming. It has happened periodically over time. Unfortunately, I am not at all happy with their service department on fixing the issues. I have also had to replace my lights continuously! Well, just finished paying the car off a couple of months back and my extended 5 year 100,000 mile warranty I paid extra for just expired. I am at almost 103,000. Yesterday out of the blue, my car started vibrating majorly everytime i started to accelerate with a very loud noise and a loud bump underneath the car. It felt like the entire bottom of the car was going to fall out. About a week ago my service engine light came on for the first time ever. Took it to one mechanic shop and they said it showed a evap code and it would not even pass an inspection. So on the following monday I took it to my mechanic; which was three days later and of course the service engine light had turned off by then. My mechanic shop didn't show a code. So they told me to drive it until the light came on again. Well, yesterday I had the problem with the vibration and loud noise underneath. My mechanic said I needed engine mounts...all four of them! Then today I was told one of the cv joints is leaking grease! Just after I paid the car off and my warranty was expired. I have not been very happy with this car and with nissan service regarding my issues. This intermittent problem with accleration has not even been recognized yet with my car and it just scares me for safety reasons; as well as my passenger airbag light blinking. I don't know if the airbag would even deploy if I were in a wreck. Unfortunately, I am out of warranty and just hope after getting the mounts replaced and the cv joint fixed, that I can get more miles out of this car. Only thing I do not understand is that my car was driving fine yesterday morning on the way to work. I stopped at chevron to fill my tank and drove on to work. Then when I went to lunch the car started having these issues. Seems like I would have been seeing earlier signs of problems...
  • my engine is at 47K and just burned out...started to stall on me and when i took it in the oil pan is dry. it's at the dealership right now waiting for a response from Nissan - what i DO know is that they asked me for receipts for all of my oil changes from the last 3 years and i definitely don't have them. did you provide yours when this happened? i've never heard of a car burning an engine that quickly.
  • This is very nerve wracking and I know what you're going through. We were able to produce the majority of them. If you went to the same place for oil changes go back to them as they should have a record in their computer. Otherwise check your check book or credit card statements if you charged them. I can't stress to you that providing the receipts and showing that you changed the oil every 3,000 - 5,000 miles is critical for you. I also did a spreadsheet and listed the date and what service was performed. I showed that I took care of the vehicle and put down other services, like scheduled maintenance, etc. My car was still under warranty and by providing the receipts it showed that there was no negligence on my part. There was sludge in the engine through no fault of mine. The final outcome for me was they put in a new engine and all I had to do was pay $50.00 as that was my deductable.

    I hope this helps. It took about 2 weeks for everything to get resolved because they need to breakdown the engine, take pictures, send them to their corporate office where a determination was made.

    Let me know the outcome.

    Windycitygal
  • I did not do this. It was an uphill battle but go to the top. For it to have no oil in the engine has nothing to do with who changed the oil.... it either lost the oil by a defect or if burned the oil ... good luck
  • PF_FlyerPF_Flyer Pennsylvania Furnace, PAPosts: 5,871
    Not necessarily. I had had my service done for over twenty years at the same place with the same mechanics. A change of ownership for the dealership took place, no change in the mechanics. At the time I owned a 200,000+ mile Altima and a new 2007 Versa. The Altima got its regular service, which included an oil change. About two weeks later, the oil light flashed on. Oil level was VERY low. I Thought, OK, maybe the car is old and starting to burn oil or leak. Then my Versa went in for its service. About a week after the service, the oil light came on, low oil again. That Versa now has over 100,000 miles on it with no issues. So while the issue being discussed here might be an "issue", you can't discount human error entirely

    MODERATOR
    Need help navigating? pf_flyer@edmunds.com - or send a private message by clicking on my name.
    Share your vehicle reviews

  • My Versa is 15 months old and has 39,000 highway miles on it. It just stopped on me one day about 4 months ago. I checked the oil, which was low,put oil in it and it started back up. I took to to the dealer for an oil change and they said everything was good. About a month ago it starts feeling sluggish and stalling. I assumed it needed more oil so I put it in. Two days ago it was sluggish again and I started to hear a rattling sound, I checked the oil again and it was full. Yesterday, the car stopped at a red light after the oil indicator flickered once, and I took it to the dealer. They told me that I needed a new engine because a baring had worn out on because of driving with no oil! I had to produce my oil change receipts to see if it would be covered. I told them that I constantly put oil in that car and even kept extra bottles of oil in my car!
  • One simple but valuable habit to have with any vehicle is to check engine oil and all fluid levels every time you stop for gas.
    Many people never look under the hood as they believe it's done by service station then when things happen they cannot give statistics on service neither have an idea if burning oil has been a problem and for how long.
  • ccnccn Posts: 1
    I have had my 2010 Nissan Versa SL hatchback in the nissan dealership so many times for the extremely loud engine noise. They keep telling me that it is a normal noise. It sounds to me like the rods are going to fly out of the engine. When I put the car in drive or reverse, it gets even louder. I am just under 35,000 miles on the car. I was still questionable about their answer about my car, so i went to a different dealership, and tried out a 2010 just like mine, with the same amount of miles....NO Knocking noise on that one. Went back to nissan dealership and explained that to them. They will not do anything for me. After all of the problems i have had on this car, I will never buy a Nissan again. Ohh not to mention all the noise on the dashboard. Plastic on plastic cracking noise all the time.
  • Indeed! I know where you are coming from. With my 2010
    I started trying to get them to acknowledge this noise is not normal and this with less than 3000 miles on the vehicle.
    I left it there a couple of times as it has always been worst when cold.
    It was at the point where it would not even start or get in the shop. Te answer has always been they do that until one day I vented to them and mentioned my intentions of taking them to court for not sharing important information etc. Their spontaneous and immediate reply was the injectors are noisy. Fix them I said, we cant do they replied stubbornly.
    That was enough info for me as I do have a bit of automotive experience so went on the web and found out this is a common unmentioned problem with many makes of vehicles.
    On advice from a mechanic friend who mentioned that injectors will indeed foul up even in a new vehicle because of poor fuel at the mexico assembly plant. this led me to research th date of manufacture which was mid april 2010. I bought the car new end of august 2010. This meant it has been sitting on the lot for four months with the assembly line fuel in it. I never went back to the dealer but started a regimen of adding injector cleaner and alternately approx 8 oz of motor oil in the fuel tank.
    After approx one year of this remedy, the noise is down to what I consider normal level. Dealers will not mention these tricks so not to contradict Nissan's policy of no additives in oil or gas.
    You also have to bear in mind that if if you got other problems wit fuel system or sensor and they can prove it, for get about the emission warranty! But it seems to be working for me and if you are not sure dont try it.
  • rockstardadrockstardad Posts: 1
    edited November 2012
    Our first versa was a 2007 sl hatchback, never had a problem, nada, zilch, my wife is in home health care, 100 miles a day at least, 5 days a week, 31 months of ownership, 98,000 + miles. The reason we traded was our dealer offered to pay off what we owed, put us in a new one, same monthly payment, so Dec of 2010, a new 2011 versa brought home, Merry Christmas baby,,,So far, until yesterday no problems, 74,000 miles already. A tap in the upper engine, sounds like a loose lifter, code P0303, misfire in the #3 cylinder, ok this makes sense, gas to a cylinder without fire, or intermitant fire can cause a ping, tommorrow I will get myself a chiltons handbook, it's kinda late tonite. Mostly I was in awe because the owners manual on 8-20 reads of sparkplugs, I did not know there where any. They are not visible, I never changed any on the 2007. I did change her oil today, and the filter, OH< by the way people, I use fram filters, I changed our filter from the 6607 model recommended to the 7317, same base, just holds more,with the factory filter, it holds 4 and 3/8ths quarts, with the longer filter mine holds 5 quarts even, does it make a difference, I dunno, but i feel better having it that way. I have noticed on both vehicles that if an oil change is overdue, lets say 1000 miles or so, they have a tendency to use it up, most any vehilce will use oil when the viscosity breaks down, like the sun burns water in the pond during a drought, your engine heat burns the oil, oil wears out too, thats why it is recomended changing every 3-5 thousand miles. You know that your spouse or girlfriend requires a certain amount of attention, and/or maintenance, so does your car, I know some cars are lemons, but so are some women, 3rd try to get it right. So, it's not what kind of car you have, but how you take care of it after the new wears off, pop the hood, once a week, check her out, wash her even talk to her..she'll listen.....Rock
  • OK, I'm back, Nissan had to replace the engine at 55,000 miles and now the catalytic converter is shot and also needs to be replaced. The car has 85,000 miles, 2008 Versa and the extended warranty does not cover it. A cost of $1,200.00. We have 15,000 miles to go until the extended warranty ends and I think it's time to trade this lemon in. Has anyone else had problems with the catalytic converter?
  • if this is a Calif vehicle and you have proof it failed before 80,000 miles you are covered --
    What Should I Do If My First Attempt to Obtain Warranty Coverage Is
    Denied?

    If your first attempt to receive emissions warranty coverage is
    denied, you should do the following:

    1) Ask for a detailed explanation, in writing as to why emissions
    warranty coverage was denied; and

    2) Ask for the name(s) of the person(s) involved in the decision
    to deny coverage, including anyone from the manufacturer's
    regional or zone office; and

    3) Ask for the name(s) of the person(s) with the manufacturer you
    should contact to appeal the denial of coverage under the
    emissions warranty.

    4) Contact and, if necessary, write to the person mentioned above
    requesting coverage and giving the basis for your request. Repeat
    and continue the appeal process until you are satisfied or have
    exhausted all means of appeal.

    Then hit up the EPA
  • I had this problem too since i bought my versa in feb of 07. Took it to the dealer several times (could never replicate) - had the fuel pressure regulator part replaced as per the tsb report (did not work at all)...

    so the other week i went to get new tires and a battery at sam's club since the car is going on 6 years old and would you believe that after 5+ years of annoyance, getting a new battery completly fixed this issue. I don't know if something was wrong with the battery or if the mexicans who manufactured these cars just didn't do it right, but...

    If you have intermittent problems starting your nissan versa and nissan can't figure it out - get a new battery!!!
  • crown5crown5 Posts: 24
    Commmon sense will dictate a factory battery should not be trusted any more after five years.
  • crkyolfrtcrkyolfrt Posts: 2,345
    Problem could have been a connection going to the battery was disturbed enough to make issue temporarily disappear. Depending on if it was a connection and whether that connection was in fact fixed by default of a proper battery re and re, it may return. If it does, suspect all connections at battery and frame etc. Even the lighter gauge wires too.
Sign In or Register to comment.