Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Saturn S-Series Electrical/Lighting

13»

Comments

  • Hi. The rear defog on my '99 Saturn sc won't work. The dash light for the switch works, but it won't actually switch on. I've replaced the interior fuse and the switch itself but still no results. Any ideas? Thanks!
  • Just wondering if you ever found your problem. I am having the same problem with a 1998 SL1 and after a month looking for the problem wired the rear lights on a separate switch. Another problem just cropped up, the HVAC air circulation fan quit working. fan, switch checks out OK. was trying to get to the resistor but don't know how to get to it, took the dashboard off but duct would not budge. This might also need a work around but would really like to the repair.
    thanks,
    Stan.
  • Make sure you have a good engine to fire wall ground, if you have to, install a ground wire(14 guage)from the engine to fire wall ! Sometimes it will lose ground,and you will experence the same problem you are having!
  • danieldkkdanieldkk Posts: 9
    edited March 2010
    My 2002 Saturn SC1 122K mi just developed the horn on condition suddenly. Were you able to solve your problem?
    Also when I bought the car 3 years ago, the dash lamp for the temperature gauge side has been out.
    Any help would be appreciated.
  • tflantflan Posts: 1
    Hey nshore. Did you find the problem to the issue you posted about the instrument panel being basically dead? I have a 2001 saturn sl1 and have the exact same issue. In fact, I drove it for approximately 20 more miles when I noticed the dash issue and then it died. It will turn over but just won't start. I'm stummped as to what it could be. Would be really interesed if you solved your issue and if you could give me a little direction.

    Thanks,
    Tlflan
  • dkbrandydkbrandy Posts: 4
    How did this electric issue get resolved? My in-laws have a 2002 Saturn with electrical issues no fuel gauge, speedometer, gauges, etc. car dies, but when restarted seems ok for a while. Its been in their local auto repair shop running up the bill with no resolution. Can anyone advise?
  • dkbrandydkbrandy Posts: 4
    Did this issue ever get resolved. Similiar issues with dash gauges, car engine dies after full stop, etc. Do you recall what the problem was? Please share if possible.
    thanks much!
  • dkbrandydkbrandy Posts: 4
    2002 Saturn with electrical issues no fuel gauge, speedometer, +gauges, etc. car dies at a full stop intermittently, but when restarted runs great again until the next glitch. Took this auto to the local repair shop ... ran diagnostic tests .... no resolution. Bill $300+ now with no resolution & no repairs. Can't afford this! Any ideas?
  • jwrong02jwrong02 Posts: 2
    I have the same issue except my car doesnt die when i lose the gauges if i tap them they normaly come back up. if I am running the ac i have to turn it off & then back on because it stops blowing cool air when the gauges go out.
  • dkbrandydkbrandy Posts: 4
    edited June 2010
    UPDATE Ref: #53: Relatives picked up the car. IT is not stalling- elderly relative misstated issue. Broken is gas gauge, radiator/heat gauge and odometer off. Air bags not funcitoning. Paid $358 for nothing. Any ideas?
  • jwrong02jwrong02 Posts: 2
    REF #54 UPDATE Possible solution. I have had what i thought was an electrical short for a few years now only for a long time I only lost my gauges here & there. however for the last 2 months its been daily I was driving 70% of the time with nothing. During the past 2 months I noticed that my gas cap was not locking on the the tank properly most of the time it wasnt locking on at all. So after my post on June 8th I replaced the gas cap more cause it was driving me crazy than anything. Since then I have NOT LOST MY GAUGES ONCE! This is the 1st time in a long time that I havent lost them at least once in a weeks time. Now thinking back every time that i did lose them it was around a time that the gas cap was not put on securly. I hope this helps those that are having similar issues. Im not very good with cars but the best i can figure is that too much air was getting in to the tank & causing everything to act up. Cant hurt to try a a new gas cap if it works its a less than 10 dollar fix & that sure beats a $400+ repair bill. I would have never put 2 & 2 together if it wasn't for the gas cap annoying me. Good Luck I'll let you know if the issue returns.
  • I am having a semi-similar issue with my 1999 Saturn S1. I was driving down the highway at about 40 mph and I lost electrical power to my dashboard (lights went out, speedometer and gauges went down to 0, radio and AC went off). Everything came back within a few seconds but the radio and clock went back to factory settings. The only other thing that happened is that when I started my car a week later, I noticed that, once again, the radio and clock went back to factory settings. So obviously, something had happened while the car was off or while it was starting. I have an appointment with a mechanic today (my second appointment) who can't really tell me what's wrong unless it's not working at the time that he's looking at it. Any tips or information would be greatly appreciated.

    Thank you.
  • Did you by chance ever figure out your problem?
  • I had a friend replace my radio on my car and when he did he cut the wires and it blew the fuse, the head lights, the interior lights. So after much research i plugged the multimeter into the fuse spot and it sparked up and now i no longer have blown fuses. But now the car wont turn over, it cranks up and tries to start but wont. Spray some starting fluid in it when your cranking it and it runs for a sec or 2 then dies out again. The gas gauge doesnt move when i turn the key to the on position and none of the lights come on, on the dash. And i have to run a ground wire from the dimmer switch middle wire to something metal to just turn the interior lights on when the head lights are on. I have a 1998 saturn sl1. Does anyone have any ideas? I am stumped.
  • I have a l995 sw2 - it has a coupleof electrical problems - ie the fuel pump relay shorts out all the time (only one prong of the relay is burned) - that is a bad ground - then it does not shift & throws tranny codes - put up info on craigslist (as I was going ot sell it ) and someone replied that it was a l0 way connector short in the pressure regulator - where is that located and what kind of job is it to fix? have a million bucks in this car & dont' want to sell it & have to get it fixed asap - wiring is a nightmare to locate short - so how doe sthat get fixed - thanks
    famouswoman
13»
Sign In or Register to comment.