Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Durango

1697072747583

Comments

  • In response to #1356, I have exact same problem. I was at the dealer and they aren't sure what it is. Did you solve your problem yet? Please post back so that I can let the dealer know exactly what the problem is. Thanks. The hissing noise only comes on over 1000 RPM and is alot louder after I take my foot off the gas peddle.
  • frankygfrankyg Posts: 32
    What kind of deal did you get? Any rebates or other incentives?
  • keejakeeja Posts: 1
    Hi, new to board. I have a 2004 Limited Durango which has been great until 2 days ago. I have 6500 miles on it and I was driving down the highway at about 70mph with both the front and back AC on high when suddenly my car died (no radio, turning signals or engine power). Luckily I was able to get to the shoulder with no problem and the car started right up again. We took it to the dealership and they ran a computer check and did not find any record of the incident. They updated the cars computer system at that time. Has any one else had this problem or any recommendations on what to look for? This makes me extremely nervous as we are planning a road trip later this month. Thanks in advance for any feedback.
  • greanbeengreanbeen Posts: 2
    I have been having the same problem. I went about 50 miles over on my oil change, and figured that was the problem, but again, the light came on. Due to time constrictions, and my own procrastination I haven't taken it in to the dealer, but the light has came on and off, several times within the last 8 months, and the truck is only 12 months old. Have you heard anything from anyone else on this?? :confuse:
  • greanbeengreanbeen Posts: 2
    Wow, I think I'm having some of the same problems as you. I've noticed that sometimes when I break, I can feel a thumping or grinding noise under the break pedal. Also, both of the seat belt covers on my two front seats, have cracked and fallen off, was that what happened to yours? The covers are made of plastic, so I can understand wear and tear, but I'm not a large person, and I've only had my truck for 12 months..

    Also, twice in the last two weeks, my truck has spun out. I've either been turning, or coming out of a turn, not at high rate of speed, and my two back tires have just went sliding. Both times the truck went full circle, rocking.. Has this happened to anyone else, I have two little ones, and I now worry about there safety in the truck??? :confuse:
  • lczechlczech Posts: 1
    I bought a 2001 Durango for my wife. We just brought it in for service because of squeaking in the rear of the vehicle. The dealer is telling me that the rear springs need to be replaced. I only have 34000 miles on the vehicle, this just doesn't make sense. Have you heard anything about this?
  • greg588greg588 Posts: 1
    I own a 2001 Durango and I have had a problem with the engine light coming on about 2 years ago. Also the truck would stall sitting at a traffic light with my foot on the brake if I didn't have the ac on to boost the idle. Every time I would take it to the dealer, by the time I could get an appointment and get it in , the light would go off . Then service would say, "Well the computer dosen't show a code , so bring it back when the light is on again." they did this till the warranty ran out. I took it to a new dealership 6 months ago because the light was on again , and after 2 trips back to the service center and $2300.00 later, the light was off. multiple vacum hose were cracked, needed to clean the intake system & replace a pump. none of this was covered since the warranty had expired. now the light is on again with the same code showing. Lets see what it needs this time.
  • hemihawk1hemihawk1 Posts: 3
    I have a 2004 Durango SLT with the 5.7 Hemi. At 8,000 miles, the driver's seat squeaks and it has nothing to do with the driver's weight! Has anyone else experienced this annoyance and did the dealerships have any suggestions or were they able to fix it?

    Also, until the engine fully warms up, I notice a single tick sound maybe every 15-20 seconds. It sounds just like the noise the air conditioning unit would make as it cycles on and off or like the sounds the exhaust system makes after the engine is shut off. I don't think it's valve lifters or other items I've seen on this forum. Has anyone else had similar experiences and what did the dealers have to say? Just trying to get my ducks in a row before the dealer tells me it's normal. Thanks.
  • hemihawk1hemihawk1 Posts: 3
    I haven't taken it to the dealer yet. I have a couple other things that need attention and hopefully they can address all at once. It appears to be related to engine speed and I doubt it has anything to do with the cooling system. It is hard to see if anything is disconnected around the engine so I am guessing it is something under the dash.
  • I have a 00 SLT 4x4 , 4.7 loaded and log every tank of gas. Over 61,000 miles the grand total all around average is 13.65 mpg. This is the real deal.
  • stegsteg Posts: 1
    I have recently noticed two problems not obviously related. First when driving over 30mph the emergengy warning bell goes into a spuratice frenzy. Its not consistent but goes off for days. during the time this happens the door locks do not work. Second whether the warning bell problem is active or not if you turn the wipers to the first notch the door locks go on and off.

    Its driving me crazy and am afraid of getting robbed by the dealer again. Can anyone suggest a troubleshooting direction? I did what the dealers service guy suggested by unplugging fuses until the bell stopped and couldn't find a fuse that changed the problem(Big help there)...

    Thanks..
  • sanidansanidan Posts: 1
    I bought my '04 SLT last Thursday, and I asked lots of questions from the service department. One thing they said about erratic behavior like you mentioned is the possible effects of aftermarket mods. Have you checked with dealer service department about what happened?
  • gill901gill901 Posts: 3
    Except for the comment from greg588, no other responses. What I finally did was buy a new gas cap. The light went on one more time after that so I stopped by AutoZone again. The diagnostic message was the same - small leak? But the fellow at AutoZone said it may be vacuum hoses, like greg588. Since then, went on a 1400 mile road trip and the light has not come on again. However, thinking of trading this one off anyway. Gas is just too expensive!
  • racing09racing09 Posts: 2
    I have had the same problem with my 2004 Hemi Durango. The first time I took it to the dealership and they kept it overnight. They could not recreate the problem and sent it back home. It continued to intermitently not start. I took it back in and they discovered a technical service bulletin and reprogrammed the front control module. It again continued to not start on occassion. I took it to a different dealership and they also reprogrammed the front control module. I am still having problems with it not starting. If I cut the key all the way off and remove the key, it will usually start right up. Also, you can give it gas and it will start. The TSB is 0802404. Please let me know if you have any luck with getting this resolved. I am on my fourth attempt to correct the problem.
  • racing09racing09 Posts: 2
    Today I got into my 2004 Durango but the air conditioning would only blow hot air after 10 minutes of driving. At that point, I turned the air conditioning off. I stopped my vehicle for about 15 minutes and when I restarted the vehicle the air conditioner was working. Is anyone else experiencing this problem?
  • andersjdandersjd Posts: 1
    My light is coming on and when taking to Autozone, the Code showed that there was a problem with the Power steering pressure valve. Does anyone know what the problem could be or should I get it checked out. Thanks
  • jimqjimq Posts: 14
    This is a known issue with the Durangos equipped with the 5.7 Hemi covered by TSB 24-006-05. The repair involves replacing the electric coolong fan, shroud and expansion valve. Also the PCM needs to be selectively erased and reprogranned.
    Be aware that there is a national back order on the parts.
  • Am considering purchasing a 2005 Durango, LMTd, with Hemi engine.

    Trading 4-door F150 mainly because want more room for passengers AND ability to tow. Once a month or so I tow a bumper pull aluminum & steel 2-horse trailer.

    Anyone out there with comments/input on how Durango w/ Hemi tows?

    IS the HEMI that big of a deal, or is it just as some have said in this venue just something Dodge is pushing as big deal?

    Also, has Dodge made improvements in 2005 models to address ball joint safety and other safety issues that were part of previous models?

    Thanks for any input! Trying to make an informed decision in G-town! MBB
Sign In or Register to comment.