Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Land Rover Discovery and Discovery II

1193194196198199240

Comments

  • Stever@EdmundsStever@Edmunds YooperlandPosts: 38,968
    The easiest way to look back is with the Search This Discussion box. ->

    You'll get hits like this early one:

    nanuq, "Land Rover Discovery/Discovery II" #56, 6 Sep 2000 3:22 pm

    (High 50's here Bob, but the hill is still open).

    Steve, Host
  • disco97disco97 Posts: 1
    I bought my first disco in 97, and I just pick up a 2000 seriesll, and that old feeling came back of driving enjoyment.
    I had a 95 classic range rover and it was good but having a disco again is great. and site like this one really helps and get a information that you might not have known

    thanks
  • peeetepeeete Posts: 136
    Ok, this may sound like a silly question, but are the batteries on the Disco undersized? My vehicle is only four months old, and yesterday I went out to the park and sat in it reading with the engine off for 2.5 hours, with the fan on the lowest setting. Naturally, the battery was almost dead when I tried to start the vehicle. It did work after I let it rest for a while.

    I've done this many times before with cars that I've owned and this has never occurred. I wonder if a larger capacity diehard would make sense.

    I guess Discos suck battery power like they do gas. :)
  • I just purchased a 97 Disco. I've never owned a Land Rover. Unfortunately, the previous owner did not have an owners manual. I've searched the internet but have not found one, only "shop repair" manuals. As I'm sure you're aware, I have MANY questions. How to engage the cruise control, how to program the garage opener (my opener brand is a Chamberlain LiftMaster), where to find parts (the power steering pump has a very slow leak), etc. I would appreciate any feedback from the veterans of these fantastic vehicles!
  • I've seen many manuals on ebay at different point in time. Worth a try. Good luck.
  • I was going to post a similar question so I'm jumping in on this one....

    I also just got my first Disco and it also did not come with a manual. I have seen many on ebay, but was leaning toward the CD service/owner's manuals I have also seen there. They are typicaly cheeper and I would assume contain a whole lot more usefull information. Most of the Disco's I looked at had no manual, is there some black market for them?

    Any insite (as always) is greatly appreciated.

    Bill
  • discomandiscoman Posts: 110
    You are right. Many people keep their manuals and sell them on e-bay. Or just keep the nice leather bound binders for other things and throw the manual away. I bought a manual on e-bay, as well as the CD and have never been sorry. Here's some more for you charlestyler1. The PS leak, is common, and almost impossible to stop. Just keep a bottle of ATF handy to top off once in awhile. The leak is on the bottom of the reservoir, and might be fixed with a hose clamp. Be careful not to tighten too much or you will be buying a new reservoir. As far as the Cruise control, it's pretty easy. The switch on the dash that looks like a picture of a bridge going over a highway is the Cruise control master switch. (The symbol actually means "Motorway", which British for "Freeway") Once that light is on, just pull back on the top switch on the steering wheel and it will set it. Keep in mind that the coast function is different than you are used to. You have to pull the bottom switch and then pull the top one again once you are at the new speed. If the master is on, and the c/c won't engage, check the vacuum hoses under the hood. The C/C vacuum hose is a rubber hose that is on the left side of the firewall in front of the driver. You will see it come out and come to a "T". One heads forward to the pump, and the other goes to the accelerator. The hose may be split or deteriorated and not hold a good vacuum. I had to cut a good 2" off mine right at the "T" and re-attach it to make the cruise work.

    As far as parts, there are several parts houses online such as Atlantic British or Roverconnection that have parts at a very reasonable price. Just be ready to work on it yourself.
  • discomandiscoman Posts: 110
    Bob, or Tincup

    Have either of you seen this one yet? I have been having trouble lately when I go to start my truck, that I turn the key all the way forward, and nothing happens, then if I let it go back and try again, it will turn over, but not start. I have to turn the key all the way back, and then all the way forward for it to start. I understand the second part, but not the first. All the lights come on on the dash when the key is in the ON position, but when I turn it to START nothing happens. Only if I go all the way back and back to start, it starts right up. It's not the Fuse thing, I already cleaned that. I wonder if my ignition switch is going bad. Any ideas? I don't want to get stranded anywhere.
  • nanuqnanuq Posts: 765
    It happens to me too when I'm in too much of a hurry.

    When you turn on the key in a quiet environment, give a listen to the passenger footwell... there's a lot of solenoid clicking going on over there. If I rush it, I'm guessing something doesn't happen before the key makes "start" contact and the ignition isn't active or whatever. So it will crank but not spark. This is just my gut feeling from how it operates. When I back the key off to "off" position and then go forward again slowly it always works.

    Remember all the interconnected systems on these beasties... my advice is to get in and turn the key one click then another, then another and listen to her go.
  • discomandiscoman Posts: 110
    I understand that part Bob, but in mine sometimes it won't even crank. If I stop the key in ON, everything looks good, all the warnings come on etc.. but when I turn it to start nothing happens. No cranking, no clicking, nothing. If I let it go back to on, and try cranking a second time, it will crank and not start. Then I have to back it all the way to off, and it will start right up. This is a new thing. Never did it before. Also I have been noticing that the lights dim whenever driving at night, and I use any other power, like brakes, turn sigs, windows, etc. No pulsing wqhich would indicate a bad alternator, buit a dimming. Wonder if it's a bad battery???
  • nanuqnanuq Posts: 765
    You have a '96 right? Take a look at the fuse block beneath the bonnet (I love saying that). It's midpoint at the engine, passenger side, about 8" long by 3" wide, black, with a bunch of cables going in beneath it.

    Scan back thru these posts and look for topics about cleaning it. All your electrical systems distribute from there, and if you have bad connections there, everything "downstream" will be weird. All the ECUs depend on clean power, and poor connections at the fuse block prevent that.

    Good luck! It fixed ALL my electrical weirdness.
  • discomandiscoman Posts: 110
    That was the first thing I did. (at least this time I had the radio code :-)) Same thing. I don't seem to have a problem with that fuse block, but I don't go off road near as much as you. I am just concerned about getting stuck somewhere. I can get the electrical part of the ignition switch for about $100. I might just change it out and see if that is it. If not, I guess I can always return it. I do wonder if my battery is going bad because of the dimming (See previous posts) It is about 5 years old. I might just replace it with an Optima spiralcell since that's about the lifespan for a battery.
  • nanuqnanuq Posts: 765
    Maybe Lord Lucas has found your truck! Have you done an LLD (Lord Lucas Disclaimer) recently? Here's mine:

    My Land Rover is the most pathetic, miserably engineered piece of polar bear dung ever to roll on 4 wheels. If its quality of construction was dynamite it couldn't blow out a candle. The electrical system engineering was discovered on the wall of King Tut's tomb, that's how archaic it is. It's a miracle the thing doesn't burst into flames just sitting there. Wait, that would mean there's a working electrical connection someplace and THAT just ain't gonna happen. I loathe this piece of pathetic British junk.

    There, think that will keep him away a bit longer? So far so good!

    Seriously... do try a new battery. And with your engine running check the voltage at the battery terminals. It should be near 14v. Perhaps your alternator is getting old too? It's time. Same for me.

    Good luck! Keep us posted. -Bob
  • Am about to head out and see about tieing in wiring to add a trailer to my '98 Land Rover LE. Am going to have one more cup of coffee in hopes I'll get some inspiration! Thanks!
  • We have a 2002 Discovery II, operating in Colorado, 5,000' elevation.

    Uphill and down, up in the Rockies or out on the flats, we see an average between 14 and 17 mpg. I don't think we've ever seen anything as low as 10.
  • I have a 2002 Disco II, and just started having that problem. But wait... there's more.

    First, the key can go all the way and no engine turnover. Take it out, repeat, same thing. Then try a Windows 98 solution: everybody get out, lock the vehicle, get back in, it starts fine.

    New one: while driving, turn on the radio. Nothing. But when you turn off the engine at the end of the drive, the radio goes on.

    Repeat the process: start the engine, turn on the radio (no radio), turn off the engine, and the radio starts.
  • nanuqnanuq Posts: 765
    If you open the right rear corner in the plastic (where the jumpseats go) you'll find the backside of the passenger side taillight housing and its wiring. If I remember right there's a plug right there just waiting for trailer lights. Give 'er a try!
  • hi,

    DiscoveryII, no warranty, has drops of oil leak. Dealer said change the head gasket on next service, if it continues. Asking around $4500. too much pricy. Any suggestions?
  • tidestertidester Posts: 10,110
    Any suggestions?

    Yes. Don't buy it until the problems are fixed - right! :-)

    tidester, host
  • climaticclimatic Posts: 4
    I am looking into purchasing a 1999 Discovery with 95,000 miles. Carfax comes back clean on it and it is honestly a one owner vehicle, very clean, immaculate actually. The dealer that has it is not a Land Rover dealer and I am concerned about the possibility of huge repair bills. I contacted the local LR dealer and had them check the vin# for service history but only came up with a visit at 74,000 miles for new brakes and a steering box. The purchase price is very reasonable but again I am not looking for a money pit. Just a safe reliable SUV for on and off road use. Any comments or suggestions are appreciated.
Sign In or Register to comment.