Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Blazer/GMC Jimmy

1131416181926

Comments

  • how do i replace the bulb in the back of the truck i cant figure how to get the cover off to fond out what sorta bulb i need
  • My "SERVICE ENGINE LIGHT" is constantly on, i didn't think it was because of the real problem that i have. The real problem now is that i live in Nebraska and we have had consecutive nights of weather below 0, not easy on my blazer which has a heating issue. Its not a issue with the truck heating up, engine tempurature comes up just fine, takes a little while before the fan produces any hot air in the interior. it is now 6 years old pretty much and just had i believe it's first proper radiator flush and the thermostat as well. Without the fan on it seems to get hot, specially around the vents.....i turn the fan up and slowly the air becomes luke warm, if that even. I can turn the fan off let it ride a lil and turn it back on and gets warm again. I wish i knew why it was doing this, I am afraid that it is the heater core and am hoping that it is just a sensor or electrode messing it up. If you can help that would be great. Peace
  • Hello Blazer owners I am a new Blazer owner just bought my first 4 months ago. Got a 2000 Chevy Blazer ( my dream vehicle).I have always wanted one. Well I am having troubles and no one seems to know what could be causing it. I have no heat. and with living in PA with temps lately in the 20's everyday it gets pretty chilly without a heater. It is odd had heat till Thanksgiving day, went out and started the truck and just didn't seem to warm up. I thought might be due to that it was only 11 degrees out, the next week had heat back but it was warmer too.
    Now this past week i barely have any you can feel it there, but just no where near as warm as should be or was. Now I have had talked to about 10 different mechanics including my dad who has worked on Chevy's for 40 yrs. They all seem to be lost. Seems to be blowing both cold and luke warm air. We have changed the thermostat. The fluids are full the radiator is full. The hises that go into the heater core are warm to touch, but i was told you should not be able to sit there and hold them and you can.
    Please Help!!! :P
  • :( :blush: I am not sure if you were replying to my message but I NEED HELP!!!!!
    Hello Blazer owners I am a new Blazer owner just bought my first 4 months ago. Got a 2000 Chevy Blazer ( my dream vehicle).I have always wanted one. Well I am having troubles and no one seems to know what could be causing it. I have no heat. and with living in PA with temps lately in the 20's everyday it gets pretty chilly without a heater. It is odd had heat till Thanksgiving day, went out and started the truck and just didn't seem to warm up. I thought might be due to that it was only 11 degrees out, the next week had heat back but it was warmer too.
    Now this past week i barely have any you can feel it there, but just no where near as warm as should be or was. Now I have had talked to about 10 different mechanics including my dad who has worked on Chevy's for 40 yrs. They all seem to be lost. Seems to be blowing both cold and luke warm air. We have changed the thermostat. The fluids are full the radiator is full. The hises that go into the heater core are warm to touch, but i was told you should not be able to sit there and hold them and you can.
    Please Help!!!
  • I had the same issue, and fixed it this weekend. Try flushing the heater core.
  • While driving, I can hear my turn signal flasher clicking, but I have not turned on my signal. The signal indicator isn't lighting up, but the flasher is clicking. It is purely random, but does it continually. The turn signals work fine when I do turn them on. I replaced the flasher, but same issue. I'm guessing a short somewhere, but before I spend hours trying to track it down, wondered if anyone has any ideas of an easy fix.
  • This is the most anoying thing in the world! I'm driving and it sounds like my turn signals are on. Does anyone know how I can fix this problem before I drive this thing off a cliff. Thanks :lemon:
  • The other forum has some info on this issue. From what I can tell from my research, it appears to be a 'multi-function switch' (ACDelco part #D6254C) located in the turn signal lever. I am no mechanic, but it appears you have to replace the lever and switch mechanism. I found the switch in question at www.rockauto.com for $105.89. Installation may be another issue - I don't know what it will take to install, but could be a b*tch. I suggest taking it to a dealer for a free quote and confirm it is that switch/lever assembly. Then if you aren't comfortable installing it yourself, find a local mechanic to do it. That is my plan, anyway. Or if you are really cheap and don't use your blinkers, you could always unplug the flasher (behind the glove box).
  • I have a 96 blazer. A fuse keeps blowing and when it does all of the gages go dead and the altinator stops charging the battery. I've replaced the fuse and it will work for a while but then it will blow again. I think it is a loose/pinched wire however I have no idea which wires to check. :mad:
  • Stever@EdmundsStever@Edmunds YooperlandPosts: 39,058
    Here's the problems forum link:

    Chevy Blazer/GMC Jimmy: Problems & Solutions

    Steve, Host
  • If no one has responded to your post, I will suggest you have the Outer-CV Joints checked on the side the noise is greatest.
  • In case this is still an issue.
    1: Record your Radio security code or set it to "0000"
    2: Check the switches in the Dash to make sure they are not defective.
    3: Disconnect the battery for 3 minutes and try to engage the 4WD. CAUTION--SEE STEP 1

    If at this point you still have no 4WD the it is most likely the Transfer Case Controller (Located in the Dash or Right Kick Pad)or the Transfer Case Encoder Motor (located in the Transfer Case).
  • Well I think i know exactly what is wrong. you have to get your heater core flushed out. You probably have the red anti-freeze called dexicool. and that usually clogs up in the heater core. its really not a problem. just get it flushed out and your heater will be working fine again. and trust me, it will be hot. i had the same problem and now i barely take the blowers speed off of one.
  • I might buy a 1999 4 door blazer or a 2000 2 door blazer. I would be buying it for my first car. If anyone has any pictures, or any kind of info on them, or what you think of it as a first car would be very helpful. Neither of them have ABS. The 4 door is tan and the 2 door is black.
  • I own a 90 Gmc s15 Jimmy which ive owned for 3 1/2 yrs..Havent had many problems,just basic stuff. Im looking into upgrading the engine, tranny, and differential..Im looking for information on which engine would be best to swap in...If anyone has information on which year 4.3 vortec engine would be best to swap..and any problems that occur...and any suggestions on a good tranny to put in...Im also looking to get the powerdyne supercharger kit...Any info would be appreciated...Or if putting a v8 Ls1 or Ls2 engine in would be best...Thanks
  • Just sold my '98 Blazer LT 4x4 with 100K miles (27K on a rebuilt engine) for $4,600. I think it was a fair deal for both myself and the buyer. Thanks to all of you who have answered my Blazer questions over the past few years.
  • Is there any way to beark into one of these safes on wheels?????
  • I am currently doing a swap in a 91 s10 pickup. It had a 2.2 or 2.5 4 cyl manual transmission. I chose a 2000 s10 4.3 with automatic as the swap. Getting it in is not that bad. I had to move the cross member for the transmission and buy new motor mounts, but everything lined up fine and fit nicely. Also, I had to buy a new radiator. I sent my old harness and new harness to a company in Texas and they spliced them together so I could retain my dash cluster. Also, you have to have the Vehicle Anit Theft System (VATS)codes removed from the computer because your truck won't start due to the chip in the ignition which recognizes the computer on the 2000 and allows it to start. You can buy a bypass if you have the key from the 2000 with the chip for a few bucks. Also, you will have to buy something called cable x a product that converts the electronic spedometer signal into a signal that your manual cable can read. Besides all of this the conversion is quite simple. I have been working on mine for while and still can't seem to get it running. I just sent the harness back to have it checked out and they think my ignition is bad so they gave me a bypass. I will be putting the harness back next week and hopefully it will start. It ran previously if you put some gas in the throttle body but I wasn't getting the injectors to pulse. Hopefully this fixes it. Also, you will need to add a high pressure fuel pump. I got one from a typhoon or a cyclone from the same year as mine as they were fuel injected. Fits right in and the harness plugs right into it. You will also need to upgrade your fuel lines to something that can handle fuel injection. Non fuel injection flows at 10-12 lbs while the 2000 motor needs 55-60 lbs of pressure. Just to give you an idea on costs I bought the 2000 motor on ebay with automatic trans, floor shifter and complete harness and computer for about 1400 including shipping. The other stuff cost me about 400 or so.
  • tidestertidester Posts: 10,110
    I hope you didn't leave your engine running!

    tidester, host
  • my 98 blazer did the same thing last year. Turn signals work fine but I heard clicking after using them. It was a multifunction switch which cost 400 bucks to dealer fix. Tricky repair cuz up in steering column under dash and air bag sensors have connections in the area. Works fine after replaced switch.
Sign In or Register to comment.