Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Blazer/GMC Jimmy

1121314151618»

Comments

  • Thanks appreciate it.
  • westworldwestworld Posts: 1
    Ok Here's the story.
    I have a 2003 Blazer 4wd 4 door 4.3L Vortec V6
    About 2 months ago the car was running fine and just died on me, wouldn't start up again. Later that day, started fine and ran ok, about 10 minutes later died again on the highway. Had it towed and it sat in the driveway for about 2 months. It would occasionally start, Idle fine, and stall about 10 minutes later.
    The other day I replaced the Fuel Pump and Filter, and it started right up idled fine and stayed running until I shut it off. I drove it the next day, and it ran ok but seemed to have less power than it did before all this. I also noticed that at highway speeds of about 60+ MPH and about 2000 RPMs, the RPMs would fluctuate by about 200 up and back down. If I drop the speed down to about 55-60 and the RPMs to about 1800 it would stop fluctuating. It seems like when the Throttle is in a specific range, the RPMs will fluctuate.

    Now before I go out and end up spending a small fortune, I would appreciate any input as to what may be causing this issue.

    The CEL did come on, but it has pretty much always been on. It did not do this before it broke down.
    My thinking was possibly the MAF sensor or clogged Injector, however the vehicle does idle fine and starts just as it used to, maybe even better.

    Thanks in advance for any help anyone can provide.

    P.S. Ironically, this all started the exact day that the check for my final payment on the car went through, Murphy's Law.
  • duntovduntov Posts: 133
    Whenever I see a 1998- or later S10/S15 Chevrolet / GMC with problems, I attribute that to the vehicle being too new. There has not been enough time for routine maintenance to correct all the original GM factory defects, If a S10/S15 can be maintained for 15 years before the owner or owners gives up and isends ther S10/S15 to the auto salvage yard, the original GM problems have been fixed and the truck has become a good reliable vehicle. I must admit it is difficult to invest $10,000 into a vehicle over a period of time that is not worth $5000. That is exactly the way the auto repair shops feel and they are reluctant to work on a S10/S15 Chevrolet/GMC SUV or truck without a large deposit before they begin the work. Most of the time the auto repair shop will tell the customer to "take it somewhere else".

    I seldom see any 1983 - 1997 S10/S15 Chevrolet/GMC SUV/trucks with problems that have not already been fixed.

    .
  • Hello, I just recently took my 97 GMC Jimmy in for emission test and they told me they cannot connect to my computer. When I turn the key the light does not come on. Also I have been reading about checking the fuse for the cigarette lighter, well it is working and I hooked my scanner up and it just tells me there is no codes. I do not have a clue what I need to do to get this truck inspected. Any help would be greatly appreciated.........thanks
  • withchinghourwithchinghour Posts: 1
    edited October 2012
    Hello,
    After spending an 18 month stint working in South Africa, I bought a 97 Blazer in 2009. Recently, I've had some headlight issues come up... namely, they don't work. I still have marker lights, turn signals, and daytime running lights, but I can get neither low beams nor high beams. I'm a diesel tech by trade, and know how to troubleshoot these things, but between work and classes, finding the time to go all out and trace the wiring is a bit lacking. So I was wondering what the most common culprit was for the Blazer, and hopefully I'll be able to go straight to the source and get it fixed, and hopefully not have to take the entire dash apart and such. Thanks for your time.
    Also, does anyone know of a compatible alternator with a higher output than the factory alternator but which is still compatible with the mounts for the factory 4.3?
  • kjh7691kjh7691 Posts: 4
    Can anyone help me with this problem with my 2000 GMC Jimmy 4x4.

    I have been reading all these posts and all seem to have similar symptoms to my problem. This car has drained the life out of me. I am just looking to make it on a trip home feeling safe!

    I have this clunking noise, most commonly backing out of the driveway. I just had the Idler and Pitman arms replaced and the front wheel bearings. Those didn't help the problem.

    Also when I have the foot on the break or the car is in park, turning the wheel either way, completely, becomes a workout. It feels like something is impeding the range I can turn the wheel only at a stand still.

    Anyone have any ideas? Clunk as is bad going over bumps, train tracks, whatever.

Sign In or Register to comment.