Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Blazer/GMC Jimmy

1202122232426»

Comments

  • i have a 97 gmc jimmy 4x4 automatic with 4.3eng. i was driving with no problems, i stopped at a stop sign and when i started out again the trans quit shifting to 3rd and overdrive but shifts from 1st to 2nd just fine. any suggestions on what happend to it?
  • I'm not sure what the problem is but all of a sudden my headlights won't turn on. My park lights work fine, turn signals are fine, and brake lights are fine. When i flick the switch inside the car to turn on the park lights and the dashboard light it works, but the headlights don't turn on. When I pull my turn signal/windshield wiper switch forward, it usually turns on the high beams or headlights, but this is not working either. Is it me? Or do I have a problem? Anyone know what I can do? :(
  • jlflemmons, years later I know but wondered if you were ever successful at converting the rear mounted spare tire on your blazer to inside? I just bought a 2001 and wanted to do the same thing. I was thinking of putting the bolts back in the holes it would leave with rubber gromits or something to seal them. So water doesn't get in and start rusting. Thanks.
  • What is the best way to remove decals from a car. Specifically, I a 2001 chevy blazer that has decals on each side of the doors (2dr). The truck sat and has not been driven (only 37k miles) but i'm afraid that you'll still be able to see the outlines. The paint is in great condition and doesn't look faded. Is this an easy process and is there an easy way to do it? Any advise would be great.
  • Stever@EdmundsStever@Edmunds YooperlandPosts: 38,912
    edited May 2012
    Some heat should help ease the decal off (easy does it).

    For the adhesive that's left behind, try Citrosol or similar citrus degreaser or something like Goo-Gone.

    Removing stickers, labels, decals, glue, sap...
  • Great, thank you very much.
  • Stever@EdmundsStever@Edmunds YooperlandPosts: 38,912
    edited May 2012
    As you skim that other forum, you'll note that some detailers don't like to use heat at all. Worth a try picking it off with your fingernail at first.
  • Steve, since you helped with my decal questions. Wondered if you had insight on my other question for the same vehicle. It's a 01 checy blazer and it has the spare tire mounted on the outside as an option was for that year, right? Is there anyway I could convert it back and take the mounted hardware off? I'm thinking of putting the bolts back in the holes with gromits or something that prevent water to get into the body.
  • ewysockiewysocki Posts: 14
    I have an opportunity to pickup a 76 blazer with only 37 k miles. Arizona car, very clean. 350 auto, ps, pb. any thing I should look for?????
  • Stever@EdmundsStever@Edmunds YooperlandPosts: 38,912
    edited May 2012
    Beats me. :-)

    I don't like spares mounted on the body but I don't much like them inside either - if they aren't screwed down (in a well preferably), they can become flying projectiles in a wreck. They get filthy, but I'd rather crank them up from underneath than lose interior cargo room.

    But yeah, I wouldn't have any issue with plugging some holes with bolts and neoprene washers or wherever. I've drilled holes in other cars and used silicon to keep the water out. Plus you should have existing drain holes in the doors, etc. Be a good idea to make sure they aren't clogged up.
  • Thanks appreciate it.
  • westworldwestworld Posts: 1
    Ok Here's the story.
    I have a 2003 Blazer 4wd 4 door 4.3L Vortec V6
    About 2 months ago the car was running fine and just died on me, wouldn't start up again. Later that day, started fine and ran ok, about 10 minutes later died again on the highway. Had it towed and it sat in the driveway for about 2 months. It would occasionally start, Idle fine, and stall about 10 minutes later.
    The other day I replaced the Fuel Pump and Filter, and it started right up idled fine and stayed running until I shut it off. I drove it the next day, and it ran ok but seemed to have less power than it did before all this. I also noticed that at highway speeds of about 60+ MPH and about 2000 RPMs, the RPMs would fluctuate by about 200 up and back down. If I drop the speed down to about 55-60 and the RPMs to about 1800 it would stop fluctuating. It seems like when the Throttle is in a specific range, the RPMs will fluctuate.

    Now before I go out and end up spending a small fortune, I would appreciate any input as to what may be causing this issue.

    The CEL did come on, but it has pretty much always been on. It did not do this before it broke down.
    My thinking was possibly the MAF sensor or clogged Injector, however the vehicle does idle fine and starts just as it used to, maybe even better.

    Thanks in advance for any help anyone can provide.

    P.S. Ironically, this all started the exact day that the check for my final payment on the car went through, Murphy's Law.
  • duntovduntov Posts: 133
    Whenever I see a 1998- or later S10/S15 Chevrolet / GMC with problems, I attribute that to the vehicle being too new. There has not been enough time for routine maintenance to correct all the original GM factory defects, If a S10/S15 can be maintained for 15 years before the owner or owners gives up and isends ther S10/S15 to the auto salvage yard, the original GM problems have been fixed and the truck has become a good reliable vehicle. I must admit it is difficult to invest $10,000 into a vehicle over a period of time that is not worth $5000. That is exactly the way the auto repair shops feel and they are reluctant to work on a S10/S15 Chevrolet/GMC SUV or truck without a large deposit before they begin the work. Most of the time the auto repair shop will tell the customer to "take it somewhere else".

    I seldom see any 1983 - 1997 S10/S15 Chevrolet/GMC SUV/trucks with problems that have not already been fixed.

    .
  • Hello, I just recently took my 97 GMC Jimmy in for emission test and they told me they cannot connect to my computer. When I turn the key the light does not come on. Also I have been reading about checking the fuse for the cigarette lighter, well it is working and I hooked my scanner up and it just tells me there is no codes. I do not have a clue what I need to do to get this truck inspected. Any help would be greatly appreciated.........thanks
  • withchinghourwithchinghour Posts: 1
    edited October 2012
    Hello,
    After spending an 18 month stint working in South Africa, I bought a 97 Blazer in 2009. Recently, I've had some headlight issues come up... namely, they don't work. I still have marker lights, turn signals, and daytime running lights, but I can get neither low beams nor high beams. I'm a diesel tech by trade, and know how to troubleshoot these things, but between work and classes, finding the time to go all out and trace the wiring is a bit lacking. So I was wondering what the most common culprit was for the Blazer, and hopefully I'll be able to go straight to the source and get it fixed, and hopefully not have to take the entire dash apart and such. Thanks for your time.
    Also, does anyone know of a compatible alternator with a higher output than the factory alternator but which is still compatible with the mounts for the factory 4.3?
Sign In or Register to comment.