Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chrysler Town Country Audio/Entertainment Systems/GPS

124

Comments

  • Hi, I have a 2008 T&C Limited. Has any one figured out how to keep the system from forgetting my Sirius favorites list? You set it up, save it on the door, and couples times later it's dropped. Thanks, Tim
  • xwesxxwesx Fairbanks, AlaskaPosts: 8,567
    I know nothing about the MyGig system, but this sounds like a battery issue. There could be several items at play: First, if the system uses a separate battery to keep the memory stored, that battery likely is dead or low, meaning it is not doing an effective job of storing the memory when the vehicle is off (this would be similar to an alarm clock with battery backup). Second, it may be the vehicle's primary 12-volt battery. If the battery is somewhat low, the act of starting the vehicle may cause enough strain on the unit's resources to cause an interruption in the stored memory - I had this issue with an '07 Outback using the stock battery (a measly 260 CCA) when temperatures were -20 or colder. I fixed that problem on mine by replacing the battery with a quality unit with 680 CCA. Third, the memory system may employ a capacitor that maintains current to the memory while the vehicle is started, and this capacitor could be bad.

    Again, I don't know anything about the MyGig system, but if the unit does store the the preferences, but then later "forgets" them, it is almost certainly an issue of power supply to the memory system.
    2010 Subaru Forester, 2011 Ford Fiesta, 1969 Chevrolet C20 Pickup, 1969 Ford Econoline 100, 1976 Ford F250 Pickup, 1974 Ford Pinto Wagon
  • jiminsandiegojiminsandiego Posts: 4
    edited April 2010
    Hi all. My wife has a 2005 T/C with the Uconnect hands free (factory installed) and the dvd/6 disc changer. About 2-3 months ago the uconnect stopped working. It also will mute the radio like its supposed to, but then the radio comes back on. I took it to the dealer and he said it was the uconnect module that needs to be replaced and that the charge to replace it was $455.00. This is crazy!!!! I'm out of warranty and the extended warranty doesn't cover it. The part number on my uconnect module is 56040974AB, which I'm told by the dealer is an outdated version, the new version is 56040974AC. Which is the same price. Now I've searched and searched all over the internet trying to figure out how to get this thing fixed to no avail. I've tried the battery cable remove process and the door open/close process. Nothing works. My questions are this, (1) Does anybody know where I can purchase a good used one? (2) Does anybody have a list that the 56040974AB part number was installed in? (3) Does anybody know where I might be able to get mine repaired at?
  • jag25jag25 Posts: 1
    I have the same problem, I pulled my unit out to inspect solider joints but found nothing.......HOW did you make out?

    jason
  • Hey Jason, Well so far I've found one company that you send it to with 239.00 and if they can, they'll repair it, if not they'll get another one for 339.00. I'm just not sure about just sending it to someone across the country with my money. Sounds too risky to me. My wife has just decided that we're just going to wait until the "December to remember" Lexus event and we're going to get rid of this van. Its been nothing but problems every since we've bought it. Have had it in for these issues:
    5 times for steering groan
    3 times for AC blowing hot, then cold, then hot again
    3 times for locks stopped working
    4 times for the front sway bar bushings
    3 times for a creaking noise in the rear when loaded

    Its just been a pain in the [non-permissible content removed], so we're not bothering with the uconnect anymore and I'll be glad when its gone! Good luck on your search for a repair. Let me know if you find a repair.

    Jim
  • To: dukester68
    Re: Your message #92 on Dec 22, 2009 (10:20 pm) >> 2005 Town & country 6 disc changer [dukester68]

    I have a 2005 Town & Country and am experiencing the EXACT same problem that you have described. What did you end up doing?
    Thank you
  • jjwhit2jjwhit2 Posts: 1
    I have a 2007 dodge grand caravan with the 6 disc rear entertainment system. The other day i realized that the sound is playing fine but when the dvd begins the picture turns white....any ideas????
  • Hey Dukester68, I haven't done anything yet. My wife is not happy with the fact that I want to get rid of her van, so looks like I'm stuck fixing it. I'm going to just get the part from the dealer that way I know its the latest part and it will be the correct one as well. I bought one on ebay from a guy that said his would work in the van, needless to say luckly I'm only out 10 bucks for that one. I cannot find one in the junk yard or online, everytime I google it, I just come up with the new MYGIG information. So I'm resolved they have me over a barrel this time.
  • abqedabqed Posts: 1
    Just to sympathize, my 2005 T/C with 105K has developed the same problem with UConnect not working (exact same system/setup), and the local Albuquerque dealership/repair has quoted me the exact same cost for replacement of the unit with no other option for repair. Please let us know if you go ahead with the dealer repair and it if it works and the price quoted remains in the that ballpark. BTW, it was an excellent, flawless, integrated system until it crashed.
  • I have a 2005 Chrysler Town & Country Minivan. The DVD Player quit working. It has no power. Does anyone no what fuse protects this? I looked in the fuse/relay box, but I cannot find any blown fuses. Is there a chance that the plug supplying power to the DVD player has come unplugged?

    Any help or suggestions would be greatly appreciated.
  • My 06 T&C has the rear flip down screen. It stopped displaying. The dvd player works, and we get sound through the speakers, but no display. Has anyone encountered this? If so, what is the fix?
  • I just bought a T&C 2006 with DVD and a rear screen.
    When I insert DVD's into the changer it accepts them ok (and ejects as well), but then nothing happens. The rear screen remains blank and there's no reaction to whatever I press on the remote. Am I doing something wrong or the RES is screwed?

    Also there's no reaction to pressing the UConnect Phone button, maybe there's a correlation?
  • tye5tye5 Posts: 1
    My wife is having the same exact problem. When we put in a dvd in the bottom player we get sound but no pic on either of the screens. When we put a dvd in the top on the front screen plays but not the back two. im looking to see if you found out anything. This defeats the purpose for us getting this gas guzzler we would have been better off getting a smaller car that saves gas.
  • kcrossleykcrossley Posts: 172
    I'm looking to replace the stereo in my 2010 Town & Country with an aftermarket system that, in addition to playing music and CDs, allows me to play DVD's, connect my iPod and iPhone, and doesn't require significant modifications to the dash.

    Any suggestions?
  • smartautosmartauto Posts: 5
    are you using the wrong wiring?
    http/www.smartauto24.com">link title
  • smartautosmartauto Posts: 5
    http/www.smartauto24.com
  • kcrossleykcrossley Posts: 172
    That's pretty cool. Thanks.

    Can I simply remove my existing standard radio and install one of the Chrysler head units or do I need some type of adapter kit?
  • kcrossleykcrossley Posts: 172
    BTW, have your ordered from these guys before? I've never ordered anything directly from China.
  • tywone55tywone55 Posts: 1
    I have the same problem with my 08, i had it diag. and they told us that it was the dvd monitor module $1000. Does anyone know where to buy one and where it is located.
  • preechrpreechr Posts: 1
    OK, same problem with the UConnect, except my dealer says it is $913.00 installed for a new module! Jim, where did you get yours done for $455? I live in San Diego, too. My UConnect, CD player, and driver power seat all went out at or about the same time! I have had no problems until this. Any ideas out there?
    Preechr
  • We just recently purchased a 2005 Town & country LImited. It has the DVD player and also a single cd changer/gps system and a 6 disc cd changer. The book says we can watch a dvd and listen to it with headphones ( we hear the audi through the headphones and speakers at the same time currently) at the same time as playing a different cd and listening through the speakers(If the adults would want to listen to music in the front of the van) : . It doesn't explain how to do this , though. Can anyone tell us how we accomplish this?? Every time we try to listen to something ,other than the movie playing.... it turns the movie off. :confuse:
  • We have the same vehicle and have tried numerous times to do what you're saying... it doesn't work. You can only play one CD/DVD at a time... unless you count the GPS....
  • hey guys. where are you buying car dvd navigation in local? could you show me some guides?

    yoki
  • hixson01hixson01 Posts: 2
    edited November 2011
    no what i mean is the owners manual for the van says the you can listen to the radio up from while the the kids listen to the dvd in the rear with the head phones. however it does not tell you how to do this. in mine you hear the dvd through the radio and the head phones at the same time.
    someone help me please :confuse:
  • Hey, I know this is years late but I fix my DVD changer the other day. There are 7 disks with finger tabs that hold the dvd a little larger than a quarter. They ride up and down a cylinder to allow you to put cd/dvds. They have 3 tiny and I mean tiny plastic fingers that keep the disk level as they ride up and down. One of the fingers on two disks broke causing the jam. I also notice that whatever lube that was in the unit for sliding part was all gone (dried UP). causing the stick and then probably snapping the plastic finger. I reassembled without the two disk and it works. except I can only put 4 disks until I can find replacement disk finger tabs..
    I'm posting this here because this DVD player flashing and broke seems to be a common problem that Chrysler doesn't want to address except to sell you a new unit between 500-1200 dollars.
  • Hey, I know this is years late but I fix my DVD changer the other day. There are 7 disks with finger tabs that holds the dvd a little larger than a quarter. They ride up and down a cylinder to allow you to put cd/dvds. They have 3 tiny and I mean tiny plastic fingers that keep the disk level as they ride up and down. One of the fingers on two disks broke causing the jam. I also notice that whatever lube that was in the unit for sliding part was all gone (dried UP). causing the stick and then probably snapping the plastic finger. I reassembled without the two disk and it works. except I can only put 4 disks until I can find replacement disk finger tabs..
    I'm posting this here because this DVD player flashing and broke seems to be a common problem that Chrysler doesn't want to address except to sell you a new unit between 500-1200 dollars.
  • jmok_fixedit:

    Thank you so very much for responding.

    "I reassembled without the two disk and it works. except I can only put 4 disks until I can find replacement disk finger tabs.. "

    How did you reassemble? How did you get in?

    Thank you.
  • rpe94rpe94 Posts: 1
    Had the "Updating Channels" on both VES 1 and VES 2 screens. Put the main radio in the front to FM, as well as both VES. Pulled the fuse (M10) for 60 seconds. Put the fuse back in, tuned the VES to Satellite. Waited 30 seconds for the "Updating Channels" message to go away, and can now direct tune in the back, again. Simple fix.
  • We had this entertainment system for 6 years until recently and you should be able to push the headphone button on the remote and then listen to the radio, satellite radio or other cd's if put into the gps slot. Did it have the remote control with the vehicle? We do not remember the button being on the dashboard system. Hope this helps. Please let me know if this helps.
  • We are trying to figure out how to attach an ipod touch or ipod video for movies to the entertainment system for the rear screens. We tried a cord with composite cables on one end and the plug for the apple on the other and plugged them into the rear jacks. We could see the movie but only hear them on the van speakers not the headphones. We are wanting to hook up an exterior device with movies to watch on the rear screens. Please reply back with any help.
Sign In or Register to comment.