Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Pontiac G6 Lighting/Electrical

245

Comments

  • I have a 2008 G6 2.4L Sedan, 58000 miles. My driver side rear door lock does not operate with the fob or lock buttons. I can lock and unlock it by manual means only. Has anyone else had problems with their electric locks?
  • gmcustsvcgmcustsvc Posts: 4,003
    maddog0324,
    I would recommend taking your vehicle into your dealer of choice. They will be able to assist you with your concerns.
    Christina
    GM Customer Service
  • gonogogonogo Posts: 869
    Gotta pull the door panel and see if power is getting to the actuator when button pressed.
  • I hear the actuator click and try to raise and lower the manual rod when I press the buttons on the fob or door panel. The manual rod does not appear to be in a bind. Since I am out of warranty, how difficult will it be to replace the actuator?
  • gonogogonogo Posts: 869
    Never done one, hardest part would be getting the door panel off. I use a tool you can buy in any auto parts store, it's for removing the clips that hold a lot of the door panel on.
    Before replacing the actuator I would check it with 12 volts, might have a low voltage problem.
  • kimchanellkimchanell Posts: 3
    edited January 2011
    My car was possessed. It would lock, unlock n vice versa by itself. I could not leave the car. Now the driver side rear door will not work. It gets frustrating especially when i have to keep rolling down the window. Ugggh pontiac and General Motors.
  • I have a 2005 G6 and i cannot change the rear bulb also. I took off the 2 nuts I found and it still wont come out so I can change the bulb
  • gonogogonogo Posts: 869
    I think if you just pry gently on the housing assy it should come loose.
  • Well, i took off the only 2 nuts and found that near the inner fender there was a black tab that looked needed to be removed, but it did not, it was a insert clip for the screw to enter into. I had to take the light and rock it back and forth like i was angry. It wasnt as simple as they say though but I was able to remove it with more force than I wanted too. thanks
  • lkelaghanlkelaghan Posts: 1
    I have an 06 G6 and it started to stall out on me while driving. The engine light pops on and the info panel tells me the Engine reduced power/Engine Disabled. I pull over for a few minutes and restart the car and I'm running again. Has anyone ever had this problem??
  • gerald700gerald700 Posts: 3
    never had that prob but have heard the same from other owners. While do not own my 06 anymore it would be feasible to take it to a auto parts store like we have here in Texas called auto zone, they can run a free diag and tell you if any codes come up. That may narrow it down for you
  • maddog0324maddog0324 Posts: 53
    Hey kimchanell,

    Did you get your lock problems resolved? My passenger-side rear door lock operates electrically about 50% of the time and the driver-side rear door lock does not have enough force to lock/unlock at all. I hear the lock accutator clicking on both rear doors. I can lock/unlock both manually, so the linkage is not binding.

    maddog0324
  • Well, I bought my kid a fairly new car (40K miles, about 3 years old) a year ago. I ran great but suddenly we have had all kinds of problems. All of the gauges in the car will go crazy when driving, and all of the warning lights are going on and off (ABS, traction control, error message on the mileage area). The car has been in a GM shop for three weeks and they have changed the BCM, VCM, Onstar Module, and now the engine wiring harness (which I had to pay for, since it is not part of the powertrain).

    Well, they called and said this would 100% fix the issue (after telling me that they were going to cover all of the costs, since it has taken three weeks at this time - didnt happen). So I start driving the car home and all of the same issues started back up again. Obviously, the dealership does not know what is wrong and I'm hoping that someone else has had the same issues so I can at least know what to do.

    I emailed Pontaic and GM but have not heard back.

    HELP!!
  • gmcustsvcgmcustsvc Posts: 4,003
    bdambrowski,
    I apologize for your frustrations. I am unsure who you emailed, but can you please email me? Please include the VIN, current mileage, involved dealer, and your complete contact information. I look forward to your response. Have a great weekend!
    Christina
    GM Customer Service
  • Christina,

    Thanks for the response. I emailed you the requested information. Look forward to hearing back from you soon.
  • longo1longo1 Posts: 1
    I bought a 09 G6 HTC a month ago with 39k mi. A dealer rep vehicle. The battery just seemed to go dead after a month. Classic clicking of the starter relay. I put 12V charger on it and it started and after an hour charge it started. I placed a volt meter on the battery with the engine running and it showed 14.18 V. I let the car sit for a day and it did the same thing. It's now on a charger. I'm afraid of getting stranded. I love this vehicle, just don't like this issue.
  • I have a 2007 Pontiac G6. The car has about 44K miles, I have replaced the battery 4 times, the first had a bad cell and was replaced under warranty. We have had a problem with the battery going dead especially when it rains, the other issue is that the factory installed remote start does not work. They ran a parabolic test but could not fine any drain. There are 2 codes in the computer P0650 & 1380 which they associate with the remote start. They want to remove the steering column to get to the control that is for the remote start but cannot tell me if this problem is related to the battery problem.

    The car has a sunroof that had a problem with the gutters & the drain tubes when it was new, we had the fix done under the recall. Before the recall was performed, the rear carpet would get wet and it you went over a bump with the radio on the AM band there would be considerable noise/static from the radio.

    The car has started fine since we had it back to the dealer until the rain we had this week and the again the batter had to be jumped. I believe I am getting a short when it rains, possibly from the sunroof which appears to be loose when it is closed although it doesn't appear to leak.

    Any Suggestions?
  • gmcustsvcgmcustsvc Posts: 4,003
    Do you plan on taking the car back to the dealership? If you give your VIN, I can look further into the situation. Keep me posted on your progress, thank you!
    Joey, GM Customer Service
  • Yes, But I am going to take it to a different GM dealer that is closer to my home and I have a higher confidence level in.
    Can you send me an email address and I will be happy to send you the VIN #?
  • did you ever get your car fixed? if so what was the problem
Sign In or Register to comment.