Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Expedition

1697072747583

Comments

  • Stever@EdmundsStever@Edmunds YooperlandPosts: 38,950
    Does anyone have an idea of what the 2006 residual value will be

    Try Car_Man over in Lease Questions - Ask Here.

    Steve, Host
  • cyr1cyr1 Posts: 2
    HEY KIM PLEASE LET ME KNOW WHAT YOU LEARNED ABOUT THIS PROBLEM. I HAVE THE SAME ISSUE AND THE DEALER WANTS 350 FOR FIX THIS. LET ME KNOW PLEASE
  • bbonesbbones Posts: 1
    Does anyone have experience with actual performance after installation? I have recently purchased a Hypertech and I've set it up for firmer shift, but I'm having a tough time finding information regarding rev limiter and shift points for 2003 Expedition 5.4L. Any suggestions or other information would be helpful. Thanks
  • gringrin Posts: 1
    I am having the same problem with my 01 EB Expedtion. Have you been able to find out how to fix this problem..

    Grin
  • twiebetwiebe Posts: 7
    My EB White is 1 year old and I noticed a rust spot on the roof. As I went around it more closely, I noticed very faint specs of rust underneath the black window trim, as well as the rear panels. The specs are also more noticable on the trim above the rear window that houses the third brake light. This car sits in a garage all day, and I take it to a full service car wash typically every Saturday and get the works (premium wash, clear coat, armorall tires etc.) Has anyone had this problem, and does anyone know what the warranty options are?
  • Hi everyone I'm new to the boards so I apologize if this has already been asked. We have a 2000 Ford Expedition and it just recently started clunking when we first start to drive. The clunking sound stops after awhile but we'd like to know what's making that sound. Thank you for your help.
  • gheimurgheimur Posts: 88
    I don't think its rust. My wifes 01 Escape which is white may have had the same thing. I was able to get almost all of it or most of it with a good wax cleaner
    /polisher. It may be tar or somthing that shows up on White cars. Good luck
  • Stever@EdmundsStever@Edmunds YooperlandPosts: 38,950
    It may be "rail dust." Get a clay bar from Mother's or Zymol (should be around $10) and try that. Check out the Store Bought Waxes Part II (No Zaino Posts) discussion and search in there for "clay." They'll be lots of posts about how it works; it'll surprise you!

    Steve, Host
  • alwaysfords2alwaysfords2 Posts: 288
    I was just going to say that and you beat me to it. Second vote for rail dust.
  • davantdavant Posts: 294
    Chuck1,

    Real world no BS miles per gallon on our 5.4L 2003 2WD XP is 16.0 (--tops, all city yields 14) MPG over 48K miles. Don't believe the optimistic computer estimator as ours lies by about 1.5 MPG. This is about a 50/50 combo overall of flat Florida H/C driving. Anyone claiming over 17 MPG on this vehicle at 70 MPH or above is a dreamer. Subtract about 1 MPG for every 10 MPH over 60.

    No brake problems other than front pads replaced at 23K. Brake dust practically eliminated at 26K miles by installing 4 dust guards Autosport Wheel Guards discussed ages ago. No, I don't work for them. Still lovin' everything about our EB XP but $50 fill ups! ;)
  • chuck1chuck1 Posts: 1,405
    Thanks,
    I guess the new ones are supposed to get about 1 more mpg than yours. Still not that great. I have an 2002 Explorer with the V6. The city mileage is not that different. However, I do get 20mpg (consistently) if Ikeep it no faster than 70mph!
  • posiedon7posiedon7 Posts: 1
    Did you ever get a response for the 2nd question with regards to the spare RCA jack? :confuse:
  • Chuck, I have a 2002 Expedition with 5.4 engine and I get between 13-14 MPG city and 17 - 18 MPG on highway. I am running AMSOIL 5W-30 motor oil with a K & N air filter.
  • I am on my second Expedition. The first one I had was 1 1997 and I replaced the first set of brake pads at 46k miles. My current 2002 Expedition has 40k miles on it and I just took it in for an alignment and was advised that I will need to replace pads within the next six months.
  • chuck1chuck1 Posts: 1,405
    Isn't the gross vehicle weight something like 4,800 pounds on the Expedition? How can you possibly be upset on getting 40K out of your brakes. I know NO ONE, that gets this kind of distance on brakes on ANY NUMBER OF SUV's! My wife who drives very conservatively got just over 25K on the brakes when she had a '99 Suburban. On her 2002 Explorer, she got just over 32K when she needed brakes. Why don't you ask around on what people are experiencing, I think it may give you some perspective....... :confuse:
  • alwaysfords2alwaysfords2 Posts: 288
    the GVW is closer to 6,000 lb, and I agree with your brake usage numbers. 40k for brakes is a lot.
  • Stever@EdmundsStever@Edmunds YooperlandPosts: 38,950
  • gt5089gt5089 Posts: 1
    HI everyone. I have 2001 Expedition. The one thing I wish the truck had was controls on the steering wheel for the radio.

    Well, about a week ago, I stopped alongside an Navigator, & noticed that it had the controls I wanted, mounted on the left side of the airbag, in place of the on/off cruis control switch.

    Has anyone tried to add these controls to thier Expedition? If so, how did you accomplish it?
  • Stever@EdmundsStever@Edmunds YooperlandPosts: 38,950
    "NHTSA looking at reports that leaks in Expeditions can cause windshield wipers to fail."

    Feds probe Ford SUV water-leak reports (CNN)

    Steve, Host
  • fitguyfitguy Posts: 222
    Steve- interesting article, has anyone heard if they may initiate a recall? I just had my 2000 done for the speed control recall, I've seen a lot of posts here about the water leaking issue as well. Seems like failure of windshield wipers and/or electrical systems while driving could be a real safety hazard.
Sign In or Register to comment.