Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Escape Mazda Tribute Maintenance and Repair

1112113115117118133

Comments

  • ochinskiochinski Posts: 1
    Hi, what brand of struts & shocks did you uses on your truck?
    I have a 2001 tribute, it's ready for new struts & shocks.
    Thanks, Ochinski
  • rhiannon1rhiannon1 Posts: 6
    Finally the dealer listened!! My ABS has started to stay on while I am driving and not even going near the brake! I took it back to the dealer and they fianlly took a look at it & said the rings are cracked on both sides so it is not safe to drive. They are keeping the car --will be another week as they still need parts -- but are replacing the rings, drive axels and the bushings under the warranty. Don't let them drag their feet - everyone told me it was safe and now they are saying it is dangerous & not drivable!
  • Well, our '03 Escape just turned 27,000 miles and while the wife was driving it, it stopped. Bottom line, catastrophic transmission failure and $3,500! I have been surfing the internet and found that this is not the only Escape to have this problem! Now, Ford warranty on the Escape transmission is 5yr/60,000! But, as of right now, Ford will NOT STAND BEHIND THIS TRANSMISSION! I have not even reached the first transmission maintenance service at 30,000! The dealership even stated that our Escape shows no signs of abuse! Never been off road! So, has anyone else experienced transmission failures like this? Is it time for a class action suit??? Depending on what Ford will do for us, this may be our very last Ford Product! We were looking at the Escape Hybrid but as this repair will cost 1/3 of what we were offered trading our '03 Escape in for a '08 Escape Hybrid, I really don't know!
  • steverstever Viva Las CrucesPosts: 40,859
    If it's under warranty, why isn't Ford going to fix it or put a remanufactured transmission in? I don't understand why the repair is going to cost you $3,500.

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • scatanscatan Posts: 4
    I too am curioius why Ford is not standing behind the transmission. What reason did they give? Have you consulted with another dealership?
  • mschmalmschmal Posts: 1,757
    He is out of warranty on time.

    If you are looking at an Escape you absolutely WANT the trailor tow package. You get an upgraded transmission cooler which gives you benefits even if you never tow.

    Many of the preowned off lease Escapes will have this feature as it was part of the lease program focus vehicle.

    Mark.
  • mschmalmschmal Posts: 1,757
    Consumer Reports may recomend that you NOT buy the Extended Service plan but try sending them your repair bill and see if they will pay it for you.

    That advice is like saying that if you are a healthy person and have good eating habits and no unhealthy habits then you should drop your health coverage as the chances are you will never get benefits equal to the premiums.
  • steverstever Viva Las CrucesPosts: 40,859
    Well, the post said the warranty was 5yr/60,000 so I took that at face value. Time indeed has run out. Maybe Ford and the dealer will meet him halfway or something.

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • mschmalmschmal Posts: 1,757
    Please keep in mind that if you are making lots of short trips or spend time ideling in traffic, then you should be following the severe duty maintenance schedule in the maintenance guide.

    Most wear for an engine occurs at startup when the oil is in the oil pan, not up in the block. Also short trips mean that the engine does not fully heat up enough to burn off acids that collect in the oil. This ages the oil much faster.

    Thats why its 5,000 miles or 6 months for Ford on oil changes UNDER NORMAL CONDITIONS!

    That being said, the trans failed at 27,000 miles on a 4 year old car. That person should have done the 30,000 mile service almost a year ago based on elapsed time no matter what the miles said.

    Mark.
  • larrygjaxlarrygjax Posts: 1
    I know your message is really old....and I didn't see anyone offer any help but my 2002 Escape just did the exact same thing....I'm stuck in park and the shifter will move but never actually change into D, R, N but the box around the P goes away when I try to move into any other gear....what caused this problem and how bad was it (cost and time) to fix it? Thanks for any help.
  • dilyhidilyhi Posts: 2
    The transmission just went out on my '06 Escape at 12,500 miles. Fortunately it is still under warranty, but now am wondering if this is a common problem. We were thinking of trading it for an '08, not so sure if that is a good idea anymore.
  • bdymentbdyment Posts: 551
    No. This is not a common problem at all. Sounds like a fluke. I wouldn't hesitate to purchase a 2008.
  • dilyhidilyhi Posts: 2
    Thanks that is good know. We are picking it up today and are going to look at the'08 on Saturday.
  • flaereflaere Posts: 3
    Just wondering whether you've been able to fix your problem? We have a 2003 Mazda Tribute 4 cylinder, 5 speed manual transmission and have had issues with the vehicle not starting (especially in hot weather). After driving it for an hour or so, if we stop to get gas or pick up groceries, when we go to start the car, it does nothing. It takes nearly an hour for it to start up again. We've taken into Mazda a half a dozen times and they haven't been able to duplicate the problem. We've had the fuel pump and relay(s) replaced ... had the keys reprogrammed ... but to date ... nothing has resolved the issue. Any one else experiencing this problem?
  • flaereflaere Posts: 3
    Did you ever find the solution to the problem? We have a similar problem with our 2003 Mazda Tribute?
  • jrosasmcjrosasmc Posts: 1,704
    My mom owns an '02 Escape XLT AWD that has 52,300 miles on it. Since she purchased the vehicle last year at 31k, there has been a persistent shuddering or grinding noise in the transmission whenever it is downshifting from 4th to 3rd on any type of incline. I've driven the Escape many times and what happens is this: If I go up a small or steep hill and the tranny has to downshift (which it does almost constantly), I hear a grinding/shaking noise coming from the tranny at speeds between 35-45 and 55-65 mph. They've had the fluid flushed and changed twice, at 35k and 50k, but the noise persists. What do you think it is- the torque converter or the solenoid?

    Just one more question as well: Does the Escape use the same troublesome 4-speed unit that the Windstar minivan used? I know that tranny gave many Windstar (and Taurus) owners a lot of headaches.
  • mschmalmschmal Posts: 1,757
    If you are looking for an Escape, insist on the towing package. The tow package includes a greatly upgraded transmission oil cooler. The one flaw of the Escape trans is that it was always prone to overheating in early model years of its use (1994 Mazda 626). Although this problem was supposedly fixed, its worth it to get the best cooling possible with the towing package.
  • rossco3rossco3 Posts: 2
    HAVE YOU FIXED THE PROBLEM? I have the same vehicle (2001).
    It starts fine, but if it's hot out it will die after driving for awhile. Then to keep it running I have to hold the gas pedal down all the time in order to keep driving, or it will die again. Not easy to do with a clutch. I would like to fix myself rather than have the dealer try, and not be able to duplicate the problem.
    Can anyone help me?
  • rossco3rossco3 Posts: 2
    2001 4cyl. 5 spd. It starts fine, but if it's hot out it will die after driving for awhile. Then to keep it running I have to hold the gas pedal down all the time in order to keep driving, or it will die again. Not easy to do with a clutch. I would like to fix myself rather than have the dealer try, and not be able to duplicate the problem.
    Can anyone help me?
  • flaereflaere Posts: 3
    No, not yet ... but will let you know if we're successful.
  • I have a 2002 tribute that is also dying on hot days. Please let me know if you figure it out. The mechanics have no idea.
  • I have a serious problem with the moonroof of my it tribute 2005 and it is that I had stopped a lot of time the vehicle and the moon roof I am not well closed, leaving a space for where entrance a lot of garbage that stride and damage the support and the guides of the glass of the moonroof and now ask to the dealer and them alone they sell the whole kit and that the parts that I need don't have P/N. Will it be that somebody can help me saying I eat up I can get those parts? Thank you Raúl Obando (raul_obando@hotmail.com)
  • scoutguyscoutguy Posts: 3
    Has anyone found a way to solve the tailgate problem of not opening?
  • I have a 2003 Mazda Tribute and live in the Palm Springs area. Each of the last four summers and on an extremely hot day (in excess of 110F), the car has shown an electrical problem - indicator lights start flashing, radio becomes intermittent, etc. When the engine is turned off, it will not restart without a jump. When taken to the dealer, the first time, I was told it was the battery and it was replaced. The second time, I was told that there was nothing wrong, but after fighting with the dealer, the battery was replaced again. Last year, they finally determined that it was the alternator and replaced it while still under warranty. Now again, on year later, I'm having the same issue. Any suggestions as to what could be causing this to occur?
  • funokafunoka Posts: 13
    I have had no electrical problems, with my 2001 Tribute, but they replaced the computer chip twice under warranty in 2002. Did they check that, or do they think it is purely electrical?

    I've had no issues with my Trib since, until this weekend. It didn't want to start after an hour and a half drive and then sitting for two days. I was parked on an incline, and it was like it wasn't gettting enough gas -- the engine turned over. After getting it started after five attempts, all is fine now. Has anyone else had this problem?
  • Hi,

    I was wondering if anyone knew of a reputable/low cost source for rear bumpers for the Tribute. JCWhitney only has front bumpers. It's not a necessity, but I may want to replace it soon for aesthetics.

    Erinn
  • othelloothello Posts: 2
    "But I also notice quite of bit of engine vibration coming through the accelerator pedal, mostly under heavy engine load such as right before the upshift while passing on the highway, though I'm not sure if it's typical for this type of vehicle as I have been driving a silky smooth Contour V6 for the last 5 years. I am a little worried that there is a loose or broken engine mount or other drivetrain component that is causing the vibration and that it will be very hard to trace by the dealer." - Kam327, July 05, 2005

    I didn't see very much response to this. I own an new '08 Escape (less than 700 miles on it right now)in which I notice vibration coming through the gas pedal. I agree that this is not a good thing - a loose or broken motor mount could fail disasterously. There is also a growling noise that shows up at light throttle (almost coasting) at any speed.

    I took it to the dealer with these complaints. The response was that there were no "unusual" vibrations or noises.

    The noise is difficult to repeat, but the pedal vibration is obvious, altho' not violent. How much gas pedal vibration is acceptable in a brand new vehicle?

    Have any other Escape owners (any model year) noticed undue vibration in the gas pedal?

    Note: 08 XLT V6 AWD 4spd Auto no extra packages.
  • tveilleuxtveilleux Posts: 15
    For everyone with starting issues (cranking but no turnover) on older autos try replacing the IAC valve (Idle Air Control). Inexpensive and easy to do (top mounted).
  • tveilleuxtveilleux Posts: 15
    Is the vibration short-lived or continous?

    There is a fairly common problem with transmision shudder that lasts for less than a second upon accelaration/shifting that is solved with changing/flushing the fluid. I am used to older cars that had longer change intervals and thus had the problem for a while before I read this and other forums that suggested this solution. With a new vehicle it may be either low fluid level or something else.
  • I had the same problem. The dealership mechanic wanted to keep the car for a week to duplicate the problem and then wanted to start replacing parts one at a time until they found the bad one. I checked on a mazda forum (http://www.mazdaforum.com/archive/threads/2003-mazda-tribute-26234-1.html)
    which recommended changing the IAC valve right on top. It was $65 on mazdapartsonline.com and easy to replace (two screws right on top of the engine). It's been 3 weeks and hot out, and the car starts up fine every time.
Sign In or Register to comment.