Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Escape Mazda Tribute Maintenance and Repair

1141142144146147199

Comments

  • Hi again:

    Well, I had the dealer replace the IAC module and it appears to be working fine now. They did the IAC replacement at the beginning of last week, so I will drive it for a few weeks to see if it does its stalling thing again. I did also ask them to check to on the recalls and both of them were done back in January.

    On another note, ever since they replaced the IAC module, my gas mileage has been really taking a beating. Since I've owned the truck (bought it last October), I was religiously getting at least 600 kms (372 miles) on a tank of regular gas (my tank is 57 litres or roughly 15 US gallons). Sometimes I would get as high as 650 kms if I did all highway driving. Now, since they put the new IAC module on, I've been lucky to get 400 kms (or 248 miles) on a tank. I've only gone through one tank of regular gas since they put the new module on the truck. I even took it back into the dealer the other day (when my tank was at 1/2 full) so they could check it over. They rechecked the IAC module (which was fine) and also tested the fuel mileage with a handheld computer, which revealed an instantaneous 27.8 mpg over a 10 km (6.2 mile) trip. This does not make any sense, as I was only able to get abut 16 or 17 mpg on the tank after the IAC was replaced (248 / 15).

    The service manager said that the fuel guage works a little weird on the Tributes. Above the 1/2 mark, the fuel guage marker takes a longer time to drop from full to 1/2 than from going from 1/2 to empty. Not sure if I buy that one or not but he had also said that it works the same way on a 6 or a 3.

    I drive the truck pretty much from home to work, which is a 50 km (30 mile) round-trip, and is mostly highway, at speeds of 80-110 km (50-70 mph). Since it is still spring up here (in Eastern Canada), I have not had the A/C on at all. Right now, the truck has 120,000 kms on it (74,560 miles) and I don't know if I should get rid of it over the next few weeks and look for something else or keep it.

    Any ideas?

    freddy :cry:
  • snowmansnowman Posts: 540
    Technically, IAC controls the amount of air engine gets during idling. When you are cruising, your air part of air/fuel mixture managed by MAF sensor. Looks like, your engine is running rich, make sure there is no vacum leak, your dealer might disconnected vacum pipes during IAC replacement, by mistake. (Listen your engine in quiet place to hear a strong hissing sound, if you hear, try to locate it, it might be a vavum leak). Get your MAF tested, and visually inspect plugs. If I were you I would replace the plugs.

    PS: I hope you didn't pay too much for replacement. IAC is very cheap (~ $50 US) and breeze to install.
  • rcinmdrcinmd Posts: 139
    Has anyone out there had their dealers, or have you yourself, tackled the creaking of door panels, interior panels, etc? The situation seems to be getting worse, to the extent that I wonder about body flex being an issue. I might be blowing this out of proportion, but I have not owned a vehicle in years which had this problem, so I guess it is more annoying to me than it might be to someone accustomed to such noises. The sounds both seem to be from within the front doors, and also perhaps caused by interior panel rubbing. Yet, if I press on the door panel, I cannot duplicate the problem.
    I'm also starting to hear suspension groans. But that I will treat with silicone spray.
  • j30j30 Posts: 30
    You too, I just got back from the dealer. I took in my Trib with 6000 miles because of a creaking drivers window. At first I thought it was the whole door but at speed when it is creaking I can put my elbow in the center of the window and add some pressure and the creak stops.

    Anyway they put me in a rental overnight and when I picked it up I was told that the regulator did not need to be replaced but he did tighten it down and they also lubed the tracks.

    Did it work, NO!

    So, I guess I will live with it...

    When the radio is on I can't hear it, unless its talk radio...

    I read somewhere else about putting some lube on the weather stripping or something but I haven't tried it yet, I need to pick up some sort of a silicone gel to rub into that rubbery gasket along the window frame, that could possible work.
    :confuse:
  • rcinmdrcinmd Posts: 139
    In my case, it is both front doors, and I may be getting a chorus at times from other interior panels. I did spray silicone lubricant along the door weatherstripping, but that did not help. There is definitely something creaking or clicking inside the door, and sometimes it will sound off during braking. But in general, I think I am getting plastic on plastic noises. I just have this fear that over time, it may become almost continuous. If so, the next owner will deal with it.
  • dc_driverdc_driver Posts: 712
    My Tribute is not doing that.. In fact, my Tribute is more quiet than my Nissan Altima as far as creaks and rattles go. So far it is the most quiet vehicle I have owned (as far as creaks and rattles go). The tires are a little noisy at highway speed, but it is an SUV and from what I hear this can be fixed when it is time to replace the OEM tires.
  • vforgevforge Posts: 1
    I have a 2001 Ford Escape XLT (Red) 4 Wheel Drive for sale. Price is $10,800.00 OBO.
    Mileage = 96,000
  • 4bib4bib Posts: 17
    I have almost 27,000 miles on it. It still under original warranty until Sept. 05.
    I started to shop around for ext. warranty. The prices range from $2,500 and up for 7y/100k miles and around $2000 for 5y/75k-100k miles

    Basically I have 3 questions.
    1) Should I wait until end of August and buy day before expiration or buy it now with current mileage?

    2) Should I stick with warranty from Mazda dealership or third-party warranty like DS(Dealer Services) letters we're getting by mail periodically?

    3) Are the prices I getting from dealerships seem right?

    Thanks a lot!
  • mrsharkmrshark Posts: 1
    Hi all:

    Took my wife's escape to the dealer yesterday for tranny flush. After I got back home I looked at the invoice closely, says they replaced the fluid with Mercon V, not Mercon. I'm hoping this is just a typo on their part. Mercon V is no good in this tranny correct?????

    I am going back to the dealer tomorrow morning when they are open to complain. Any chance you think they put Mercon in, just typed Mercon V? They charged me $19.00 for 12 quarts of Mercon V, which seems cheap to me.

    Also , if damage occurs, do you think the dealer is at fault? I don't see how it could not be.

    -Mrshark
  • dc_driverdc_driver Posts: 712
    On some other Escape/Tribute message boards it has been made pretty clear that you should always use Mercon vs. Mercon V. I know the owners manual states to use Mercon.. I would take it back in, and have them re flush with Mercon (and it had better be free). At this point, I would not take the dealers word on it. I would also document this in case you have any issues with your transmission after your warranty expires.. In the grand scheme of things, you are probably okay, but better to be safe than sorry.
  • escapenutescapenut Posts: 117
    Any older Escape/Trib. owners experience an odd engine whine ? Mine just cropped-up a couple of weeks ago. Not sure what it is yet, but I'm trying to trace it as best I can. It's annoying at lower speeds when you can really hear it. It's a high-pitched whine like something is winding up-down. Oil level's fine, tranny fluid's o.k. too. Had it at the dealer for re-flash, wonder if there's any correlation.
    Just had the latest computer flash done. Seems very odd, but everytime I get one of the purported 'PCM-upgrades' done my mileage seems to go down. For instance June 2004, I had the re-flash done per recall. Mileage went from 18-19 City to 16-17 City. With the latest upgrade (done ~2-weeks ago) I expected to
    re-coup my mileage or so at least I thought. I've been through 2 (soon to be 3) full-tanks of gas and my average mileage is about 14-16. I don't know what kind of upgrades Ford is doing, but it's obviously not working to improve mileage figures.
    I could get a full-size V8 pick-up and get the same mileage in-town. This really sucks big-time. I'm going to request that the dealer re-flash the PCM back to
    at least one program-back.
    I've had the upper-induction service and fuel injector service done several thousand
    miles back. Either the engine is getting less efficient or there has to be something else wrong. Any ideas appreciated.
  • snowmansnowman Posts: 540
    This is not a pleasure for me to tell you but this sounds like tranny. I am very familar to CD4E whines from my 97-626. Have your truck put onto lift or dyno, so you can listen your tranny...
  • escapenutescapenut Posts: 117
    Snowman: ThanKs for your reply. I started hearing about the infamous CD4E
    tranny problems long before I had the Escape. I had a friend who had a 1997
    Mazda 626. His transmission gave-out at 75K miles. I didn't know that the
    Escape had a modified (and hopefully) improved version of the CD4E transmission
    until about 1-year after I purchased the Escape. Looks like it may not be that much improved, if any, from what Mazda is loading into the 626's in the past and present.

    I have contacted a reputable transmission specialist who obviously needs to put it on the dyno immediately. Judging from my description, he thinks it may be the
    torque convertor, which can be replaced separately, but may have caused enough damage (if it's the problem) to warrant a complete rebuild. I'll let you know once I
    have it done what the diagnosis/prognosis is.
  • gheimurgheimur Posts: 88
    Go to http://www.fordwarrantys.com it will be the ford warranty and cheaper
  • mvarnalmvarnal Posts: 1
    I've had my Ford Escape XLT V-6 since September 2000. I've been obtaining 265-280 miles per tankful with maybe 1.5 - 2.0 gallons left in the tank when I fill her up again. I've a slight lead foot that has me travelling around 70-75 mph when traffic permits. I've racked up 83,460 miles on the odometer and I'm very happy with the vehicle even though mileage would probably be better if I modify my driving. Two sets of tires going on my third replaced the OEM with Goodyear Forteza tires and it improved road noise and handling. No problems with the vehicle just a persistent overtemp light (red radiator) which was due to a crack overflow bottle took the mechanic a while to figure that one out. Ex-Explorer 1992 owner - miss that vehicle but I'm content with my Escape.
  • arcarc Posts: 1
    My cd player just went out today, 2002 Tribute with 27,000, 6 cd player.
    Cannot load any cds, remains in the wait position. It is empty.
    How did you resolve your cd player problem?
  • chrisptownchrisptown Posts: 11
    i am thinking of moving from my '04 sable to a new 05 escape. the one thing holding me back is gas mileage. i am looking at a 2wd xlt v-6. anyone have any experience/thoughts on this.?
  • I am so glad I found your message. My Tribute is creaking, ticking and groaning most of the time. I have a 2005 with 8000 miles on it. The dealer (wood pontiac Mazda) call it "flex" sounds and say they can do nothing about it. I have complained extensively to Mazda and they sent the Factory Rep to deal with it. He said sure, it makes alot of noise, but so do all the Tributes (in varying degree of noise) and so it is considered "normal". I disagree, and told him a brand new car should not sound like an old wooden boat. I am pursuing the Lemon Law. And I would encourage you to complain to the Dealer; my dealer said there is no other complaint on record with Mazda. Of course they will try to wiggle out of it. My car gets louder with time. And probably your will too. They should not be able to get away with such shoddy workmanship.
  • dc_driverdc_driver Posts: 712
    My 05 Tribute does not have this problem (creaking all over). As a matter of fact, as far as rattles and squeaks go, this car is the most solidly built, rattle/creak free vehicle I have ever owned. I have owned multiple Nissans, multiple Mazda's, a Saturn, and a Volkswagen.

    Not sure what to tall you. I find it hard to believe that "all Tributes", as your dealer rep stated, make these noises. Have you tried another dealer? Have you tried driving a different Tribute? I have never seen complaints like this one on other Escape/Tribute message boards...

    Good luck!
  • snowmansnowman Posts: 540
    Mine (05) is a solid built vehicle, haven't heard and ding, ping, creak or any other strange sound you describe. Very happy with the performance also, specially during past PA winter.
Sign In or Register to comment.