Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Escape Mazda Tribute Maintenance and Repair

1154155157159160199

Comments

  • I'm also curious about this problem -- my odometer backlight just went out on my 2002 Tribute (60K).
  • wtd44wtd44 Posts: 1,211
    If I assume you have an automatic transmission, then the answer may be that the engine is being "bogged down" by the transmission and/or torque converter not allowing high enough crankshaft RPMs to generate the torque needed to rotate the wheels. This does not necessarily mean that anything is wrong with the drive train. Keep in mind that the Escape/Tribute was not built to be an off road recreational vehicle. In an emergency, you might get the wheel rotation you seek by revving the engine in neutral and jerking the tranny into gear. You just might seriously damage the drive train, though.
  • :cry: I have a 2005 FWD Escape XLT with 18K miles on it. I've had loud brakes, black dust and squealing since day one. I took it to the dealer and they said that it was, "normal". Now at 18K miles, they tell me that I need new brakes. Something about hard pads vs. soft pads wearing out and the "driver" ... blah blah blah. Is that normal? Oh - and I have to pay for it. No 36K warranty to be seen anywhere on this one!
  • bj02176bj02176 Posts: 115
    I have a 2005 4wd xlt, 21,000 miles, no squealing, no black dust, it has disk brakes on all 4 though. Very good brakes overall.
  • I started my 2001 Tribute and when I tried to shift into Drive the handle pretty much slipped back and forth (didn't click into R, N, D, etc.). I wiggled it a little and now the display thinks it is in Neutral, but the handle position is at the top as if it is in Park. It will not move out of that position. Key can be removed/replaced and it will re-start as if in Park but display shows the box outline around N. Replaced battery in May and had terminals cleaned last month (as the battery was DEAD and wouldn't even jumpstart). Local dealer wants me to tow it in. Favorite shop is closed until after the 1st. Any ideas?
  • The same happened to me but my Tribute is a 2002 model and I wonder if this is a safety feature built into the tribute so as not to damage the transmission. Also the air conditioning unit shut down. When I got towed out of the bog and after a period of about 15 minutes or so driving the air conditioner re started.
  • Yeah, I think I got a bad batch of brakes. I just dug out my receipt from 5K miles when the brakes were noisey and touchy the first time. I was told then that it's "normal" . I've been doing research and I'm find that having rotors and brakes replaced at 18K seems to be unheard of!
  • gaetangaetan Posts: 1
    I had that problem and I had to be towed to the dealer to replace the ignition but I think the problem is the key itself check on the side if the tiny slot is damage
  • sks2sks2 Posts: 1
    Hoping you can help. A week ago I had my brakes checked, tires rotated, fluids changed, and radiator flushed. Three days later my 2002 Ford Escape xlt started to squeak every time I turned the wheel. I checked the steering fluid and it is full. This vehicle only has 33,000 miles on it and was running fine until I took it in for routine maintenance. Do you have any ideas what could be causing this noise?
    sks
  • wtd44wtd44 Posts: 1,211
    Could you possibly narrow down the location from which the noise comes? First, is it in the cab or under the hood? Then, where from there?
  • I had the same problem with my 03 escape. The General AMeritrac tires are bald after 20K of mileage. The dealer is no help. I am told that it is up to me to prove manufacturer defect. Has anybody come up with a solution on this?
  • I would presume that the place where you took your vehicle did something to the brakes or your steering components so you would have to bring the vehicle back for costly repairs. If you think I am kidding, think again, it is done all the time by private garages as well as new car dealer service departments.
    Do all your maintenance checks yourself. If you can't, get word of mouth references for a good mechanic. Not the one that is most convenient to go to, or does a lot of advertising. Good mechanics don't need to advertise...
  • 24kilo24kilo Posts: 1
    I just bought a 2003 Escape Limited, The horn doesn't work, Book says the fuse id suppose to be top drivers side fuse hole under the hood. Problem is it's a blank hole, so where's the fuse? BTW The Panel diagram and the owners manual jibe up, Haynes manual doesn't show it, and can't find it in the schematics
  • patcalpatcal Posts: 1
    I have a 01 Trib DX with the 2.0L I4. I have a rough & unsteady idle after the car is warmed up. I also have no codes. I pulled the IAC & cleaned it with carb cleaner. While it was out I checked it for resistance between the plug & got 9.7Ohms. I re-installed the thing & still have this issue. I have checked for vacuum leaks but found none. Before I spend $117 (local dealer price) for a new IAC, what else should I look at? Thanks.

    Pat Callaghan
  • we also have a 01 Tribute that is dead. We brought it in 4 times for a stalling issue, just last month after spending 585.00 to fix it, stalled on the way home at 50 mph, after being parked it won't start. You can also file complaints with nhtsa.gov and autosafety.org. I have and so have many others. Best of luck to you. We are fighting the same battle.
  • wtd44wtd44 Posts: 1,211
    I am wondering what response you might get if you offered to trade it in at the original dealer's place for some other vehicle. This might give you a far better insight into what they really think about the problem, and possibly give you some "ammunition" for further action-- or make the trade, if the offer is good enough.
  • ukbornukborn Posts: 1
    How is this done when the door won't open to give you access to the front panel screw? :confuse:
  • I have a 2002 Tribute, purchased 7/02, with less than 35,000 miles and am told I need a new exhaust manifold. I am past the 36 month warranty period, but obviously concerned that a manifold would go out with less than 35,000 miles on it. Anyone have any information on hidden warranties, or ideas how to approach dealing with such an expensive repair so early?
  • tclinetcline Posts: 5
    I am sorry, I haven't figured it out yet. It seems as though right around 60k miles it dies. I recently pulled the dash apart to look at it hoping it was a bulb but I could not see anything. I didn't want to pull the whole assembly apart to investigate further for fear of breaking something else. If anyone else has figured it out, please post the problem. Thanks. :sick:
  • I have the same problem - brakes gone after 20,000 miles on a Ford Escape 2005. I agree - this is unheard of on any vehicle with this low mileage. No adjustment offered at the dealer. Did you get any relief from Ford? I can't send $275 for new front end brakes every 20,000 miles. Also - per the dealer the rears are being reworked from some recall. Anyone have any suggestions??
Sign In or Register to comment.