Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Escape Mazda Tribute Maintenance and Repair

1156157159161162199

Comments

  • pilot9pilot9 Posts: 3
    The most I've driven with my 03 is 25 miles and sitting on the red line.
  • brad54brad54 Posts: 5
    Hello,

    The light for the gear selector on my wife's Escape went out. Can this be fixed by replacing a fuse or is it more likely to be a bulb that needs replaced?
  • brayboyjbrayboyj Posts: 1
    Got it check from dealer can,t find the problem but now the 2002 ford escape will bottom out if I get on the gas. And runs ruff. I was told to change my Ignition Coil I need to find out what the problem is before I pay for something I don't need. Please help me out!!!! :(
  • pmeindlpmeindl Posts: 2
    I had a battery go bad in my escape. According to autozone, the battery's cell went bad. Anyway, i jumped it and replaced the battery. However, i noticed too that my radio, dome lights dont work. As a matter of fact, it appears that every time i turn the key off now, it kills power to everything that work when the key is on like headlights, power door locks, keyless entry and etc.

    I pulled my battery terminal off last night just to see if something needed to reset. I too am stumped as to why everything worked before the bad battery, but not after the bad battery.
  • pmeindlpmeindl Posts: 2
    I have an 02 escape xls v-6 with 85,000 miles on it. Only problem i have had so far was after a battery dying, my radio nor lights work. Other than that, its been a good vehicle. I also towed a small trailer and boat with it before Katrina. It was easier hauling small trailers with that over a f-350. But so far, i have been pleased with its performance.

    Like another person said, the trans that failed in afew hundred miles is a factory defect. Most other stories about trans failing (like at 60,000 - 80,000 miles) are usually because the fluid and filters are never changed. I change my engine oil every 3,000 - 5,000 and trans fluid and filter every 30,000 - 35,000 miles.
  • tonyfordtonyford Posts: 14
    "and trans fluid and filter every 30,000 - 35,000 miles."

    All Escapes have the CD4E automatic transmissions. This transmission has NO servicable filter. Inside the transmission there is a screen that provides some sort of filtering. The only way to access this screen is take the transmission apart. Some mechanically inclined owners have installed their own outboard filters in the return transmission coolant line from the radiator.
  • tonyfordtonyford Posts: 14
    You should get that Mobil 1 synthetic oil out of the CD4E transmission before you do permanent damage to the transmission.

    After reading the message below I called Ford and they did confirm that only Dexron-III/Mercon made from natural oils (no synthetics)should be used in the CD4E transmission which is used in all Ford Escapes.

    Ford Special Service Message 16896:

    SPECIAL SERVICE MESSAGES 16896
    2001-2004 ESCAPE USE ONLY 'MERCON' -- NOT 'MERCON V' OR 'MERCON SYNTHETIC' FOR THE CD4E TRANSMISSION ALL 2001-2004 ESCAPE VEHICLES EQUIPPED WITH A CD4E AUTOMATIC TRANSAXLE EXCLUSIVELY USE 'MERCON' FLUID -- NOT 'MERCON V' OR 'MERCON SYNTHETIC'. MERCON IS THE ONLY FORD APPROVED AUTOMATIC TRANSAXLE FLUID FOR USE IN THE CD4E. MERCON FLUID PART # IS XT-2-QDX (QUARTS) AND XT-2-DDX (55 GALLON DRUM). FOR CANADA MERCON FLUID PART # IS CXT-2-BM FOR BULK, CXT-2-4LM FOR 4 LITRE BOTTLES, AND CXT-2-LM12 FOR 1 LITRE BOTTLES.


    Do not use synthetic Dexron III/Mercon or Mercon V in the CD4E transmission. Use Dexron III/Mercon made from natural oil. The is a case where the cheapest is better, no additives or inhibitors added, the trans does not like those things.
  • wtd44wtd44 Posts: 1,211
    How about my 2005 V6 Escape XLT? What tranny fluid should it have?
  • tonyfordtonyford Posts: 14
    quote myself; "After reading the message below I called Ford and they did confirm that only Dexron-III/Mercon made from natural oils (no synthetics)should be used in the CD4E transmission which is used in all Ford Escapes.

    Unless you DON'T have a CD4E transmission, read the above. The dipstick and handle were changed in 2003 or 2004 to read "USE MERCON"...

    Do NOT use Mercon V or synthetic Dexron-III/Mercon. Just regular Dexron-III/Mercon...it's not that hard to remember..

    This fluid is sold as Dexron-III/Mercon....I have yet to see just Mercon on any bottle of this fluid...reason is the fluid can be used in some GM transmission as well as Ford and other types of transmission requiring either Dexron-III or Mercon...
  • escapenutescapenut Posts: 117
    I've been running Mobil 1 Synthetic Transmission Fluid since about 45K miles, when the tranny was well out of warranty. I currently have 88K miles, no problems. The shift-points are smoother and generally the tranny has functioned as normal (or better than). My tranny dipstick from the factory even says Mercon V, which I was told in earlier posts was a factory error/flub-up. Funny thing was I ran the tranny on Mercon V after a flush at 25K miles, no problems. When I converted to the Mobil 1 Synthetic I hesitated at first, but decided to go ahead d/t Mobil 1 being compatible with all fluids and most transmissions with few exceptions. Still no problems yet.

    I talked with a very reputable transmission shop in town. The owner stated that the CD4E is problematic and usually has had a history of cratering at 75-80K miles. Ford did some modifications to the CD4E to bolster it a bit before it went in the Escape or so I've heard. I'm banking on my average of every 25K+ miles flushing the transmission to avert problems. May or may not happen, but if I go over 100K miles (probably by EoY 2006) with the transmission functioning as normal, then there may be something to be said for the Mobil 1 syn. trans. fluid changeover. I firmly believe flushing the main fluids in any car should be done as matter of course every 30K miles. At least I'm sold on it.
  • tonyfordtonyford Posts: 14
    Believe me, if what you say is true, your case IS the exception and NOT the rule...

    I don't have enough fingers and toes to count the number of trannys that went south because Ford or the owners used Mercon V or synthetic Dexron-III/Mercon...

    www.escape-central.com...engines and transmissions
  • I've had my 2002 Escape for about 2 years. I love this vehicle, but for the last few months the radio has been behaving erratically. It will go into the seek mode all by itself. Or it will skip to the next CD if I'm in that mode. Sometimes it turns on all by itself or will jump between FM mode and CD mode. I think it is possessed. Has anyone else had problems with the 6 CD radio? Is there a fix outside of a new radio or aftermarket radio?
  • escapenutescapenut Posts: 117
    Don't know what to say, other than I tried it and it has worked for me so far. However, I realize that the CD4E is problematic and could crater at anytime regardless of what I have in the transmission.

    My transmission-questions experience with Ford corporate and the purchasing Ford dealership were not great, because my Escape was out of warranty. The dealer told me not to worry about the Mercon V dipstick (out-of-sight, out-of-mind) and Ford corporate did not seem too terribly worried one way or the other. So based on a good mechanic's advice I went with the Mobil 1 Synthetic tranny fluid at 45K miles (I posted 25K in a previous post.
  • tonyfordtonyford Posts: 14
    You know what they say, "If it ain't broke, don't fix it"...just continue what your doing if the tranny is running good...sometimes you wonder who to believe anymore and the only way of truly finding out is from your own personal experience...
  • cruise1cruise1 Posts: 8
    Hi:
    I too have a 2002 Tribute. I didn't buy it new but used in August 2005. I strongly suspect that it is a cracked Exhaust Manifold. Are you having a lot of fumes coming into the car when the heater motor is running? That is my problem. My car has 53,000 miles on it. I'm told that if you have a 3 way valve Catalist on your manifold you are under warrantee up to 80,000 miles. It is a difficult job that will take some time to fix. Let me know more about what you experienced with your problem. Good luck!
  • escapenutescapenut Posts: 117
    ALLDATA says that the parts are $510 for RH manifold and $325 for the LH manifold + 2.7 and 1.4 hrs. labor respectively to replace each separately. A mechanic friend has told me that I've got a minor crack in mine that hasn't expanded yet, so no problem so far, but it could become one later. Seems hard to believe that parts and labor could run so high or effectively about $1400-$1500 to replace both manifolds. According to what you wrote, I may have been covered up to 80K miles, but am well past that now. Oh well...
  • cruise1cruise1 Posts: 8
    2002 Mazda Tribute. I bought it in August 2005. Using the air conditioning never showed the problem of strong exhaust smell in the duct system. Once I used the heater I had this "strong exhaust" smell. When I stop at the light it is so strong that I must turn the blower switch off. I took it to a garage and we hoist the car and found not leak at the donut. We opened the hood and found a very strong exhaust smell at the exhaust side of the engine. We heard the leak. I took it to a Mazda dealership in PA, and they checked it out. I got the message that their is no exhaust leak. Later found that this was one of their best Mechanic's, said. They sprayed lemon disinfect in the vent system saying that mildew is in the air condition system. I don't believe them. I do not have an odor when driving down the road with the air conditioning or heater motor on. I have been a mechanic since I was 15 years old. I am now 62 and still doing it but at a slower pace. Who can I contact to get this heard? Now I have 53,000 miles on the car. The exhaust manifold has a 3 way Cataylist valve system on it. That gives me warranty up to 80,000 miles on the exhaust manifold. I'm not happy that I am driving a car that isn't allowed to be on the road because of exhaust leaks according to the Pennsylvania inspection code. Something must be done soon. I feel they need to check this smell with a meter that detects exhaust Carbon M. Thanks Please get back to me on this.

    PS. Today, I went down to the dealership and the service manager was very courteous and tried to smell the gases under the hood. I felt sorry for him because he had been sick with a head cold and couldn't smell. He offered to have another Mechanic look it over. I respect that. But after he said that we started to just touch the throttle under the hood and speed up the Rpms. He noticed the exhaust lead through sound. It is now being going over. I don't know where they will find the leak. Pleas respond if anyone has had this kind of problem with their Mazda or Escape. Thank You
  • cruise1cruise1 Posts: 8
    I don't understand what is being said when you said your friend said: RH manifold & LH manifold! It just doesn't make sense that both exhaust manifolds are cracked. In my case the odor is coming from the firewall side which is close to the windshield. I do know that the dealer said that if any manifold is cracked up to 50,000 miles you are protected through the warrantee. If above that amount up to 80,000 miles and you have a 3 way Catalist attached to exhaust manifold. By giving your vin number you will know if you have this 3 way set up. Do you get a lot of fume in the heater system??? That's my problem. What I understand you saying is that you are way past the 80,000 miles. Do you know that the exhaust manifold is steel? You could take it to a reliable indepenent garage and have them take it off and weld the manifold. That was one offer I got from a friend of mind who has been in the garage business for quite a while. You don't want to run the high risk of having gases in your car and perhaps die. Let me know what you think! Thanks
  • escapenutescapenut Posts: 117
    Can't remember which exhaust manifold it was but one of them was cracked, but not all the way through, so no exhaust fumes, etc. in the car yet. The friend indicated that it may have to replaced or fixed one of these days, but hopefully not nay time soon. It'd be a rather expensive fix, unless the bead-weld might fix the problem, if the it was fixable like that.
  • I have a 2001 Ford Escape. Lately some wierd problems have been happening, milage is currently at 67K. First thing to occur was that it wouldn't want to always crank up. It wouldn't roll over until keeping cranking it much longer than its supposed to. Hasn't done it in a while, I cleaned the battery terminals, but also has been cooler outside if that has something to do with it.

    Next thing that occurred was the radiator fluid light is on constantly. The fluid was full when I check it, and the car never gets passed the middle mark on the thermostat, infact it never budges at all. Had the radiator flushed, still does it.

    The most recent and the BIG BIG problem that worries me is that the overdrive light has started flashing. The speedometer started acting erractic around the same time, jumping from around 20mph to 60 although going the same speed. Got the transmission fluid changed.. it didnt do the overdrive light thing for a week. Fiance called today and said it started flashing again.... Haven't noticed any performance changes cept that today she said it seemed like it was changing gears a lot more than normal.

    Please help, there is no possible way I can afford a new transmission... and I fear that is what it is coming too :(
Sign In or Register to comment.