Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Escape Mazda Tribute Maintenance and Repair

1166167169171172199

Comments

  • explorerx4explorerx4 Central CTPosts: 9,459
    it is not still under warranty? check your owner's manual for why the light is on. it may not be the emergency brake.
  • I bought a new convenience 06' Mariner AWD and it makes this noise even when parked. It is like a grinding noise that transfer some vibration to the sterring wheel. I hear it all the time during acceleration, slowing down and when pressing the gas pedal when parked. I've taken it in to the dealership twice and they tell me that they've compared it to other similar models and they all make this noise.

    It is becoming very irritating, specially for new car. Does anyone have any similar experiences with a new Mariner, Escape or Tribute?
  • bdymentbdyment Posts: 549
    Well, overall we are very pleased with our 2007 Limited. One complaint--the hardest, unpadded armrest-- in the recent history of auto design. I have some left elbow problems and this armrest sure doesn't help.

    Bruce
  • I have a 2002 ford escape with 143000 miles. I have noticed recently that when I go over a bump or pothole in the road, I get a noise that's a cross between knocking and creaking. It's in the front axle, and I believe it to be mainly on the passenger side although it could possibly be accross the front. I'd like to know if anyone else has had these issues, and what it ended up being. I just replaced the tires so I don't want to drop a load of money to not fix it. Also, my front driver side speaker has blown. I never had this problem in my Camry. Anyone else experience this? Thanks!!
  • jonj1jonj1 Posts: 1
    when looking at the rotors there should be clips that look like washers on 2 of the wheel studs. remove these however you can. I usually cut them off with a pair of dikes(pliers). then if the rotors are stock on the hub still take a hammer and hit the rotor a few hard hits between the wheel studs. That should loosen them up. Do to the differant kinds of metal used there is often a type of electrolysis that forms almost welding them to the hub. it usually only take 2 or 3 good hits on the hub face of the rotor to free them up.
  • Just happened across this site looking for a brake booster. I am glad to hear other people are having trouble with the seats in there Ford Escape. I had my 2005 about 5 or 6 months and my rear seat started fraying. At that time no one had ever sat in my back seat. I now have a dog I take with me in the back seat, however they frayed long before I got her. Like everyone is saying this will kill my trade in value. I went to the dealer with the problem and told them I knew upholstary was not covered under warranty but would they please look at it. They did and said they have a company that would look at it and maybe the dealership would warranty it after the company looked at it. Problem was that the company had shut down for 2 weeks for their daughters wedding. That was last year and like others due to my working schedule I never got to make an appointment to have them check it out. Now I am almost embarrased to ask. Maybe with copies of these messages in hand I will go to the dealer and ask again.

    Thanks

    Sparkyd
  • I bought 2001 3.0 tribute last summer and there was no problem until the summer was over. I'm in cold area, Calgary Canada, by the way.

    I'd noticed rough idle when cold start in the morning around October and it's getting worse(sometime stall) as the tempature went down. Once the engine tempature goes up to normal, no more rough idle.

    I've also noticed that if I use "block heater" during the very cold days, rough idle is not so bad.

    Finally, I got the engine check light on, so replaced spark plug, fuel filter, air filter, IAC valve and ECT senor by myself. Sadly, I still have the rough idle in the morning. :cry:

    Are there anything I can do before I go to mechanic or dealer?

    Please help....
  • I am having the exact same problem with my '01 3.0l Escape.
    As soon as the temp gets into the 30's (F) the idle goes to hell in the morning. Once it's warmed up it's fine.

    I replaced the plugs about 2 weeks ago, but that did nothing. I haven't had the check engine light come on, yet, but I am dreading the morning it does.

    I have also run a small heater (blowing warm air under the engine compartment) overnight and this does seem to help.

    Wish I knew something to be of help to you. I'm just hoping someone out there has some idea of what our vehicles problems are.
  • Hello,

    I've been trying to figure out how to adjust the parking brake on my 2005 Tribute. I assume there is a screw to adjust under the center console. The problem I have is I'm having a difficult time trying to get the console off. Being that it's made out of plastic, I don't want to try and force it too much.

    Thanks for any help.
  • Underneath your car there is a row bar, I believe it's called. They are held by 2 clamps that have like a rubber insulation so that the clam and the bar don't grind. After years the rubber really dries out. It's best to change the 2 clamps. I lubricated them and the sound goes a ways for about a week or 2.
  • I had my master cylinder right before Thanksgiving. My brake warning light came on again the other day. I took it by the shop and they said the master cylinder was bad again. Luckily the second replacement won't cost me anything, but I'm concerned. The person at the shop indicated that Escapes tend to have trouble with replacement master cylinders, and they often take a few tries.

    Has anyone else experienced this? Could it be a problem with the shop that I use?
  • My 2005 Escape had it's fraying front seat covers replaced at 5000 miles. I now have 50,000 miles and the rear seats need to be replaced and the front ones could be replced again. Today I asked the service writer about it and they said they've never heard of any problems with the fabric seats. I am not surprised to hear that I am not alone. Are there more people with these seat problems?
  • With the parking brake lever in the down position, look on the left side of it. There is a rubber strip between the lever and the plastic housing, peak down between the lever and the housing and you will see a screw head. I think its a 10mm. Use a deep socket to adjust it.
  • Every now and again the stereo display will fade out/go dark and then come back on after a minute or so. I haven't played with it so I dont think it could be a loose wire or connection. Any ideas? Thanks
  • caschecasche Posts: 1
    I also have a 2001 3.0 Tribute that is experiencing the same problem. When I start it in the morning it will barely idle and want to die. This is only on very cold days. After it warms up it is fine. I recently took it to a local mechanic and it was diagnosed with an upper intake leaking vacuum...I believe a plenum gasket. I am having the dealer where I bought this take a look at it next week, so I can take advantage of the extra mechanical warranty coverage I bought with this vehicle. I hope this helps...
  • Does anyone at the dealership know the "fix" for a transmission that "shudders" when shifting from 1st to 2nd running between 40-45 mpg at approx. 1500-2000 rpm?? I have a 2003 Tribute that exhibits this problem. I have the extended 100,000 mile warranty with about 70,000 miles currently on the vehicle. This problem is not consistent. Dealerships says bring it in and they will have a look (for a $100 charge for looking) If the problem happens when they are doing the test drive, I just have to pay my deductible and they will "fix-it" (What ever that means) If they can't reproduce the problem,,,,,,I'm out the $100 bucks and down the road I go.
  • bdymentbdyment Posts: 549
    What engine and transmission combination do you have?

    You say the transmission shudders from 1st to 2nd between 40 and 45 mph. Don't you mean it shifts from 3rd to 4th at that speed range? If it is at 40+ you are winding the engine way too far for 1st to 2nd. What is probably happening is the torque converter is locking up at that speed range or you have just gone into overdrive--4th and the engine has lugged momentarily. I don't think it is serious.
  • I am having the exact same problem. I just had my second master cylinder replaced. Have you found out any more information, is it the shop or the Escape?
  • Hello.
    Who ever you are taking your escape to, whether it be a Mom and pop auto repair or a dealership, you might want to change repair shops. i see this all the time, you might get a bad master cylinder once in a while, but to hear your repair shop saying, this happens to all escapes, and it usually takes a couple of times to get it right. :P BALONY!!! There was air in the Brake System, and he was too lazy to purge the System. That is why the Master Cylinder went bad. Please take it somewhere else. I hope this cleared up anything. :)
  • I have replaced my master cylinder on my 01 escape for the third time since September 06. The first two were rebuilds, and both were leaking into the brake booster. The third one is brand new so hopefully this will be the cure. It was a defect in the rebuilds so they tell me...New run about $100 more than rebuilds.
Sign In or Register to comment.