Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Isuzu Trooper Engine Misfire

2»

Comments

  • sounds like the o2 sensor(s), that was the problem with my 92 trooper. i had changed it a few months earlier and that o2 sensor failed....it was putting up black smoke, running rough and using at least twice as much fuel. i replaced the o2 sensor again and it has been running fine ever since. the code for mine was 17, but its the old style computer, the o2 light never came on, neither did the check engine light, but the code was there. after changing the sensor, the codes were clear. i hope the problem with yours is that simple
  • paisanpaisan Posts: 21,181
    When did you change your plugs last? Could need new plugs and/or wires?

    -mike
  • Just had the plugs replaced. Still doing it. Checking next week on the O2 sensors and the coil packs. Check engine light came back on less than 5 minutes after being reset at shop. Any other ideas? I'll let y'all know. Thanks!
  • Not sure about the '98 but 2000 Trooper will only like the 3 specific plugs listed in the manual. Using any other plug will probably trigger the CEL pronto. I have these listed in my notes as being recommended in the manual. My '00 had the 3rd one listed, Champion. That is what I used for replacement

    K16PR-P11
    PK16PR11
    RC10PYP4
  • Change the timing belt & timing belt tensioner. I'd also change the water pump while I was in there. Problem solved. (Been there, done that).
  • my bother is have a problem with his trooper his number five cyl does not have any spark all the rest seem ok he took the plugs out in check them they all look good but number five plug.He move the coil pack from a good cyl to number five still no spark change plugs.Number five plug is wet with gas when he take it out. it a 95 anybody have these kind of problems. :mad:
  • I have a 2001 trooper . i am getting the p300 EGR and p1340 ignition controle misfire......now...i have read the topics of the egr and i took the egr off and cleaned it well.....cleaned the tube perfectly.....im thinking im gonna have to buy a egr.....but what is the p1340 the engine seems to run great....i went by auto zone and had them reset the codes and the engine light came on right after leaving the parking lot.....im gonna go back and get them to do it again......but what is the misfire code telling me other than just misfire......is there anyone out there with details of their issues.....thanks....
  • atfdmikeatfdmike Posts: 414
    I could not find specific code but it is a misfire. Your trooper may have that fancy ion sensing system for ignition....fussy about misfires and plugs.
    found this on another site: "If you have a 2000-2004 Isuzu, make sure you only use Denso K16PR-P11 spark plugs. The 2000-2004 engines have the GM/delphi "ion sensing" ignition system where the spark plugs are used as a sensor (when they are not firing) to measure the electrical resistance of the gasses in the combustion chamber. Other plugs may cause the ECU to register a code (misfire code: P1340). Also, it has been noted that some 00 trucks came with champion plugs from the factory, which cause knocking, due to to ion sense coils.

    If you have 1998-1999, the suggested plugs are NGK or Denso or Champion double platinum plugs"

    HTH
  • wlbrown9wlbrown9 Posts: 835
    I have a '00 Trooper with the Champion plugs from the factory. Replaced them with the exact same and have never had an issue with knocking. The following are what the manual shows for '00:

    Manual:
    K16PR-P11
    PK16PR11
    RC10PYP4 (Champion I believe)

    Bill
  • diesel3333diesel3333 Posts: 1
    I hate to dredge up an old thread but came across your experience while researching about a similar experience I'm having with my 2000 Trooper. The engine bogs at 40-45 mph and won't maintain speed (65-75 mph) in top gear on the highway. An abrupt downshift brings back the power and speed but after the resulting upshift back to fourth gear, no amount of throttle will maintain speed. After about two cycles of this shifting and bogging/lugging, the CEL will flash but doesn't leave a code. Upon slowing down, the CEL goes off and the engine stalls when I come to a stop. A compression test shows 150-155 psig on five cylinders and about 135 on the passenger side front cylinder. All plugs look fine (dry with a little black on the end) and the plug wires/coils also appear to be in decent shape. I will clean the EGR and PCV tonight. The trooper has about 55k miles (unless a previous owner has messed with the odo) so I'm a bit baffled by this lack of performance. Lastly, the fuel mileage has dropped from about 14 mpg to less than 12. Any help would be appreciated. Thanks in advance.
  • wlbrown9wlbrown9 Posts: 835
    I'm no expert and this is a shot in the dark...but how is you cat converter? It might be possible that it is starting to plug and back pressure could cause the problem with maintaining speed on the hwy. But if you can downshift and get decent performance in 3rd that might make that possibility a no. Good luck on finding a resolution.
  • This problem showed up about 8 months ago. since i have replaced all spark plugs with ngk and then again with champions, i replaced fuel injector, coil over plug, muffler, and battery. ive cleaned egr valve and maf, and throttle body. intake gasket is fine had a shop replace the timing belt and checked compression in all cylinders. compression is 170 - 172 in all 6 cylinders. when i change something it runs 2 - 3 weeks then bam code p0303. any ideas would be greatly appreciated.
  • 1996 3.2,which cylider is 3 if u are standing in front of car looking at engine?
  • atfdmikeatfdmike Posts: 414
    #3 is on passenger side (Right), middle cylinder

    firewall
    5 6
    3 4
    1 2
    fan
  • lemon19lemon19 Posts: 8
    HELP.... I recently change out the motor on my 2000 trooper 3.5L and change the water pump and timing belt and retime. The engine would start but run really rough. I can take out plugs 2,4,6 and the car wouldn't stall or act like its losing power or die out, but if you take out 1,3,5 it die out right away. Is this normal????? Also no power when driving the car. I check for compression and sparks everything there. Really confuse, what could be wrong? Please help....
  • catfuzzcatfuzz Posts: 1
    You have timed the engine wrong. If you followed a Haynes or Chilton manual, this is the result. They don't have the correct procedure for these engines. Tear it back down, line up the crank mark with the mark on the oil pump. Now, locate the timing mark on the passenger side head. Turn the cam and it will thunk thunk into certain spots. Keep thunking it around until the mark on the sprocket naturally lines up with the mark on the head. It may take several turns. Then go the drivers side. There are TWO marks on the head for this one. One that is in a similar location to the passenger side and another one about 90 degrees to the LEFT. Thunk, thunk the cam until it naturally lines up with the second mark mentioned. Now, turn the sprocket to the right 90 degrees to line it up with the top mark. It may not want to stay there. Install your belt with the marks on the belt lining up with the timing marks and hold it in place with some clips. reset your tensioner and install. You can install the lower crank pulley temporarily and start the engine to confirm you got it right.
  • lemon19lemon19 Posts: 8
    Catfuzz your the greatest. You are a pro... Next time they should let you write the book.. Thanks for your help. I did tried it 3 times and it didn't work. My friends thought I was crazy bout only one side of the head working. Again thanks.
2»
Sign In or Register to comment.