Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Blazer Trouble Codes

2

Comments

  • My check engine light came on and the blazer was running rough so I pulled in to auto zone and had them hook up the machine to it and code p1406 came up. I was told buy a dealer that it was a EGR sensor. So I have 3 questions for any one that can help me 1) will it make the rpm needle go crazy (up and down) 2) it it hard to replace and 3) where is it located?

    THANK YOU IN ADVANCE
    FOR YOUR HELP :cry:
  • jlflemmonsjlflemmons Posts: 2,240
    1. It can make the idle irratic
    2. Located on the front of the engine. Go to Autozone online and you can look up the part and see what it looks like.
    3. Easy repair.
  • hey has any one had this trouble
    I have checked fuses and replaced mir 3amp fuse that should run the tailgate and door lock and power mirrors as per chevy but still no go.
    key fob will not open up tail gate as well.
    any ideas ?
    thanks
    Doug :(
  • duntovduntov Posts: 133
    If the accessory control switches are functional, it is likely that the relay for those accessories is bad. Replace the power door lock relay because it is also common to the other accessories you mentioned. You can use Power Door lock Relay from AC Delco F1788, $42 (GM 88922752 - MSRP $78 ); Standard Motor Parts RY246, $26; or Air Tex 1R1269, $23. That relay was used on many GM vehicles with power door locks since 1980. The relay is located behind the headlight control switch cluster on a 1989 - 1995 S10 Blazer. I am not sure where it is located on other GM vehicles. If a auto repair shop replaces the relay, they will charge 1/2 hour labor cost plus the cost of the relay. That will be about $100+ total .replacement cost.

    A bad relay can also cause a 200+ ma parasitic power drain on the battery even when the ignition key is off. If the vehicle sits for a week or two without being started, the power drain could completely discharge the battery, especailly if the battery is over 18 months old.
  • RABIIIRABIII Posts: 2
    Any idea what these codes mean and how to repair the problem?

    1996 Blazer LT 4.3 190,000 miles & still runs good
  • jlflemmonsjlflemmons Posts: 2,240
    P0719: Do your brakelights work? This is the code for low voltage in the brake light circuit. Blown fuse?

    P0753: Transmission solenoid related. How is the transmission shifting? Could be anything from a shorted harness to the tranny to a bad shift solenoid.
  • RABIIIRABIII Posts: 2
    p0719 - Corrected by installing a new break switch and fixing a frayed wire.

    p0753 - Corrected by replacing both solenoids in trans.

    $54 in of parts & $314 in labor to to pass emmisions test.

    Go figure.....
  • I've had some problems with my blazer. It started skipping/missing a little, not much. Drove it from a cold start about 3 miles to get gas, gave me trouble cranking but did eventually crank. Did this a couple times. Drove it between these events and then one day at work tried to leave and wouldn't crank again, at all. Tried a few days later, no luck. Been about 3 weeks and this morning it did crank, idled for about 15 minutes, drove it a couple blocks and parked it, shut it down, restarted it but did start hard. Talked with a mechanic and was going to drop it off for them to do the fuel pressure check and all. Cranked right up, ran a minute, then stalled and now it won't crank again.

    We put a new fuel pump on it about 1-1/2 yrs ago but the oil changes haven't been kept up for the last year or so. The check engine light has been on for a long time but never did anything about it because it seemed to run fine. We are short on vehicles and I need help. Hoping it's not the spider injector. Can anyone give me direction?
  • Sounds like your EGR valve :)
  • ppickappicka Posts: 2
    I have a 99 Blazer w/63K miles when the 4 WD light came on.I went to a Chevy dealer and was told that a DTC CO323 was the problem and would cost $830.00 to fix .Additional info from dealer :Regular production option code NP8-transfer case two speed push button.Could anyone help me understand this problem ?Also if I have this fixed will my 4 WD work?? Thanks
  • diedie Posts: 4
    Engine light on scantool code p0128.. does the engine have a mechanical thermostate or do you change the censor...
  • jlflemmonsjlflemmons Posts: 2,240
    Change the thermostat. Take a look at your temp gauge and I bet you are only reading ~150 when fully warmed up. I had to change the thermostat on both my Blazers this winter for the very same condition. They open up too soon and the engine never gets to 195. The pluses are that it is easy to change, a top quality (Stant) part is not expensive, and you may actually get a bit better gas mileage out of it as they are more efficient when fully warmed up.

    With the engine cold, just pull the thermostat housing off without draining anything. You will have to remove part of the throttle cable brackets to do this. Once the bracket is clear, pull the housing, swap the thermostat, and put it right back together. You won't lose but about a cup of coolant. You will need to have the SES light reset. Autozone will scan the code for you, and then hand you the reader to reset the code. I think for liability reasons they cannot reset the code for you.
  • diedie Posts: 4
    thanx for your help....much appreciated :)
  • diedie Posts: 4
    I have a 2005 jimmy , i had a p0128 and changed the thermostate, was reset and showed the codes p0053 and p1133. the engine light came on a few days later.. why after fixing one code two more appear.. (two oxgen sensers were also replaced previously).. I only have 36.000 klms. I know short driving distances are harder on your car, but this is awfully frustrating...as a previous owner of a 1997 astro van, i didnt need any serious work on it untill it was over two hundred klms.. could you tell me pls tell me what i need to replace. and also do you have a 800 number where i can phone and get a service manual for my jimmy,,I had one for my van and it was one of my better investments as my hubby does most of the work thanx
  • jlflemmonsjlflemmons Posts: 2,240
    Both of the codes listed relate to a defective O2 sensor. Could be premature failure of one of the sensors replaced earlier, or it could be the wiring to the sensor got pulled/damaged during the thermostat replacement.

    Is the engine warming properly now? As in going to 195F (90C) within a short period (<5 mins)
  • The code reads "Secondary air injection - incorrect flow detected...please reply if you have had experience repairing what may be causing this code to cause the service engine light to appear.

    Had a complete tune up last month and soon after the service engine light popped up. I took in back in to the dealer and they changed my thermostat. Now I'm getting a PO410 code. I didn't take it in for service yet - thought I would try this forum first.

    Hope someone somewhere knows - I really like my blazer but I have already replaced the trans. which set me back big time. Now it's just general maintenance but the engine light code my be another big expense.

    Thank in advance for your input. VGK
  • diedie Posts: 4
    my husband changed the thermostate first,(under a ten dollar part, we always change the cheapest part first) but the light came back on , apparently there is another thermostate censor... my engine light is off now only cause its warner out... it went off by itself after drivin it in the warmer weather... I still need it changed......good luck ...and let me no how it goes...If u no someone handy its inexpensive to pick-up a code reader...
  • richk28richk28 Posts: 3
    P0410 code is the secondary air pump. This code appears when water gets in the pump and freezes. You should replace the pump and relay. The new kit re-routs the air inlet tube up next to the battery. It is not hard to replace takes about an hour. The best price I found is GMParts house ask for Gene. The kit is about half of what the dealer charges.
  • Your advice is very helpful. Just wanted to say thanks - I'll probably look locally for the pump/kit as I'm on the PA/Jersey border. Have a great day.
  • i have a 2000 chevy s10 blazer ls with about 190000 miles. and my check engine light is on and it is an emissions code. what should i do? and also my interior thermometer reads "OC" how can i fix that?
  • duntovduntov Posts: 133
    I would first check or replace the EGR valve on the engine. They can get stuck with carbon deposit in a high milage engine when the vehicle is held at a continuous highway speed above 60 MPH for about three or four miles. That especially occurs after the vehicle has been in slow stop and go traffic for a few months. When the SES light comes on, stop the car, turn off the igintion for ten seconds and the SES light will go out. That is what I have to do on my 1991 S10 Blazer. I fixed the problem by driving at 80 MPH for about ten miles about once a month. Tell the police that you are testing your EGR valve, .I am sure they will understand.
  • jlflemmonsjlflemmons Posts: 2,240
    Do you have the code that has been set?

    OC on the temp indicates either a failed temp sensor (behind the grill. You can see it clipped to the radiator support) or a damaged wire/connector. The "OC" means "open circuit".
  • jlflemmonsjlflemmons Posts: 2,240
    There is a temp sensor located in the drivers side head, just above and between the #3 and #5 sparkplugs. That would be the middle (#3) and back (#5). What does the gauge read when the engine is fully warmed up?
  • i believe that the code is P404. but i could be wrong. someone told me it was my purge valve solenoid :confuse:
  • jlflemmonsjlflemmons Posts: 2,240
    That code comes back to an EGR issue. Here is some more information:

    GM P0404
  • i have a 2000 chevy blazer with about 197000 miles. my check engine will not go off and it is reading p440
  • jlflemmonsjlflemmons Posts: 2,240
    Check the gas cap, and also the hoses and canister behind the drivers side rear wheel. This is an evaporative emissions code, so something is wrong in the capture systems. Look for cracked or broken hoses, most are bigger than a vacuum line and smaller than a heater hose.
  • i have a 2000 chevy blazer and my check engine light has been on for about a month now. i bought a lock gas cap, and replaced a cracked and disconnected vacuum line. what else would it be. and how could i fix it?
  • I had a PO 410 code and my mechanic found a 30 amp fuse for the A.I.R. pump. He was going to replace the pump but after taking it out and testing it, it was okay. Since the new fuse was put in...the light hasn't come back on but it's only been 200 miles. Good luck with your 440 code.
2
Sign In or Register to comment.