Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Lexus RX 300

1290291293295296304

Comments

  • sam421sam421 Posts: 14
    Hello all I resolved the problem (well the dealer did). I took it in yesterday (this is the 4th time for this problem). I bought the car June of last year and 3 months in I hear that noise. It feel so damn good not to hear or feel that noise! The dealer said it was a faulty rear speed sensor. Here is the info directly from the work invoice if it means anything to you:

    A. 896091 REAR SPEED SENSOR (ONE)
    115IELEX
    1 89545-48020 SENSOR, SPEED, RR RH

    B. CU STS TRACTION LIGHT
    989 SEE LINE A.
    115 ISP

    Fortunately, it was covered under my CPO 3-yr warranty. Somehow, at first they thought I didn't have the warranty (why I have no idea?) and were going to charge me "half-price" which came out to $640.00 with tax and all. I asked why it wasn't covered and at first they asked if I had an extended warranty. I said no I have a 3-yr CPO warranty. Then he said that all the work is considered "maintenance." I disagreed and said I do not have the money for these repairs. He said he would call me back. He never did and I just went there and got the invoice with all work complete at no charge. I guess it was my lucky day hahaha !!

    Moreover, if they did not fix it I was going to bring it to my mechanic and he said he would charge me half of the $640.00 for all the work. He is very good with Lexus vehicles and orders parts directly from the dealer i go to. I know this because I went with him to pick up my "Lexus" brakes and other stuff when I needed them done! My mechanic charged me $400.00 for the brakes work instead of the $750.00 the dealer wanted. What a rip-off the dealers are.

    Hopefully this helps others and I will definately be back to the board for updates and information. Thanks all and Happy Halloween!
  • Using my remote I no longer hear an audible verification when my vehicle has locked. I do hear the sound when I unlock it. Any thoughts?
  • cc2718cc2718 Posts: 18
    Thanks for sharing the info. Should there be any warning light if ABS speed sensor fails? I'll keep that in mind.
  • chikoochikoo Posts: 3,008
    My mechanic charged me $400.00 for the brakes work instead of the $750.00 the dealer wanted. What a rip-off the dealers are.

    Was this all 4 wheels brakes replaced? Then it sounds good.

    If it was only the front brakes, I did get my nephews Lexus brakes done for about $200. Purchased the parts from PartsAmerica.com, took them to my mechanic who charged an hour of labor, when in reality he worked for less than half an hour. But I was willing to let that slide. That's it.
  • sam421sam421 Posts: 14
    No, it was only the front brakes but I wanted the exact parts and things directly from that Lexus dealer. I felt as though it was worth it because I got it done without the full labor charge. Thanks for the info though ... maybe I will go that route next time.
  • cc2718cc2718 Posts: 18
    Front brake pad set costs less than $100 if you buy from the Dealer. So $400 seems little high even if it includes the parts. Toyota/Lexus's brake is very very easy to work on. It should not take a trained person more than 30 minutes.
  • I changed the battery in my '99 last night. This morning the instrument panel is blank and the screen is blank. Car starts fine. I'm not able to shift into gear either. Could this have been caused by an electrical shock? Any suggestions on what I could try to fix?
  • wwestwwest Posts: 10,706
    You missed connecting the "accessary" wire to the battery..?

    Assuming there is such a thing...
  • avery1avery1 Posts: 372
    The warning light that indicates a rear bulb failure has come on. I believe I have checked all the rear lights-backup, regular, brake, license plate, turn, even the little lights on the side of the bumper. Nothing is out. So I assume it is a corroded connection or loose bulb. Does anyone know which bulbs this warning light monitors? And can anyone think of an easy way to solve this without checking and cleaning every bulb? Thanks in advance.
  • pschiffepschiffe Posts: 373
    Also check the "high-mount" stop light bar at the top of the rear window if you haven't done so!

    Pete :)
  • avery1avery1 Posts: 372
    I feel like an idiot. That was it. Now how do I get into it? I don't see any screws on the cover. Thanks for the help.
  • chikoochikoo Posts: 3,008
    slide your fingers carefully and pull it off. It will come off. Use your force judiciously.
  • pschiffepschiffe Posts: 373
    My experience is that you need to use a genuine Toyota bulb. I have found that the similar 921LL Sylvania lamp is subject to premature failure in this application.

    Pete :)
  • chikoochikoo Posts: 3,008
    you need to use a genuine Toyota bulb

    as if Toyota makes the bulb themselves. Sylvania or GE will work just fine.
  • avery1avery1 Posts: 372
    Thanks everyone.
  • mikey00mikey00 Posts: 462
    Using a genuine Lexus/Toyota is not a bad suggestion. We all know that they don't actually make the bulb themselves. It is outsourced same as many of the parts on the car (brake pads, filters, and on and on). I used a aftermarket bulb and it did work ok but the failure indicator on the dash remained on. A Lexus bulb fixed that. Others have reported the same problem on the other Lexus discussion sites.
  • chikoochikoo Posts: 3,008
    Interesting. I just recently replaced the top-mount brake light with a GE light from Wal-mart. Works just fine.

    I am sure others must be using some boutique brand of bulbs that is causing a problem. GE/Sylvania/Osram set the standard in lighting across the world. I cannot believe that Lexus needs a special bulb. In fact, the owners manual also simply states the standard model # of the light bulb and no mention of using a "Lexus" only bulb.
  • wwestwwest Posts: 10,706
    The (non-standard) bulbs labelled "LL" for long life use less electric current/power and will oftentimes trigger the bulb failure circuit.
  • mikey00mikey00 Posts: 462
    As you said Lexus does not really require a special bulb. But the high mounted brake light seems a little picky about the bulb you use. The bulb works, it is just the failure indicator that doesn't like some bulbs. My replacement that I had trouble with also came from Wal-Mart (can't remember the brand). I did read posts from other RX owners having the same problem. It is not necessary to get the bulb from Lexus but it is good to be aware of this issue and try another brand if the failure indicator stays lit.
    I don't think the previous poster was trying to insinuate there is a big bulb factory with the Lexus/Toyota sign on top. But if you buy the bulb at a Lexus/Toyota online discounter or parts counter you most likely will not encounter the problem.
  • chikoochikoo Posts: 3,008
    The (non-standard) bulbs labelled "LL" for long life use less electric current/power and will oftentimes trigger the bulb failure circuit.

    Now this I understand. Thanks!!!!

    I did not use the "LL" bulbs. I just picked the regular one.
  • I was wondering if anyone could tell me where I could find a 3rd brake light that lights up "LEXUS" I was behind a pathfinder the other day and when they stepped on the brakes the 3rd light lit up "Pathfinder" it looked really sharp. I want get one for my Lexus truck but I'm not sure what it would be called or where to find it. I checked a few auto sites but I came up with nothing.....
  • wwestwwest Posts: 10,706
    Ebay.com....

    Has replaced the Sears/Roebuck catalog for product browsing.

    But not in the outhouse.
  • la4meadla4mead Posts: 347
    There doesn't seem to be much market for aftermarket RX parts generally, other than typical appearance items and baubles (sp?), unlike other makes and/or truck-based SUVs.

    I'm still looking for a source for larger/stronger sway bars to improve the sloppy body lean and handling. The stock ones allow way too much roll/sway, and my major peeve about this car, well above anything else. The handling could have been much better, with little sacrifice in ride or weight.

    I've found lowering kits, but that's not what I'm looking for. Wider/better tires helped a lot (sacrificing some of the soft ride), but clearly the wimpy sway bars could have been stronger, but I haven't found a manufacturer that offers them for the RX.

    Anyone know of a source?
  • steverstever Viva Las CrucesPosts: 41,618
    Did you check the laundry list at SEMA?

    Moderator
    Minivan fan. Feel free to message or email me - stever@edmunds.com.

  • HELP! I have a '99 RX that had the sludge problem and it blew the motor! Now we have over $8000.00 in repair estimate and we never received ONE letter!
    Where can I find this information? I've just called Lexus and I want this information if.. and when... they call me back.

    Thanks for any help you can give me! Happy Holidays!
  • chikoochikoo Posts: 3,008
    I am glad I could help....

    http://www.oilgelsettlement.com/

    http://www.oilgelsettlement.com/detailed_notice.pdf

    Affected models:

    MAKE MODEL MODEL YEAR
    Toyota Camry 4cyl. 1997-2001
    Toyota Camry 6 cyl 1997-2002
    Toyota Solara 4 cyl. 1999-2001
    Toyota Solara 6 cyl. 1999-2002
    Toyota Sienna 6 cyl. 1998-2002
    Toyota Avalon 6 cyl. 1997-2002
    Toyota Celica 4 cyl. 1997-1999
    Toyota Highlander 6 cyl. 2001-2002
    Lexus ES300 1997-2002
    Lexus RX300 1999-2002
  • Help please! My daughter is driving in FL for Christmas in the RX. There "Check Engine" light is on. They drove for 2.5 hours and the transmission stopped propelling the vehicle. The fluid is normal. They wait for 1/2 an hour and the trans will propel them for 10 minutes. GOT ANY Ideas?

    Thanks
  • rugmankcrugmankc Posts: 133
    Sorry for your trouble with the RX. I am no car expert, but sounds like overheating. Don't know if a certain part is to blame that can be replaced. I would leave it at a dealership and rent a car. That way she is not stuck in a bad place. I have a 2002 and change the fluid every 25k. I started doing this after the first fluid change when my mechanic said the fluid was burnt and very dirty. I blame the high RPM's the engine runs at. Makes the fluid too hot in my opinion. I say that because at 70MPH the tack shows 3K. On my Windstar it is 2200 at 70MPH. If you don't need a new transmission, I would at least change the fluid and keep doing it every 25K at least. If mostly city maybe more. If she is only 3 hours away you may want to go get her.

    Good luck to your daughter,

    Ken
  • Thanks Ken... The RX is on it's way via car trailer to Tampa. The daughter has a rental car is on her way. We did a tranny fluid refill today and that may have helped, but not enough to resolve the problem. I agree - overheating - but why? I found another post on another site that indicated that this is a Lexus common problem and the resolution is a new or rebuilt tranny. Thanks.

    Happy Holidays
  • rugmankcrugmankc Posts: 133
    Glad it worked out from a safety perspective. Don't know why it has to overheat or run at so high an RPM. Not a car tech. I have 98K on mine and it still seems brand new. I hope the 25K xmission fluid changes keep it going. Great SUV. Do the same on all my cars now. Insurance I hope. Happy Holidays!

    Ken
Sign In or Register to comment.