Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Blazer GMC Jimmy Maintenance and Repair

1138139141143144179

Comments

  • repairdogrepairdog Posts: 948
    Lines are additional usually and called a nut kit for some reason that eludes me. As for the 4wd if its 3 button np233 case (tag on transfer case) then it could be many things such as vac line leak, 3 port vac switch on case, front vac actuator, sensor on axle, encoder motor on case that activates the 3 port and front drive shaft, or the TCCM or 4wd computer.
  • havr had that same problem but my heater core was the problem it would clog found that by cutting the end of a water hose and plug it in to the passenger side entry tube on fire wall for the heat core it should blow out anything cause it to not flow or slow the flow of the coolant
  • My 2000 Blazer 4 door 4WD Trailblazer trim 62,500 original miles has its hood latch release lever not working. I can pull the lever and the wire is still attached and I see the wire being pulled, but the hood does not open. How can I fix this?
  • Pull the lever and with a flat side of your fist rap the hood above the release (not so hard you dent it) and it should pop open - then spray that latch above the grill with white lithum grease so it operates.
  • I'm sorry I took so long to get back to you. I unplugged the TCCM and the car is accelerating fine. I've tried cleaning the plug connections on the TCCM and harness but I still don't get any lights on the dash shift buttons, so I guess the problem is the board or the wiring.Because the 4wd has started working on its own twice now I'm thinking it's a wiring problem(maybe a ground)? The service engine soon display is now off.
  • toridtorid Posts: 1
    have 95 S 10 : replaced fuel pump/ filter/fuel pressure sencior / air valves checked lines ..bleaded lines still no fuel to start..can pour gas in and will start till it runs out..now I am not a Mech..I am reading most of how to do on line due to not much funds to work with..single Mom and all..I was told there is a shut off switch for this now some where? That could have been the problem from the start? can some one tell me? If so where I can not find one in the book or on line?
  • Hi Repairdog,
    Your instructions worked perfectly. Thank you as always.
  • I have a strong engine in my blazer that claps.i have replaced vacuum hoses,spark plugs and cables. problems occur with loss of power which i found that some plug cables were not correct. been told to checkk distributer. what else must i look into. Like i said engine is strong does have high miles(140,000)
  • Do you mean misfires or backfires? Timing is #1 to check so need a timing light and set to spec which means loosen the dist holddown and turn to set - assumes wires connected in right order. Need more info if not what you meant. Only 20+ years old.
  • I have a 2000 GMC Jimmy 4.3L 4WD with the Tow/Haul switch on selector and was wondering if it could tow a boat that weighs 3000 lbs?
    I have towed a smaller boat and I am concerned if it could handle a larger load through the hills from N Carolina to New York. Does the Tow/Haul switch realy make a difference
    or is it just for towing at your local marina?
    Is there anything I should be aware of so I don't burn up a tranny? Thank You...
  • I have a 91 Jimmy 4.3l 4wd. It has no crank and the headlights don't work. All other lights work. Where do I start. Battery is good.
  • Specs are listed in the owners manual based on hitch type. The switch alters trans shift points. For extended towing need to add a trans cooler that mounts in front of the radiator, change the fluid and filter every 30k miles are when it smells burnt, and as for the weak point its the sun shell that is a weak piece and goes when a large load or shock and the neck breaks and lost rev/2/4 - been there.
    Bog boat big truck - never tow antthing heavier than the tow vehicle. You may have to go thru the brake system also and add high heat pads like cermanics to stop it.
  • Battery cables and ground OK, relays, fuses (ECM bat, ECM ign, Eng 1), starter OK (give it a wack with a hammer and see if it then starts), and finally are you sure that battery is really good and fully charged?
  • My 98 Blazer headlights quit. Marker and turn lights all work.
    I tried to ground the circuit at the lights, one light came on and the other 3 came on but dim (highbeams too) Highbeam indicator on dash doesn't come on. Where is the ground for the headlight circuit? I had no probs with this vehicle until 130,000 miles, now it's constant elec. problems. Thanks.
  • All runs thru that light switch on the left side dash - try rotating the DRL switch to force/turn the lights on. Those dash switches do fail. Have to take the dash bezel off to get to it - 1 screw above the steering column and some under the bottom column trim, then pops out but do not break the hazard switch button off as you pull the bezel out.
  • :confuse: Yes I agree this is od as I can not find the source either. I have a 1996 4 x 4 Jimmy with 269,000 miles and it started the churping bird thing on accelleration a few days ago. It will go into the shop tomorrow and I will let you know.
  • I have a new battery, had the alternator checked, belts are relatively new, starter doesn't show that it is failing, fuel pump is working. Had new plugs, wiring harness, rotor, and distributor cap put in about 4 months ago, new water pump about 6 months ago, the fuel pump was put in about 18 months ago, and a new fuel filter(within the past week). When I turn the key the starter engages but engine does not turn over. If I can get it to start it runs fine. I just ran some fuel system cleaner through it to with the last tank of gas. Any suggestions as to what could be wrong
  • Sounds like the starter is trash - the bearings are really bushings and the whole assembly drops internally as it wears. When it happens hit the starter with a 3 lb hammer and if she starts thats it. Also look at the primary ignition wire from the key and see if the little nut is tight on the starter. Local alternator/starter/gen shops do only that and usually are very helpful.
  • Hello. This is my first post as a question. The board is great I have gotten lots of info off of it already. Just could not find the below question asked after looking for about a week here and there.

    I have a 2002 Blazer LT 4wd 78k miles. The truck is awesome and love to drive it.
    When I drive at high speeds I hear air noise in the cabin. It seems the drivers side window is not sealing correctly. The passenger side is fine are the other 4. I was wondering if there is anything I can do to end this. Not a huge problem but still would like to know. Also if I buy those Thule Wind Rain guards for the truck which I like. Do they cut back on this wind noise?

    I did a search on the board for a previous post but could not find any.

    Maybe my problem is not really a problem. Lol.

    Hope to hear from you guys soon.

    Thanks in advance.

    BklynBlazer02 :shades:
  • They say it is the Catalytic Converter, may be, as my friends who have a 95 and a 97 both say that was the problemo. I will get it changed and see if that is the deal.
Sign In or Register to comment.