Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Blazer GMC Jimmy Maintenance and Repair

1160161163165166179

Comments

  • jlflemmonsjlflemmons Posts: 2,240
    I am a bit confused with your question. To change the turnsignal bulbs, the grill snaps off and you can access both sides. If you are talking fog/driving lights, they are accessable from underneath.
  • auto9999auto9999 Posts: 86
    Hi jlflemmons,

    Thank you for your message.

    I am thinking of taking out the entire turn signal assembly - about 1.5 feet wide, a few inches tall, a few inches deep - with the orange plastic front plate equipped with the turn signal only. Then I would install a replacement assembly with both the turn light and the fog lamp.

    image example: http://ketech-llc.amazonwebstore.com/shared/viewProductImage.html?http://ecx.ima- - - ges-amazon.com/images/I/41X6Z1Jxc-L.jpg

    The assembly seems to be being fixed to the bumper unit by screws but I do not see the screws from in the engine room or from under the bumper.

    The body shop knowingly installed the wrong assemblies - he said that he found a used set of parts without the fog lamp at a discount price. I benefited from the pricing, so I felt I would not ask the body shop to redo the job.

    I would appreciate if you could tell me how to remove the turn signal assembly.
  • jlflemmonsjlflemmons Posts: 2,240
    Well, as I type this I am sitting in my garage with the assembly sitting next to me. The grill and turnsignal assembly is all one piece and is held in by snap clips. Open the hood and pull on the top of the grill gently and the top snaps will come out. Pull on the ends of the turnsignals and those snaps will come out. Unscrew the turn signal bulbs and the whole assembly is right there in your hands.
  • auto9999auto9999 Posts: 86
    Hi jlflemmons;

    Thank you for your message. Your information based on your real experience is the most valuable. I will try and replace the assemblies on my Blazer.
  • pvanmanpvanman Posts: 10
    ok here;s a new one, I replaced the flashers on my 95 s-10 Blazer, now the gear shift indicator light flashes when I put on the turn signals, (column shifter) I bought and installed another new flasher thinking the first new flasher was bad, but the same thing happens with the second new flasher. The gear shift indicator wasn't flashing before with the old flasher installed.
    Any ideas?
  • MrShift@EdmundsMrShift@Edmunds Posts: 43,640
    cheap parts maybe? wrong part?

    Did someone hand you this or did you look it up on a chart from a chain store or was this a dealer item?

    What I'm driving at is that if you went to a chain store, you might try something a notch up, like NAPA.
  • pvanmanpvanman Posts: 10
    Mr. Shiftright, took your advice, bought another flasher this time at NAPA, and, bingo! Turn signals work and the shifter light is back to working normally. The place I bought the original flasher the guy at the counter didn't speak English too well and I think we had a breakdown in communication. Lesson learned.

    Thanks again for your advice.
  • What is the easiest and best way to remove a starter motor from a 1995 Chevy Blazer 4WD 6 cylinder? Should I remove the connections first? I tried removing the connections from the starter by going through the wheel well.
    I also tried dropping the starter to get to the connections, but could not get the starter to come out. Do I need to take the flywheel cover off, or should I be able to get the starter out without removing the cover? The flywheel cover bolts are very tight (cannot loosen even with air tools). Please advise on how to take starter motor out. Thanks.
  • MrShift@EdmundsMrShift@Edmunds Posts: 43,640
    * Place the vehicle on a hoist.
    Remove:

    1. Negative battery cable.
    2. Brush end mounting bracket (if equipped).
    3. Solenoid wiring.

    o Raise the vehicle.
    Remove:
    4. Skid plate (if equipped).
    5. Bolts and the two brackets holding the brake pipe to the crossmember.
    6. Crossmember (three bolts on each side).
    7. Bracket holding the transmission fluid cooler lines to the flywheel housing, brace rod to the flywheel housing, and/or the lower flywheel housing if necessary.
    8. Two bolts holding the starter to the engine.
    9. Starter and the shim (if equipped).

    Install

    1. Starter and shims in their original locations (if equipped) to the engine with bolts.

    Tighten

    * Starter mounting bolts to 43 Nm (32 lbs. ft.) .

    2. Lower flywheel cover (if removed).
    3. Transmission lines bracket to the housing (if equipped).
    4. Brace rod to the housing (if equipped).
    5. Crossmember to the frame end with six bolts.
    6. Two brake line brackets to the crossmember with bolts.
    7. Skid plate (it equipped).
    8. Solenoid wiring
    9. Brush end brace and wiring (if equipped).

    Tighten

    * Brush end brace nuts to 11 Nm (97 lbs. in.) .

    10. Wires to the solenoid terminals.
    11. Negative battery cable.
  • I read a lot about fuel gauge bouncing, some say possible grounding issues on sending unit. The bouncing needle works fine till half tank then stays there. When i first start the truck it will slowly go to roughly the right spot then bounce up and down. Once I start moving it goes to half a tank and stay there. The whole thing is kind of annoying at best, but can be dealt with. I guess I should state this is a 99 Jimmy with about 130k miles. I have nearly replaced the entire front end ( ball joints, a frame, bearings and hub) Last thing I had to replace was muffler system to cold power loss. But the most important thing I want to fix is the high speed power hiccups. I do 150 miles a day on interstate. Low speeds this vechile is very powerful, But at 70 mph, I am getting this random hesitation or power hiccup. It is rather hard to explain as it is hard to realize unless you push the truck, but if you push it to far it will just shift down and go like a bat of hell. Any ideas what i can look at? Thanks in advance
  • I have a question for you all. I have just noticed that my blazer leans on the driver's side( or its somehow lower on that side). Now is this common for blazers? I just happened to look at the parking lot at work which is flat and level, but my blazer was sloping on the drivers' side.

    2000 Blazer LS 4x4
  • johnss10johnss10 Posts: 46
    This is not uncommon in 4X4's they use torsion bars in the front suspension, since the front drive axle's go through where the coil springs would be. There is a ride height setting procedure in the Haynes or Chilton repair manual. Also, a front end shup will do this as part of the alignment. The alignment may well be out as well, so probably best to take it to an independent, locally-owned shop.
  • johnss10johnss10 Posts: 46
    These two things might be related. The high speed miss could be a weak fuel pump or clogged fuel filter. Cheapest/easiest is the fuel filter.

    The gauge is either a poor connection, or more likely a worn float assembly. The float assembly and fuel pump come together for these vehicles, so replacing the fuel pump/fuel sender may fix both problems. About $130 for the parts. I'd check with Rock Auto on the net first, ususlly have best prices.
  • victor60victor60 Posts: 1
    My 96 GMC Jimmy keeps blowing the #9 fuse. which control the fuel pump, fuel control relay sensor, the ecm. All of these have been changed and yet it still blows the fuse. Stopping the engine from running. After they were changed it started but when i put it in reverse it shut off. And blow it again. Now when i put the key in the position it blows the fuse. :cry:
  • To me that sounds as if you either have a short or a bare wire exposed.Maybe in the fuel system, like between the tank and body. I'd guess that when you put it in gear it viberates and shorts out or maybe just cranking it causes enough to short the wire(s) out. I'd have to start there, and run down the wires until you find it.
  • duntovduntov Posts: 133
    Whenever the fuel pump is replaced, it is recommended to replace the fuel pump wiring harness and the screem. The wiring harness and screen usually does not come with the fuel pump and must be purchased separately.
  • My 99 2dr 4wd Jimmy makes a popping noise in the the front. It is happening more and more often. It gets much worse during wet conditions. I replaced the ball joints on both the driver and passenger side wheels within the past year. I put new brakes and rotors on less than 6 months ago. I cannot figure out what keeps making the noise. Can anyone give me any ideas?
  • duntovduntov Posts: 133
    Check the front wheel bearing/hub assemblies.Premium Timken bearing/hub assemblies cost about $160 a pair at auto parts stores but you can find cheap Chinese made bearing/hub assemblies for less on e-bay. The Chinese parts may be just as good as Timken but I would not use them.
  • 1986blazer1986blazer Posts: 6
    check your cv axles and u-joints
  • sealteam8sealteam8 Posts: 11
    You can check the sway bar end links in the front end as well! They go bad and make a popping or clunking sound
Sign In or Register to comment.