Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Blazer GMC Jimmy Maintenance and Repair

15253555758179

Comments

  • Don't give up...

    Get all you can out of that warranty.

    They will eventually find the problem.
  • rmnrmn Posts: 1
    Bought my 96 Jimmy about 1 and 1/2 years ago with 140,000kms on it. Has the
    same problem you described. I have put 60,000kms on it with the noise. Tried new
    tires, replaced the right front wheel bearing twice & was told recently by a driveline specialty shop that the problem was the thrust washers in between the right drive
    shaft and differential. I haven't tried this as yet. I would also like anyone elses input.
  • bwolfordbwolford Posts: 1
    Three weeks ago I was going to the store. Went out to the blazer, and turned the key, nothing happened. The battery was fully charged, but there was no sound when I turned the key. Poked around a bit, but could not get truck to start. Left alone, and tried it the next morning, and it started fine. No problem since until this morning, now it won't start again. Any Ideas?
  • dipdotdipdot Posts: 1
    HI! Our college daughter drives this car and is having occasional problems
    with the car not starting...........because she lives away at college, I really need
    (for her safety!) to find out what the problem is and fix it once and for all!

    Most of the time, it seems that the car starts fine.
    Then, sometimes, it won't start at all. Won't turn over.....I think she said it begins
    to start and the just won't. The lights work, etc......so doesn't seem to be the
    battery. To get it started, she waits a few minutes, or a few hours or a day or so.......goes out, tries it again, it seems fine!

    Yes, she has gas! (I asked!) Someone told us they ONLY way to diagnose this is to have a mechanic look at it WHEN it won't start. If I knew when this was going to happen, it would be a lot easier! ;)

    ANY advice or ideas would be appreciated! :) THANKS THANKS THANKS! :mad:
  • efalconefalcon Posts: 4
    Hi, anyone know how I can get the radio on my Blazer unlocked??? I just bought a1999 Blazer and had to do some repairs on it. Finally it is all done but i can't get the radio to work, it seems to be locked somehow is there any safe way to unlock it if I don't have the original password or should I just give up and buy a new radio??

    Thanks,
  • 92blazer92blazer Posts: 1
    I have a problem with blower motor. I have replaced the relay,still same problem. The fan goes on when the relay is taped on. It only works in one speed HI. :sick: ">link title
  • alcanalcan Posts: 2,550
    Easy, just take the vehicle registration document to your closest GM dealer. They'll be able to provide the code for a fee.
  • efalconefalcon Posts: 4
    Is the procedure for engaging 4X4Hi the same as in all traditional 4WD vehicles???
    1.- Stop
    2.- Shift to Neutral
    3.- Press 4XHi button
    4.- etc, etc

    that Sort of thing, or can I just press the button any time I please???
  • I gotta 95 Blazer, i baught it recentley it has about 183,000km my problem was not gettin a warantee in it,ONE day I was driving fine, and then the car stalls, it shut off on me, i knew i had gas, constantly i tried to start it till i fedup, checked for oil, coolant, everything seemed fine, called my friend, and he looked at it, and he said the gas is not goin through to the engine, he tryed to hit it from underneeth where the gas tank is, and still didn't work, he told me i need a new Fuel Pump, i paid 400 bucks for it and i gotta a year warantee ..I guess these things happen alot in Blazers, get your warantee bumber to bumber thanks
  • shep1shep1 Posts: 1
    Recently my 96 S10 jimmy ahs been slow to start(fire). :sick: It cranks good just won't fire.Usually have to try starting 3-6 times before it does start.I have 170k vortec 4.3.Any ideas would be appreciated.I've thought I might change the spark plugs and go from there. :confuse: ">
  • I have a 1994 jimmy sle. Since christmas is been stalling, when idling and when you go to give it gas, it will die, not all the time but most times. I have replaced wires, plugs, egr, coil, timings fine. Dad replaced the fuel filter yesterday, when he went to start the truck, it wouldnt start, He placed the battery on a charger and today it wouldnt start. He took the battery in to be tested, he touhgt maybe it had a dead cell. The battery is fine.....so why all of a sudden would my truck not start?? please give me some ideas that I can pass on to him. Hes not shady mechanic and knows what hes doing but hes stumped, he didnt touch anything electrical, he mentioned something about ignition starter may need to be replaced. Anyone have any ideas?
    thanks for any help
    Me :) :)
  • xbdg101xbdg101 Posts: 3
    i had the same problem with my 1994 jimmy
    you have a vacume line off
    start the truck and listen for a whistle
    if you vin code has the "W" in it or its a 4.3 liter v6 with fuel coming in through throttle body not port injection the check for a vacume line off its connector right behind the throtle body in between the throtle body and the fire wall on the passenger sige of the truck

    im sure its around the same area for the other engine
    "Z" in the vin code or direct port injection

    hope this helps it fixed my 4wd drive not engaging like it said it was
  • j9sjimmyj9sjimmy Posts: 1
    I have a 2000 Jimmy and I had the exact same problem, both gas gauge and signal noise problem.

    I just took it in and they said it was my multifunction switch that was screwed with regards the signal problem. Which was covered under my extended warranty.

    The fuel gauge was fixed too. They just added some sort of cleaner to the tank which was about $15.00.

    Hope that helps!
  • efalconefalcon Posts: 4
    Hi there,
    You might want to check for the correct fuel pressure, Vortec engines need at least 55psi to run, otherwise it wont start. If gas pressure does not meet the 55psi then you will probably need to replace the fuel pump. But before you get in to that, you might want to make sure you are getting a spark from the Spark plugs and a signal to the fuel injectors. (if there is no spark or signal to the fuel injector then the ignition starter is probably the problem).
    Now getting back to the fuel system, if you have enough fuel pressure, spark and a signal to the injectors, you should check for clogged Fuel Injectors.

    Please let us know how it went.
  • jmaxejmaxe Posts: 198
    I hear a whine in the rear end at about 50 mph that I can actually change the pitch by pressing and then releasing the accelerator. I've changed tires so that doesn't seem the likely cause. Could it be the differential, U-joint?
  • alcanalcan Posts: 2,550
    Classic symptoms of crown and pinion gearset noise. First check, is there any vertical or side to side play in the pinion yoke? If so, probably needs pinion bearings. If not, the gearset can be re-shimmed IF the problem hasn't been present long enough to cause excessive wear on the gear teeth. Best bet, find a shop which specializes in 4X4 and off-road stuff, they usually have lots of experience setting up rear axle gearsets.
  • radiomanradioman Posts: 1
    Check the hinge pins on the door that is making the noise, mine did the same thing and what I found is that the hindge pins were rubbing the door spring, so I drove them back up and everything is fine. I worked for a dealer in SC and their body guy raised hell with a mechanic for Yanking on a door like that, he said it would prematurely wear the bushings. I believe this because I ended up replacing my bushings too.

    My 96 jimmy right front noise was teh computer beating the top of the coolant tank. I thought it was the battery, but I fixed it and it makes no more noise. see the last post that I made to correct it.
  • jmaxejmaxe Posts: 198
    Does anyone know if I can bleed air from the radiator? I recently had to top off the coolant in my '00 Jimmy and now there is a distinct gurgling sound in the area of the heater core. I suspect air is in the system.
  • jmaxejmaxe Posts: 198
    Thanks Alcan. I'm not familiar with these terms(c & p gearset) but I'll look into it and let you know the outcome.
Sign In or Register to comment.