Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Colorado and GMC Canyon Electrical Problems

1101113151634

Comments

  • RU saying that the fuse was bad even though it was good? Here's my problem and it has been noted before. I have a ground somewhere on the positive side of my electrical system. It drains the battery in about 2 days. It blows no fuses and melts no wires. Here was my analysis attempt. I charged the battery and pulled the red lead off. I put a meter in line between the positive post and the red lead and sure enough it reads voltage (it shouldn't of course but that indicates a ground.) I then pulled the cover off the fuse box. I pulled every fuse and relay, one at a time. The voltage on the meter never dropped. How the heck can that happen? Isn't every circuit fused? But now that you mentioned the 100 amp mega fuse at the entrance to the fuse box it makes me wonder. my mega fuse is good or at least it reads continuity.
  • mikeyrmikeyr Posts: 2
    Hey Webman,

    Not sure if you got your part number, but I believe it is GM PART # 25779767. I don't believe you need to program it, but am not sure and would like to know that myself. I can send you a link to a form were a number of people have bought and replaced it.
  • :shades: Hello single mom dont listen to the guy with a chip on his shoulder with the last reply. The colorado does not come with a book its a dvd. But anyway just have all the fluids changed trany. Flush the radiator and you can but dont need to have the transfer case oil changed. The oil change should be every 3000 miles you also can go with the 5000 mile oil. If you are really bad about changing the oil use 50/50 half sinthedic oil. Its a better oil last longer and does not break down as fast. Go to a oil change place like jiffy lube and thy will put a sticker in the window so you will know when to change the oil again. Hope this helped. steve
  • I have an 04 colorado and the wipers will not shut off. I am thinking there is a wiper module or something that runs them that needs to be replaced but I cannot find it. Any help would be greatly appreciated.
  • hi i have a 2005 canyon i was driving along and i put my charger in the auxillary power outlet, then all of a sudden my turn signals stopped working as well as my forward high beams, the light for the 4 way, and the light for the heater controls. somtimes when i pull back on the high beams everything will come back and if i plugg something in it will go off again and sometimes even when i just start the truck up after it is off this happens, any insite?
  • gbohegbohe Posts: 1
    My 2005 chevy colorado started idling rough and burning alot of gas, after I hit a deep pot hole driving about 8mph. Will not stay running when I first start it in the morning unless you constantly mash the gas pedal. I took it to Auto Zone they hook it up to a diagnostic reader, it showed 3 different code numbers all having something to do with a vacuum leak. I have 88000 miles on the truck warranty ran out how do I find the leak.
  • I have a 2008 GMC Canyon SLT crew cab 4wd, and I have exactly the same problem you described. I have no idea as to a fix, sorry. Maybe as we add to this web site someone will take note. Two 2008 trucks doing the exact same thing as this cannot be a fluke.
  • Had the same problem with a 2004 Colorado. Here is how to fix it. Pull the bulb out of the socket and take a small file ( I used my multi-tools smallest screw driver blade) and scrape the carbon build up off of the connectors inside the socket. You may also have to pry out the wire on the bulb socket about a 16th of an inch. I have to do this about two or three times a year.
  • I went out to my truck today to find the battery dead, after realizing the interior light wouldn't shut off after closing the door. I charged up the battery and started the truck only to find the DIC saying that the doors were ajar. I ran around the truck shutting every door, I have an extended cab and still the message on the DIC won't disappear and the interior light won't shut off. Any suggestions or ideas on what could be causing this? I
  • dmathews3dmathews3 Posts: 1,739
    Let me ask the dumb question first. Do you have the interior light switch turned on and you are just thinking it has something to do with the doors? Wouldn't be the first time so double check the light switch to make sure it is in the off position.
  • No, I have the turn wheel all the way down as low as it can go so that the lights inside the vehicle would be dim and so that the interior light isn't clicked on. The reason why I think it has something to do with the doors is since the DIC on the truck has the DOORS message displayed however all the doors are securely shut. I shut the dome light off manually last night by hitting the manually dome override button on the truck but that only keeps the light off its not helping get rid of the message on the DIC, and since it thinks the doors are open it wants to keep the interior light on.
  • dmathews3dmathews3 Posts: 1,739
    You could take off the neg. cable on the Battery for a minute or two and see if this resets everything.
  • I had the same problem occur about 4 years ago, with my '05 Canyon. The light switch, located at the bottom of the door jamb, has gone bad, causing the lights to stay on, and the computer to think the door is open. Replace the switch and you'll be OK.
  • Not sure if this will help, but....
    I had to slam on the breaks 'cause of an idiot in a van3 years ago. All of a sudden my 05 was running rough and backfiring. Got warning notice on dash. OnStar said ok to drive but to take right to dealer. Dealear did a diag and there was a problem with the device that adjusts the valve timing. The computer changes valve timing on the fly I think. They changed it and my gas milage went UP!! I was getting 14/19. Now, and this is NO BULL.... I'm getting 17 - 18 in town and 24 to 25 on the open road. Drove to Fla from NJ and back twice. Even running at 75 mph I was seeing 23 mph. I"m happy - Oh, it's the I-5 engine.
  • 2006 colorado i have same problem as message 248 of 257 when this was happening pull light switch back and dash liights will come back on i am thinking bad switch
  • I have an 04 crew cab with the exact same passenger door problem. If you bang on the inside of the door or pull on the glass it will work. Any help is appreciated! I hate to buy a new window motor and find I still have the problem
  • I just changed the original battery in my 04 Colorado and now the driver side window does not work. The passenger side window and all door locks still work. Quite odd. I will scream if the window motor went out because of a battery change. I did hear sounds (like motors moving) when I connected the new battery. Anyone else had this problem? I am going to try to disconnect and reconnect the battery later.
  • I have a 2004 colorado crew cab with the same problem with the locks and drivers window. On dec 26th I decided time for a new battery and which I replaced and that's when this problem started. Could this problem come from just disconnecting the terminals?
    Well thanks to HopeGMC it's working again. I took it apart and looked at everything and things looked OK so I tapped the relay and put everything back togather and wow it worked. A GMC/ Chevy repair......
    My hats off to HopeGMC thanks alot. What is the BCM and TSB. Just for reference I might need later. Thanks again... ZIPY

    Hope this helps. This was a year ago for me. the relay is like a small aluminum block on the circuit board. Also spray the connectors when putting back togather. Go back and read this on page 15-16-17.
  • well i dont know i if you have fixed this problem yet but i have had my 04 do the same thing all the others work but not the drivers window, after a lot of trial and error i got aggrevated took the posotive cable off the battery and left it for about two hours and like a miracle it worked again, since then i have had to unhook the battery several time to put in upgrades and little trick (stereo, amp, speakers,etc) and everytime the wondow stops working, so i will unook the hot cable for about 2 hours and pretty as you please it will work again, if you have this problem again try this, from what you described i about 95% sure this will fix your problem. good luck
  • I also am having the same issue..I had to put the brakes on pretty hard a few days ago and now the engine is running very rough. This has happened before but it worked itself out..but recently it has gotten worse and will not work itself out. Having it towed today to get looked at.
Sign In or Register to comment.