Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Suzuki XL-7

1596061626365»

Comments

  • hey ivan thanks a million for the info ,you have helped me ease my mind /your the best / how are these suvs do you like them /any other thing i might need to know hope to hear from you /if i can help in anyway please ask/ later dude
  • kc5ytikc5yti Posts: 38
    By 2003, many of the issues were repaired. However, one of the more common issues is timing chain tensioner failure. This is most common around 30-60K miles. The main symptom is the sound of the chain rubbing on the block during startup. According to Suzuki, it could make the noise for a very short amount of time, but it should never last for longer than 30s. To, me, it sounded like a bicycle chain hiting a chain guard while peddling. To help avoid this, use good oil and filters. I use Mobil 1 synthetic, and the Purolator Pure 1 oil filter. She now has just over 61K miles, and I have not heard the issues since I had it fixed at about 43K miles. She treats me well, and I return the favor.

    Regards,

    Ivan, kc5yti
  • vudutwovudutwo Posts: 1
    hi everyone, i purchased my suki about three months ago ( 65k ) miles and i just noticed a springy / squeaky nioise coming from the front. anyone ever heard of this? driving me crazy...
  • About 3 years ago I had a problem with my truck as I was braking. When I would put my keys in and turn the ignition then press my brake pedal to change to drive my engine would rev. That happened a few times. Also when I press my brake pedal the truck would rev and suddenly accerlate nearly causing an acident. I had brought it into the dealership to look at was told nothing was wrong they never heard of that problem before. Then someone had suggested a cable (I don't recall off hand which cable but I do have the paperwork) so I then went back and had that cable changed under the warrenty as a safety issue. Prior to that I did get a recall notice about a cable and did get that cable replaced.

    Now just the other day it started to happen again and again luckly I was able to avoid an accident. This time I had truck towed to the dealership for fear of not being so lucky again to miss an accident and just for fear of my safety and those on the road. Again dealership said there is nothing wrong couldn't find anything and had NEVER seen that before or heard of. I reminded them that I was there 3 years ago with same problem but was told no nothing wrong.

    Any ideas as what the cause is??? Any insight would be greatly appreciated as I am very concered for my safety and I truly don't feel safe driving it even though it is claimed that "nothing" is wrong.
  • Does anyone know about this....I have a 2001 GVitara xl7 driving I heard a loud noise and when the mechanic checked there is a bolt in the engine that was broken and damage the engine valve head gasket...my mechanic is going to rebuilded but he is not sure is this is going to be a problem in te future due to high milage?
    Does anyone know about something like this? the engine have > 190K
  • help2009help2009 Posts: 1
    Hello, I need help. I live overseas and I'm planning to bring my car to the US this summer but the car is righthand drive. Is it possible to switch it to lefthand and how much approximately it will cost me. Appreciate any advice. THANKS!!
  • poorcruzerpoorcruzer Posts: 141
    I am looking to buy a 2004 to 06 XL-7. I really only need a five passenger version but have been finding that most XL-7's are seven passenger. If I removed the rearmost seats entirely, which would increase cargo area and reduce weight, would it leave the carpeted floor like in the five passenger versions? :shades:
  • anybody have a complete manual for 2003 suzuki XL7 thanks tom
  • I live 5 miles down a dusty dirt road and the hole around the handle allows in so much dirt that it only works for about 2 weeks. Has anyone else had this happen and what was the solution?
  • dws2kdws2k Posts: 12
    When we start the truck, it sounds ok at first. It then makes a loud grinding noise fromm the engine for a few minutes and then it stops. What could make this noise?
  • I just bought an 08 Premium XL7 2wd, 3rd row seats. 30k miles. Paid $15k. I really like this vehicle. Perfect for my family of 5. The engine has plenty of power and the trans is smooth. The interior panels are a little "plasticy" looking. The seats are kinda soft and will probably start showing wear later. But everything else is great. It's much better than paying $35k for a new SUV. This vehicle is a lot of bang for the buck. I'm very happy so far.
  • You can remove the back seat if you want, it will increase big space there but the carpet floor goes to the beguining of the seat and if you remove it you won't have carpet there, you will also have to remove the back of the seat and the plastic box that is on the back of the car.
  • tremirratremirra Posts: 1
    edited March 2010
    I have been having this problem at least 4 to 5 times this year. I am scared of this SUV now. I would begin to slow down to stop then I would hear the engine rev and the brake pedal would be hard to apply and the car wouldn't stop. One day I got to a stoplight and begin to stop. The car rev up and it sound like the car was getting ready to take off. I quickly put the car in park. I was very scared. I took my car in to check the brakes and rotors and was told nothing was wrong. I will be writing Suzuki about this problem because it sounds like the same problem Toyota is having. The bad thing is, I love my Toyota and Suzuki cars.
  • I own a 2002 XL-7 Grand Vantara. The stereo & CD Player is Suzuki by Clarion. None of the controls (buttons) work. One day they were fine and the next, nothing. I can play a CD and get it to eject, but nothing happens when I try any of the other buttons. Any help would be appreciated
  • dws2kdws2k Posts: 12
    edited June 2010
    Where can I find the receiver drier on the XL? There is a sight glass but no drier under it. Would it be next to the condenser or up against the evaporator?
  • Be sure the interior fan switch is in the off position or it could be your power steering belt needing adjustment.
Sign In or Register to comment.