Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Tahoe

1959698100101205

Comments

  • sebring95sebring95 Posts: 3,233
    Kinda funny because the early models Toyota Camrys (4cyl models years 1992-1996) all had terrible vibrations when idling with the vehicle in gear. Rattled and shook the steering wheel. I never heard of anyone getting their car bought back and there really was never a fix until the new body style (1997) models were introduced. This from one of the most reliable best selling vehicles in the world. Oh well, I guess they weren't $35,000-$40,000 either. No matter how you twist it these are just trucks.
  • Sorry if this has been covered before. I have just returned to this board now that I am carshopping again!
    Anyhow, I have found a '03 Yukon with 5.3, 3rd row seats, tow pkg, split bench, Carbon black, cloth interior, and the rest of the Std stuff. Its pretty basic. They want $29,800 plus tx and lic. Good deal? Can I do better? Anyone seen the Denali grill on a Yukon? They want $1K for that! Please send comments to scottay@socal.rr.com Thanks!
  • dardson1dardson1 Posts: 696
    It s about time for a replacement air filter. I keep hearing about K&N.....claims for better milage and power.....went to their site (K&N) and read the testimonials. While the testimonials are glowing, I noticed K&N dances around the subject, in the end making no promises. HUM! Anyone experience one of these? Seems to me if something as simple as a cotton/oil air filter could increase milage by a mile per gallon, GM and everyone else would jump on it.
  • steverstever Viva Las CrucesPosts: 41,630
    More here: K&N Air Filters, bolt-on power?


    Steve, Host

    Moderator
    Minivan fan. Feel free to message or email me - stever@edmunds.com.

  • ianshawianshaw Posts: 119
    The comments on the Better Business Bureau are contrary to my experience. I did go through the BBB when I was having all the problems with my Tahoe. And, they basically told me that if the car didn't qualify under Wyoming's lemon law, then they weren't going to be able to do anything for me. I wasn't all that impressed!!!
  • It's too bad that it ended there. The program summary available from them or on their website specifically details remedies associated with either a lemon law or non lemon law. As stated earlier, There's a 2003 brand new Tahoe sitting in my driveway as a result of a non-lemon law judgement. I will say that when I first filed they began to talk about the lemon law proceedings but I told them that I am seeking judgement under the non lemon law process (basically a replacement remedy does not differ that much in a lemon-law vs non-lemon law judgement). You must remember the people you first talk to may not be that well versed sometimes. Soon you are assigned a case specialist and things get better.

    I also learned that it's easy to give up in the beginning but it gets better as your journey continues. For some reason the desire to keep going gets stronger because you hate to lose the time and investment you have already made. Like a diet, it's harder at first then get's easier as you see progress.
  • Hi, been reading the board for a while, but this is my first post. Bought a new 2003 in October, now have about 2000 miles on it. Had a few strange problems so far, wanted some input...

    First problem, as the weather got colder, I noticed that the temperature display on the mirror was a bit goofy. When temp is in the 40's, the display is reading "9*", for example actual temp is 43, display shows 93. When it displays "ICE", (by the way what makes it say ICE? doesn't seem consistent with the temperature) on ours it says "IEE". I assumed that meant the top and middle bars in the tens digit was stuck on, as display was fine for 30's and 50's. Took it into the dealership, and they tried to 'recalibrate' it, had to talk to four different guys before I could get the point across that it was fine at all temps except the 40's. They then said that they had heard other reports of problems with the mirror so rather than replace the mirror they needed to forward the problem to a GM engineer and wait for a 'software' fix from the factory. They would call when a fix arrived.

    Next problem, the night before taking it into the dealership had a message show up in the DIC saying 'Service 4WD'. As we were going to the dealership in the morning anyway we had them look at it. They checked the computer and found that it had not kept any error codes. We were insistent that we had seen the message, so they had a tech drive it with the computer hooked up. He found messages pop up, but again it would not save the codes in the computer. They agreed this was something strange, but again a punt to the factory with a promise to call when a 'fix' arrived.

    Took it on the first road trip this weekend for Thanksgiving. About 150 miles into the trip the CD player quit momentarily and then came back on, no big deal, figured it was one of many scratches on the kid's Disney CD's. A minute later it quit again, this time after a few seconds, the entire radio unit went dark and appeared to have lost power for a few seconds. It came back on and the time showed "12:00" but it began playing again. About 30 seconds later it quit playing, and then the unit became completely unresponsive. None of the buttons worked, clock still showed 12:00 (several minutes later), couldn't power off or anything. Completely locked up. I pulled over, turned off the power and opened the car door. No dice, although the car's power was off, the door open and the keys removed from the ignition, the power was still on on the radio and it still showed 12:00. Nothing I did would make the power shut off. We stopped for breakfast about an hour later. Went in to eat, and kept stewing (not relishing the remaining 7 hours of silence with the kids asking 'are we there yet', or spending the day after Thanksgiving in a dealership 500 miles from home). Went out pulled the fuse on the radio, and it finally shut off. Put the fuse back in and everything was fine and worked great for the remainder of the trip.

    By the way, the temp dropped down to 19 on the trip, the temperature display was fine, but was bad again when it got up to 40. So that kind of blew my theory about the mirror, too.

    Sorry this got so long, here are the questions.
    1) Does anyone really think I will ever get a phone call saying "guess what, your software fix is here, come on in and we will install it."? Or was this just a way to get me out of their hair?
    2) Has anyone seen or heard of any of these problems?
    3) My understanding is that Chevy made a point of their new 'multiplexed electrical system, blah, blah, blah' for this year. Is this just symptoms of first generation problems that can be fixed, or am I getting the ingredients for some first class lemonade?

    Thanks for your help.
  • By the way, Steve, I'm from Boise, too... So you may be able to have some insight on the likelihood of me getting a callback with a fix from everyone's 'favorite' Chevy dealer on Fairview Ave...
    Take it easy,
    Jeff.
  • steverstever Viva Las CrucesPosts: 41,630
    Hey Jeff - I've only been here for ~2 years now, so I haven't had the pleasure :-)

    But any town with a 26 year old used car dealer called "Fairly Reliable Bob's" has to be ok....

    Steve, Host

    Moderator
    Minivan fan. Feel free to message or email me - stever@edmunds.com.

  • I recently purchased a 02 z71 and I think I recall a posting about adding a cross-over or some other modification to the factory stereo to get better sound. I currently have the 9 speaker setup. If anyone can point me in the right direction I would appreciate it!
  • sebring95sebring95 Posts: 3,233
    anyone have trouble with the passenger side seat-belt locking the passenger in? Mine started recently pulling my wife tight into the seat and holding her there. She has to unlatch it and rehook and sometimes it quits other times it does it several times. I'm sure the dealer will replace it but was curious if others have had any problems with this or if there was a simple fix?
  • ianshawianshaw Posts: 119
    Yukon 97 - I just looked real quickly and found a reference to the sterio fix post at #2088. However, post #2088 refers to prior posts. Hopefully that will point you in the right direction.

    Sebring95 - we had the exact same problem with our first 02 LS Tahoe with the bench front seats. My wife decided she hated the truck just because the seat belt was such a problem. We, however, sold the truck before we ever made it to the dealership to see if they could fix/replace the seatbelt. Good luck!
  • lobsenzalobsenza Posts: 619
    The seat belts (rar for sure, i am not sure of the front) go into locking mode if the belt is pulled all the way out and released. This means they will take any slack given to them and not release it. The purpose of this feature is to better hold chikd seats. The seatbelt must be fully retracted in order to get it out of this mode. This feature has saved me a lot of time installing child seats.
  • '01 Yukon has developed a problem with the throttle sticking at idle. Push down and it comes loose but accelerates too quick. Dealer says that they are having problems with this on Yukon and trucks. They say that cleaning the injectors with clean the carbon from around the throttle valve for about 30,000 miles. Has anyone else had the problem.
  • My front climate control for my 2002 Yukon XL heats air only at the highest setting, 82 degrees, or if all windows were open at freeway speeds when not in auto mode. Otherwise, cool air would be present regardless of the temperature selected. The only way to regulate the air temperature in the front cabin is to set the heater at 82 degrees until the inside temperature is comfortable, then turn the heater off until it becomes too cold, then turn the heater on again, etc. This causes constant drivers distraction in order to regulate cabin temperature. Rear heater works as normal. Manufacturer states the climate control system is operating as designed and refuses to correct the problem. Manufacturer is stating that even when the climate control system is taken out of auto mode, the system will still regulate temperature, therefore cool air may be present. I have never owned a vehicle in which the climate control system cannot be turned off and used as a manual heater/AC system if desired. My dealer states other owner's of 2002 Yukon's have complained about the same issue. Dealer also states the 2001 used a different climate control system and 2003 are fully digital, so the complaints are only for 2002 models. I found one other post about a 2002 Tahoe from bigred18, but no replies. Has anyone else noticed the same problem?
  • lobsenzalobsenza Posts: 619
    Why don't you try another vehicle on the lot and see what it does. Otherwise I would try another dealer.
  • whskvswhskvs Posts: 28
    In what '03 month are the new 2004 Tahoe / Yukon models expected to come out?
  • Expect to see them on the lots for sale to the general public around late August early September. If you wanted to order one you can get it sooner than that, like late July early August, but you can't order '04 till mid June.
  • I have 2001 Tahoe and did the stereo mod. with great results, it used to be posted on a GM board which does not seem to exhist any longer. I can send you file with mod instruction if you want.

    bradjohn2@yahoo.com
  • whskvswhskvs Posts: 28
    thanks for the models release date response.

    whskvs
  • ianshawianshaw Posts: 119
    My 02 Tahoe with climate control does not seem to have that problem. Next time I drive it I will check more carefully, but I am sure that I have been able to both shut off the climate control by taking it off of the "auto" setting and I'm also sure that I have been able to get warm air to blow from the vents even when the setting is around 74 degrees. Sounds to me like your dealership is giving you the run around!!
  • My Tahoe has the same problem with the front seat, I took it in and was told by several different people that this is normal. They say it's for a child seat to help lock it in. I told them I didn't agree there was no shut off for the air bag, so why then would we be expected to put a child sit up front. They still told me it was for a child sit, and yes when the belt is pulled out all the way it locks as the slack is taken up. My wife is pregnant so she hates sit when it locks up on her.
    On a lighter note, we went to Georgia for Thanks Giving to help build a barn on my Mom's property. It was about a 10-hour drive and the Tahoe did really well on the road. However I did notice the speedometer is off by as much as 4 or 5 miles per hour. I noticed this when I drove past a posted radar unit near a construction site.
    The property was really muddy due to poor run off, and a bunch of rain in north Georgia, almost to Tennessee. My stepfather got his 4x2 F-250 stuck several times (really stuck up to the axle), my Tahoe pulled it out with no problem and no slippage of the street tires that are on it. (which will be replaced when its time for new tires) Because of the mud he used the Bobcat to get the horse trailer and bring it to the front of the property, it too got stuck while pushing the trailer. I again hooked up to the trailer and pulled them both out, I'm sure the Bobcat helped after it got traction, but it was fun to rub it in about pulling out the Ford. I was impressed to say the least, I'm very happy with my purchase.
  • Lawdawgfl, I am guessing you are referring to those radar speed signs that Georgia has placed on I-75 in the construction zones between Valdosta and Macon. I have found them to be way off in my 02 4x2 LT as well.

    I actually checked the speedo by setting the cruise at 60 and timing from one mile marker to the next...I did this at 3 separate places along the interstate then averaged the times...found out my speedo is between 1-2 mph slow.

    On the bright side...averaged around 18 on my Thanksgiving trip from Atlanta to Orlando..with a high of 19.7 on one tank...not bad for 78-82 mph with the a/c on. Love my truck!!!!
  • lobsenzalobsenza Posts: 619
    The purpose is so you can have a locking mechinism should you ever need it in the front seat. I actually used it to hold cargo in place in the front seat.

    A seat belt extender could help your pregnant wife.
  • Parthery; We probable passed each other, I was on I-75 going north from Florida, a little further south than Orlando, Naples actually. My sister leaves in Orlando and drove up the turnpike to Ocala. I also got great gas mileage. I'm so glad I found this truck. I was looking at mid-size SUV's with a third row sit, and came across my Tahoe, a 2001 with 12,000 miles. Since my wife was pregnant and we were now expecting I needed a bigger vehicle. I had an Isuzu Trooper, it was a good truck my only complaint was the A/C. I had to replace it twice under warranty and was not looking forward to doing it out of warranty. My wife wasn't crazy about the color, bright red. But she loves the Tahoe now. The bad thing is I do not get to drive it much, and let me tell you. There is a big difference between the Tahoe and my Xterra. How was Orlando? Did you see Mickey?
    Lobsena; Thanks for the seat belt tip, I will look into an extension for her.
  • lobsenzalobsenza Posts: 619
    By the way, they are FREE at the dealer. Tough to beat that price. They come in 2 lengths, I think. The key is not to get one too long so that the seatbelt crosses the body correctly. I would get one of each length (I believe they will let you get 2 for free). I have used them to help attach car seats. It made it easier in some cases.

    Once you have your little one you will be very greatful for the ratcheting mechanism. It cuts car seat install time in half.
  • I have had a 97 lt for almost 2 years has 65,000 miles on it.. is it uncommon to have to replace the Idler arm and pittman arm so soon?? I'm not sure even what they do on the front end... and is anyone having trouble with a tranny movement .. feels liek when i ytake my foot off the brake after a stop like someone just booted me from behind??? any one having the same problem??
  • davids1davids1 Posts: 411
    The idler arm and pittman arm are known for premature wear.

    The boot you feel from the rear is probably the rear slip yoke.
  • dustyonedustyone Posts: 262
    3151 of 3165 Throttle Sticking by steve6666 Dec 03, 2002 (08:52 pm)

    '01 Yukon has developed a problem with the throttle sticking at idle. Push down and it comes loose but accelerates too quick. Dealer says that they are having problems with this on Yukon and trucks. They say that cleaning the injectors with clean the carbon from around the throttle valve for about 30,000 miles. Has anyone else had the problem.

    '00 Silverado 5.3l had the same problem at 25K miles. The dealer cleaned the throttle body. This cleared up the problem. Use a fuel system cleaner such as REDLINE SI-1 regularly for more power and less sticking. See Redline SI-1 Fuel Injector and Intake Valve Cleaner. Hope this helps. I add REDLINE regularly to wife's '01 K2500HD Suburban, at 20K miles no problems seen
  • lobsenzalobsenza Posts: 619
    I had an occasional surging idle. The dealere replace the throttle body. The problem is gone and the highway mileage jumped 2 MPG.
Sign In or Register to comment.