Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Isuzu Rodeo

1106108110111112

Comments

  • I have a 94 Passport and I am having a heck of a time finding a used harmonic balancer/crankshaft pulley and the entire fan assembly (hub/mount, pulley, clutch and fan). I have posted to many junk yards and the only thing that they can seem to get me is a crank pulley. I would just rather get it all at one spot if possible. Anyone know of a junk yard that is hot on Isuzus & Hondas? Anyone have a junker that they would like to make a little money with? Thanks
  • rtop6300rtop6300 Posts: 1
    Hi I have a 1999 Isuzu Rodeo and been experiencing problems with steering. The wheel, does not return to the straight position after turning. The steering is tight when turning and will not return. Almost feel like no power steering or rack and pinion. Took to a mechanic but they cant find out what the problem is. Problem does not happen all the time but is occurring more frequently. Tight Steering/turning. Thanks. Can anybody help!?
  • chrismr2chrismr2 Posts: 1
    Hum I went to smog my 1991 Isuzu Rodeo a week ago, and the truck passed the emissions part of the " test only" smog. But when the man came to take a visual of the smog system, he said ohhhhhhh nooooooooo, you took your smog pump off. I said i don;t even know what the hell it looks like much less took it off, Now remember the truck passes the emissions test, He tells me that my truck is suppose to have a smog pump on it. and mine does not. It is a 1991 3.2 L6C and it comes in to play that his smog manual says I should have a pump, Well guess what I dont, and he was looking at the 3,1 motor not the 3.2 because it is not in the smog manual. so guess what i have to go to the referee and have the state referee do the smog. SO i go to the ref and guess what he tells me One book says it has a smog pump and one book says it does not have one Oh joy now what NO SMOG CERTIFICATE IF YOU WANT TO KNOW AND SINCE THE TRUCK DID NOT FAIL SMOG DMV WILL NOT GIVE ME A TEMP OPERATING PERMIT SO MY TRUCK SITS THERE WITH OUT REG AND GONNA GET TOWED BECAUSE THESE PEOPLE CANT FIGURE OUT WHAT SHOULD AND SHOULD NOT BE ON MY TRUCK ANYONE GOT ANY IDEAS FOR ME?????CHRIS THANKS
  • I posted this on another forum, because some guys were having the same problem, but I never got a answer. So I am posting it here.

    I have a 1993 Isuzu Rodeo 3.2 I just changed the timing belt idler pulley and the tension pulley, it went great for about 3 weeks then about 4 days ago got this sound like the ones in those videos on page one. The thing already had tapping, but this extra noise is more than I can bear. It still has great power it has not lost a step, when it comes to power,I really hate to have to break this thing down again. But it does sound like those videos, I wonder if they could have sold me a faulty tension pulley and arm. It has 173.000 miles on it and the body is still clean it is not banged up at all, and I really like this SUV. So who knows what it could be, I think it has something to do with the timing belt system, then again I could be wrong. But it does sound like those videos. And as for the tapping the owner before me did not take great care in oil management. I knew I should have changed that spring loaded tensioner. That is the part you all are talking about aren't you ? And it is not the crank, knocking. And when I accelerate to enough rpm's it goes away, but at a traffic light you can really hear it. :cry: :mad: :confuse:
  • my engine has been racing on 2rpm and earlier i got a tip to disconnect the battery erasing the computer. this worked for awhile but the problems has come back. all else seems to be working well but it still races so much i must press hard on the brakes when at a stop.
  • dmiah298dmiah298 Posts: 8
    I was wondering if you ever found out what the problem was with your son's rodeo? Mine started with trottle position sensor problems, and after fixing that 1st gear started to hesitate before it would engage, then 2nd gear did the same thing, now I have lost reverse also. I am getting ready to put in the shop, but would rather know what to expect cost wise before I do. Very upset with this truck- I've only had it for 2 months.
  • jengirl029jengirl029 Posts: 1
    Hello,

    I'm having problems with my 1999 Honda passport. I drive my car alot in one day and when I'm going from place to place and having to keep starting and turning off my car it starts to give me a problem. I'll start my car fine and then it will just cut off. The check trans light comes on for just a sec the goes off. I'll have to press the gas and turn the car on to get it to stay on. Sometimes when I get to a stop light it will turn off also, or the car will just rev for a while untill I press the gas or it will turn off again. I can't find anyone who knows whats wrong with my car. Is anyone else having the same problem?

    Also, like everyone else my gas light is always on, even if i have a full tank. Has anyone had theres fixed yet? What;s the problem, how much does it cost if it's worth fixing. I can live with the problem I count miles pretty well. LOL Any help thank you!
  • cracoviancracovian Posts: 337
    Clogged fuel filter maybe?
  • zman19374zman19374 Posts: 1
    I have a 1992 Isuzu Rodeo 3.1L V6 and frequently I will get in and try to start it with no luck. It will turn over just fine, all dash lights, radio etc work, yet it wont start. I have cleaned all the fuses and their contacts, the battery is fairly new and I have just put in a new starter. After about thirty minutes or so, the car will start and run perfectly. I have tried and tried to fix this problem but it keeps reoccurring. Also when not starting, if I roll and pop the clutch, it starts fine.
    -Zach
  • 32port32port Posts: 1
    Hi Just wondering if this window regulator is what moves the window up and down mine is not working but you can hear the motor turning in the so i think its the regulator but have never had one apart before. Was in a hurry to get it done so i could go to work in the morning so didn't play with it to much that night but need a new one.Is there any different in the different priced one one the net you can order? thanks
  • bucsngoofybucsngoofy Posts: 6
    Don't know anything about what a 'regulator' is, but I do know that when I had one of the windows on mine checked, it wouldn't roll down, you had to replace the whole system for all four windows, on my Explorer, each window had it's own 'system', much less expensive than replacing the 'whole' system... hope it helps...

    Lorie
  • cakey1953cakey1953 Posts: 1
    I am thinking of buying a used Rodeo with 137,000 miles,but have read terrible reviews about this SUV...gas mileage problems, recalls and all that goes wrong with this vehicle after 99,000 miles. Anyone out there with a GREAT Rodeo story?? The sellers are asking $2,500 for it, and it looks very clean from the outside. I have had a 2000 Ford Ranger that I bought 2 years ago, which has been (and still is) a no-problem dream truck...But it fits about 2 1/2 people, and I need something with room for at least 4, plus space for my paint tools. Anyone who can recommend a better used vehicle than this Izuzu Rodeo, please let me know!!
    cakey1953@yahoo.com Orlando, FL
  • http://cgi.ebay.com/ebaymotors/ws/eBayISAPI.dll?ViewItem&item=370186282353
    with a 2" block in the rear, or just crank your torsion bars down with a 2" block. or crank the torsion bars down, get the drop spindles i included the link to and a 4" tapered lowering block. in any of these options you will have to cut the bump stops front and rear. the front will touch if you crank the torsions bars down leaving you no suspension travel, and the rear is only a few inches away from the stop and every hard bump will bottom out.
  • cf14cf14 Posts: 3
    (2000 Rodeo, V6). The low fuel warning light started flashing constantly, even with a full tank and the check engine light came on so we replaced the fuel sending unit and the car was dead. Wouldn't even attempt to start. Unplugged battery and re-connected and tried again, no luck.
    A guy came out and read the codes and nothing showed up and I thought that the same instrument he used to check to codes could reset the computer and my husband, who WAS there said he didn't ask.
    So, am I wrong or are we going to have to haul the bloody thing to an Isuzu dealer some 200 miles away?

    Thanks for any input:)
  • This is the same thing we are going through now. Did you ever figure out what it was? If so, PLEASE let us know. Thanks!
  • cf14cf14 Posts: 3
    Well, o'Reilly Auto parts told us to disconnect the battery to reset the computer, after we'd cleared the codes, which we did and it spluttered but still didn't start, then we had a listen to fuel pump and it seems to be inoperative, so, we're replacing that part this weekend and we'll let you know if it fixes it.
  • cf14cf14 Posts: 3
    I'm sorry, Angelwings, I thought you were answering my post.
  • alabamadialabamadi Posts: 2
    The AC on my 2002 Rodeo works fine once moving but noisy when compressor comes on. When stopped or in slow traffic it is not cool. the freon was checked and is fine.

    a mechanic determined the fan in the front of the car was not coming on but the switch worked fine. He could do something with a jump wire in the fuse box under the hood and the fan would come on. He checked all the fuses and they were ok.

    Would this be the compressor. When I had it to a dealer for another problem the mechanic there told me in abt 2 minutes it was the compressor because of the noise and it would be $2100.
    thanks
  • heartcarheartcar Posts: 1
    I have a 2001 Rodeo that will not start. I have done all the basics.
    Empty-ed cleaned and installed all new gas,cleaned injectors, Plugs, check timing on belt, Replaced ECU. Ran Scanner and no codes stored. Engine turns over with spark and plugs are getting wet like I'm getting fuel but nothing. I'm wondering what does the alarm do if it's activated and would it let it crank over but not start? the alarm light just blinks all the time as long as the key is in the ignition. Is that normal or is that the problem?
    P.S. anyone want a rodeo cheep... LOL!!!!
  • To avoid a $200+ repair, has anyone had experience with the dashboard bulbs (not the warning lights) and radio antenna going out at the same time? I replaced the dashboard fuse three times and it blew within an hour each time of turning on the headlights. This also silenced the warning rings when headlights are left on. The fact that the radio went on the fritz (sound but no antenna) the same time makes me think there is a short somewhere between the two components. If I can pinpoint the short, I can get a much cheaper repair.

    Flo S
Sign In or Register to comment.