Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Isuzu Rodeo

1106107109111112

Comments

  • mikadencomikadenco Posts: 2
    SUV has been virtually problem free for 125K miles (7 years). It has had all regular maintenance performed, esp. timing belt replacement, recent tune up, etc.
    After a lot of water was dumped on hood of car, (don't ask, but engine was cold), the engine would crank but not start. (key would stay in crank mode unless turned back). I believe that this is normal, key should go back after ignition. Not?
    Fuel Pump is ok. Local mechanic is looking at computer run ignition system but after two days still has no idea what is wrong.
    Any ideas? Remember this Rodeo has been better than great until now.
  • rickiesuerickiesue Posts: 4
    Did ya get the problem fixed? We are having same problem(read my post) it seems to be the alarm, because it ran fine the 1st week we had it, then one nite, someone tried to break in it & set the alarm off- it didn't come with a remote key lock, but I turned the alarm off when I unlocked the truck with the key. But the next morning when I got in it to leave, it kept dying. So we put battery cables on it to jump it, it drove about 1/2 block then died. Now, it won't crank at all! Been to about 5 different shops, dealership included. No one seems to know how to shut the alarm off, bypass it or whatever need to be done to fix it. I am so upset & running out of money! So if ya have any ideas, please let me know! I hate for it to be a total loss because I don't have the money to buy anything else, now that I've put all this money into this truck. It's a 2001 isuzu rodeo 2wd-thank you for any help
  • I keep reading about these problems with the Passport...I had a Jetta that had similar problems and it was a fuel mix sensor that was bad. Good luck.
  • brendtbrendt Posts: 3
    came across your problem. I have the same situation too with a 2002 rodeo I just purchased, however the radio I just installed professionally works. My dashboard lights and rear tail lights are out. Breaklights and headlights still ok.
    In my case it was not the bulbs. And its baffled the technicians so far, as they check for shorts in all the wires and lights.
    In my case I think the previous owner was doing some off-roading with it which is what the rodeo was designed to do, however it can really jar-up the electronics on the inside.
  • I just bought this Honda with 81,000 miles on it and after driving it for a bit I've noticed a popping coming from the rear (what seems to be). when I'm rolling forward at a light I notice it more than coming to a stop but it happens wither or not my front wheels are turned which leads me to forget the bearings, CV joints, or front axle. Sometimes it will even cause the cab to bounce a little bit. I took it in to my mechanic and he checked out the front end and the bearings needed to be greased but were not terrible. He checked the rear fluid and seems to be fine, but other than that nothing out of the ordinary. I didn't have the time to have him drive it around to see if he could feel it so I thought I would try to find out if anyone had an idea of what it could be. thanks guys..
  • brendt: you said you had the same problem w/ your 2002 Rodeo? Do you mean you couldn't bypass or turn the alarm system off? And that yours wouldn't crank? If so, how did ya fix it? Ours not cranking started w/ the alarm being set off. Now the truck won't start at all- when trying to crank it it shuts everything down as if someone is trying to steal it. And no one-professionals, dealerships, etc, know how to fix it! I can't believe this! Don't know what else to do!
  • rickiesue: your truck is not cranking after the alarm was set off! try pushing a button under the fuse box ( to your left under your fuse box there's a small button that you have to push when you crank your truck) it happened to me and nobody know when I call the dealer so just tried this and it worked.
  • Were you able to fix your problem? just concern coz it happened to me too and the dealership dint help me at all so I just keep researching and there is this 1 button where (under the fuse box below the steering wheel ) that you have to push when you start the car. I think thats the switch to stop the alarm.
  • No, it's been sitting at another mechanics house for about a month now! They have tried everything. From what I remember, there's no button like you're describing, only a little light under there that lights up to show that the alarm was activated or working or whatever but nothing to push! I can not believe that no one can figure out how to fix it! I talked to the service manager at the dealershikp- he guaranteed me he could fix it, but that we need to put a new fuel pump (they said about $700) in it-when all this started not a thing was wrong with fuel pump, so why now?! I just feel they are trying to get us to spend all this money! I don't know what else to do! We actually bought a little Kia Sportage 2 weeks ago-got a good deal on it, but I hate we have spent all this
    money on the rodeo! I hate to take a loss we really can't afford on it!
  • Hi, my 2000 Rodeo reach 93k and I am preparing for the 90k service. I am planing to have my independent mechanic doing the timing belt. What else should I replace while he is changing the timing belt? The 30k and 60k service were done by dealer. Now they are all gone. Thanks in advance.
  • cracoviancracovian Posts: 337
    Add the water pump to the list. Try not to pay more than $400 for timing belt and the pump.
  • How do I find out what the trim level is on my 1992 Isuzu Rodeo? I do not see it any where. Please send answers or ideas to shaunida@mchsi.com

    Thank you.
  • To all the people posting on this site, have any of you been reading or are any of you aware of the issues with the Rodeo and Passport vehicles? The rear driver's side torque bar rusts off and causes accidents or near accidents. There is currently a federal investigation in the process with the hopeful outcome being a recall. This covers vehicles from 1995 to 2002. Go to Edmunds.com forum and go to Isuzu Rodeo then Rodeo Frame Rust, and read the issues so many of us are having. You all need to be aware of this. The frames are rusting like swiss cheese. This is a safey issue and Honda and Isuzu refuse to acknowledge any responsibility. Because of the number of complaints, a federal investigation is in the process. Derek Rinehardt is heading the investigation, all that info is available on Edmunds forum. If you drive your family, please make sure your vehicle is safe and free of rust. If it has the same problem as hundreds of us, contact Mr. Rinehardt, file a complaint with NHTSA and with Honda and Isuzu. Let them know this is serious. Honda and Isuzu just hopes we will go away. I have been working on this for a year in January, since my near accident which occurred when the torque arm rusted off while driving my 1998 Honda Passport. This occurred without any warning, as it has occurred to many other drivers. Suddenly it feels like you are driving on ice and then BAM the torque arm falls off and there you are. I realize this is not an issue previously covered in this forum, but anyone who drives these vehicles needs to be aware.
  • tidestertidester Posts: 10,110
    Here's the link: Rodeo Frame Rust

    tidester, host
    SUVs and Smart Shopper
  • WE HAVE A 1991 HONDA PASSPORT WITH A 3.2 V6 MOTOR DOHC, ONE OF THE CAM PULLYS DID A GRENADE ACT, WHAT WE NEED TO KNOW IS THIS AN INTERFEARENCE MOTOR OR NOT. PLEASE HELP THANK YOU. GOSLING ONE.
  • tidestertidester Posts: 10,110
    Isuzu made interference engines for the Rodeo up until model year '96 so that should include your '91 Passport.

    tidester, host
    SUVs and Smart Shopper
  • patsyldpatsyld Posts: 3
    I am new to this forum...I have a 1999 Isuzu Rodeo. I have had problems with the check engine light staying on, I live in a state where DEQ testing has to be completed in order to license my car, and if the light is flashing no licensing. I had it hooked up to a reader and it said the # one cylinder needed to be replaced, so I had it replaced along with all of the spark plugs. The light was then reset, It immediately came back on, I had the car tested again and it said that the #1 cylinder was misfiring. I had a mechanic friend of mine looked at it and said that there wasnt a spark going to the #1. any ideas what might be going on, I cant afford much and I need to get my car licensed. I need HELP PLEASE
  • rtittortitto Posts: 3
    last week when i was driving Isuzu Rodeo 1999 with 133K miles on it - on the way to work on highway suddenly it started making rattling noise and i slow down the SUV and took exit and it stopped and not able to start, i ended up towing the car to mechanic and he said - Engine has issues with pistons - out of 6 pistons one piston broke and it is making noise. Mechanic suggest to replace the engine, quotation i got from mechanic is total of $4000 to replace with 100k Miles used engine. I am not sure it is worth spending to replace the engine with $4K?
    As per mechanic - it is known problems with Isuzu engines as it is design flaw that is what he is telling. Is it worth contacting Isuzu for explanation?
    I also reached out to Isuzu dealer for price quotation for new engine - it costs around $9000.

    Any one ran in to this kind of scenario? Any suggestion to keep replace with 100k engine by spending $4k, is it worth spending?

    Appreciate!!!
    ~Raj :(
  • edhinfledhinfl Posts: 9
    I have a 1998 - engine replaced at 75,000 miles - I would NEVER AGAIN spend that much money on an Isuzu. Parts will get harder to find since they are pulling out of the US.
  • dougw2dougw2 Posts: 4
    Check the frame condition around the trailing arm connection, this is the arm that connects the rear drive axle to the frame, Mine was also making a popping noise when stopping, couldn't find out where it was coming from till my frame rusted at the mount and the trailing arm fell off. after fixed I never did hear the popping noise again. 1 year later my coil spring and upper shock mount rusted off at the frame?? If your frame is rusted , Check forums for Rodeo frame rust, file complaint if you still have the vehicle.
Sign In or Register to comment.