Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Isuzu Rodeo

1106107108109110112»

Comments

  • jonhexxjonhexx Posts: 1
    I have a fuel smell in the cabin. I checked engine compartment and it seems that smell is on passenger side. Any ideas?
  • I've been searching and searching for fender flares for my Rodeo similar to that of the bushwacker cut-out series. I've had no results in finding any. I know that there has to be some sort of a fender riveted fender flare that'll fit it because I've seen pictures but no results of where to order any. Could anyone please help me?
  • I had the same problem after installing a used brake booster. Apparently it was a vac leak in the booster
  • SGT-HALKA.....

    Did you ever get your passport to start again after all the stalling???
  • lmnoelmnoe Posts: 1
    im having issues with my heating fan on my rodeo. sometimes it works, usually when it is warm and sometimes it jus doesnt. sometimes it works fully and other times it seems as tho the fan is struggling to work at all. other times, usually like i said when it is cold it does not work at all. iits funny because it only works in the winter once the vehiclle has been run fpr upto a half hour. ive checked all connections and everything sems to be in place. the fact that it is spiratic is what really confuses me. if anyone has any idea of what to look for or a solution to my problem it would be greatly appreciated.
  • It is a 2001 Isuzu Rodeo and I bought it non running, the battery has been disconnected so there are no codes to read with my scanner. When I try to start it I get no fire, it turns over fine. The fuel pump is working. When I put the key in and turn to the first position the anti theft light is out and also in the second position its out but when in the 3rd cranking position it flashes. I have read that it is the anti theft keeping it from starting but I don't know how to fix it, please help.
Sign In or Register to comment.