Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Isuzu Rodeo

18788909293112

Comments

  • I have a 1994 rode. It overheatedx3. Had the radiator, waterpump, therm, head gasket replaced. It still leaks radiator fluid. And now it won't start. Had spark plugs changed, nothing. What could be the problem with this car? Starter and alternator are fine.
  • Boris2Boris2 Posts: 177
    I think it all depends on how agressive you use them.

    My '01 Rodeo has almost 80K on it and i am getting ready to replace front brakes. They are not squelling yet, but the truck starts to shake when braking at high speed.

    The rear brakes are still very good and will probably not need to be replaced for another 30-50K
  • garssgarss Posts: 1
    I have a 2000 Honda Passport with just 70,000 miles on it. A month and a half ago, it suddenly just stopped running. Two mechanics and 3 Honda dealerships later, I was told that they can't do anything to fix it. They first thought that it was a problem with the timing belt so they had it replaced. Then they replaced the tensioner, worked on the cam shafts, did a pressure test on the engine but found nothing wrong. The Honda dealership tells me that it seems only half of the engine is running. They had a new computer chip shipped to the dealership so they could try it on my car but it didn't fix the problem. I'm close to giving up on it. I was also told that there's another Honda passport out there having the same problems. Do you guys have any suggestions before I junk the car?
  • Hello. .
    I'm NOT a mechanic and I live in a foreign country where nobody has computer diagnostics here for my Isuzu Rodeo 2004. The vehicle has 5,000 miles on it. Previously, the 4WD would work fine. At some point, the 4WD would not turn off when I turned the 4WD switch off. The only way to turn off the 4wd would be to stop the vehicle, turn off the engine, and then turn off the 4WD switch. This worked for a while. Then, I turned the engine off 1 day, turned off the 4WD switch, and the Check 4WD Indicator Light lit up. The indicator light has been on for many months now, and the 4WD won't turn on at all now. Any ideas of what is wrong? What is the fix? Thanks so much!
  • My back window won't stay latched. I tried adjusting the window latch on the window, but the latch mechanism is just worn out. I bought a replacement one from the dealership. I have the Haynes book and it seems pretty straight forward, but I know nothing about working on my car has ever ended up being simple. I have a feeling that removing the actuating rods and installing them will be a nightmare. I was just wondering if anyone's replace it and if anyone had any tips for a single girl doing it herself.
  • I have a 97 passport that had hard shifting problems when stopping and it would occasionally loose power in the lower gears. You might want to check the gear select switch on the side of the transmission, they tend to get dirty and send improper gear selection info to the computer. The switch can be taken apart and cleaned. Not sure if yours has the same tranny as mine(4L30). Hope this helps.
  • I recently went to start my car and, nothing! No warning before this. No other major problems. Not the battery. Radio and indicator lights still work. Not the starter as confirmed by the first mechanic who looked at it. Isuzu dealer says it's the transmission harness. I could pay $390 to have them replace a wire and bypass the harness ground. This may fix this problem but may not prevent future problems with the harness. Or, I could pay $1055 and have the whole thing replaced. Ouch. Anybody else have problems with this. I feel they have me over a barrel. My car won't even start. Help!
  • makayemakaye Posts: 81
    You might check for recalls or technical service bulletins for this condition. Look from 1998:

    NHTSA CAMPAIGN ID Number: 98V170001
    Component: ELECTRICAL SYSTEM:WIRING:HARNESS:FRONT:UNDERHOOD
    Manufacturer: ISUZU MOTOR, LIMITED
    Year: 1998
    Make: ISUZU TRUCK
    Model: RODEO
    Manufactured From: JUL 1997 To: FEB 1998
    Year of Recall: '98
    Type of Report: Vehicle
    Summary:

    Vehicle Description: Sport utility vehicles. A ground connection terminal was not properly crimped in the supplier's engine wiring harness manufacturing line. This improper crimping process can leave an impression on the terminal that will eventually cause a stress fracture. Q: If a terminal is fractured, the powertrain control module
    (PCM) can receive an erroneous signal indicating a high vehicle speed, thereby causing the PCM to cut the fuel, causing a 'no-start' condition, or a possible engine stall.
  • My rodeo is having problems, it starts and as it is idling it sounds like it is struggling to get fuel or power. I also notice that the battery indication fluctuates when I press on the brake. When I put it in reverse it almost stalls out. I backed out of the driveway slightly then I put it in drive and it just started rolling back and the brakes wouldn't even hold it. I can fix an airplane, but I am out of my element with cars. How often should a battery be changed? I left the interior lights on last week and I had to jump it, could this be related?
  • When I start my v6 rodeo (automatic) on cold start it revs to 4500 rpm, then slowly goes to normal idle after about 2 min. Seems like it is waiting for the water temp to heat up? Once warm it seems fine. Its the initial 2 min high rev that is scary. I don't dare put it in gear until it idles under 1000. :cry:

    Any ideas what is wrong? Any help would be appreciated!

    Mulcher1
  • I had the same problem with the gas light on my 2000 Rodeo. The problem is a sensor in the gas tank, which cost around $550.
  • dcamdcam Posts: 15
    Does your reduced power lamp come on?Does the vehicle run normal and then die?Sounds like a wire harness problem.This is
    common for your year model.Take it to an Isuzu dealer.If this is the problem,they should be able to diagnose it quickly.
  • dcamdcam Posts: 15
    Hey snow.non interference means if the timing belt breaks,the pistons will not hit the valves and cause engine damage.I would recommend taking it to the dealer.It is very easy for a mechanic not familiar with the product to set the timing wrong.Look to replace the timing belt tensioner and waterpump
    at the same time.
  • I replaced the lock mechanism. It wasn't too bad. I closed the window it worked. I tried it again. It worked and the fourt test, it quit working. The brand new window latch mechanism isn't locking. I tried removing the striker part on the window and getting the mechanism to lock and then just tightening it down. I couldn't get that to work. I couldn't get it to square up and stay locked it would pop unlocked. I don't know if the latch on the window part needs replacing or if i just got a bum latch mechanism.

    Any Help is GREATLY APPRECIATED!
  • I have a 2001 Rodeo sport. I had what sounds like a similar problem. It would lerch while shifting or while stopping. I had to have mode switch replaced it's under the dash, it communicates between the indicator on the dash and the gear on the floor board. I'm not sure if yours is set up this way, but it is a lot cheaper than a new transmission.
  • I have 84K miles and I'm being told by the mechanics to have timing belt changed and they recommend changing the water pump. If I don't change the timing belt right now should I be worried about blowing my engine. The mechanics are telling me I will blow my engine if it breaks. Is this true? I've been quoted between $350 - $500, does that seem reasonable?
    Any help is appreciated. Thanks
  • dcamdcam Posts: 15
    If you have a v-6 engine,you will not damage your engine if
    the t-belt breaks.If you have a 4 cylinder,then you will damage the engine if the belt breaks.You should replace the timing belt,tensioner, and waterpump at one time with your mileage because they tend to fail at around 80k miles.The price seems reasonable if the waterpump is included.Check with an Isuzu dealer because they usually have a timing belt package price that is very reasonable and the parts are factory.
  • wlbrown9wlbrown9 Posts: 837
    I have a '00 Trooper. Just got an estimate from the local Isuzu/Chevy dealer on timing belt and water pump. They want $800 for the package. I'm looking at other options now...that is a little bit high for me.
  • does anyne here have to specs for a tow hitch for a 97 rodeo. i'm too cheap to buy one.... but if i can get the dimensions on one, i can build it... please help
  • jnealjneal Posts: 247
    Not trying to be facetious but if this were mine I would jack it waay up in the air and drive a new vehicle under it and go about my business.......
    Sounds like it is going to cost you more than the vehicle is worth, especially given all the trouble you have had with it.
Sign In or Register to comment.