Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mercedes-Benz M-class (ML320, ML350, ML500 and ML55) 2005 and earlier

1191192194196197261

Comments

  • akin67akin67 Posts: 62
    11,000 miles is really early for changing rear brakes. Assuming they really needed replacing, there must have been someting wrong that caused them to wear down so quickly. In daily use I didn't smell the brakes burning or anything.

    And as I have stated earlier the service rep was particullarly surprised at the rear brakes wearing down. Apparently usually the front brakes wear down much sooner than rear brakes.

    Also, the rear hatch lock does not lock with the automatic lock switch or the remote unless I open up the hatch and manually lock it. This is annoying since whenever you stop the car and turn off the ignition all of the locks automatically unlock including the hatch. I then have to go and manually lock it each time. I will have this fixed as well.
  • This is a copy of a posting I made to another list on 10-29-'01:

    I read so often of poor brake pad wear life on the M-Class. I just inspected my pads with 39,550 miles on my 1998 ML-320 and the front pads are 0.263" thick and the rears are 0.308" thick. New pads are 0.383" thick, and the allowable minimum wear is 0.120". This calculates to my brake wear being 40% for the front and 30% for the rear. If the wear was linear it would mean I could expect to reach almost 100,000 miles before the front pads require replacement, and 138,000 miles for the rears. I don't expect this since the rotor surfaces are no longer perfectly smooth, and the wear rate should increase somewhat.

    My driving is mostly highway, with few hills, except for the two trips to California across the Rockies. Also, I'm a conservative driver and usually get excellent brake and tire life.
  • cielciel Posts: 2
    Tomhock - TWO separate MB service managers stated to me specifically just yesterday that they are replacing brakes in these cars as early as 10K. Most are making it to 20K.

    How did you manage to measure brake pad width? And what do you make of all the brake noise and dirt that they give off? What about the BAS lights going off - separate system I realize but still related to turning & braking....

    AKIN67 - I never had a door latch problem but beware - my GPS died on two separate occasions (faulty) And check the trim around the two front doors - it may start to buckle (defective).
  • ciel: I measured the brake pad thickness the last time I rotated the tires. I used a dial calipers with a depth measuring rod. Using the depth measuring feature it was easy to determine the thickness of the pad material without removing any brake components. This probibly isn't clear, but if you remove a wheel and just look at the pads you can get a very good feel for the material remaining on the pads. I looked at a set of new pads, that I purchased in anticipation of needing them after reading all the reports of early replacements, and measured the pad material that would remain once the wear indicator was contacted. This "minimum" allowable pad thickness is 0.120 inches(on the set I measured). Keep in mind that when this point is reached it is just a reminder that your brake pads will need replacing soon. They still have 30% of the new pad thickness, and thousands of miles of use remaining once the "Brake pads" dash light comes on.
    On my vehicle I never had any brake noise. My brakes have always been smooth and quiet. The brake dust is another problem I guess we all have. I spot clean the wheels with a paper towel and WD-40 when it bothers me and I'm going someplace where I want it to look good.
    Regarding the "BSA" lights. I don't know what that is. I have no indication while driving that my ABS is malfunctioning, and the ETS warning light only flashes (very infrequently) when I drive on snow covered Wisconsin roads.
  • wnielwniel Posts: 97
    I have a 1998 ML and now have 51K on it and have replaced the front pads at about 30K and the back pads haven't been replaced at this time. However, I'm expecting that they will need replacing in the not too distant future. One can look through the opening of the wheels with a flash light and see the pads and get an estimation on the amount of wear left in the pads. My truck gets a mixed amount of highway and town driving but do not drive too aggressively requiring heavy braking.
    Wally
  • pooliopoolio Posts: 18
    I would like to know if enyone has ever attached the ML wing on the back of there Benz,if it would obstruct the opening of the rear door if you had the ML phone antenna.
  • I have the rear wing (roof mounted spoiler) on my 2002 ML500, and it does not impede the rear hatch opening or the roof antenna in any way.
  • mark156mark156 Posts: 1,992
    Roger23.... how do you compare your 2002 with the 2000 ML that you had?

    M.
  • Having had both, I can honestly say that my 2000 ml was a significant improvement over my 1998 ml320,and the new 2002 takes a similar leap in terms of fit and finish, new technology, and driver/owner satisfaction.
  • pooliopoolio Posts: 18
    Thanks Roger23.I'm really considering getting the ML wing now.Might help keep some of the dirt off the back window
  • I have a 1998 ML320 with 72K miles. In Sept. 2001 the fuel pump failed at 62K and was replaced at my cost. In early Jan. 2002 it had to be replaced again (under warranty) and I went for the suggested fuel line upgrade. In late Jan. it failed again while we were on vacation in FL, was towed again, and replaced. In each of these instances, we were unable to start the vehicle while it was standing parked. Yesterday, while driving, the engine cut out and our ML is back at the FL dealer's shop. That's 4 failures in 4 months. They seem to be trying to correct the problem but don't seem to have a clue. Anybody got any suggestions? In a couple weeks I've got to drive back home, and frankly I'm not looking forward to the prospect. Advice will be appreciated.
  • ML fuel pumps were redesigned in early 2000. If you are in fact getting these new pumps and hopefully in error,not 'old inventory', you should not be having this recurring problem.
  • steverstever YooperlandPosts: 40,209
    I seem to recall a key problem, gman20, esp. with those very early models. If you have a bunch of keys on your keychain (more than 2 or 3), the key loses contact with the immobiliser system (esp. over hard bumps). If it keeps happening, the car will shut down.

    So I'd check out the immobiliser - (aka driver authorization system) or just empty your key chain a bit. Good luck.

    Steve
    Host
    SUVs, Vans and Aftermarket & Accessories Message Boards

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • While I don't suffer from any problems aside from this creak/squeak coming from the windshield, it's enough to drive me insane! I'm tired of taking it down to the dealership at this point -- I've only been down there two times, and they have tried to fix both times and were very pleasant -- no complaints about dealership (RBM of Atlanta).

    Anyway, what I have is described more as a creak than a squeak. There is no metal involved in the creak and I can't seem to pintpoint the location. I've had my wife drive and I've tried running my hand along the areas up against the windshield/dash to see if I can make it stop... but I can't.

    Also, the creak ONLY appears to happen when the weather is cooler. If it's warm (>55 degrees or so) then this doesn't happen.

    * 1st time this occured, it seemed to be a slight creak... and then it eventually crawled all the way across the base of the windshield. Went to dealership and they sprayed some silicon down in there (or somewhere) and it went away only to come back later.

    * 2nd time this occured, it seemd to only be on the passenger side near the base of the windshield. Wife took it to the dealership and they said that a clamp was loose and then this is what was done "NON TO R&R UPPER PORTION OF A-PILLAR TO APPLY FELT AND LUBE". Now the problem appears to be on the driver's side of the car?!

    Help me fix this problem as it's extremely aggravating. :)

    Thanks!

    This is what you said about it:

    <<<<
    Spraying some silicon spray into that area (along the base of the windshield/dash) and letting it work its way in for a few days solved the probem for me. However, I did mention it at Service A. FYI, according to the work order, "A-pillar trim fit foam under dash corner to realign corner of dash. Refit A-pillar trim". The slight amount of play that used to be there is now completely gone. It is as tight as the A-pillar trim/dashboard on the driver's side. No squeaks, no creaks. :-)

    Drew
    Host
    Vans and SUVs message boards
    >>>>>
  • When we put the ML430 into reverse and the brakes are applied, we get this tremendously obnoxious squeel from the brakes. When we are going forward, this doesn't happen.

    Can anyone offer suggestions on addressing this issue?

    Thanks!
  • dt77dt77 Posts: 232
    I got major squeal too !
    this occurs going forward and backward!
    turns heads.
    no warning on brake wear sensor...
    i hope it's brake dust. or else..i'm pretty much wearing out my brakes and rotors ...
    service b coming up..so maybe i'll have it checked out...

    dt77
    fullspeed.to/ml
  • dt77dt77 Posts: 232
    I just looked at my service record:

    Sometime last March, I had complained of brake squeak when backing up and when slowing to a stop.

    Service advisor told me rear pad need a changin'.
    The warning sensor had not come on yet, but I forget wat percentage he told me was left of it but he said it was almost down to the sensor.

    That say, my brake pads were replaced at 9962 miles. cost : $276.53 (parts and labor).

    I have pics below of the old pads - almost down to the sensor.

    *** on a side note, my fronts were replaced a few months under warranty for squeak.

    dt77
    2000 ml430
    fullspeed.to/ml
  • dt77dt77 Posts: 232
    steve is right about the keys. service advisor has spoken of instances where owners ml's would shut off randomly. He attributes it to having too many keys on your key chain.

    I had a fuel pump problem last year too. couldn't start car, fuel was spilling out from under the tank (the fuel line came loose after a previous service). fuel pump was replaced if i rem correctly.

    dt77
    fullspeed.to/ml
  • Cassiri - I had the local tire shop install my SP5000's last week, what a difference. They are so quiet and smooth I actually enjoy the truck 100% more. I go them through the Tire rack $153 each, so there not too cheap, but it could be worse. No rain yet, but the spray pattern from wet (sprinklers) roads leads me to believe that these will be much better than Grandtreks, only down side is the side of the truck was filthy as they throw much more debris. The truck handles much better with no more of the "dead on center" feel that the stock tires had.

    Brakes - while mounting the new tires, the wheels were actually so stuck to the hubs that the shop had to use penetrating oil to help break free the hubs. They then sprayed the brakes with brake cleaner and viola, the annoying brake squeal this truck has always had disappeared (95%). Unfortunately, I need rear brakes, so I'm sure my new pads will squeal as before. (I've fought with the dealer to resolve this problem before and they were unwilling to do anything until I needed new pads).

    On my way home, I opened the sunroof and off came the wind deflector (pop-up one). I stopped and picked up all the parts, put them in the back seat, and will take it to MB to see what they say.

    SRS light, for the third time my SRS light is going off. Dealer has replaced two seat belt assemblies and now will do the rear three. They claim that the childseat may be culprit as it's always in the car! We'll see.

    FYI, i also was called about an engine cowling recall, anyone had this done yet? What was the problem?
  • mbaombao Posts: 1
    Hi,

    I just brought a new ML500 from a north Jersey dealer last weekend. The purchase contract says the truck has "10 miles" on it but when I got home and found its meter actually read "500" and change. I called the dealer back. They first denied saying every Mercedes was like that. When I challenged them, they admitted the the car had been used as a demo. The nav records showed this "demo" had been through many trips to Manhattan and once even to Conneticut. What do you think I should do in this situation? Please advise. Many thanks.

    mark
  • What the @#$%! I assume the drive from the dealership to your driveway wasn't 490 miles?

    The mileage on the vehicle is supposed to be recorded at the point of delivery. So if your paperwork says 10 miles, then there should only be 10 miles on the meter when they handed you your keys and gave you your intro to the car's feature and function.

    I'm not sure, but I don't think this is legal and completely fraudulent on the dealer's part. And if so, this would also be grounds for a breech of contract.
  • Just want to report the issues that I have so far on my 2002 ML 320 M1, M5, Bose:

    1. There is no "door ajar" warning light. I hate my 540 because it doesn't say w/c door is open but this is worse. You would think this would be standard.
    2. The passenger side rear view mirror does not tilt down. I had the dealer check this and they said that the M1 and M5 package doesn't cover it huh?
    3. Volume control is out of the way. Noticed that this is very popular on the list.

    Other than the above, the car is an excellent SUV.
  • 1. I was also puzzled about not having any warning light or sound when one of the doors was not shut completely. Unfortunately, you are going to have to rely on the dome light being on as your only indication that one of your doors hadn't shut properly. Good luck during the daytime though.

    2. I believe this feature can only be had with the M2 option.

    3. I too felt that the AutoPilot's automatic volume adjustments were annoying - at first. But it kind of grew on me and now I think it's quite useful. Either way, you can always have the dealership adjust its sensitivity or deactivate completely if you wish.
  • chowrchowr Posts: 11
    I just called my local Mercedes of Portland dealer and he basically told me that if I wanted a ML320 I had to pay MSRP. When I said that I heard people were getting discounts he said thank you very much but we don't do business that way and hung up. Is this what is going on or should I just find a better dealer?
  • mark156mark156 Posts: 1,992
    I got $1,500 off MSRP on my 2002 ML500 on special order in October 2001.... you can do better chowr. I waited 8 weeks for delivery. I got it a week before Christmas. The ML320's are more common and you should get a decent discount.

    M.
  • pooliopoolio Posts: 18
    Where can I get the cross bars for my 2000ML Roof Rack.
  • jrosasmcjrosasmc Posts: 1,704
    The 1998-01 M-Class uses body-on-frame construction, right?
  • thor8thor8 Posts: 303
    Yes, all of them including 2002.
  • Jon90Jon90 Posts: 33
    Your dealer better think again. I picked up an ML500 last month for below INVOICE. I never really calculated off of msrp but it was something like $3500 or so... Go to another dealer that will respect your money as well as your decision to buy a good auto.

    Good luck!
  • kiiwiikiiwii Posts: 283
    If I were you, I would definitely call MBUSA to establish a record.
Sign In or Register to comment.