Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda Tribute

1545556575860»

Comments

  • I wanted to tell you that the cold starts in the mornings is the air intake casket probably the lower one. It wasn't too expensive, but I had my uncle fix it for me. I just had that replaced this year. I don't know where to start with my tribute. I have had it for 5 years now & can't wait to get another car. The door handles tear up. I replaced the driver's side within about a year of having the car. Now the passenger side door handle is broken. I have a problem right now when driving down the road it shakes. We replaced the coil pack on cylinder one & the EGR valve & that didn't take care of it, BUT that is what the guy said the diagnostic machine read. The locks keep tearing up. Sometimes the back hatch doesn't want to lock & sometimes it locks & doesn't want to unlock. I keep reading other blogs & shaking my b/c I am having or have had the same problems. I will never buy another Mazda b/c of this car. I am going back to Toyota. I don't care what they have been thru lately they still hold up. I would advise any person with this car that is NOT long term.
  • Hey had mazda 42 long,I recently replaced upper and lower intake manifolds gaskets and the spark plugs my self I'm some what of a do it your self kinda guy,it saves me money that the mechanics wish they can pocket,and so far so good!!!next will be what ever is loose in the right front tire or suspension area, I'm getting a knocking sound like somethings loose,anyway u said that when u drive your getting some shaking going on, have u check on the motor mounts?? I've read that could be a problem with these mazda tributes as well so check that out and let me know how that goes,thanks again.
  • I've seen alot of "lousy mpg" problems people have been reporting, but I think (and am hoping) my case is slightly different. I don't know too much about cars, but I just bought a used 01 tribute ES 4wd that is getting piss poor city milage, and alright highway. I'm very light footed on the gas - I consistently get better then average millage in other cars, but for some reason I'm getting ~10mpg city, and 21 highway. One of the reasons I bought this car was because it had better then normal advertised mpg for the size SUV's I was looking at in my price range. The highway is fine, it'd be nice if it was better (I drive ~65mph, I'm not driving at 80), but I can live with 21, but does anybody have any advice for getting better city mpg? What parts do I need to look at, clean/replace? where should I start?

    For reference, the car has ~94K miles on it, no gas smell, and is idling very smoothly. I've been using 87octane gas (which I understand is recommended?). The 'closest' things I've seen to my problem are dirty MAF sensors, but my understanding is that there is a smell associated with them? I can't really afford to get 10mpg, but I also can't really afford to sell the car and take a hefty hit on it.
  • I have a 2001 Tribute ES with 4WD/AWD and would like to get chains for it. I've never had a 4WD vehicle before. Do you buy 2 sets or 4? If 2, which tires get them, the front or back? I believe when not in 4WD mode it is rear wheel drive so I assume they would go on the rear but I'm not sure.
    thx
  • Well, after I posted I went and googled chains on 4wd and learned that ideal would be chains on all 4 wheels but I could get by with 2 and the best place for them would be the rear. Just in case anyone else needs to know...
  • Hi - I have the same year/make of Tribute as you and am getting ~14mpg in city (winter) and ~16mpg in the summer. I too am no mechanic but do notice the mileage improving once I've replaced the air filter and a fresh oil/filter change. Probably not it but are you keeping up on that?
    Beyond that I'll defer to others more experienced. Sorry couldn't be more help.
  • bdymentbdyment Posts: 548
    The Escape/Tribute is front wheel drive when not in four wheel drive.
  • I'm looking at buying a 2005 Mazda Tribute with 120k miles on it. It had a new Engine and Transmission put in it recently.

    Anything I should pay attention to? Obviously I need to check struts, axles, radiator, fluids, oil, underneath the car, etc...

    From what I'm seeing, it looks like it should not be surprising that a new engine/transmission was put in it. However, what things should I be aware of if that did happen? If my e-mail shows up or there's a way to contact via e-mail, do so.
  • 8737987379 Posts: 2
    Yes! It happens to my wife's 01 Tribute DX-V6 4wd as well. Always feels like Im driving a stick. I don't know if it is a problem and not sure if it's been like since we got the car from the lot. We would have noticed it right away.
  • 8737987379 Posts: 2
    I took my 01 Tribute 4wd to Midas in Fremont CA to be diagnosed because the check engine light came on. P0401 insufficient air flow it what came out to be according to their scanner. Replaced EGR valve. Paid $385 parts and labor. After it's been driven 1-1 1/2 miles light came back on so I took back the next. Drove it again, light came back on again and it went on like this for a week. I got tired and took to recommended shop and found the the DPFE and solenoid were bad. My question is...should Midas reimburse me for not fixing the car?
Sign In or Register to comment.