Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2001 Tahoe- Fan/pump running after I shut down engine.

sgsmythsgsmyth Posts: 1
edited March 11 in Chevrolet
I have a 2001 tahoe w/74000miles. After I shut down the engine, a pump or fan noise from inside the engine continues to hum or turn. The only way to get it to stop is to disconnect the battery. After letting it sit for a few hours, I reconnected the battery and the noise started up again. Is it a fuel,oil, or water pump??? This is the first time this has ever happened. I know it's not the radiator fan.

Comments

  • jlong66jlong66 Posts: 4
    I have a similar problem on a 99 Tahoe. It is a noisy electric fuel pump right behing the left rear wheel. It drives me crazy. It runs for several seconds after turning off the ignition. I had the original replaced a couple years ago when it went out. A mechanic told me this one was noisier than most. Gee Thanks !

    Maybe yours is a cooling fan if it is up front. Just a guess.
  • march222march222 Posts: 4
    I had the same problem, it was the ABS motor, that runs to the brakes. To repair it factory part only, $1000.00 yeah thats right! A mechanic told me to disconnect it would be ok but no ABS. I guess it depends what is important to you. I had it fixed.
  • i have a 2001 model and the pump stays on even when engine is off. the only way to shut it off is by removing fuse. can the pump be reset somehow.
This discussion has been closed.