Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Cherokee

1103104106108109126

Comments

  • have had my keyless entry checked by service dept at local dealership, was told i need to replace my remote keyless entry module located in passenger door of car. this is almost $400.00 and cant afford, was going to go to salvage yard and get used one. does anyone know if this can be installed fairly easily and how do i then reprogram my current remotes. thanks.
  • dancermandancerman Posts: 220
    Around 40 psi is normal oil pressure with some fluctuation with engine RPM. Mine is usually on the high side of 40 psi.
  • Two things about Cherokees:
    1. the sender goes bad or leaks oil into the connector contacts...clean first
    2. The instrument pack connector goes bad or fries...check repair or replace (cut on off at the junk yard and splice it).
  • XJs run at 210, but can get hotter when off-roading at slow speed. If you run it colder, you will loose gas mileage because the O2 sensors will richen the mixture up.

    The electric fan comes on when:
    1. the AC is switched on
    2. when the temp sensor in the radiator says it is overheating
  • i have a 89 cherokee inline 6/4.0 engine.........its very hard starting,seems to have no power on accel(by the way its a 5speed manual)! i have to ride the clutch and gas to get anywhere...........very depressing! ive run lucas fuel injector in the gas to clean the injectors and still it seems to wanna stall and has no power.
    any advice would help alot!..........is their a way to bypass the egr valve? or atleast check to see if it is the cause of my nightmare? its just a work car but im used to driving it! im not a mechanic so please keep it simple.....thanks
  • I recently had my tranny replaced at a shop and when I got it back the temp gauge no longer registered any type of temp reading. The tranny shop insisted it was not anything related to the work they did. I just found a sensor of some kind hanging loose when I did my oil change. The sensor end is a sealed type (non-liquid)sensor with two mounting holes that appear to have recently been mounted somewhere (clean of oil & dirt where two nuts would have been). The opposite end is an electrical plug with four pins. I do not know if this is related to the inoperative temp gauge or not. Anybody have a clue on either of these two issues? FYI, the inoperative temp gauge is not fuse related (as suggested by the tranny shop).
  • I have a '93 Grand Cherokee Laredo with the 4L 6-cylinder engine. I recently had to replace my passenger side headlight bulb. I disconnected the battery, replaced the bulb, re connected the battery and just like that the truck wouldn't start. It cranks just fine, turns over and revs for a moment before dying out. I had a mechanic look at it and he was clueless as to what the problem was. He ruled out all the usual stuff and told me that it was getting all the necessary ingredients but I'd have to take it do a Dealer(I refused to do this blindly for a vehicle I paid $2500 for.) This mechanic is very reputable so I'm guessing he isn't really familliar with older Jeeps and that's why he didn't know about the diagnostic check you can do by turning the key three times(thanks to Paul at O'Reilly's for the 411!!) I performed the diagnostic check and got three codes...
    11- No distributor reference signal detected during engine cranking. Check the circuit between the distributor and the PCM.
    12- Problem with the battery connection. Direct battery input to PCM disconnected within the last 50 ignition key cycles.
    14- Manifold absolute pressure sensor voltage too high or too low.
    then of course the 55 end of message code.
    The engine has 170,000 miles on it but the previous owner,an Air Force pilot I went to church with took very good care of it and I have kept up with the standard preventive maintenance. I had absolutely no problem with this vehicle before I changed that headlight bulb.
    I have a Hayne's manual now(that's how I know what the codes are0 but once you get past basic mechanical stuff(this one's a phillips, this one's a flat-head) it might as well be written in Japanese. Any help,advice, insight etc. would be greatly appreciated. Thanks,
    Mark
  • I had the coil tested also had the ignition module tested the starter is 5 months old the starter relay is new the battery is new it was cranking but just wouldn't start can anyone help me out with this i don't want to get rid of my jeep just yet
  • Hi. As an owner of a 1993 Sport I know exactly what you are talking about. Of course you should check what you can and even buy a radiator flush to resolve the obvious. There is so much that goes into the heat issue (fan clutch, radiator efficiency, so)....
    I have seen the best luck is to improve the original. There is a High Output radiator (tow package) from Jeep, but some what cheaper are multiple core radiators to replace the underated original (online around $220). If you have AC and the small electric fan, replacing it with a after market fan provides superior performance. There is often a problem with the fan clutch, some after market fans (flexible fans with no clutch) work much better than the original. I have heard a few accounts of a replacement electric fan which is much more efficient for cooling and provides better fuel economy AND power.
  • I wouldn't reply as someone already stated the truth. The electric fan is an assist fan for the AC. It does not run unless the AC is on and the sensor temperature is exceeded.

    As other noted, Jeep Cherokees run hot from the day you drive one home (but you may not had to test it by loading the engine in a hot environment), and the cooling often degrades over time. Lots of posts will give you better performance parts from Jeep or other aftermarket companies.
  • Does anyone know the tow rating for a 99 cherokee Sport. It does not have a tow package. Can I safely pull a boat which weighs 2500 lbs (boat and trailer). It does not have trailer brakes. Maximum tow distance will be 1 hour. Thanks
  • In recent months has become harder and harder to start, cranks good, runs great after it starts. had fuel pump changed and it started fine for 2 days then same old problem, replaced that pump, no help. replaced crank position sensor, fuel cap, plugs. have spent a lot of money and i have the same problem i started with..HELP
  • i bought 2 keyless remotes from an internet web sight for my 2000 jeep cherokee. got both for around 30 bucks. it cost me 25.00 per remote to have the local dealer program them. heck of a lot less than $400 try google amd search for jeep keyless remotes .
  • I've got a 2001 Jeep Cherokee 4x4 Sport with and Auto Trans. It's just when over 70K miles. I've just recently noticed that when driving at 50 or better it seems to jump between gears. When going 50mph it will jump from about 1500rpm to about 2100rpm. There is no change in modulation to the gas pedal and this is done on a flat road so there is no change in hill accent/decent. I first noticed the problem when the car was going between 60-70mph. The RPM's will jump up for a little bit then jump back down. It will continue to do this for a while. I'm not sure how long this would go on as my typical drives are not great in distance. It has been getting significantly colder and I am wondering if that could be part of the problem, but I fear that this isn't it. My inclination is that it might be: a sensor, something with the transmission, or throttle body (just putting it out there). Has anyone had a similar problem or knowledge of potential solutions to this problem?
  • hello, just bought my 3rd jeep, (94 wrangler, 87 cherokee and now a 2001 cherokee limited )

    we got really "duped" by the seller...forgot to mention about the rebuilt/salvage title...it was stolen and no damage was done to it but still got that title...anyway long story but the good thing is that the bank is ok with it. phewwww!

    now, 3 days later...
    i tried to put it in 4H and it kicked "itself out" when i was driving. i did think that i probably did not put it right in gear and did it again. one more time, it just went back to 2wd by itself.
    a little later i tried it again and not only did it go back to 2wd (or else?) again but it made a HORRIBLE noise and scare the living sh** outta me!

    I stopped at the jeep dealer on my way to work, the guy was not very nice, said i was not engaging the lever into the right place. well he did it and got "the noise"!! he said, well your transfer case is having problems, gotta change it"
    he said it was not a "big" repair....only 1500$ plus time!!
    :surprise:

    so not only did we pay wayyyyyy too much for the truck but now it has a problem...
    can anyone give me some advice pleaseeeeee????? :)
    what could be the problem???

    thank you :shades:
  • My '93 Cherokee has had this intermittent power loss problem for a while, but it is extremely indiscriminate. I would be driving and all of a sudden the engine just stops, I have all electrical power but no engine. I know about the CPS unit, but a friend (mechanic) has suggested it could be a relay or the ignition module. Has anyone had this problem and if so, what was the resolution to it? Thanks. It is so indiscriminate that the only possible commonality to the engine loss is moisture if that.
  • tuggajbtuggajb Posts: 646
    first off used two typs transfer for this jeep
    1 you have 2 w drive
    2 full time 4x4
    3 4x4 part time
    4 4x4 low
    use only 4x4 part time and 4x4 low on slipury roars

    can use 4x4 fulltime all the time

    check oil change look for iron shavings
    could have linkage out of adjusment
    do that then see what happens
  • thanks for your reply!

    right now I have the one with the command trac (part time) but my other cherokee had the select trac (full time) so i knew how to use it and i also used the awd really often with my wrangler when i was back in canada and never did have that kind of problem :confuse:
    the problem with this one occured when i was on a snowy road so i know it is not because of dry pavement. :sick:

    the oil has been change last week by previous owner and my husband checked it this w/e and it was nice and clear.

    I will relay your infos to my husband ;)

    thanks again! :)
  • I have a Jeep Cherokee 2000 modle 2.5tdi. It only has 101000km (not sure what that is in milage) so the engine in theory is still in good running order and probably could run for another 100 000 - 200 000 before the engine needs to be overhauled. The problem that i am experiancing is that the car is smoking. I know desiel engines do smoke, but this seems to be smoking more than others seem.i don't seem to be suffering a loss of power, but i also have nothing to compare it to as this is the first jeep that i have owned. I have heard comment previously regarding Jeep diesels smoking. Is this normal for the Jeep to smoke so much. If it is not is there anyone who can give me suggestions on how to solve this problem.
  • Try running cetane booster in each tankful - it usually quiets the diesel down and promotoes cleaner burning (less smoke). You can buy it Walmart or most any autostore. Powerserve is one brand that I have used. :)
Sign In or Register to comment.