Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Subaru Tribeca 2008

1303132333436»

Comments

  • With less than 11,000 miles on this vehicle here is what has gone bad:

    Transmission Wiring Harness
    Exhaust Heat Shield needed replaced - transmission was whining at 3000 rpm.
    Right CAT Converter had a loose pipe inside and it needed replaced

    Mechanic tore my whole back end apart to find out what was rattling - He replaced 3 rear panels, clips in the headliner in cargo area were loose so he fixed those, wiring harness running along the rear panels were making a noise so he used electrical tape to prevent them rattling. He found the camera was loose and tightened that. He put electrical tape on the striker and greased up some of the rubber fittings in the rear hatch. Did a pretty good job in reducing noise but then I couldn't open the hatch. Took it back in to have the hatch fixed and now some the rattling is coming back. Not as noisy as it was originally. Mechanic said that it appears the rear hatch is moving around and doesn't appear to be stable.

    I have to say the folks at Camp Subaru in Spokane have been wonderful with me in trying to resolve these problems. They are just as frustrated as I am. Per their request, I submitted a complaint letter to Subaru Headquarters. I received a prompt response and will be meeting with a Subaru Rep in Feb 2010. Subaru Headquarters is also willing to work with me to purchase 2010 Tribeca but I have asked to be compensated as to what I have put in towards this vehicle. I've owned Subaru's before so I know they are a wonderful vehicle. I just happened to get a lemon. I could be a real pissed off customer but the customer service I have been receiving has been outstanding and I can't fault the dealer for what is happening. I'm impressed so far with Headquarters. We will see what they can offer me in the way of trade for a 2010. I've never had to do anything like this and I don't want to be taken advantage of. If anyone has any suggestions of what I should expect from Subaru, I'd like to hear them. I bought the extended warranty, towing package, lifetime oil change and have a very low interest rate on my loan and have been making double car payments to get this paid off early. I need them to make it worth my while.
    :lemon: :lemon: :lemon: :lemon: :lemon:
  • ateixeiraateixeira Posts: 72,587
    Fortunately you have a good dealer, keep working with them and be as pleasant as you can. Good luck and keep us posted.
  • MNSteve:

    I realize your post is over quite old now, but I am in the same situation you were in. That is, I cannot find any auto parts store that has a driver's side wiper blade replacement for my 2008 Tribeca. I have not gone to the Subaru dealership yet, but wondered what you ended up doing. Like you, I have replaced the passenger side without issues.

    Thanks,
    P. Hoffman
  • toboggantoboggan Posts: 283
    This reply is even older ;-)

    I ended up getting the refills from the dealer. $9.95 for passenger side, $11.95 for drivers side, and $5.95 for rear wiper. The front refills are just the rubber. You must dis-assemble the blades, remove the old rubber and insert the new rubber into the silver metal backing plate.
  • I have 38,000 miles on my Tribeca Limited and it is 40 months old. I have had three low beam bulb replacements. (two on the driver's side and one on the passenger side)

    Has anyone else had this problem ? It sure seems like this is too frequent. :sick:

    I have also had issues with rough transmission shifts, brake master cylinder replacement, nav system error codes just to name a few glitches. My first and most likely last Subaru ! :mad:
  • my tribeca is 2008 with only 28000 miles. Never replaced any bulbs. I had issues with the transmission but dealer changed the fluid and is fine. I have issues with Nav screen going black while driving. Took it to dealer thery rebooted but today is doing it again.
  • my tribeca is 2008 with only 28000 miles. Never replaced any bulbs. I had issues with the transmission but dealer changed the fluid and is fine. I have issues with Nav screen going black while driving. Took it to dealer they rebooted nav system but today is doing it again. Going black.
  • My driver door started rattling a couple weeks ago. It sounded like the window mechanism was broken, but the window works fine. So when I took it in to a body shop to open the door panel and have a look, they found out the collision bar had come loose on one side. Popped the spot welds, somehow.

    My question is whether anyone out here has seen such a thing. The mechanic at tw body shop was pretty surprised, and claimed to have never seen such a failure before.

    I'm hoping that Subaru would repair this, seeing as it is obviously a defect of some kind, and not a matter of a part wearing out, or degrading due to lack of maintenance. Also it is a safety issue.

    The body guy said the door would have to be replaced, and that is something I simply can't afford at this point.

    Any insight or advice would be greatly appreciated!

    Thanks!
  • uscar4meuscar4me Posts: 3
    edited December 2012
    I have the exact same problem. US Model 2008 Subaru Tribeca.

    I reported the rattle in my front drivers side door to my local Subaru dealership (in early 2012) where I get my regular servicing, and only on the 3rd diagnostic did they find a cracked spot weld on the side collision bar in the door. They said it would only be covered under the 3yr warranty, not the 5yr. So they referred me to a collision repair company, and when I spoke with them on the phone, they said the cost would be over $1000. I found this unacceptable.

    However, I just did some google searching and found a possible similar issue acknowledged by Subaru in a Service Bulletin for the 2005-7 Legacy/Outback. I found the service bulletin on another online chatroom/board, but can't post the link here. If you google "Subaru door rattle cracked weld", it's the first link. I plan on taking this to my dealership and seeing if it's a similar issue. Hope this helps.
Sign In or Register to comment.