Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Suburban All Wheel Drive Problems

I have a 95 K1500 Suburban with a 350 and 161,000 miles on it. I went to put it in four wheel dive the other day and the lights on the indicator by the stick never changed. It still shows 2wd. The transfer case engauged because the gears are lowered. I can shift it with no problems but the frontend never locks in. Is this the Four Wheel Drive Actuator that went bad? Id there a way to check this?
God Bless,
Kevin

Comments

  • r8dr23r8dr23 Posts: 1
    I have a 99 Suburban 4x4 K1500..it's started making this noise (clunk-clunk) when accelerating from a dead stop, louder as I go faster. Noise reduces when slowing down or completely goes away when I hit the brakes. Noise also goes away when I put it in neutral. HELP!! Please..
    Efren :confuse:
  • just curious if you have checked the universal joint.
  • 5sobs55sobs5 Posts: 1
    Our Burb made the clunk sound when stopped or taking off from a red light. After doing this intermittently for a couple months, it stopped dead at a busy intersection. Check your Transfer Case level immediately!!! $1300 later, I have a different used Case.
  • Did you ever get your problem figured out? I've got the exact same thing that happened to me. 95 4x4 suburban with 350 engine and 186000 miles on it.

    Thanks, Randy
  • i makes a clunking noise when i brake quick at a red light and when i take off i hear it again but if i brake slowly i dont hear it or when i take off and the vehicle has 73899 miles any body had similar problems please help thanks
  • I just bought a 95 Suburban 1500 w/ 193,000 miles. Won't go into 4 wheel drive, will shift but indicator light doesn't come on, not engaging - previous owner insists that it works, but a little tricky at first. Now snowbound but feeling burned
  • I have had problems with the front axle engaging. It is a floor shift 4x4. I replaced the actuator on the front axle and still it will not engage! I know the transfer case is locking in gear but, something is not locking the front axles. Does anyone know what to do? Do I need to replace the harness? Maybe the selector switch? I am at whits end with it! :confuse:
  • spiceyladyspiceylady Posts: 1
    I am looking at an 05 Suburban with AWD, autoride, stabilitrak - 124k miles. Have there been many problems with these systems? I haven't had much luck looking on the internet for areas that discuss the AWD Suburban. I'm sure it must be an uncommon thing. I'm not really sure why anyone would order a vehicle with it. We currenlty have a 97 4wd burb and love it just need to add to the fleet with a teenager coming up.
  • acosta1acosta1 Posts: 1
    when turning my steering wheel left, my car raises on the left side in the front.
Sign In or Register to comment.