Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Toyota Avalon Windshield Wipers

greenbeltgreenbelt Posts: 55
We have a 2000 Avalon XLS which we really love. I had to change the wipers just before the big Noreaster last weekend. Since the Avalon is so big, I ran the wipers and then stopped the engine when the main wiper was right over the steering wheel, making access easy! Changing the wipers was then a snap.

However, ever since I did that the wipers won't park and don't run on intermittent!

Does anyone know what this happened and better still, how to reset things in the car so they work correctly?

Comments

  • brettybretty Posts: 1
    Having a 2000 XL, same situation has occured, with the windshield wipers off (in normal down position), push down on one of the wiper arms (it'll apply to both wiper arms), until you hear a clump-type sound (repositioning of wiper blades) and wiper blades are below the edge of the hood near the windshield. You will have to exert some effort but, once the wipers are below the edge of the hood (near the windshield) you will hear a clump-type sound. :)
  • greenbeltgreenbelt Posts: 55
    Thank you for your response.

    Unfortunately, I can't press on them hard enough to make the clump-type sound occur.

    It's also hard for me to get the wipers to stop in the 'normal ' position. Whenever I turn off the wiper switch, they just stop right there in the middle of the windshield, so I have to try to time it. Intermittent doesn't work either.

    Any other suggestions?
  • karateboikarateboi Posts: 2
    I actually have a slightly different situation with my 2000 Avalon XLS. The wipers hit the bottom of my windshield (the black plastic things right under) everytime the wiper comes down. That should be the "normal" position, and it shouldn't hit it (which makes a loud noise).
  • DID YOU EVER SOLVE THE PROBLEM AND, IF SO, HOW? I HAVE THE IDENTICAL PROBLEM -- THE WIPERS STOP IN THE MIDDLE OF THE WINDSHIELD AND INTERMITTENT DOESN'T WORK.
  • trmarascotrmarasco Posts: 3
    I know it's been a while since you had this wiper problem, but how did you resolve it? I have the exact symptoms on my 02 Avalon.
  • wynn711wynn711 Posts: 4
    All of these problems are being caused by the wiper motor. I had the same problem and just ordered new motor from Toyota of Dallas. The motor control all functions of the windshield wipers. MSRP on the new motor was over $200, Toyota of Dallas $148. Parts4U.com. Installation calls for 30 minutes by a mechanic or $20 in labor for me with a real mechanic from Kentucky, not a dealer!

    Wynn
  • Thanks for the info. I'll go the Parts4U route & attempt installing it myself.

    Tim in PA
  • nimiminimimi Posts: 249
    Shouldn't that be covered under warranty? Did the service shop indicated that the motor was bad? Is there any way to test it?
  • wynn711wynn711 Posts: 4
    The wiper motor sits under the left side of the top portion of the engine compartment. The mechanic showed me, it was about six inces long maybe four inches wide. Not very large but hook through the firewall to the wiper guides. The wipers have to be removed and the top cover of the firewall just below the windshield has to be removed and that opens up the compartment where the motor hooks into the wiper guides. It should not be a very difficult job and as long as it is lined up properly, the motor controls everything else. Probably on one set of wires pug into the motor from the wiper switch inside the car. I watched the machanic look it up on a CD which told him what the problem was and what the fix was for the car and the estimated time to repair. Mine has already been shipped from Dallas and will be here tomorrow with installation scheduled for Wednesday,. Good luck on your own, I am a half machanic but want to make sure everything is lined up properly and do not mind to pay $20 to have the installation performed by someone else in case something happens later down the road.
  • Nimimi - long past extended warranty. This one's on me.

    Wynn - you are lucky to have a mechanic that will do anything for less than the one-hour labor fee. Since I am 0.52 mechanic :-) I'll give it a go on my own. The alternator on the Rodeo is next.

    Thanks again.
  • Pushing the wipers down until they "clumped" worked perfectly for me on my 2000 Avalon XLS. Mine happened on a snowy day and ice blocked the wipers from closing all the way down below the hood line. I picked out the ice and then pushed both arms down at the same time while grabbing them about 4 inches up from the base of the arm (don't grab the "blade" part). Like mentioned above, you have to use some force - thanks for the advice!
  • robbie123robbie123 Posts: 1
    i also noticed that my windshield wiper motor is not working. i already tried to reset the control. im looking also for tsb for this part. please help.
  • This guy had a similar problem on his Toyota Sienna and detailed his repair here. He found the control module on the motor itself.
Sign In or Register to comment.