Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Kia Sedona Transmission Problems

13»

Comments

  • hi guys just an update whent to my local garage and they changed the gear box oil and the gear box oil was fine except it was dirty after speaking with the owner and them taking it for a test they thing it could be the clutch plate being weak
  • still trying to sort it out been told so many diffrent things dont know were to start been told its the diff is the problem :mad:
  • Same problem!!!! I replaced both the output and input sensors, but the van still jerks into 3rd gear and stays there until I turn the van off and back on again!!! Please help!!!!!!! :cry:
  • I have a 05 Sedona with 100k on it. The transmission makes a noise almost like a small jackhammer at all different speeds. We are now haveing a problem with what seems like it is slipping in and out of gear. My rpm gauge will drop down to almost 1000 rpm at 70 mph, and the van feels like it has come out of gear. It does this normally at a high speed, but has now started doing it at lower speeds as well. It doesnt seem to be 'sluggish' on take off or while driving. Just at high speeds........ANY HELP WILL BE APPRICIATED
  • I have the same prob, it only has less then 70,000 on it...I just had to replace the Heater Core lines, and when I took it in to have it replaced they said there was a knocking noise and that they thought it was low on oil, well it was not, its a Rod, I think that its broke...What did Kia do for you? They ever fix that for you? They are wanting to charge me 2100 just for the part., Not even for labor..Any advice?
  • I just replaced my Kia's Heater Core lines, that cost over 600 dollars for the repair.Now I have a knocking noise which I think is a rod that is broke..I know that you have had this up for a while, but what did they do for you, as I can not find these parts any where to fix myself..I am stuck..Its still drivable as I have driven many vehicals that have broken Rods, but this one is under 70,000miles on it..They are wanting t2100 for the repair at the dealership..They fix it for you since low miles on it??Thanks for what ever info you have for me..
  • I have the same problem with 2005 Kia Sedona 110,000 miles? I I have a 2005 Kia Sendona. It has 110,00 miles on it. Lately, when on accelerate out of a stop light the engine kicks back lick its going into 3rd gear. Also, it feals like I'm losing power when I accelerate from a stop light, I have to layoff the gas and re-apply gas slowly. I really concerned that the engine will drop into a lower gear at a high rate of speed. I took it into a indeoendant shop they thought it was the Output sensor from the trnasmission, they put diagnostics on it and saw that it was dropping rpms from 4000 down to almost nothing when going about 40. That cost me about $400. Now I have to take it back to them. They also drained the Transmission fuild, NO metal shavings were found in the drain. I'm afrain its the Transmission. What do you think? had the output sensor replaced, still have problem code is PO720.
  • hi is there any sort of noise when relising the clutch pedal as i have the same problem as you described and it is the thrust bearing in the clutch ... it is costing me £420 my car is also at 110,000 miles ...... it might do it when you change gear and then take your foot off clutch pedal ... it might be same problem always when the car slows down by it self it doesn't like 4th , 3rd or2nd ,1st find it hard getting into reverese...OBD Code P0720 refers to
    The speed sensor detects the revolution of the idler gear parking pawl lock gear and emits a pulse signal. The pulse signal is sent to the TCM which converts it into vehicle speed.
    Symptoms
    Possible symptoms of OBD code P0720
    - Engine Light ON (or Service Engine Soon Warning Light) - Speedometer improper reading - Possible shifting problems
    Causes
    Possible causes of OBD code P0720
    - Speed sensor harness or connectors - Sensor circuit is open or shorted - Speed sensor The Error code is generally activated on detection of the following conditions: Diagnostic trouble code is detected when Transmission Control Module (TCM) does not receive the proper voltage signal from the sensor.

    hope it helps a bit :sick:
  • aneefaneef Posts: 1
    I have a 2005 Sedona and it will only work in reverse and neutral. When you shift into any kind of drive it will act like it is in neutral unless you floor it then it will accelerate up to a certain point but not enough to drive it anywhere. Any ideas? :sick:
13»
Sign In or Register to comment.