Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Check Engine light

1505152535456»

Comments

  • srs_49srs_49 Posts: 1,394
    For some more detailed information on what other things can cause the same CEL to come on as a loose fitting gas cap, look at messages 664-667 in the "A Mechanic's Life - Tales From Under the Hood" forum.

    thecardoc3, "A Mechanic's Life - Tales From Under the Hood" #664, 12 Dec 2012 8:13 am#MSG663
  • jprocjproc Posts: 135
    Much Thanks!
  • fendlayfendlay Posts: 3
    I am having a serious problem with my 04 isuzu axiom and I have replaced the fuel pump in the parking lot of autozone all day today. I also changed the fuel filter and check the spark plugs. I checked all the fuses under the hood and they are all good to go. I had talked to a few people and they said it might be a spark plug coil. I do not know and probably don't have the tool to check a coil. The car cranks and doesn't start. If anybody has any ideas. Believe me it will be appreciated. I'm about done with this car today. Tomorrow is another day. Any suggestions?
  • fendlayfendlay Posts: 3
    check engine light has been on for awhile. It used to go off from time to time. Also got lucky passing emissions because the engine light went off while I was driving to emission station. Then I knew it would pass as long as that light stayed the hell off. It stayed off till the next day. Now it's been on for the past couple months. I change the oil regularly. I have replaced three alternator's in this vehicle so far. I bought it at 80,000 miles. I now have 124000 roughtly. I had to replace a battery as well as a fuel injector. And now this unusual problem. Before all this happened, I got into an accident. Somebody hit me from behind at roughly about...35 mph. Moving forward I'm back to square one and now don't know where to start. oh, I went and tried to replace all the spark plugs and when I got them from the auto part store they did not fit my car and the employee searched by year, make, and model. Could it possibly be that the engine has been replaced with a different model or something?
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,692
    Tell us the year, make, model and engine size and we'll post the correct spark plug for your engine.

    MODERATOR --Need help with anything? Click on my name!

  • fendlayfendlay Posts: 3
    2004 isuzu axiom, 3.5Liter V6
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,692
    ...as the orchestra on the Titanic strikes up "Nearer My God To Thee".......

    The author wonders if GM execs don't know or don't care and the answer is....both.

    MODERATOR --Need help with anything? Click on my name!

  • brian125brian125 New york / S.C. myrtle beachPosts: 3,078
    Try changing the gas cap. sometimes older cars have a cap problem and it sets off the sensor

    2013 Genesis 5.0 R-spec, 2013 Accord EXL V-6, 2012 BMW x-5, 2012 ML350

  • imidazol97imidazol97 Crossroads of America: I70 & I75Posts: 18,465
    You can do some sleuthing as to the origin of the light or you can take it to a box store that does free code checking to see what code is showing that's turning the light on. Don't buy anything based on the code, just report it and let some folks try to help narrow it down.

    The items besides the gas cap leaking that can cause codes are the purge valve and the vent valve along with some rubber tubing that carries the vacuum to the tank to do emissions checks.

    The rubber parts deteriorate and crack causing a leak of the vacuum setting off certain codes. Heat above the engine aggravates the aging.

    The purge valve may not be turning on to send vacuum to the charcoal cannister to let air flow through to remove gas vapors caught in it.

    The vent valve may not be closing for the times when the emissions check verifies that there are no leaks in the tank, cap, tubing, etc., to allow the gas fumes to vent to atmosphere instead of being forced throught the charcoal canister where they will be caught by the carbon granules.

    There also is a pressure sensor on top of the tank that measures the vacuum drawn on the tank/system by the purge valve and how quickly that vacuum deteriorates (measuring the leakage of air into the system).

    Also note the relationship to the volume of fuel in the tank. The typical GM algorithm is to only run the leak tests when tank is between 15% and 80% or so in gasoline. Also the engine needs to be luke warm--not cold and not full normal temp. Try keeping your tank between 1/4 and 3/4 for a couple of weeks and lots of key starts. See if the light goes off because the system is able to correctly do several leak checks. The computer has to do a certain number of good tests before it will turn off the light.

    Good luck.
  • jprocjproc Posts: 135
    thx-it turned out to be an air fuel sensor-spent close to $600 to get it replaced at a Toyota dealership.Hoping to get a few more years out of my 14 year old Sienna with 200k on the clock. Gotta admit though this car is getting expensive to keep on the road
  • maxima8maxima8 Posts: 9
    I have maxima 1996 with code PO745 line pressure solenoid and I put a new one but still the same code and O/D flashing16 times when I star the car I need help


Sign In or Register to comment.