Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Geo Metro Engine Questions

greersgreers Posts: 1
I have a 93' Metro that acts like it's not getting fuel? It's a 5-speed, so it will run when pushed, but when you try to stop, it tries to die( kinda hard to keep it running and not run over people in front or behind me). We have changed the fuel filter. Any suggestions would be helpful. Cindy
«13456714

Comments

  • have a 1.0 that blows oil out only 1 cyl figured bad rings so pulled head & seen that one valve was burnt out also looks like leaky head gasket in that area but not sure Anyway would that be y it was blowing oil ? or ?
  • The Geos are bad about burning up the exhaust valve. Most likely you have over 100,000 miles on the car. Fix the head, put it back on and go again.
  • yesme2yesme2 Posts: 4
    kinda spendy fix... sucks that i have 2 of these tin cans & both need it & i just got another one that died on owner probly same thing ? ill pull head on it & look then laugh & spend more money & sell it i guess thanks for info.
  • skausskaus Posts: 11
    Hi All
    It is cold outside and I replaced my water pump
    Now I can not figure out how to reinstall the timing belt and the tensioner
    I have Metro book but it does not show diagram of 1.3liter 4 cyl engine. Even new book only shows 1 liter eng
    Can anyone describe how to align timing belt and tensioner
    Thanks
  • stobarstobar Posts: 110
    Skaus, recommend you re-post your question at the "Chevrolet/Geo Metro" Forum. Just type in "metro" in the search forum block and you'll find it. There are several Metro Mechanics that will be able to answer your question. Also, if you have some time, you can review old posts as I believe that question was answered already. Hope this helps!
  • Hey everybody. New here. Got a question. I can get a 95 suzuki esteem w/out trany for $200. I would like to swap this 1.6l into my 94 geo metro 2-door. Will it bolt up or do i need alot of fabrication. I know i need teh ecu and wiring. Just wondering if it will fit. Thanks all.
  • kristlekristle Posts: 5
    Hey everyone.
    I just purchased a 1996 Geo MEtro 4 door in September and have began observing a few things about it. First my Metro seems to hesitate out of nowhere after its been running fine. Any one else have or had this problem? I am a college student with not a lot of funds to be taking it into the shop every month or so.
    Thanks so much
  • amdrakeamdrake Posts: 1
    im having a similar problem, i just dropped in a new motor into my 91 geo metro, but i didnt take pictures of the wiring before i took the old one out and now i have two mysterious wires just loose, ones hot and the others not, is there anyone who knows where these two wires go, they are close to the firewall, behind the airfilter, the car wont start and i need this car fixed asap, anyone know anything about this? ill post pictures up soon, just let me know if you can help thanks alot.
    image
    image
    image
  • atessmeratessmer Posts: 1
    I just purchased a used 94'Geo Metro. It's a great little car but I'm having a problem with it stalling when I shift it into gear or come to a stop. Other than that it runs great, idles good.
    Any suggestions?
  • newman283newman283 Posts: 1
    I have a leak at the Crankshaft Position Sensor on the oil pan on my 99 Metro with 136,000 miles. Is replacing the sensor going to fix the leak? Anyone else have this problem? According to the dealer there is no gasket on this part.
  • PF_FlyerPF_Flyer Pennsylvania Furnace, PAPosts: 5,860
    If the dealer says there's no gasket, I'm going to assume he knows what he's talking about. Perhaps it's the crankshaft seal that's leaking and not the sensor?

    MODERATOR
    Need help navigating? pf_flyer@edmunds.com - or send a private message by clicking on my name.
    Share your vehicle reviews

  • kristlekristle Posts: 5
    I have a 96 Geo metro sedan and have had a few issues with it.
    FRist off, has anyone else have the SES light on constantly in their car? I have taken mine to the mechanic twice and hes checked the car and reset the light within a week it is back on.

    Second, anyone ever replaced the engine in the car? I have suspcion that my engine is NOT the original engine in the car and is actually a junk yard one if it is, i may look into replacing the engine as this is my only mode of transporation to and from Cal State Fullerton.
    Thanks for your help!
  • tripstertripster Posts: 10
    Newman,,,,
    My car seems to be leaking from the same area, I have replaced the oil pan gasket and now after looking at the crank shaft seal, it appears to be dry there.
    What did you find on you car, im grasping at straws now.
  • grace4evergrace4ever Posts: 30
    I have had to 3 mechanics. First said to tune up, did that, second, new battery, did that, third said, new alternator, did that. It will start fine for the first 3or 4 days, then when I go to start it, it is dead. No clicking sound, no engine turnover at all. When jumped, it starts and then will run great for another 3 days and then dead again. Anyone else having this problem or know what it could be?
  • msims56msims56 Posts: 2
    I have a 1993 Geo Metro Hatchback (4dr) and I am having the same hesitation problem. Had major tune-up, oil change, fuel system cleaner, Hapco engine cleaner,and coolant flush.
    Still have the same problem. HELP!!!!
  • gehriggehrig Posts: 1
    I just bought the above mentioned Geo Metro. It's not running but supposedly it was running like a time until the distributor shredded itself. I want to change the distributor but it takes a star drive tool that I don't know the size of star drive required to remove the bolt. Does anyone know what size star drive I need to get the distributor off the engine?

    Harris
  • msims56msims56 Posts: 2
    Have your sensors checked.
  • ntlntl Posts: 1
    I just purchased a 92 metro xfi. I loved it the first 2 weeks of driving it. Then it started slowing down like 15 mph going up hills and a couple days later it wouldn't start. It turns over but won't ignite. I have checked all the obvious. Replaced ECM computer and now it starts if I hold down on the pedal while starting it, but it does die and runs really rough. Really low compression in one cyclinder. Any suggestions. I would like to get this car back on the road.
  • yesme2yesme2 Posts: 4
    I just got done with a complete tear down & rebuild new everything, it started right up i drove it outside & it lacked power going out & then died & hasnt started since.
    i ran compression check again 190lbs. fuel pressure 30lbs. & checked spark had 30000 volts, so whats left ? i installed new cap, rotor, plugs, wires, has spark gas & compression Y wont it run ? & this is a 1.0 automatic 1993
  • mgrellamgrella Posts: 2
    Hi , I just joined tonight I hope someone can help I just bought a 93 Geo metro Conv.65k original miles 5 speed mint condition however it idles rough at 8 to 900 rpms! Ive had it tuned up Ive had the compression done on engine its perfect.ive run high octane other than the idle it runs great no hesitation! Ive also put fuel injector cleaner in the gas tank! someone told me to change the egr valve Does anyone know if this will work? Thanks Mike G
  • doggie3doggie3 Posts: 1
    went to slow down my idle on my 98 cyl metro. but dist which i was gonna turn is bolted tight with no way to adjust.??
  • had similar problem w/95 GEO but was automatic. It was the fuel injection system. Once that was fixed it ran great.
  • How does the oilpan come out?
  • tripstertripster Posts: 10
    Pan comes off pretty easy, just remove all the bolts, the brace on the back of the pan going to the motor mounts and the sensor on the front of the pan. Then turn the steering all the way to the passenger side and the pan will almost fall off.
  • Hello,

    I just bought a '96 Geo Metro today. It runs great but I have to put in a left hand signal light and the purple????? paint is fading in two spots. One area is on the roof and the other is on the trunk. Can this be polished out or am I going to have to buy purple spray paint to fix it?

    Sean
  • kristlekristle Posts: 5
    My 96 Metro that is also Fading in those spots but the paint is green. I tried to polish but it only seemed to make it worse. I think your best bet would be to buy spray to fix it unless you want an entirely new paint job.
    Kristle
  • 93 Metro, 1.0L, Automatic,A/C,I have several problems.
    1. Motor rattles at higher RPM under load, let foot off throttle and rattle goes away. ( Valves or Bearings? )
    2. Transmission sometimes will not downshift after coming to a stop. Have to do it manually. Sometimes motor will try to stall, have to drop transmission manually into 1st.
    3. Running the A/C,headlights car dies due to battery dieing, Had electrical system tested, they said that it was fine.
    Would it be better to repair the car or get rid of it...
    Any suggestions would be helpful....
  • check for stuck egr first. with engine warmed up,push up on egr diaphram plate,if engine runs the same rpm the egr is clogged. also bear to mind the egr passages may be clogged,for my metro this involved removing the intake manigold and digging out carbon with cloths hanger wire, mechanics wire, and help from b12 solvent 199000 miles. first try cleaning egr with b12 and do a vacume check on diaphram.
  • motor rattle could be detonation. usually caused by carbon buildup on high mileage cars, wrong ignition timing on newer. another cause could be motor mounts. valves dont rattle and you probably would have already thrown a rod if it were a bearing, but then again bearings knock instead of rattle.
    have your transmission filter changed and see if that isnt the problem.
    I question the quality of the electrical check. check to verify alternator belt is properly tightened, do a charging voltage test on car while everything is running, and verify the engine idles up when ac is engaged.
    If your after gas milage a metro is hard to beat!!! find a honest mechanic and invest some money in it. had a 87 and have a 98 metro I have a advantage by repairing myself 87 250000 miles,gave to mother, 199000 miles 98 just did valve job.
  • Hello,

    After my original post I looked at the spots closer and had the car washed. The spots are very rough like sand paper. It would appear that you are right. Perhaps I'll sand them down first and then try and find the right spray paint. I noticed this problem seems common on the dark color Geo Metro cars.
«13456714
Sign In or Register to comment.