Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Aveo Engine Problems

15681011

Comments

  • astarastar Posts: 8
    I had a chevy 4-cyl Berretta that started overheating and valves clattering and lagged and dragged and did not want to go into third gear, three dealerships later found that two plugs had burned up, so what caused the overheating and the plugs to burn up? A catalytic converter which was receiving a mixture of gas that was too rich and was melting the plastic insides of the converter. After replacing the converter and adjusting the gas mixture coming off the engine and changing all the spark plugs and wires, the engine was once again running on four cyl, not dragging and not overheating, the initial problem was caused by the dealership adjusting the gas mixture when tuning up the vehicle, they set the gas mixture for a 6 cyl engine by mistake, and it melted three converters before the third dealership discovered how the problem was started. Also, sand can clog the converter and not allow the exhaust to leave the engine fast enough which will also cause overheating problems, you can blow the sand out of a converter and continue using it instead of getting a new one, just make sure no areas are melted inside the converter.
  • barkydogbarkydog Posts: 45
    Two questions about your comments:

    Please tell us what parts of a catalytic converter are made of plastic. (?)

    Please tell us how sand could possibly enter a catalytic converter and clog it. (?)

    If your advice is not credible, why should we believe it... (?)
  • karebearkarebear Posts: 1
    I have a 2004 Chevy Aveo LS which I purchased a little over two years ago. The first two years of owning this car were bliss, but the last two months have been horrible.

    In May my thermostat housing broke while I was driving home late at night, which left me stranded in the dark with a car that I was unable to drive. I had the car towed to a mechanic, who was shocked to see the state of the thermostat housing, as it had snapped right down the middle. They told me they had never seen that on a vehicle before. A few hundred dollars later, it was fixed. I should also note that at this time I had to have my break switch fixed as the lights would not turn off.

    Then this month, I started to drive my car and it was working just fine. All of a sudden, the engine light started flashing, the motor was shaking very badly and my car was maxing out at 10km. I took it to a mechanic (very slowly as the car could barely drive) and they told me the spark plugs were shot, the wires needed to be replaced, and my ignition coil was no longer working. 600 later, and the car was fixed.

    The next day I was driving and my engine light came on again. Now I am being told that the catalytic converter needs to be replaced completely. They were surprised by the fact that my coils and converter all went at the same time.

    Not to mention the fact that the alarm on my car goes off about 10 times a night if I lock the car remotely.

    I seriously regret buying this car.
  • rjbruner7rjbruner7 Posts: 1
    This needs to be a recall ( You hear that Chevy!!!!!!) I had the same problem with my 2009 Aveo at 48,000. I have a scanner and found a misfire in cylender 4. The dealer threw a $300 price at me. Luckily I had bought 2 cars from them in one year, so they dropped it to $250. Chevy needs to reimburse people for this!!!!
  • barkydogbarkydog Posts: 45
    Why should they?

    GM is very good at giving the consumer apologies. But you can't take their apologies to the bank. :mad:
  • bgwbaddbgwbadd Posts: 1
    edited August 2011
    The problem I am having is after the engine is up to operating temperature. When I stop somewhere for a short period of time and turn the engine off (5-10 minutes), when I come back and start the car, as I begin to move in drive, the engine bogs down and almost quits. You can put the accelerator to the floor and nothing happens. After a few seconds, the engine then begins to run normally with no stalling problems until the next time I shut it off and come back after 5-10 minutes. I took it to a local Chevy dealer and their lead technician drove it and said he had NEVER seen this problem in his time as a mechanic (close to 30 years). There has never been a check engine light and diagnostics shows no problems.
  • bgwbadd
    Mine is doing the exact same thing mine is doing did they come up with a solution or a fix for it?
  • mikeyj18mikeyj18 Posts: 2
    edited August 2011
    My 2005 Aveo wont start about 90% of the time unless I give it gas and hold RPMs up. I have to press brake and gas peddal to shift into reverse/drive and when I stop to keep RPMs up. And sometimes the car runs perfectly normal. The car had a tune up around march and theres no codes or check engine lights on and I went to auto zone and they checked my ignition system and it passed. The car turns over and has full electric power when it stalls but im not sure what the problem is. Any ideas on what the problem may be?
  • We have the exact problem with our '09 Aveo. It has been going on since we bought it brand new. We have brought it to the dealership four times, twice they kept it several days. Each time they say no codes come up and they can't replicate the problem when they drive it.
    The car was purchased for our two college age daughters to drive to work/school, and I am afraid every time they take it out. Yesterday, right in the driveway, as soon as the car was turned on (still in park!) it bucked and lunged. Halfway up the block it lost power even as my daughter pressed on the gas. Then the power suddenly kicks in and she shoots forward,
    My daughters report that as they depress the gas pedal, the rpm's go up, but the car continues to slow down. Then it suddenly kicks in. It also will buck when stopped at stop signs and stop lights. These issues happen mostly when the car is first started and running for a short while, but this is not at all consistent. It can happen at any time every day for weeks, and then not at all for weeks.
    The advice I got from the dealership? If you aren't comfortable with the car, you might want to trade it in! What kind of help is that? I would expect better.
  • I am presently experimenting the exact proble with my son's Aveo, What was the solution to correct the situation.
  • In my car's case, it ended up bein the idle air control valve. Its located behind air intake and close to left shock tower by firewall and easily accessible. Nothing needs removed to get to it. The parts only $100 at autozone. You can check it when the car turns over, but doesn't fire up unplug the idle air control valve and plug it back in. If car fires right up, as the mechanic that fixed mine told me, that is the problem.
  • Was your problem corrected? What was the corrective measure?
  • Hello-
    I own a 2009 Pontiac G3, which I purchased new in Feb of 2010. The car has just over 8000 miles on it. The car is a manual shift.
    My issue is that intermittently, the car will stall while going down the road, looses power, will not accelerate, etc. After a few seconds it will pick back up and run fine. It will also stall completely at times while at low speed (it has shut off 6 times so far while making turns at intersections, etc.
    It has not set the SES light, and there is no stored history. It has been at the dealer twice so far for this issue, but they find nothing.
    I need some ideas, as this is a dangerous condition, and leaves me with no confidence in the vehicle.
  • PF_FlyerPF_Flyer Pennsylvania Furnace, PAPosts: 5,896
    Since there aren't any G3 discussions, you might get a better answer by posting in the Got a Quick Technical Question? topic. There are a number of auto techs and very helpful folks who hang out there that should be able to give you some ideas

    MODERATOR
    Need help navigating? pf_flyer@edmunds.com - or send a private message by clicking on my name.
    Share your vehicle reviews

  • Possibly, but , I posted here as the G3 is merely a rebadged Aveo hatchback, or, Aveo5. Other than Pontiac badging, they are identical in all respects.
  • I have a 2007 Chevy Aveo. Lots of problems, but let get to yours. Mine started acting up last Friday, idling rough, and actually stalling when I turned the A/C on. So, I took it in on Saturday. Hang on to this one. The dealership replaced 4 spark plugs, threw in a free throttle clean, and replaced a cracked air hose for free. Cost $150.00. So, since throttle and hose were free. I was charged 150.00 for 4 spark plugs!!!!!!!

    Anyway, it resolved the issue.

    Rotors will never be right even after putting new ones on. And, the repaint that was recommended by the dealership won't be honored by big GM in the sky either.

    I hate G.M. Service centers. They do not know what they are doing, and create worse problems when I leave. I am now looking into a Hyundai.
  • Hello Everyone,

    I'm a car dealer (a small one) and I basically buy salvage car's and repair them and than resell them. I recently bought a 2009 Chevy Aveo5, and it had no engine damage, just hit from the side door. No airbags were blown out either. After I got the body work done on the car, I tried to start the car but it wouldn't start. It gives me the sound that someone is jammed sort of, like giving off sparks. I think what happened was that when it had the impact, the gas stopped going into the engine to stop it from blowing up incase. So I assumed that somewhere on the car there is a switch? that can release the gas flow back into the engine. There is no battery problems, and it's full on gas. I don't want to take it into repair, I'm a good mechanic. So I need help asap!

    Cheers,
    Yunus
  • I HATE my '09 Chevy Aveo. In fact, as soon as I can, I'm turning it in. I'm sitting here now waiting for my 3rd tow in less than 3 years of owning the car, and it only has just over 19,000 miles. Same problem, different day. Car is completely dead. A few days ago, I noticed the "low tire" light (the one with the !). Well the dealership has told me several times to ignore that light - it's pretty sensitive and I figure it's been a little chilly out (40 degrees at night here in the South). Anyway, last few days when I started my car, it was a "hard" start. Car would start, but none of the needles would move (i.e. gas needle, RPM,s).. took about 5-10 seconds for those to move. Huh, weird.. so I was going to take it in today and bam - car was completely dead. 1st time this happened, my car completely died WHILE DRIVING IT, thankfully I was in the parking lot of my apt. complex and car was less than a year old. It had to be towed and they said they couldn't find anything really wrong with it, but they thought it was something with the gas and told me to buy only quality gas (Shell, exxon) that don't use large % of ethanol. They "flushed everything". um... Okay. So I did that, and all seemed to be well, but my car died once more. I restarted it and didn't have a problem again. Well, last year I came home from a month's vacation and the car was completely dead. I figure - it might be because it sat for a month. They jumped it, it started. Low and behold though - same thing happened 2 weeks ago. They were trying to blame me, but I know what a dead battery is.. I didn't leave anything on and proved it to them. I'm sitting here waiting for my THIRD tow. Again - 2 days ago, hard starts and slow movement on the dashboard, so I felt this one coming. Guy came out, tried to jump it and he told me this is a much more serious problem. Plus he told me he's seen this with MANY Aveos. I'm about to give em' hell here in a bit. Had it with this.
  • Have a aveo5. Have had nothing but problems since purchase in may of 2009. First recall on tires. Then this power down , serging issue. Have had it in the shop many times but when they check it nothing happens. they caught two different read outs but they cancelled them now nothing. Finally they kept it now for two weeks no readings after it finally did it for them. They almost ran into a building because of it. But since there is no readings they can't fix the problem they are giving us back the car today. We don't know what else todo other than get a lawyer.
  • psmurphy28psmurphy28 Posts: 1
    edited December 2011
    HOW YOU DOING? i HAD THE SAME PROBLEMS WITH NOT JUST ONE SPARK PLUG BUT WITH TWO..TOOK MY 2010 AVEO IN TO THE SHOP CAUSE OF A VERY SLUGGISH ENGINE..HAD A BAD NUMBER 1 PLUG..THEY FIXED IT AND SAID THE CAR RUNS GREAT...NOT EVEN 1 FREAKIN HOUR LATER THE CAR STARTING RUNNIN LIKE CRAP AGAIN..THEY KEPT THE CAR OVER NIGHT.PKED IT UP NEXT Day, and i was told it now was the number 4 plug was cracked and needed a new coil wire too.I been havin lots of other problems with my car....front end alignments 3x and need another.2 headlights goin bad.wiring problems..engine racing on the highway..rotten egg smell when racing engine..now i smell antifreeze after the car runs for a little while..i agree with you,RECALL!!!!!! my car still runs like crap..could be another plug!!!!!!!!
  • ang83ang83 Posts: 1
    Back in November I had an issue where my heat stopped working and then the check engine light came on. Turned out my radiator had a leak and needed to be replaced. Now, less than a month later, the transmission felt like it was slipping and my check engine light came on again. I took it back to the shop and one of the clamps on the transmission line had broke causing it to leak transmission fluid, causing the engine light to come on. This car isn't even two years old and has less than 25K on it. I find this is to be extremely ridiculous for a new car. I find it even more ridiculous both times that I've had to take it to the dealership,they want to blow it off and say "hey that light can come on for anything, your gas cap may not be on right." Really?? Both issues could have been detrimental to the health of my car!
  • Boy, after reading these posts I don't feel so alone anymore! I bought a brand new 2007 Chevy Aveo from MIRAK CHEVY, which I will NEVER buy from again. My boyfriend and I went up to purchase a new car for me. Spoke to the NEW sales guy CHRIS, and told him explicitly what I wanted. I wanted two things; a car with AC and a CD/Tape player, which I had a $400 voucher for that I downloaded from their website. It's November, he tells me the car is already equipped with AC, but they would have to install the CD/Tape player, No Problem well.. you would think! Traded in my Malibu, which was still running pretty well, but felt I wanted something new, and nice, and reliable. HUH! Took my son up to pick my brand new nice car up, and lo and behold it's stalling going out of their driveway! My son asked me if I knew how to drive it LOL because it is a stick shift, and I laughed and said yes, and that the car was fine when I took it for the test drive. About 100 yards down the road the car starts smoking, and I mean smoking. Called Mirak told them to come down the road to tow the car back, got there and asked if I could have my Malibu back because I'm already not liking this car, but of course you know the answer to that question. Now I need a car to drive, they send me to enterprise and they want my charge card to put a $300 hold on it, and I said no way, call Mirak they sent me here so I could borrow a vehicle while my BRAND NEW car that I spent a whole 5 minutes in is being looked at. So, the car is ready in a few days, pick it up, seems ok, a week later starts smoking again on my way to work, they tow it back, claim there is no problem with it because if they admitted to anything and it happened again HELLO LEMON LAW, 3 strikes and it's a new car for me! The smoking never happened again, but in April when it was a pretty warm day, and warm for me starts at about 60 degrees, so I thought I'd try out my new AC, but nothing but warm air is coming through. So.. I'm thinking and looking, don't see the A/C button that is normally in a car with A/C so I bring it to my personal mechanic, he opens the hood, and looks at me with a startled face and says it's not even installed in my car, and knowing how MUCH I hate the heat he was ready to run for the hills after telling me the bad news. So.. I call Mirak, and they claim that I knowingly bought a car without A/C, and wanted to charge me $2,000 to install it, had my lawyer send a letter to both GM Headquarters and Mirak, but got absolutely nowhere. First of all I cannot imagine a car being made these days without A/C automatically installed in the car, second I purchased an extended warranty for $1,100 and another $900 in optional accessories so why in the world would they think that I wouldn't pay a little extra when I initially bought the car in order to have A/C in it???? So it's been 4 years, I ride around with all the windows open, but all my hair off when the temps hit 60 and haven't killed anyone yet, close, but not yet. Also, the driver's side door lock fell out, the radio works when it feels like it, and that wonderful CD/Tape Player I had installed does not work at all. Got a flat tire the other day, took that stupid little tire out they call a donut, put it on and that was flat as well, and no good! So... would I ever buy from Mirak again? NO, NO, NO! Will I ever buy from GM again, NO, NO, NO! Hyundai here I come!
  • Hello, I have a 2007 Aveo I missed lemon law by 2 month's, but I did get a componet letter From GMC , which covers all my work w/ front end until 10/2012. Call the main office # 866-790-5600. I am getting very good service w/ the main people and they are always checking on my car when I have issue's to make sure they get fixed which at this time My Air bag light is on still haven't fixed that yet they are still playing w/ that and Struts for the 3rd time.. Good luck, Deb
  • my 2009 aveo was fine for the first 2 1/2 years here lately the engine and hold lights came on flashing and sometimes just stayed on but mostly flashing i took to autozone cylinder #2 misfire replaced plugs problem solved for about a day :( so i asked my cousin what he thinks the problem is since hes a chevy tech and he said to replace the coil pack i did and hey problem fixed for about a half day i have no clue what to do about this im already -165 with unneeded parts has anyone had these problems lately???
  • post number 70 was absolutely perfect. i started having the same problem on my 09 aveo. It had run perfect up til then, rough idling and missing and flashing engine light. thought is was bad fuel. i had added an additive was going to change the fuel filter then looked it up on line as it was out of warranty. when i seen this post i immediately went to auto zone for the free test. Sure enough it said mis-fire on #4. i ordered a coil pack right then, my son put it on in 3 minutes. I paid $139.95 + tax and my car is running like new, THANK YOU SO MUCH FOR THIS POST. Had i not seen it i would have spent endlessly looking for a cheap fix.
  • I have a 2008 Chevy Aveo I bought new. A couple of months ago it started blowing white smoke from the exhaust when the engine(44000 miles still under warranty) was cold. Only a small amount at first,but after longer trips of an hour or so after sitting over night it would fill the garage with a white smoke that had a pungent sweet smell.This was just starting the car up and backing straight out. The car had never overheated .I checked the coolant and the reservoir was low.I filled the coolant and decided to check the oil to see if there was coolant in it. I changed the oil and found nothing wrong.I called the local Chevy dealership because it was closer they said it would be 3 weeks to get it in so I called the dealer i bought the car from and had my wife take it .
    I told the dealership
    1. It was loosing coolant but i couldn't see any leaks and that I had refilled it a day before.
    2. I had just changed the oil and found no coolant
    3. I had no warning lights.
    4. The engine only smoked when it was cold and after long trips and it set over night without restarting it. I explained how to duplicate the problem to see the smoke
    This is what they told us after taking it in right after my wife got to the dealership
    1. The coolant reservoir was full(I had just filled it)
    2. There was no coolant in the oil and was not low(I had just changed it)
    3. There were no warning lights or errors(Nothing i didn't already know )
    4. The engine showed no visible smoke from the exhaust(The engine was already warm just the opposite of how i told them to see the smoke)
    5. They did a pressure test at 19 PST for a few minutes and it was fine they couldn't do anything and charged my wife $50 for diagnostics.
    I was ticked they totally ignored me and pretty much charged $50 to blow me off
    I complained on the Chevy website And promptly received a phone call from a rep.I explained the situation and that i was loosing coolant slowly.They set me up to take the car in again.The mechanics manager was very nice .He explained if we made the hour trip right then to the garage he would check it himself and give us a loaner so he could keep the car over night.
    This is what he said they would do
    1. Leave the car sit over night to duplicated the smoke in the morning when he got in.
    2. After seeing the smoke to verify it he would have die put in the coolant and leave pressure on it till the next day t see where the coolant was going.
    3. If it was the head leaking which is what he thought i was describing he would have the whole head changed instead of just a gasket.
    As i drove home I was happy and sure the problem would be fixed.The next day He tells me this
    1. He started the car and moved it after i left didn't notice any smoke(not what he said he was going to do)
    2. Started the car the next morning with no smoke but after it warmed up it started smoking(I had never and still have not saw the car smoke when warm it's been almost 2 months since)
    3. After he saw the dark smoke when warm he knew exactly what was wrong and removed the valve pan cover to see sludge(even sent me a picture of the sludge which was small and from a cell phone)He also said the valve pan cover was black with sludge and worse but the picture didn't come out good.DUH the inside of the valve pan cover is black you couldn't see sludge from the distance he was taking the pictures anyway)
    4. Engine had black death syndrome from no oil change or too long between oil changes.(I told him i change the oil regularly with the recommended 5w/30w .He said i should have used synthetic. At this point There was no use arguing with him.He was telling me I needed to replace the whole engine or trade it in to them(for a low trade in value of course) for another car
    I retrieved my car the next day he was nice enough not to charge me again.When i got home I noticed the black oil streak on my floor mat,the dirt all over my seat, after further inspection later found 3 loose bolts on the valve pan cover,and both hose clamps from the hose on the pcv valve were gone and I never got an answer about a possible leaking head gasket.I guess they were mad about me contacting Chevy
    The Chevy rep continued to call and promise to talk to her supervisor .After talking to several mechanics I found leaking coolant can sludge up an engine. A small leak wont show up noticeably in the oil if changed frequently.I probably have a bad head or gasket.I told this to the rep as well as about the loose bolts ect...
    After over a week i got my answer.The supervisor agrees with the garages findings and they can't help me.
    I have a 2002 cavalier with 216k miles i drive to work 50 miles one way every day .I do most of my own maintenance .If not me then my father-in-law who is a mechanic takes care of it .I think I know when and how to change oil in my car.
    I would not advise buying a Chevy from Washington Chevy in PA .The mechanics manager flat out lied about the smoke and now I have to deal with a car that looses 1/4 inch of coolant from the reservoir in a months time and still smokes.As far as Chevy is concerned there's nothing wrong.I am lost as what to do
  • I'm glad you had some luck.I have the same problem .44k miles on a 2008 Aveo .White smoke with a sweet pungent smell at cold start.Loosing coolant about 1/4 inch of the reservoir bottle a month.My dealership found sludge and said it was from improper oil or too long between changes.They did one test my first trip in and didn't bother checking where the coolant was going once the saw some sludge. I have a cavalier with 216k miles i drive 100 miles a day 6 days a week for work.I think i know when and how to properly maintain a vehicle.Hopefully more people post about this problem .I can show this to a Chevy rep and get mine fixed
  • suzy89rsuzy89r Posts: 2
    YUP! ive had my 09 Aveo5 LT for 3 years now, had 4 miles on it when i drove it off the lot, was in college and working fulltime raking up the miles. now after just under 3 years and 80k miles later, and changing spark plugs 4 times, i now know, my coil pack is defective, 2 of the coils inside the pack have NEVER got hot enough to spark the plugs for 1st gear and overdrive. Now that i know this which i learned this past saturday, i did find a coil pack at Autozone and Advanced Auto Parts for 139.99. not bad. but am i going to have this same problem with a new one? Im so tired of dropping money into my car. Ive probably put just as much into it as i have paid for it so far. This car should definately be a lemon-law claim type of deal. :lemon:
  • meshell55meshell55 Posts: 6
    I just got a letter yesterday from Chevrolet on an emissions recall for all 2009 Chevy Aveos with a 1.6L engine. They are going to replace the spark plugs and boots with new ones with different numbers and gaps. I hope it fixes my car as it just yesterday had the check engine light come on. For the past 1-2 weeks it's been jerky going into different gears and acts like it's got a governer on it by not letting it pick up speed when I give it the gas... I hope this fixes the problem....
  • gmcustsvcsarahgmcustsvcsarah Posts: 1,964
    meshell55,

    I hope that the recall work improves your ride for you as well! Looking forward to an update on how everything goes for you with the repair.

    If we can look into anything, please don't hesitate to get in touch with us at socialmedia@gm.com (include the last 8 digits of your VIN).

    All the best,
    Sarah
    GM Customer Service
Sign In or Register to comment.