Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Kia Sedona Computer Problems

twinmom01twinmom01 Posts: 3
Ok - first off I have to say I have been VERY happy with my kia over the past 5.5 years...

However last week we had to replace the shocks, struts and wiper motor to the tune of $1200 - considering it just came out from under bumper-bumper warrenty about 6 months ago (we have 71K miles on it) and we haven'thad big upheavels before this we are OK with it...

However the other day a bunch of lights flckered on and off (battery, parking brake, ABS) - we figured maybe the mechanics knocked a wire or two loose when replacing the wiper motor...

Well it up and died on us - we got it jumped and was heading to the mechanic to drop it off when waiting for a red light it let out a screeching sound and died...had it towed to our mechanic...

he looked at it said our Alt. was fried but called Kia because he said that hey had seen some computer problems on older Kias...sure enough the Kia service center said it sounded like something they would need to fix - so it got towed to the service center and now we wait...

Has anyone expereinced this??? We are waiting to hear back from the service center - we are lucky in that in previous minor problems (when under warrenty - things like our CD player dieing - one of the sliding doors getting stuck and something to do with the power steering column - all fixed no problems - no $$ out of our pocket) we have had excellent service from this service station so I know we are in "good" hands...
«1

Comments

  • we have 3 kias in our family 1 sedona and 2 sephias. our sephias both have flashing CEL. checked gas covers. sometimes on, car hesitates etc. both the same, took to 2 different mechanics, 2 completly diagnosis! one car is dead and sell it asap. please help
  • Any resolution to this, my 02 Sedona just started doing the exact same thing, except my alternator is still good. Any luck?
  • we ended up with a new Alternator, battery and timing belt...this was right after we got the shocks and struts replaced...so we spent about $2500 in about 6 weeks time on the car...we are 3 payments from having it paid off...I figure with the amount of money we have sunk in - the only major thing left to go is the transmission and since that is still covered until we hit 100K miles...

    Considering before this incident the only thing we paid for was oil changes and an occassional new tire I am still happy with my Kia and thier warrenty...I figure we will drive it until we hit 100K and then buy a new car...
  • Thanks so much for your reply, we'll prepare ourselves. We have been happy with ours too, no major problems. We did replace the power steering pump right after having the 60k service. Other than routine items and service, it's been a good van (fingers crossed). Thanks again.
  • Oh my gosh...we had to have our power steering pump replaced too - luckly we totally looked over our van and made note of any weird noises and decided to take our van when it hit about 55K to the Kia service center - our side door was getting stuck and the steering wheel was a little shakey - they ended up having to install new bearings on the door and the power steering pump...and since it was prior to the 60K mark everything was covered.
  • We just had a similar problem.
    "alternator overload" Insurance said no coverage.
    While driving at 65 on highway 2002 sedona exploded all/many electronics fried battery exploaded.
    please email coughlp@comcast.net if you have any suggestions We have 90000 miles, car was great up to that point.
    Now it is totaled from ins co but they say mechanical failure so no coverage.
  • dodedode Posts: 13
    I am having same problem right now. The air bag, battery light and brake light went on. we finished up errands, car ran fine. when wife took out at night and turned lights on they went on, but went out right away. turned brights on and they went on then out right away. Taking in to dealer tomarrow. will keep posted. It is a 2002 with 71000 miles
  • dodedode Posts: 13
    UPDATE>>>>>>>>>>>>>>>>>>>

    Took car to kia today (MON) said they could'nt look at till Thur. No Good, my only car. Took to local garage, did testing and replaced alternator. Said alt was putting out around 19 volts, should of been around 15.5. This also caused damage to 2 year old battery (leaking). Got that replaced for free. 660 bucks for alt and belt. (had to change belt again as new alt is different than original so need different belt) 120 bucks for 4 new headlights, yes, the on and then off was them burning out. Brake light and battery light went off, but airbag light is still on. seems to run fine though. Any body know how to make airbag light go off. P.S. while car was in for work wife went with mother to local indian casino and won 1050 bucks. So all is not as bad. Who would of thunk hey!!!
  • I live in Nashville & from Korea.
    After I bought 2002 Kia sedona turn on Check engine light.
    I want to fix for registeration in Nashvill TN.
    I visited KIA dealer shop in Antioch. I spent 2800$ for changing coils, wires, catalitic converters, timing belt...etc if include the other fix prices? more than 3500$, but they could not fix. :cry: And also the computer message was different every time when they check. Finally they said "Actually I don't know why"

    I'm Korean. So I asked to KIA Factory in Korea about this problems directly.
    After a few days, I got a message from Califonia Kia Factory's someone who he got my message from South Korea.

    He said "We know this problems but we can not tell you now yet. If we do not offer this problems to each dealer shops, they can not fix it, Even though they can fix it, in KIA dealer shops they can change only whole parts. This is law"

    So Haow are ridiculous! :mad:
    They should not have changed it if they don't know that.
    If you have a check engine or electronic problems on doubt, Please do not fix it.
    KIA Eat Your Money like your Blood!
    Nobody know right now before announce a statement about this problems from KIA
  • wonderinwonderin Posts: 1
    I just brought my van from a used car dealer last month. It had 80,000 miles. I never had a Kia before, love the van. Tonight I was driving around a jug handle, it made a strange noise as if I had accidently hit it out of drive. i checked to make sure, tried to push on the gas and the van just sat there. Nothing was leaking and nothing smelt like it was burning. It just would not move. A friend said it looked like it a belt had came off. He said he could hear it trying to connect with the transmission but it wouldn't. Please help! Has anyone experienced this problem? :cry: :confuse:
  • adriver4adriver4 Posts: 4
    Regarding the problem with the confuser (computer). No further comment needed.
  • What did you find was the problem? My sedona did the same thing last night, it will work in reverse but not in drive.
  • dodedode Posts: 13
    Just recently my steering seemed to get a little harder to turn then normal. When making a turn, the wheel does not come back to straight like before. It almost seems like I have only half power steering. Is there a power assist unit on this?? I checked the fluid and it is full. Any Suggestions??
  • Is your van still under warranty? Your power steering pump might be failing.
  • dodedode Posts: 13
    Just turned 104,000 miles. I don't think thats part of drive train 100,000 mile warranty.
  • Have the intermediate shaft checked. TSB # KT2008101402

    In areas where heavy road salt use occurs, customer complaints have identified increased steering effort and noise (from the steering intermediate shaft) for the 2002-2005 (GQ) Sedona. The increased effort is usually first noticed at low speeds with noise or rattle. When addressing such customer concerns, replace the steering intermediate shaft using part number 0K52Y 32550
  • On all OBD2 computer systems,the check engine light will flash if there is a cylinder misfire bad enough to cause cat damage. Possible Coil,Plug wire,or plug
    Scanning should tell what cylinder is misfiring.
  • I purchased my Sedona new in May 2006. It has run fine for the first two years, no problems at all. Then my problem started. It all started when as I was driving the brake light would flash on and off, the abs light would come on bright and the dim and then coming back to bright, then the check engine light would come on. After about 5 minutes all the lights went off except the check engine light. I took it to the dealer the next day and they could find nothing wrong. They told me to bring it back if I had any other problems. After going about 300 miles, it did the same thing. Again I took it back and again they could find nothing wrong. It seemed at that time it was a on going problem at around 300 miles. When I was approaching the next 300 mile segment, I took it to the dealer and told them to drive it for awhile and see what happens. Guess what they found no problem after putting and additional 123 miles on the Sedona. The van ran fine for about 2 more months and 740 miles. The the problem changed a little. Now when I crank the car up the break light comes on, the abs light is dim and then bright and the check engine light comes on. When you attempt to put it in gear it dies. I put it back in park and crank again. It dies as soon as I put it in gear, no matter how long I let it run. I finally figured out if I wait about 15 seconds after it shuts down, it will crank and the break light and abs lights go out but, the check engine light stays on. I called the dealer and told them of the newest situation and I was told to bring it in the next day and they would read the check engine code. As I was driving to work that day the check engine light went off. The dealer said that without the light being on they could not tell what was happening. As I was coming home from work two weeks ago, I was stopped at a red light and the break light, abs light and check engine light came on as before. I put my flashers on waited the 15 seconds and the car cranked right up. I put it in gear and it ran but would not shift. I pulled over at the next exit and cut the car off and waited another 15 seconds and tried it again. This time all the lights went off, even the check engine light and it ran great, no problem at all. I took it to the dealer and he has had it for a week and has been driving it, putting about 150 miles on it and he says he has not had a single problem. The one thing I forgot to say is that this is the second dealer that has found no problem. Anybody have any advice. Thanks
  • kiatech1kiatech1 Posts: 4
    TSB KT2007111401 Is for a bad ground to the ABS module. This will cause ABS
    light to come on,and the check engine light p0501 Veh speed sensor. the pcm receives vss signal from ABS module.This would explain the engine and ABS lights.As for the stalling,ill check some things and get back to ya.
«1
Sign In or Register to comment.