Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Monte Carlo Instrument Panel Problems

My 2004 monte Carlo SPEEDOMETER IS ERRATIC, indicated going 30 mph, even though I was driving at or near the speed limit on Interstate 55 MPH OR I was going 80 MPH and it read 45 MPH. Dealer wants $500.00 to fix I Hope GM recall soon. GM trucks and suv have this Problem.
«1

Comments

  • pittgradpittgrad Posts: 1
    My 2004 MC speedometer just stopped working. All my other gauges in the panel work perfectly? Fuses seems to be okay. . .not a lot out there I can find on fixing this problem other than taking to the dealer.
  • MY GUAGES WORKED FOR A WHILE ALSO AFTER MY SPEEDOMETER QUIT ON MY '04 MC. NOW THE OIL GUAGE AND TACH ARE BOTH ERATIC. SO FAR THIS PROBLEM HAS COST ME $225.00 IN SPEEDING TICKETS.
  • no recalls. you all need a new cluster. about $250 for the part. has to be programed at the dealership.
  • My Mom's 2004 Suburban is also totally ERRATIC. She was at a stop and it said she was going 120 MILES PER HOUR!!!!!!! Her speedometer bounces back and forth with no rhyme or reason.This should be an immediate recall by GM and Chevrolet.
  • I'm having the same problems! First it was my tachyometer which was showing in the red zone, though the mechanic said nothing's wrong (except for the gauge itself) and today my speedometer was showing 30mph when I was doing at least 70mph...

    I'm thinking if enough of us complain about it, they may recall, cause there's a definite pattern:
    http://www-odi.nhtsa.dot.gov/
  • I just read these postings and am having the same issue with my 04 MC. I just called the NHTSA and they said there has been 6 reported complaints on this problem with the 04 MC. The lady said everyone needs to call (888-327-4236)
    into file a complaint for it to be investagated. Please call and maybe we can get a recall going!!
  • I have the same problem, but with my 2004 Trailblazer. My speedometer and tachometer stopped working at 32,000 miles. Chevrolet has recalled four models from the same year for having the same faulty instrument cluster, but not the Trailblazer. What needs to be done to get Chevy to recognize that Trailblazers were affected too? The only answer I've been able to come up with is to make a claim with Chevrolet at 800-222-1020. I was told that is as far as it can go, and that there's no one I can submit my complaint to in writing. Chevrolet needs to accept that this is a larger problem then they're willing to admit! Please call!
  • I'm having the same problem with my 2002 Monte Carlo SS. Not just the speedometer, but the oil pressure, RPMs, and temp. The only thing on my panel that works is the gas indicator. It all started when I hit 70,000 and I'm now at 78,000. This is making me crazy and our local GM dealer quoted $680 to repair, and said it must be repaired at a GM dealer because of all of the work and programing that needs to be done. I loved this car until this major problem started. After reading all of the other issues and GM's lack of recall, I'm real tempted to leave GM -- and we've been GM for three generations in my family and this really stinks.
  • Hey. I just replaced my instrument cluster on my 2005 Monte last month for $430..Im going to call NHTSA to try and get us all some refunds!! Thanks for posting the number!!
  • jeff818jeff818 Posts: 8
    I filed a complaint with the NHTSA and also got on chevrolet.com and posted a complaint with them. I told them we are a 3-generation family of Chevy owners and this was making Toyota look attractive. They have called me three times, but I've missed them. I called back on Friday and am awaiting another return call. I'll post to let everyone know if I get any results.
  • Thank God I havent had an issue with my speedometer, but I did have an issue with my oil gauge on my 2000 SS. I would be driving and all of the sudden the needle would just start bouncing from one end to the other. Turned out all I needed for that was a new oil level sensor. Other than that the only problems I have had with my cluster is light bulbs burning out or going dim. Most frustrating. I try very hard to maintain my monte and keep it looking new, but the quality of the car makes it difficult.
  • jeff818jeff818 Posts: 8
    The oil level and gas level gauges are the only thing that work on our cluster. We love our car and are trying to work something out with GM. I sent an e-mail to them and they are apparently considering these on a case-by-case basis. I hope we are approved for their help. I'll update after I find out.
  • i have a 2001 Monte Carlo SS Im having issues with my security system.As long as im driving and the security light comes on the car will start again if the light is not on and i turn the car off 9 times out of 10 the car wont start the light just flashes sometimes the car will start after 30 minutes i know other people who own GMs with this same problem i truly feel General Motors need to correct this issue because its definetly a manufacturer's issue also the traction control,ABS,and service traction system light is on i seen many GM vehiches with these same problems GM need to recall these vehicles and not expect the consumer to pay for a manufacturer's mistake hit me up if you experiened problems like these or something similiar
  • jeff818jeff818 Posts: 8
    I haven't had that problem. Just the cluster issue. I got on the GM website and e-mailed them about my problem. We first had our car checked at 65,000 miles for the cluster failure. Given that fact, GM is going to cover the cost of the cluster (over $600) and we need only pay $85 for labor. That's a blessing and I urge you if you have a problem similar to get on the GM website and e-mail them. They are handling these cluster failures on a case-by-case basis. Good luck!
  • THANX 4 YOUR ADVICE DUDE I TRIED 2 GO ON GM.COM 2 E MAIL THEM BUT I DIDN'T SEE AN OPTION THAT SAID E MAIL IF YOU CAN GET ME THE DIRECT INFO HOLLA @ YA BOY GOOD LOOKIN OUT
  • DONT BUY A TOYOTA EVERY CAR COMANY HAS ITS ISSUES I'D BUY A NISSAN BEFORE I BUY A TOYOTA OR HONDA
  • jeff818jeff818 Posts: 8
    I went to chevrolet.com instead of gm.com. Sorry bout that. At the very bottom of the page is a Help Center. Click on there and explore Maintenance, Service, and Repair. I kept looking for a contact me, or file complaint section. Good luck.
  • thank you homie i appriciate da love!!!!!!!!!!!!
  • jeff818jeff818 Posts: 8
    You're welcome!! Have a great day.
  • tamusetamuse Posts: 1
    I have had a problem with the electrical system since I bought mine... Seems like the lights dim and brighten whenever they feel like it, my cd player would work then not work, my battery gauge has been all over the place and everytime I asked the dealer they said there was no problem, now all my gauges are out of control, most recently my speedometer went out when I went on vacation I nearly lost control on a curve due to not knowing it was messed up. It slowly goes further and further out as I drive until Im going 0 miles and hour and passing people. They still refuse to fix the issue, had to call a friend who's is a mechanic to find out it was the instrument cluster and would cost anywhere from 200 to 2000 depending on the cluster. Wow..with as many people that have had this problem you would think it would have been resolved by now.
  • I have a 2005 M.C with 44,000 miles and my cluster is gone also. I called GM and they told me that unless the have a number of people in a certain area call in with the same problem they will not recall this is crap i take great care of my car and looks like it did the day i purchased it so lets all get together and bug the mess out of them its gonna cost me $480 to get it fixed :mad:
  • jeff818jeff818 Posts: 8
    Leslieann -
    I would go to the Chevrolet website. We are a five-generation family and I told them that. Esp. since you only have 44,000 miles. That's not right. I went to the contact us part of their page and filed a complaint -- that's how I got action -- and my car had 68,000 at the time. It's worth another try. You'll have to have your Vehicle ID number and they'll want the name of the service dealer you contacted. I hope it works for you. Don't give up. Here's the website I went to: http://www.chevrolet.com/helpcenter/contactus/ Be sure to use the link to e-mail them. A form comes up to complete. I had a response in about a week or two.
    Good luck! Jeff
  • gwlkdlgwlkdl Posts: 2
    I have a 2001 Monte Carlo and have had similar problems as the ones Ive read about here. The security system is completely screwed up. I went to the chevy website that you listed in your post and I filed a complaint. I was contacted the next day. I was told that noone else has filed this particular complaint so there was no recall on it. I have read enough on the internet to know that Im not the only one having these same issues. I think Chevy needs to be flooded with calls and emails until something is done. It is going to cost somewhere in the neighborhood of $500 to have it fixed. I was given a service request number and the guy said if anyone else calls with the same complaint it will be filed under this number and then after enough complaints something will be done...Lets flood them with emails people...
  • ClairesClaires Chicago areaPosts: 975
    If you haven't done so already, check for other reports at NHTSA Office of Defects Investigation and file a complaint.

    MODERATOR
    Need help getting around? claires@edmunds.com - or send a private message by clicking on my name.

  • gwlkdlgwlkdl Posts: 2
    Thank you. I I asked the guy at chevy for the web address for NHTSA and he said all he had was a phone number. Thanks for the info.. I will file a complaint with them also.. I hope others will do the same. Especially when there are so many people with the same problem.
  • I've got a 05 Monte Carlo (Tony Stewart Edition) with the same instrument cluster problem. Dealer told me it was not covered under any recall, so I've just sent a email to chevrolet.com. Hopefully I'll hear from them soon!
  • Be sure to list your loyalty to them and how you would hate to change automakers in this economy because of a problem GM is aware of. I told them we are a 3 generation GM family -- I think that got their attention. Good luck!
  • Ok. i see that several people have had the same issue. So has a outcome been said yet about what to do. My car has 53,000 miles and the cluster went out. The speedometer works off and on, the gas gauge doesnt work at all and the Rpms dont. Any help on what to do would be great!! Thanks :mad:
  • I have 2006 70,000 miles and the speedometer quit yesterday and the transmission started slipping at same time. I have been looking for two days now and it seems it might be a speed sensor or worse. Any suggestions?
«1
Sign In or Register to comment.