Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Pontiac Torrent Ignition Problem

vickytvickyt Posts: 2
I have had my '06 Pontiac Torrent since Jan 1 2007. It has been in the dealer 3 times for ignition problems. It started out being hard to turn, then I would have to jiggle it for quite a while to get the car started. I took it in the first time and they said it was a factory defect, removed the ignition, cleaned and oiled it and that should fix it. I could tell it was still catching but I gave them benefit of the doubt because they said GM would not pay for a new ignition switch. That lasted about 2 months and it started again, this time they replaced the ignition switch. Yesterday it was towed in and is currently in the dealer for the third time.
I love everything about this vehicle, but this is not making me a Pontiac fan. Has anyone else had this problem?
«134567

Comments

  • dannyd3dannyd3 Posts: 56
    I have a 2006 torrent purchased in sept. 06, the odd time it is as if the key gets stuck and wont turn is this what has happened to you. I know from previous vehicles sometime the steering wheel has to be moved to unlock the key... Have you had any prob with rear spoilers expanding in the heat and hitting when opening the trunk?
  • vickytvickyt Posts: 2
    I wish the ignition problem was as easy as moving the steering wheel. They are replacing it again and giving me a new key this time. I guess they realized that keeping the damaged key from last time wasn't a good idea! Go figure. I haven't had any problems with the rear spoilers. I haven't had any other problems, knock on wood.
  • dannyd3dannyd3 Posts: 56
    I'll keep on eye on my ignition, wonder how long it is covered under warranty
  • rlt2rlt2 Posts: 13
    Hi all, I'm also having an ignition problem. When I turn my key to start vehicle, it doesn't always "turn over". Sometimes I have to keep key turned for about 10 seconds before it starts. Anyone have this problem?
  • dannyd3dannyd3 Posts: 56
    As far as I understand or so someone told me the Pontiacs have an electric starter. There is nothing wrong they just turn over sometimes and I guess try to find their sparking point, but I am going to ask my dealer about it all the same b/c my torrent does it also the odd time. Weird but I am told normal
  • dannyd3dannyd3 Posts: 56
    also I forgot to mention you actually dont have to hold the key just turn and let go the car will start try it. It is habit to hold the key I know.
  • rlt2rlt2 Posts: 13
    FYI - I took my Torrent into service to check out the starter. They ran diagnostics and found no problem. Hopefully it's normal We'll see what happens.
  • I have a 06 Pontiac torrent since 4/07. I have had the key completely stuck in the ignition. I also have had problems with excessive cranking with the starter. I turn the key let go and the starter tries to turn over. My vehicle has been to the dealer 6 times. They have replaced the relay,the cylinder & key, ignition switch and regreased everything. Yesterday I tried to start my car and it just cranked would not turn over, tried for 3 times later my husband tried and got it to start. Today it started the first time but the second time it acted funny again. This is very frustrating because you dont know if it will start. My sister also has an 06 torrent and she has had the cylinder replaced on hers. I spoke to her today and she said recently her key stuck on her. Obviously there is a bad design with the starter/key set up. I will call the dealer tommorow and waste my time again. By the way one of the mechanics told me the 07 has a new design-gee I wonder why.
  • I have had my 06 since September 06 and I have had that same problem from day 1 but it doesn't happen as frequent as it seems yours does. Speaking with other people I was led to believe that it is the electric starter system but nothing wrong, I am going to question my dealer about this as well. Also my key sometimes gets stuck. My inlaws have an 07 I am going to see if theirs has this problem.
  • rlt2rlt2 Posts: 13
    Hi. I have had my 2006 Torrent since 9/06. I have had the same problems as you with the ignition cranking and very slow to start. It usually starts...eventually. I've brought it back to the dealer 3 times and they tell me "it works as designed". I'm due to go back to dealer again and this time bringing my husband since they don't seem to take me seriously being a woman! Now that I know it's not just my vehicle perhaps they will listen!
  • bccledbccled Posts: 1
    I have the 2007 Torrent- the first time I had trouble I was able to jiggle the wheel and get the key to turn. Today I was unable to turn the key no matter what I did. What was funny was the remote start worked but I was still unable to turn my key. I called the dealer and they were going to tow it but I ended up getting a ride home to get my spare key to try which did work. Now my regular key works too. I have a service appointment next week, it will be interesting to see if any problems show up.
  • Ive had my Torrent since April of 06. Occasionally I have had the problem where it takes a few seconds to start as described above, but sofar it has always started.

    On Saturday, the key got stuck in the ignition, and was absolutely not comming out with any amount of steering wheel turning and wiggling. I was still able to start and drive it while the battery still had juice, but I was not able to remove the key from the ignition. With the key stuck in the ignition, the battery remained engaged, and the vehicle at risk of theft. Because the Pontiac Dealership is closed on weekends (and no I did not disconnect the battery), the battery died completely by Monday morning - I couldnt even unlock the doors to get in. It was taken to the garage by tow truck this morning (after the towtruck driver broke into it from the inside). I will followup with what the problem was.
  • My 2006 Torrent has had intermittant issues with starting. The engine won't fire. This has gone on for a year with increasing frequency-at the dealer 3 times this month. Eventually it starts but may take 3-8 tries at starting. Seems to happen when I do several short trips. Dealer has done hot soaks, load test battery, fuel pressure test and cleaned tac bore. Have also done several software updates and checked service bulletins but no definitive answer. The "patient" is home now for another test run. GM engineers are now involved. Anyone have a solution to their starting difficulties? I have also had the check engine light go off and on often and they aren't sure if there is a connection. :mad: :confuse:
  • There was an object interfering with the shift lever, preventing it from fully engaging in Park (according to the mechanic, the cable was out 1/8th of an inch). So if you are having problems removing your key from the ignition, and it hasnt anything to do with the position of your steering wheel... check taht the shift lever is engaging fully into park, that nothing has fallen into the well...then try to remove your key.
  • I am having the same intermittant starting problem with my '07 Torrent. This too, has gone on for the last year, with increasing frequency. The 1st time I took it to the shop, they got it to start no problem and told me nothing was wrong. They said if it happens again, don't try to start it, so they can run diagnotstics on it. It stranded my brother once after that, but the tow truck man got it to start, so it wasn't towed it. The next time it happened, I did what the service people said. I left it as it was, had it towed to the dealership to get looked at. They told me it was loose battery cables, and they fixed it. 2 weeks later, it was back in the shop. They said they could not find anything wrong. I said to keep the car until they fixed the problem, they said they cannot do it. I was left with no choice but to take back my car. They said AGAIN the next time it happens, to leave it as was.. blah blah blah. Today (2 days after pickup) I got stranded out of town again. Howver, I ignored their advice, and on the 3rd attempt (luckily) my car started. I am starting to think that I will have to live with this for the remainder of my lease.
    :mad: :mad: :mad:
  • dahlbpmndahlbpmn Posts: 12
    Thanks for posting. I haven't had problems since March-until today. I made a quick trip (which I am avoiding due to gas prices) and it happened again. It always has started but has taken anywhere upto 8 tries. I have even taken the key out and turned it around. We are describing it as the engine not firing. Last time I was in I was running up to the end of my 36k warranty. The dealer suggested I call GM and I did. They started a file, worked on my car some more, were in contact with the dealer, etc. I ended up with an extended warranty to 100,000 miles at no charge to me. I am too good of a GM customer at that dealer for them to risk losing me. I have bought my last 4 cars there and have all my service done there.
    Make sure you are documenting everything and insist that the dealer check with GM because they do have a history of my vehicle. Keep in touch.
    Good luck.
  • joeltahoejoeltahoe Posts: 3
    I have a 2006 Pontiac Torrent with the same hesitating start. The dealership replaced the key cylinder and made some computer adjustments, but the problem returned with increasing frequency.

    Until recently, the car always started; however this Saturday, the car would not turn over at all. Fortunately, I was with mechanic at the time, and he said to depress the accelerator to the floor, and the car started. He said it suggested a problem with the fuel pump.

    The dealership tied to make me feel better by saying that the same problem exists with the Vibe, and Lucerne. I told him my German and Japanese cars don't do this, and that GM has had 100 years to design an ignition system that works.

    He said to bring the car back to the dealership. We'll see what happens.
  • mmckeemmckee Posts: 3
    I HAVE HAD SO MANY PROBLEMS W/ MY TORRENT. I AM ABOUT READY TO LET THEM HAVE IT BACK..... IT IS OUT OF WARRANTY NOW SO IT IS COSTING ME NOW. IGNITION X2, SENSORS KEEP GOING OUT, BATTERY, RADIATOR FANS AND FAN MOTORS. ALSO IT SHOCKS THE DAYLIGHTS OUT OF ME ALL THE TIME... THE CHECK ENGINE LIGHT STAYS ON NEARLY ALL THE TIME... THE DEALERSHIP IS BASICALLY GOOD TO ME. WHEN I WALK THROUGH THE DOOR THEY SAY HERE COMES TROUBLE.... I GET SO FRUSTRATED. IT IS NOT THEIR FAULT I KNOW BUT, I HAVE TO GRIT MY TEETH.
    PLEASE ANYBODY THAT KNOWS WHAT I CAN OR SHOULD DO PLEASE LET ME KNOW............... :cry:
  • dahlbpmndahlbpmn Posts: 12
    Have you talked to GM? When I was having problems someone at the dealer suggested I call GM directly. You need to get your dealer, GM and yourself all working together. Tell your dealer you are contacting GM and tell them of your issues and that they need to offer more support to your dealer. In my case GM started a file and worked with the dealer-staying in touch with them. My car seems to have settled down(starting issues and the check engine light coming on) and I was also given a 100,000 mile full warranty. I was just about out of my 36,000 and that is why I pushed them to find a solution. Good Luck
  • dannyd3dannyd3 Posts: 56
    Hello everyone,

    I was having problems with my ignition as you have read in the past finally the dealer noticed that there was a reprogram notice in the system for certain Torrents but not mine. My dealer went ahead and reprogrammed my Torrent with this update. I will keep you all posted if it helps.
  • I have a 2006 Pontiac Torrent with the same intermittent starting problem, or failure to turn over as described by other. I've been through reprogramming the computer and the ignition replacement, and most other repair attempt listed.

    After 3 visits to the dealership, they determined that I had a very high level of "Upper-End Carbon Buildup" in the motor. They performed an "Engine Decarb Procedure" as described in SI DOC 03-06-04-030F (whatever the heck that is?)

    In any case, I have not had any starting issues in 2 months. They may have been giving me a line of bull, but so far, the problem has gone away with this Engine DeCarb Procedure.

    I don't really know how the engine had such a bad carb build-up as we take long trips in the car and always burn good gas (Chevron).
  • dannyd3dannyd3 Posts: 56
    Thanks

    I will keep this fix for future fixes, for now my is working well no problems in 2 weeks but it is still early to tell.
  • Hello everyone,

    Let me first say I am actually happy to find this site as I was being led to believethat no other torrent is full of probs. I own a 06 sport. I bought it in dec'06 as a clearout, after my partner bought one in June06. 2 wks after purchase I had to have it towed to the dealership as it was dead in the morning- no cranking nothing. When they finally got it in it started like a dream, I brought it home and within a wk was doing the same thing finally they kept it overnight and lo and behold I wasn't just a dumb female! That was fixed- replacement of computer module. However this is where my story gets good-- I have replaced both front hub assemblies TWICE, the dealership and GM have not done anything to date as to why this is happening! Oh the RKE, I have had issues with this as well, they both are currently working but range is terrible. Today the beast was in again as the air bag sensor light has been on since Monday contsantly. Another expensive repair if I wish to fix it, just the power window motor that I have also had to have looked at.
    I am hoping to get rid of this vehicle. And if you are wondering about the other one it has had hub assembly replaced on fr dr side and there was a time we thought another would have to be done but it was the brake rotor
  • hello - Just as an fyi for people who are having problems with the key sticking in the ignition, this happened in my 06 torrent and after having GM mechanics tinker with it for hours, they discovered that it was an interference with the gear shift - IT WAS NOT FULLY ENGAGED IN PARK. The mechanic said that if the gear cable was out of line even a hair the key would stick.
  • tidestertidester Posts: 10,110
    You can read more about the Pontiac key problem in the Pontiac Grand Prix Key cannot be removed from ignition discussion.

    tidester, host
    SUVs and Smart Shopper
  • This sounds just like my car! I have a 2006 Torrent and the engine won't fire! Its sounds like it trying but will not turn over! My car has been at the dealer about 12 times for this! The mech asked if anyone else drives my car bc they thinks i'm crazy! I have called GM spoke with someone that could not speek very good english! Now I need to call them back I got to tired of messing with it I said just 4 get it! I'm over it! well now i'm tired of it doing it and I want ANSWERS!!! I have had the car since sept of 07 ( I have 34,000 miles on the car) so my warrenty runs out at 36,000 what do I do!!! If anyone has a phone number for GM please give it to me!
  • I was wondering if the truck is still problem free starting, the reprogram didn't seem to work on my vehicle as i had hoped. The dealer wants to charge me $130 to do the de-carb thing you did. I have had this prob from day 1 so I dont understand the carb build up.
  • I have two phone numbers I found in my notes. I am not sure which one is the correct one for GM customer service. 800-462-8782 or866-790-5700. You need to pursue this and also work with your dealer. I told GM that the dealer needed their support to solve this. The dealer was very willing to work with GM but it had to be initiated by me. They started a service contact number for me and over about a 10 day period they seemed to have solved it. The last problem I had was last winter except for one time on July 4, 2008. My Service Manager at the dealer went to bat for me and I got an extended warranty-bumper to bumper for 100,000 miles. I pointed out to them that I was an excellent customer and they didn't want to lose me. I had purchased my last 4 cars at the same dealer. I think that was a lot of the reason why I got the extended warranty. Take notes on all conversations! Good Luck!
  • Hi dannyd6,

    Problem has started again. I think there might be something to this "High-End Carbon Buildup" that people are talking about. I run long trips, and only burn Chevron, so I shouldn't have this problem.
  • samiamlsamiaml Posts: 10
    :mad: I have this same problem.... 3 weeks ago i bought a 2006 Torrent wit 32,700 miles and within a week i started havin this long crankin time prob when starting... My husband was drivin at the time and i just though he was holdin the key to long it being a new vehical and all and all cars are different.... But now its been starting to happen to me... Sometimes i can hold the key and count to 10 slowly in my head and still no start... I dont want to ruin the starter or n e thing so i let it go and try again and sometimes nuttin or sometimes it starts....Sometimes it can take 5 or 6 try before it will start.... Really weird if ya ask me... like it has a mind of its own...lol... Im worried one day it wont start then im stranded..... Which is horriable for just gettin the truck 3 weeks ago.... So i called the dealer and explained my prob and they told me to bring it in... So i did... and later that day they call me and tell me my truck is ready to be picked up... so i ask what did they find wrong with it and he said nuttin... they started it cold... started it warm ect and it started all times fine.... So when i went and picked it up i said you know this is a big issue not only did it start having this prob only a week after i drove it off there lot but im worried one day it will not start and then im stranded some where and cant make it to work or pick up my daughter from school ect,,,,, He said he understands my anger but if the dignoses computer dosnt throw up a error code then as far as hes concerned theres nuttin wrong with the vehical... I said do you think i like to take off work and deal wit you and this dealership because i think its fun????? He said im sorry mam theres nuttin we can do at this point.... By this point i was furious...... So i left... I went home and contacted GM and told them my prob... He told me he will make a file on this and contact the dealer and see what we can do from there.... He calls me back and says take it to the dealer again and this time leave it there for a few days and see if they can find the problem... So we'll see.. i gotta take it there later today.... I see alot of people have had this same prob but nobody really said what was done to fix the problem permently... So if someone knows what was fix on the vehical to stop this plz post and let me know...... Maybe i can fill the mechanics in on something they apperently dont know...lol

    Thanks,
    Samantha
«134567
Sign In or Register to comment.