Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Pontiac Torrent Ignition Problem

12467

Comments

  • Hello Caron,
    Nice to see you are monitoring this thread, I do not see, or overlooked, your business address and phone number. Please share it as I am interested in getting some relief for the starting problem I am experiencing.
    I further add that I should not have to pay a diagnosis fee for, or for that matter, the repair cost to fix it, as many others are also experiencing this same problem as evidenced in this blog. In my opinion, this is a quality deficit of this vehicle model caused by the manufacturer, or at the very least a quality deficit with my vehicle. As for the ka-kunk sound emanating from the floorboard between and to the rear of the front seats as I previously described: should I have to pay out of pocket to render a solution as to what it is and what it might affect in terms of drivability and maybe my safety? I like the Torrent, saddened to see the Pontiac brand disappear, and am loyal to a point: the point of being financially drained by the stiff garage repair rates of the dealership.
    Dave
  • steverstever Viva Las CrucesPosts: 41,246
    Just click on Caron's member name (or anyone else's) to see their Profile. Many members make their contact info "public" that way (other members can see it but it slows down the spammers).

    Moderator
    Minivan fan. Feel free to message or email me - stever@edmunds.com.

  • Our torrent battery was going dead too. Discovered that the brake pedal was pressed and the brake light was draining the battery. I bought an expensive part from the dealership to replace on the brake pedal, but found that the issue was just a cracked plastic collar (white in color) with cogs that you can adjust at what point your brake light engages. I got a plastic collar from the dealership and replaced it on the brake pedal under the dash, problem solved. This also fixed the cruise control intermittenly shutting off since tapping the brake shuts off the cruise. Hope this helps. I still also have the ka kunk sound and starting issues though.
  • I have the same exact problems with starting and ka kunk. PLEASE let me know if you find a fix. 06 Torrent
  • gmcustsvcgmcustsvc Posts: 4,125
    Dave,

    I apologize for your frustration; however, having the vehicle diagnosed is the first step in our process of handling your concerns. As every major company we have standard operating procedures and having the vehicle diagnosed is just that. This helps us to get technical information on your concerns. I apologize; but this is at the cost of the customer, but this is the only way we can evaluate your situation. If you would like to take your vehicle in to be diagnosed, please feel free to email me directly with your contact information, VIN, mileage and involved dealer. I look forward to hearing from you!

    Thank you,
    Caron, GM Customer Service
  • gmcustsvcgmcustsvc Posts: 4,125
    1chevy2007,
    Have you spoke with a dealer or Customer Assistance? Can you please email me and explain your experiences? Please provide your VIN and current mileage.
    Christina
    GM Customer Service
  • mwj8mwj8 Posts: 1
    I also have had this ignition problem and the kachunk kachunk noise. The k-k noise has occured since the vehicle had <20k miles or so. Only when the car was not warmed up though. Once warm, it doesn't happen. The ignition issue is my current problem. Just tried to get the car inspected and it failed. First time for this. I have 52k miles only. I usually buy 89 octane gas, but the last 2 times I've filled up I used 87. Regardless of the current gas though, I've had the check engine light come on if I sat idle for 10 minutes or so. If I run the highway, it usually goes away in about a day. Seems like the fuel is not getting into the ignition very well when I turn the key. I'm having to press the gas peddle to feed gas in and then it will start, but sluggishly. Another problem I had to have repaired was the key ignition sticking. Got so bad I got stranded at work one night. The key would not turn. They ended up replacing the whole key assembly after trying some temporary fix using teflon that worked for about 1 year. I love this car, but I'm getting fed up with the issues. I'm going to try to run some 92 octane gas thru it and try to get the car to pass inspection after a full tank is used.
  • gmcustsvcgmcustsvc Posts: 4,125
    mwj8,

    Have you taken your vehicle in to be diagnosed by a GM dealership?

    Thank you,
    Caron, GM Customer Service
  • ryff21ryff21 Posts: 2
    Dear Caron
    We have taken our Torrent to a GM Dealership where they coudnt figure it out since the key sticks only sometimes . They even replaced the ingnition. Still have problems. Also when it fires up it continues to crank until you hit the gas or it fails to start.
    We are going on 2 years now with the same problems.
  • gmcustsvcgmcustsvc Posts: 4,125
    ryff21,

    I would like to set up a case with GM Customer Assistance. In order to set up the case I will need your complete contact information (including full name, mailing address and phone number), VIN, current mileage and involved dealership sent to me in an email. Also, please provide a brief description of issue you are experiencing and the screen name used on the forum.

    Thank you,
    Caron, GM Customer Service
  • deb81deb81 Posts: 1
    I am having the same problem. I had to get a ride home from work today because the key won't turn in the ignition. I also have the sound coming from underneath like 2 thuds when it is cold. This is my third Pontiac and I have always loved them but this one I am not to sure about.
  • gmcustsvcgmcustsvc Posts: 4,125
    deb81,

    I apologize for the issue you are experiencing with your ignition. Were you planning on taking the vehicle into the dealership to be looked at?

    Thank you,
    Caron, GM Customer Service
  • col072col072 Posts: 1
    I, too, had the same ignition problems. My key was stuck in the ignition and won't let it turn. It had to be towed to the dealership. The whole ignition assembly and housing had to be replaced. Also, the turn signal relay was shorting out.
  • jordomom8jordomom8 Posts: 1
    My 2006 Pontiac torrent wont start, two weeks ago this happened at my son's daycare, the key turned and the lights came on but it wouldn't turn over, after letting it sit for a half an hour it started and has been running fine since , until today upon leaving work it happened again, my car is now stuck a town over. I am a single mom and don't have money to bring it to a shop does anyone know what it could be?
  • tanyavtanyav Posts: 6
    Hello fellow Pontiac Torrent owners/leasees,

    I own a 2006 Torrent which I bought off the dealership lot brand new in 2006. I have been having problems with this vechile since within the first year. Ignition and starter and front wheel bearings and lurching and squeaking passenger seat and rubbing side vehicle panels (no one has mentioned this one yet), the paint literally 'popped off' the vechile to the bare metal, remote key entry.

    The reason that I am creating a post is beause obviously there are many many people who are equally frustrated with this vehicle. I am reading a common thread throughout everyones messages posted over the years. You all feel alone. You feel like the dealerships are treating you as though you are the only one in the world with these problems with your Torrent.

    I am a firm believer in the power of numbers. I am going to provide my name and location and the dealership I use to any of you that wish to ask me. I am hoping that together we can create a list of names (if you want just provide your first initial and last name and the name of the dealership and location.

    I need your help just as much as you need mine. To add your information to the 'LIST' simply 'reply' to my post. Feel free to add comments and share your stories too.
    Thank you Brenda V. You were my inspiration.

    Thank you everyone.

    T. Vernackt
    Disbrowe Pontiac Buick GMC Cadillac
    St. Thomas, Ontario, Canada
  • tanyavtanyav Posts: 6
    Hello JordoMom8,

    I feel your frustration. My car is "stuck" out in the country at a friends right this minute. The key would not turn the car on tonight. When it did turn in past days....and years.... it would take many, many attempts to start. I feel like a foolish women who does not know how to start her vehicle and I have been to the point where peope have come over to my vehicle to offer assistance in the past. How silly do I feel telling them that there is "nothing" wrong with my car? VERY foolish!! The dealership has brushed me off in the past when I complained of the vehicle not always starting right away. Now it will not start at all! I have had ENOUGH and I am using this site and all of the posts to create a file that I am going to literally dump on the desk of the dealer. I am asking for names. Yes, REAL names to create a list to show the dealer. Then they can see that other dealerships have customers who are just as upset and we ALL want answers and a solution. It is worth a shot, nothing tried, nothing gained. Please let me know how you made out Jordo Mom 8. Thanks!
  • tanyavtanyav Posts: 6
    Caron,

    I can completely understand the customer paying initially for the diagnosis upfront and then being reimbured after a problem that is NOT customer error is found. However in this case (Dave and the rest of us on here because of our Torrents) making the customer - YOUR CUSTOMER. PAY for a problem that is clearly an ongoing issue and has been from day one with the Torrents is absolute rubbish. I do not mean any disrespect to you personally Caron, I understand this is just your job but you need to pass my information and everyone elses on to your superiors. Why are these 'issues' still issues 5 years later? Has anything been done to resolve all these customer complaints?
    I welcome any information that you can provide. Thank you.

    Tanya
  • tanyavtanyav Posts: 6
    Hi Dustrej,

    You are the most recent post I see on the forum. Have any of your issues been resolved yet? Thanks for your time.

    Tanya
  • gmcustsvcgmcustsvc Posts: 4,125
    tanyav,

    i would encourage you to contact GM of Canada at 1-800-263-3777. Hours: M-F 7:30am - 11:30pm, Sat 7:30am - 6:00 EST.

    Thank you and have a great day!
    Caron, GM Customer Service
  • pt74pt74 Posts: 5
    Ok, a bit of an update:

    (1) the power lock issue was indeed a torn wiring harness.
    (3) ABS/traction control was a faulty module, cost me about $300 or so to fix.

    Haven't gotten the sunroof fixed yet, it's bearable and not critical.

    But - the check engine light came on a few weeks ago and the garage initially thought it was a loose 'snorkel' tube in the gas tank. Fixing that did nothing, so I brought the car back and now the diagnosis is a shot 'ERG' (?) valve which will be about $300 plus $60 labour. Again, not a safety/drivability issue but it will need looking after soon.

    Plus, we did a long weekend road trip (about 1500 miles over 5 days) and at the halfway point, a loud grinding noise started to come from the front wheel area. It was present at all speeds but got louder with acceleration. I didn't want to interrupt our trip and made it home, but my guess is that it's a front bearing. I'll find out tomorrow at the garage. Sigh.
  • Just came across this Forum and thought "hey what a great place to air my woes!". So for my wife's graduation (and every other special occasion for the next 4 years) I (we) bought her a brand new 2008 Pontiac Torrent. Wow did we feel special it was great, video player in the headrests for the long trips to Ottawa (2 kids 7 and 9 at the time) Chrome handles and running boards, trailer package to pull the tin can around, Onstar so she was safe and had roadside assistance, we were happy :) Then.....about a year and a half ago she calls me on her way home from work and had shut off the car for a train. Wouldn't start, turns over starts, then stops running almost immediately. Try's again and again nothing calls onstar tow truck comes try's and says sounds like a fuel pump issue. Takes it to the dealer we wait till morning as it was after 5 and they say there is nothing wrong car starts fine. Few months later same issue again towed suggested that it is a fuel pump issue still when it gets to the dealer it starts fine. The "Cold Start is a quote from the service rep when listing the problem" Well november rolls around and we are close to the end of our warranty and it happens again this time it doesn't start for the dealer. They decide that the main fuse block needs replacing. Great problem solved! and just under the wire for the warranty women says I was lucky because it was a $7000 fix!
    Wipe the sweat from my brow and drive away :).......:0 what..fast forward a few months and the problem is back again problem does not show its ugly head for the dealer after a tow. Off we go on a trip to Kenora this past July Stop for gas in Wisconsin car won't start :( same problem... so I roll the car forward as a towtruck driver had suggested in the past that might jar the fuel pump and low and behold it starts! back in the car and off we go we get to Kenora and stop for the bathroom 5 min from the hotel... car won't start. Roll it back and forth and eventually it starts but not as easy as the last time oh oh. We get to the hotel and there is a dealer next door so I figure I would take it in first thing in the morning. Wouldn't start, I roll it still no start...On star to the rescue! tow me over two driveways. The dealer was great, was a busy Friday but was able to fit me in, problem was it started so.... no problem found. I mentioned the fuseblock replacement and he did some more tests still nothing, he moved the car around to the side of the building and parked it on an incline. Went to start it and bingo no go. (don't really think the incline had anything to do with it) He opened the main fuse block re seated the fuel pump relay and it worked. He said that he didn't have the part and I should be ok to get home. Off we went a few days later for the two day journey home we had problems every time we turned off the car, but re seating the relay seemed to be working got home phew... Went out to take it to the dealer in the morning and no amount of re seating or wiggle would work, car no start. Onstar to the rescue.:) Dealer want to test and charge even though I already paid for the testing at another dealer he takes the paper work and says leave it with me. Turns out yes they believe that the block is a bad block and needs replacing again and yes even though the vehicle is out of warranty the part was still under warranty. They replaced it and life is good. That was three weeks ago, we have had two cold start issues since the last one yesterday and the re seating of the relay seems to work. Problem is this has been an issue for almost two years now and in a few months I am helpless without a warranty. (we even had an extended warranty). Well thats my rant, I am going to call the number that was listed a few posts back and see what GM has to Say.
    Thanks for listening.
  • gmcustsvcgmcustsvc Posts: 4,125
    ptproblem,
    Have you spoke with Customer Assistance yet? If so, can you please send me your case number? Can you please include your VIN? I look forward to your response.
    Christina
    GM Customer Service
  • pt74pt74 Posts: 5
    Christina, with the utmost of respect, what can Customer Assistance do that a dealership can't? You often suggest that people contact GM Customer Assistance, but what's the point? As is typical in almost all of these threads, 'ptproblem' has visited his dealership more than a few times without a satisfactory resolution. Is there some secret super-power that the Customer Assistance operator on the other end of the phone use to fix the problem?
  • sgtvsgtv Posts: 5
    This is a pretty nice vehicle, but I to have had door wiring harness issues were the wires broke of inside the rubber boot. ( out of warranty of course by 358 miles) Now I am having the problem of not starting, and the dealer has told me that I would pay 90 bucks per hour while they tried to find the problem which is intermittent. I am going to clean the battery teminal tomorrow, and see if that does anything. The ignition has always been kind of hard to turn, and sometimes sticks and it must be forced back to the run position. I think the ignition may be the reason that I'm having starting issues with my Torrent.

    This not starting stuff is really irritating, and the starter is hidden up under the vehicle in a hard to reach position. If cleaning the battery terminals doesn't work, I will attempt to remove the starter to have it tested. Of course everthing that has went wrong was right after the warranty ran out. YeeeHah!

    Oh yeah I forgot about the heater core leak. $800.00 to replace. If we are all having these same problems, why is there no recalls on this vehicle?

    Add me to your list of names; R. Vincent Jr., and I bought mine at Foreman Blair Pontiac in Springfield, Ohio.
  • sgtvsgtv Posts: 5
    Don't feel like you're alone on this one. I have been having the issue just like you describe for about two weeks now, and the dealer has already advised me that if the vehicle starts when they look at it, then they won't be able to fix it. It will start after about ten-fifteen attempts. Sometimes it starts right away. It's frustrating knowing that the dealership will charge me $90 per hour to diagnose the problem if they can find it. If not I will still have to pay. I am just going to try to clean the battery terminals, and if that doesn't work I'll pull out the starter and take it in for testing. A starter only costs about $100 after the core charge. What's a guy supposed to do that is unemployed. Maybe I'll just sit down and have a good cry,,,,,, lol.
  • gmcustsvcgmcustsvc Posts: 4,125
    pt74,
    Dealerships are independently owned and operated. When you speak with Customer Assistance they are working to come to a resolution for both the customer and the dealership. When you speak with customer assistance you are reporting your concerns to GM. For instance, let&#146;s say you have 30,000 miles and you go to the dealer with intermittent concerns, but the dealer is unable to duplicate it. This interaction is not documented anywhere with GM. Now if you were to call Customer Assistance, they will try to involve technical assistance to try to diagnosis your vehicle as well document that you were experiencing the concerns while still in warranty. Now if at 40,000 miles the problem is apparent and they are able to diagnosis and pin point it, there is documentation that you were experiencing this concern while still in warranty; this is just one example. Another case I came across last week a customer went to the dealer for the concerns. There was a special coverage for the concern that was not yet updated in the dealer&#146;s resource as it was new. I spoke with him as I do many of you, and we were able to direct the dealer about the special coverage and get the vehicle fixed. Each case is different with different circumstances, so we evaluate things on a case by case basis. Customer assistance has different tools and resources to try to resolve customers concerns and situations. I hope this helps.
    Christina
    GM Customer Service
  • Need help with a 2006 Pontiac Torrent. The issue is an intermitent no crank condition. It started out as very rarely to now being almost everytime we go to use it. I have experience as a GM mechanic and have the priveledge of still having contact with some very good electrical/driveability techs at a local GM dealer. I have spoken with them extensively and still have not been able to nail down the root cause of my problem.

    To date I have replaced the ignition cylinder housing as I believed the passlock was an issue. The light would come on when there was a no start condition. if left for 10 minutes then it would normally start with no further problems. That did fix the theft light problem and it still does come on at times but if we're on a good day then it will still start despite the theft light being on.

    The no crank condition still happened a few days later so I removed all wiring from the remote starter and replaced the ignition switch on the ignition housing. This repair was benneficial as it made the R.A.P. start working again. It started perfectly for about 2 weeks but then it has started acting up again and will not start (no crank) more often than not. I have thoroughly inspected, wiggled, pulled, disconnect/reconnect all wiring components related to the ignition and security under or near the steering column.

    I have replaced the battery and inspected the cables and ends. I checked all fuses and relays and swapped the ignition relay with another of the same number.

    I have removed the starter and cleaned and inspected the terminals. The car DID start after this was done (Tested it about 20 key cycles) but then would not start again after it was driven for awhile.

    Today it started fine and i function tested aproximately 40 key cycles and it started every time. I ran some errands but left it running the whole time for fear that it would not restart. The passlock light came on in the cluster and once home i turned it off and it restarted ok. tested aproximately 40 more key cycles and it started every time. The only thing that may be of note is that the starter did seem to drag 2 times in the 40. Otherwise it started and ran perfectly.

    I am at a loss as to where to look next. everything I have done has seemed to make a difference at least for a little while.

    Just to confirm, this is a NO CRANK condition. It is not the cranks but will not fire problem many have complained of.

    I have not had this vehicle in to the dealer for this complaint since we purchased it in May of 2010. I am confident in my trouble shooting skills and as mentioned i have a good relationship with some very good GM techs.
  • I think I was one of the first to post with this issue. I have a 2006 with 107K miles on it-one owner. Mine will still not crank on occasion but I have found that if I step on the gas a little when I retry, it will start every time. That makes me think there is something going on between the gas and the starting mechanism. I am not a mechanic, just my observation.
  • I bought a brand new torrent in 2007, it now has 36,500 miles on it. I have had nothing but problems with the check engine light, abs light, and traction control lights. I have had this car in numerously for repairs and still having problems with it. I am now into the extended warranty for repairs for the same problems during the factory warranty. Again it is in the shop less than 2 weeks later for repair for skipping -jerking, and decrease of RPM power when hitting speeds of 35 to 40. I was told a spark plug and wire, which i had to pay for to replace, and it is still skipping. The dealer is no help, i am getting tired of taking the car in for repairs, ( 5 times in a 3 week period) and getting nothing done. they admit there is a problem but don't know what it is, what is up with that? The service manager has an attitude and I am just so frustrated with it. I also get the grinding noise at the left front wheel as well. I have not had the time to test on the interstate the ERG valve that has been supposely replaced just 2 weeks ago to see if the traction control, check engine, and abs lights are repaired. I am tired of the car just being put on a computer to check and being told nothing is wrong, and the computer just being reset. What is there i can do to get these issues resolved? this is time and money and i am so annoyed with the problems.
  • oh yeah, i also have a problem with the key sticking in the ignition when turned off. They told me they lubed the ignition but i still have the issue
Sign In or Register to comment.