Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Neon Squeaks, Rattles and Noises

jakebrake1jakebrake1 Posts: 2
edited 12:03AM in Dodge
I have a 2004 neon sxt, 4 banger, and there is a loud humming noise coming from front, I bought 4 new tires thinking that would solve it and to no avail it still does it. when I turn the wheel to the right it gets louder, and when I turn to the left the sound dull"s a bit if anything the radio covers the noise really well, but any ideas as to what is going on would be great

Comments

  • fat24fat24 Posts: 1
    try checking the front wheel bearings
  • I have a 2002 Dodge Neon SXT with 111,000 miles. Fuel consumption is about 22mpg or 225 miles on one tank. A couple of months ago I began hearing a tapping noise coming from the head when I started it up in the mornings. I'm almost certain it is a valve or "lifter". I noticed a fluid in my intake manifold while servicing the air filter. My exhaust does not have visible emissions. During acceleration I lose power. The car also idles loud and at 650RPM, sometimes it will putter. Any suggestions???

    I'm afraid it's a head and timing issue... timing I don't mind, but replacing the head is questionable. Love the car would like to resolve this issue in an affordable manner.

    Thanks
  • Hi, i have a 1998 neon sport with many problems,leaking from somewhere(sunroof,tail lights,ect) but the newest thing is a thump noise comming from the pass backend.Any ideas?
  • teenneonteenneon Posts: 1
    Hey I am 18 years old and I think I may know your problem. I love my neon it is candy apple red I keep it nice and clean all the time. I recently heard a tapping noise at start up and when i would turn it off and also when it was running and could not figure it out. I finally opened the hood to see that one of the spark plugs was loose and not torqued down. Not long after that the aprk plug popped out on me and i had to have it towed. The problem is fixed now and the car is quite again. I am not sure this is your problem but it sounds somewhat like mine so i thought id give my input.
  • normb1normb1 Posts: 1
    Hello, I have 1995 Plymouth Neon 78K miles has been very well taken care of. The problem is when I first start the car in the morning after a few seconds I can hear a tapping noise, after about 20 seconds the noise fades away and will not come back until the next morning it seems to be coming from under the engine area. The longer the car sets say 2-3 days the noise will be louder but will go away after 20-25 seconds. The engine oil I can drink it is so clean. Any help at all would be great.
  • jeepboy08jeepboy08 Posts: 49
    My 2005 Dodge Neon (Metallic Blue with chrome accents) did that to me earlier this year. I could not find out what the problem was, even though I am great with cars. I decided that I need to have the FRONT brakes looked at, as they were getting to be a little weak. Maybe that could be your problem, but then again, I am not completely sure. It shouldn't hurt to get them checked out.

    GOOD LUCK!! :D
  • fuze59fuze59 Posts: 4
    normb1.. I have a 2001 with 147k on it.. I have the exact same problem! When i start it up i get an engine tapping noise.. if i dont start for 3 days the tapping noise is quite a bit louder.. on cold mornigs its quite bad too..goes away when warmed up..

    Hoping its not an engine knock!!!! as i just got the car last week..
    I remember on my motorbike (kawasaki) i had the same thing. mechanic told me cos the piston and cylinder were made out of different materials they expand at different rates.. when its cold thast the slap of the piston..once it warms up and metals expand that fraction of a millimeter it will go.. hope this is not the problem cos it only gets worst..

    any suggestions would be great..
  • bmulderbmulder Posts: 1
    98 dodge neon electrical system is dead, car will crank and battery is charged. I have no lights of any kind, radio. Prior to this my radio would go dead and come back on, the headlights at night would go bright than return to normal. I am thinking alternator/voltage regulator or computer. Battery id not going dead just absolutely nothing electrical works car will not run.
  • Have the same problem on my '97 Expresso.

    Does anyone know the cause and solution?
  • bmulder the electrics on my neon also went. and on my friends neon too! i had the exact same electrical problems you described. last weekend i did what i should have done a long time ago, i traded it in and got a toyota!
  • I have a 2004 Dodge neon and lately I started hearig a loud rattleing noise comming from the engine area whenever the car is in drive. I had reasontly changed the top and lower right engine mount but that did'nt solve the problem. This sound only happens when in drive not neutral, not reverse and it has started to get louder. I suspect wheel bearings but cant afford to keep guessing. Not only is the noise loud but it also vibrate through the gas peddle. Any idea what this could be?
  • diezeldudediezeldude Posts: 1
    have you checked the cv joints?
  • shlack123shlack123 Posts: 1
    Check the CV joints. I had that problem recently, and the CV joint/axle was the issue.
This discussion has been closed.