Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Venture Heating / Cooling

I have a problem with my rear A/C in my Venture. I have owned this vehicle for over 4 years and basically we love it. I have read all of the issues on this board and I guess I consider myself lucky. I am wondering if there is a second set of connections for the A/C in the rear somewhere. I have no cool air coming from the rear vents unless It is really early in the day. I am in the Phoenix area and A/C is a necessity. Is there a second compressor or possibly a secondary place to check refrigerant pressures? I have already done the check under the hood and pressures are good! Please, any information that would help me out here would be greatly appreciated. Thank you!!!!
«134

Comments

  • Our heating system works in the front but not in the back. Thats were we have the kids and really need to fix it before winter hits! It does not blow heat at all. Has anyone had this problem?
    Help please!
  • 1997 Venture van, extended. 105,000 miles. My heater fan switch suddenly stopped working on 1 thru 4. It only works on "high", position 5. Any comments? Just the switch? Resistors? How hard to replace it?
    Thanks

    Also, I've had so many of the problems everyone else has had. Caliper bolts falling out, over heating and having the head gaskets replaced. (water in the cylinder) I've had window switch failures, lost brakes and fluid when brake lines rusted out prematurely.
    Windshield wiper "home" or down position issues. Sometimes they stop in the up position when turned off. I've replaced the front pads and rotors several times, while the rear drum brakes don't seem to wear at all. I've done all the repairs myself except the head gaskets.
  • 442dude442dude Posts: 373
    If you've done the repairs you've mentioned yourself, this one will be a breeze.

    The switch is most likely OK. You may want to check it before replacing this blower motor resistor but I'd bet $ 1.00 that your resistor is the problem.

    Its located in the passenger side footwell behind the blower and mounted to the firewall. Remove the blower motor and you'll see it. Its got the footprint of a credit card and is less than 1" tall with a bunch of wires attached to it. If you follow the power wires from the blower it will lead you right to it. Before you remove it, make sure the connections are tight and try it one more time. If that does nothing - Take out the 2 small bolts holding it in and replace. Part is around $ 20.00. You'll need to be pretty flexible to get to it but other than that its easy to replace. Its a common problem on the Venture.

    Make sure you check your fuses 1st though. I think the # 5 speed has its own fuse so if you've got a bad fuse for the other speeds it will still work in # 5. I'm still betting that the resistor is the problem though.

    Also, the fail to park on the wipers is typically the wiper motor going bad. Another common Venture problem. Its not really too hard to replace either. I'd post the procedure but its got too many steps to type. Get a haynes or chilton manual, its in there with pics...the haynes manual even has a diagnostic step by step procedure to do it.

    Good Luck...

    John
  • I have a 2000 Chevy Venture, and recently, I noticed that when I turn on the AC or heating, the air blows out of all the vents at once (the ones by the feet, the vents on the dashboard, and the ones by the windshield). Turning the nob that's supposed to control this does nothing. It used to work fine. Does anyone have any ideas what the problem is or how to fix it?

    Thanks!
  • 442dude442dude Posts: 373
    One of 2 likely problems - both easy to fix...

    1. The vacuum hose that provides vacuum to the switch has become disconnected. look behind the vent position control knob and locate the vacuum hose that is attached to it. Is it not attached? if its ok there, open the hood. the other end of the hose attaches a vacuum port on top of the engine, just above the accessory belt. You'll see it, it attaches there, jumps across and wraps around the washer reservoir before heading to the firewall. it may have fallen off or it may be broken, kinked or split. If you're still OK, go back in the car and disconnect the vac supply hose and then start the car. You should hear/feel the vacuum in the hose. No vacuum???The hose is plugged - run a new one through the firewall and attach it to the port on the engine. Our 2000 Venture had a plugged hose...

    2. The switch is shot. Basically, if you've got vacuum the switch should work - very rare that the control switch is dead.
  • Thanks for your quick response! I was waiting to take a look at it before I responded. All the fuses and connections seem ok, so for $20 or so I'll assume it's the resistor. I'll pick one up before I go thru the trouble Of removing it and the heater motor. Thanks again....Jim I'll let you know how it works out.
  • My problem is with my '04 Venture van since it was new. When I set the temperature control anywhere in the cool zone, and vent control to any setting which includes the floor vents, I get cool air coming out of the upper vents and hot air coming out of the floor vents. On long trips I get a hot foot as the floor vents blow right onto my right foot. I have to use the cruise control to get some relief and/or take off my shoe. The sides of the centre console also get quite warm. Needless to say, the A/C works against itself and I have to set it to max to get normal temp.

    After years of complaining, my dealer finally admitted there is a problem. They've taken it in recently and after taking the centre console apart and replacing the actuator(?) control (from another van as they weren't sure this would solve the problem) the problem persists. The dealer mechanic said they got in touch with GM engineers and they said they had no idea what the problem was, but to let them know when the dealer found the cause of the problem.

    I'm taking it in tomorrow again for as second try. I figure they'll be taking it apart again and look some more. They might or they might not find the problem. I have a 1,500 mile trip coming up this weekend (to Fla.) and I sure would be thrilled to get my climate control finally working normally. (So would my wife).
  • I have the same exact problem. I'll try the repair suggested and see if it works.

    I also have a problem in that the unlock switch on the arm rest does not work. I have to manually lean over and unlock the door (to let someone in, for example).

    Any ideas?
  • 442dude442dude Posts: 373
    Does the switch on the other door work or are all switches dead?

    Or is it just that the passenger door doesn't unlock?
  • I have the same problem with the unlock switch. I have a 2002 Chevy Venture that I bought new. The drivers side unlock switch stopped working a few months ago (the "lock" function still works, but the "unlock" doesn't do anything). Now the passenger door switch is doing the same thing.
  • 442dude442dude Posts: 373
    Sounds like a switch issue - interesting that its happening on both sides - First things first, you need to confirm the operation of one of the switches (you'll need a multimeter to check it out - you can get a decent autoranging one under $ 50, it will pay for itself with your first repair: This is how you test the switch for proper operation:

    Pop out the switch panel from the armrest on the door with a small screwdriver. You then want to disconnect the plug from the switch. When you disconnect it, you'll check for continuity in the switch - you're basically checking to see of the switch is working. After you unplug the switch - look into it with the square hole for the connector to the left and the contacts to the right. Touch the multimeter to the contact on the bottom right and to the one in the top middle. Depress the button to "lock" the multimeter should indicate continuity as the connection is made - repeat the process with "unlock' while touching the top left with the top center. There should be continuity between these if the switch is working correctly. If either fails the test, the switch needs to be replaced. I'm guessing that you'll wind up replacing both switches since neither are working for unlock. Post back and let me know how you did...if your switches pass the test then we can go further. As always...be sure to check for loose or corroded connections and make sure the fuses are OK. Good luck - let me know how you make out...
  • gmz1gmz1 Posts: 6
    Dealer changed blower motor resistor then informed me it was it might be control head ($600 part). Are they talking about actual fan control sw? Any advice to check control head.
  • 442dude442dude Posts: 373
    I believe they're talking about the actual fan switch - you can't replace just the switch you have to replace the whole dash part including the temp control, etc.

    The way to check the operation of the switch is to disconnect the plug from the switch to the blower resistor at the resistor and then use a test light or multimeter to see that the switch is sending 12V to the resistor in each of the respective fan speed positions. Personally, if I needed to replace the control head I'd get one at a junkyard, while I don't think they're trying to rip you off, $ 600.00 is pretty steep. Its an easy install for the DIYer...

    I can post later to let you know which pins to test with each speed as I don't have the diagram with me. In the mean time - make sure that the plug going to the resistor is completely inserted - had trouble when I replaced mine and it turned out that the plug had not fully seated. The resistor is located on the pass side firewall right behind the blower - its got the footprint of a credit card. Will post the pin details later
  • This is not a constant problem, but when the AC is on the rear vents will put out heat. This is an 02 Venture. I've read that there's a "flap" that's not working correctly. Has anyone else seen this, and can I fix it myself?

    Thanks
  • 442dude442dude Posts: 373
    OK here goes -

    pull the connector from the blower motor resistor - as you're looking at the plug with the"slots " which clip the wire to the resistor at the top...

    The connector looks something like this as you look at it:
    ________________________________
    _____!____!___!______________!____!____!______
    !__________________________________________!
    !_____!____!______!_____!_______!_____!_______!
    !__G__!_F_!___E__!__D__!___C___!__B_!___A__!
    !_____!____!______!_____!_______!___ _!_______!!

    I filled in the letters for clarity - making this diagram was a pain!!! :)

    E is the ground - touch one probe to it from your test light or multimeter to it for each test and follow this order - each terminal corresponds to a blower setting. You should get about 12 volts for each test (ignition on - engine not running) The blower resistor then steps down the voltage to get the blower to spin at the appropriate speed.

    A+ E = SPEED SETTING #2
    B+E= SPEED #1
    C+E= SPEED #4
    D+E= SPEED # 3
    F+E = SPEED # 5 (HIGH)
    G IS HOT AT ALLTIMES YOU SHOULD ALWAYS GET 12 v HERE

    If you don't get 12v at each when you change the switch to the corresponding setting and test then the switch is most likely the problem (assuming that the connector at the back of the switch is attached securely and that the wires are in good condition) If all get 12 volts when you switch to them then the blower resistor is most likely NG.

    This gives you enough info to test it - let me know how you make out...
  • 442dude442dude Posts: 373
    Hello,

    I've not had this problem before but here's some thoughts:

    To access the "flap" that you mention - remove the rear left quarter trim panel - behind it is the blower and the mode actuator (controls the "flap"). The actuator is vacuum powered. There's really only a couple of things that could go wrong back there...

    First I'd check to see that it is getting vacuum - start the engine and remove the hoses from the actuator (its the round thing about the size of a fuel filter with 2 hoses attached. With the engine running you should be getting vacuum to at least one if not both if them. I'd be willing to bet that you're not getting vacuum. If you are getting vacuum, check the actuator and the stuff its attached to for smooth movement, maybe its hung up on something or perhaps the actuator is shot.

    If you're not getting vacuum, see if you can hear vacuum with the engine running - these vac hoses get brittle and break from time to time. If everything you can see looks good, after that its tough to find the problem. You'll have to do some Dick Tracy work to figure out where the hose is routed and where it gets its vacuum supply because I'm not sure. Check under the hood for a vacuum leak or a vac hose that is broken or has fallen off. The other possibility is that the vac hose is plugged - I had one of them once in the front.

    Its something you can fix yourself if you're patient in trying to figure out where the leak/blockage is - Just for reference - the vac hose at the actuator goes to the overhead console control which in turn gets its supply from a vac header somewhere under the hood - I'm just not sure where.

    Good luck - post back with your hopeful success.... :)
  • sh00trsh00tr Posts: 4
    I have had the same problem since I bought my 99 Venture used 3 years ago. However, now I have a problem in that my blower motor stays on even when the ignition is turned off. Did the resistor replacement fix it?
  • sh00trsh00tr Posts: 4
    I had some of these problems with my 1999 Venture (extended). Power locks didn't work with armrest controls on either side, and passenger window stopped working from driver's side armrest control. I solved it.

    The wiring harness goes under the carpet under the passenger side door area. This seems to be a place where salty water from winter roads collects and drains out from under the carpet. In my van, the wiring harness is not protected from the salt water, which got into the splices and rotted them out. The harness seems to lie right in this channel. I replaced all the splices and I got my power locks and windows back. I re-sealed the splices and wrapped them with cable coax di-electric to ensure get the wire harness up out of the drain channel.
  • sh00trsh00tr Posts: 4
    OK. I can confirm that replacing the blower resistor gave back my variable fan speed. Before I had low, and high. Now I have off, 1,2,3,4 and full. On inspection, it seems that somehow water is getting down in there, causing corrosion evidently causing the resistors for 2,3,4 to fail open circuit.

    This is a real beeeyotch to replace. You need to take out the blower motor first. The rear screws are almost unreachable. Best to just back them off a couple of turns and then pull the old one out. Then you can slide the new one back in.

    I lived with this for about 2 years until yesterday, when the battery died because the fan was stuck in the full position.

    I tried replacing the heater control like this one
    http://cgi.ebay.com/ebaymotors/ws/eBayISAPI.dll?ViewItem&rd=1&item=360028990803
    but it didn't do any good.

    I think the water might be coming in from around the top of the windshield, as I notice there is a bit of water now in the dome light somehow, and the rubber around the window isn't as tight as it might have been one time.

    Hope that helps...
  • 442dude442dude Posts: 373
    Hi sh00tr....

    Lets think about this one for a minute - if I think out loud and type maybe we can figure it out together - it might look like random thoughts and that is precisely what it is...(and yes...the resistor is a pain to replace, my back still isn't the same from last summer when I did mine)

    So you replaced the resistor and now all 5 speeds work...but you can't turn the fan off? Am i reading this correctly? Or you replaced the resistor because you couldn't turn it off and now you have all 5 speeds and you're trying to figure out how to not have this happen again?

    I'm not completely convinced that water that you think is coming from the windshield was the cause of the demise of the resistor - these resistors are known to fail even in the best of conditions, it wasn't a smart idea to mount it right near the fan on their part...not that its not possible that its water of course. There is one pin that's always got 12 volts on it no matter where the switch is set - it powers the blower relay. If the relay is stuck closed - you'll have nothing but high speed at all times - even with engine off if I'm reading the wiring diagram correctly...Is the carpet wet on the pass side? I know you've seen water in the dome light, you said that...

    Did you confirm that the blower switch is working correctly with a multimeter? I'm wondering what is going on when you turn the switch to off - a multimeter can tell us what's going on...A couple of posts previous there's a really poor diagram that I created to tell how to test the switch & resistor. Its a small circuit so finding the faulty component should be pretty easy...

    I know I'm shotgunning the problem at this point- post back and let me know where you're at right now and we'll figure it out...just typed in some random thoughts to get the thinking process started...I'm only a mechanic when there's a shade tree and some beer around but I know that you and I are smarter than our Ventures - I'll be happy to walk you through diagnosing and fixing the problem...I'll look for your reply...
  • sh00trsh00tr Posts: 4
    Hey 442dude. Sorry if my post wasn't clear. I'm confirming that replacing the resistor block solved two problems for me.

    1) High and off only; positions 2,3,4 were all "off" 5 was 5 ...I had that for about 2 years...,

    2) More seriously, it started shorting to on/High only regardless of the position of the console switch, and regardless of ignition on or off or set to accessory.

    This progression was very problematic as the only way to avoid killing the battery was to disconnect it! Not ideal as it's been -20C (-28F) the last couple of days.

    I confirmed the blower switch was working by testing continuity for all 5 positions.They were all good. I also have two spare ones here if anyone wants one cheap (one for a 99 the other for a 2000...)

    The factory resistor showed signs of either burn off or corrosion. The green coating had flecked off in a strange sort of way; I think it was water damage.

    http://fhlsim.com/images/7692.JPG

    http://fhlsim.com/images/7693.JPG
  • 442dude442dude Posts: 373
    Hey sh00tr...

    So you're fixed then...excellent...

    These are a really common failure...mine looked scorched when I replaced it...looked a lot like yours - its the peril of mounting the part so closed to the blower where all sorts of dust & what have you is kicking around (moisture, heat, etc)

    Looking at the wiring diagram and your pictures tells me a couple of things

    -there is 12v power to the blower resistor at all times, ignition on or off

    -the #5 position is wired directly to the blower relay, so when you choose # 5, its basically a straight shot of juice right to the blower motor ... if that relay fails closed ( like yours) that would explain only full blast, (the relay is on the resistor part) No matter what you set the switch at, if the relay fails closed, you're getting full blast all the time...

    Mine looked very much like yours, although yours does look a little worse...I don't think its a water issue although you still may want to hunt down the source of the leak...

    Post any time...I'm always cruising around here & willing to help :shades:
  • modrace18modrace18 Posts: 3
    Thanks John, it was the relay. I'd like to shoot the designer who put the screws where they are. Pretty miserable to get at the screws for such an easy task.
    thanks Jim
  • 442dude442dude Posts: 373
    No problem...I'm glad to be able to help...if they tried to pick a horrible place to put that thing I'm not sure they could make it any worse...

    Best,
    John :shades:
  • My heat started acting up last winter. I would start the car and start the defrost in the morning. When I came back out a long period later, the cabin would still be cold and no defrosting occurred. When I drove the car to work the heat began to warm up and get to a comfortable level. I also started to notice the temperature guage rising above normal when I went on long trips (over an hour). Before it got too cold I flushed the radiator to see if this was the problem, but did not fix it. Summer has come and now the A/C does not work. Attempted to recharge the A/C since it had been 4+ years since we bought the vehicle. This did not work. I get warm air from the vents. When I turn on the A/C I get a noise that I assume is the compressor kicking on, so it appears that it is working. I have not taken a PSI check on the system yet though, but if the pressure is NOT correct I assumed the compressor would not come on?!?! Since they are faults that occur seasons apart, I did not make the connection until now. Is it possible they are related problems... Would a vacuum hose leak or disconnect cause both of these probblems? If so, where is it and how do I T/S it. If not... What are some recommendations for T/S or rectifying these problems?

    Thanks in advance for any assistance.
  • I have a 2002 Venture LS that has developed a problem where condensation somehow leaks into the cabin onto the driver's floorboard. After I've been driving with the AC on for a while and then I get out of the car, when I come back the carpet on the driver's side is wet and the ground directly under the driver's side is wet also. Can someone tell me what is going on here?
  • 442dude442dude Posts: 373
    There is a drain for the AC that is either disconnected or plugged. Chances are there a bunch of glop in there which plugged it up. Clean it out and make sure the drain hose that goes through the firewall is clear and your problem should go away.
  • I took it to my mechanic last week. He hooked a long nozzle to his air hose and then stuck that in the drain tube underneath and blew it out. It drained outside for a couple days and the inside carpet started to dry up. Then evidently it stopped up again because now it's draining back into the floorboard again. Does it need to be blown out from underneath, or should it be drained from the inside? How can I get to the drain from the inside? Is it behind the center console? How does that disassemble?
  • I have a silhouette, but same difference. I justa had an episode where the front wasnt cooling but the rear was, and I hooked up guages and it read normal. So i took it in to the shop and it was a pound and a half low of refrigerant, somehow since it holds more refrigerant the guages read normal readings. I know there is only one compressor, and only one place to hook guages. The only way to really know if the refrigerant is low, is to reclaim it with a machine that weighs it.
  • chaseschases Posts: 41
    Blowing it from the bottom to the inside just unplugs the hose, but the junk plugging it up is still in the unit. At this point, if you want it fixed for good you need to consider taking apart the inside to get to the coils and then clean it out.

    Preventitive maintenance, like frequently blowing out your inside air filters, could have prevented this. This is commonly overlooked. When I purchased my van at 70,000 miles and checked those filters, they were plugged and had 6" of pine needles stacked on top of them.
«134
Sign In or Register to comment.