Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Durango Electrical System Problems

13»

Comments

  • sexys312sexys312 Posts: 2
    my 2000 dodge durango did the same thing I replaced the battery and battery cable cords and it stop, no more problem since, disconnect the cable cords from the battery and replace both.
  • unc_jakeunc_jake Posts: 1
    My 2005 Durango has some weird electrical problems going on with it. It started out with the front blower unit quitting working. Soon after, the radio quit (completely), power door locks quit (unless the key is in the on position), windshield washer fluid pump (completely). When you turn the key off, its as if you unhooked the battery. All power to the entire durango stops. Any ideas on what could be the problem. Is it the ECM? :confuse:
  • I have a 2004 Durango and my battery goes dead. i have recahrged the battery and it will still go dead. the battery ahs been checked and i was told it was good. does anyone know what is causing the drain on the battery.? everything seems to be shutting off
  • I am having the same problems,my engine went out,car sit for 3 years. I have had to re-do everything under the hood;but now it will not run without cutting off after 2 hours,Dodge dealership said I need to take it back to the shop that did the entire engine work,but when I drove outta shop,they didnt lock my engine in,after they completed repairs,they cracked my windshield. I am so stressed out,I've taken my truck to 3 shops since the repair have been done,now it shut off after being driven for 2 hours,to crank up 2 hours later,please help someone???
  • Rear hatc door stopped working. Howdo you access the door to work on the problem?
  • Hello fellow dodge drivers, I would like to first say i've been a chysler owner for 5 years now, and ive always liked there products, I recently bought a 2006 dodge durango with the 5.7 hemi. First month i owned this truck I loved it, then the 2nd month it started to skip ocasionally. Took it to the dealer they said it was a bad coil pack, they replaced it and on my way home it started skipping again. So I then take it to another shop they fixed a bad wire and sent me on my way, on the way home it started skipping again. I take it back to the shop the next day where they ran some tests and found I had a bad pcm (computer). Ive had this vehicle for 4 months and I have over $1000.00 into it. I talked to the dealer and they said that there was a 80000 mile waranty on it. Which i didnt know. So now its been three weeks and i still dont have my vehicle because the part is on national back order.
  • slomo2slomo2 Posts: 1
    I have the exact same problem!
    How did you fix it?
  • I was driving a few months ago and my radio stop working along with the back windshield wiper, and interior lights. Just recently my turn signals have stop working the signal light does not come on inside nor outside. All the fuses are fine I just don't know where to look or who I should be calling to have it fix. Does anyone else know?
  • did you solve this problem? If so, what did you do?

    Thanks for the info!
  • I am also having the same problem with a 2005 durango.. Did you fix your problem??
  • I just purchased a new battery in June, because dealer said battery was reading dead. Since i put in new battery, everything fine except no cd player on radio. Then 9/2/ car 100 % dead again.. This time 24 hrs before when got in unlocked car horn went on and stayed on after car was started and put in gear and was driven several feet. The drove it about 50 miles before battery went dead. It is like something is drainging the battery.. Any ideas before I take it to the garage and they rip me off??
  • Shannel,

    You probably ARE blowing a fuse....just not one that is in the fuse box that is on the drivers side dash...you have probably blown a MAIN 40AMP fues in the box over the drivers side Wheel under the hood! I ran into a similar issue. I blew the 40 AMP main and all that stuff wouldnt work...I replaced the fuse and would blow it a few days (maybe minutes) later.

    The problem was that I actually USE my emergency brake when I park in my driveway. There is a bundle of wires that are right next to the gear teeth on the top of of the E-Brake pedal Over the years...those wires rubbed against the gear-teeth until the insulation wore off. Then when I applied the E-Brake....sometimes it would short that wire ...blow the main fuse...and ALL the stuff you listed....wouldnt work anymore.

    Solution: Cover the exposed wire with electrical tape. ZIP-TIE the bundle further up in the dash....replace the MAIN fuse. No problems since.

    Good luck!

    JJ
  • Sorry, I have no advice ... but I'm having very similar problems, so if you figure it out, please let me know - and I will do the same!

    My 98 Durango drains the battery every time it sits for more than a couple hours. Took it to a shop who couldn't find anything wrong, despite spending around 10 hours on it. For now, we are unhooking the battery EVERY TIME we shut it off for more than a few minutes, but that's a pain in the butt and I'm sure it's not good for the battery, either. Any suggestions would be appreciated! Thanks!
  • Pull the plug on rear wiper motor, It does not complete its cycle and continues to draw current, about 8 amps and will kill battery in a few hours to a day and also check light under hood by pulling connector off and check fuse #12 inside fusebox in truck and replace if blown after doing the above. These 2 items, rear wiper and under hood light fix a lot of electrical problems when disconnected. Interior lights start working and radio starts to keep proper time, etc. etc. Hope this helps.
  • Wow - thanks a bunch! The hood light hasn't worked in a while, but the rear wiper was just as you described - about halfway through it's cycle. So I unplugged it, and so far it's been a little less than a week with no battery drain! I can't tell you how excited we are - this has been a constant pain in the butt for MONTHS now. Once again - THANK YOU very much! It's amazing that something that has been so vexing for us can have such a simple solution...
  • I see this problem happened quite a while ago. Now my vehicle is doing this also. Does anyone know what the solution was? I hope its not one of the control modules.
  • boydfboydf Posts: 2
    edited May 2012
    Simular Problem have had my 2000 durango for 3 months no problems at all until tonight. Drove the Durango to the store came out dashlights where acting not normal and the truck would not start. I tried jump starting the truck it would start immediately but than die just as quickly. The Durango is still in the store parking lot, after reading some of these post I am curious if it will start now that it has sat for a few hours. My initial thoughts was a bad alternator, but I have never seen one go out so absolute so quickly.
  • dwgreendwgreen Posts: 4
    My rear hatch was going up, hit the garge door and came back down. Now it won't lift out at all. I've disconnected the battery as a reset but it still won't work.

    Any suggestions?

    Thanks!

    Damien
  • NOTHING works anymore... got a tune up and works great, all except.. no BACK WINDSHIELD WIPER Functions. ABS light always on and Emergency brake light always on... speedometer works ONLY AFTER 40 mph...2 days after tune up..NOTHING when turned the key. fuses and battery ok. VERY FRUSTRATED... cannot seem to get a brake with this vehicle. Any ideas at all? battery anf fuses ok, fusible link? wiring? HELP PLEASE with any ideas.
  • unc jake
    I am having the same problem. My blower went out, turn signals do not work, and the radio as well. The radio and turn signals go on and off. Do you know what this could be? Some please help! My durango has been in the shop 4 times now.
  • johnny717johnny717 Posts: 1
    Have a 2004 Durango Hemi, never had a problem with the radio...now, just changed alternator and radio now turns on, crackles, speakers play for about 15 seconds, then crackle again, and sound/speakers cut out. The radio appears to work perfectly, but without sound! I can shut it on and off but sound will not come out of speakers. BUT, this repeats every time I shut car off and restart it for another trip? I tried playing radio on just battery (without alternator running) and the same thing happens..Anyone have a clue?
    Thanks, J
  • verahverah Posts: 1
    This happened to my Durango. I took it in and they had to replace both side lift gate shocks. This solved the problem. It was under warranty so I have no clue of the charge - sorry.
  • how do you unplug the rear wiper motor??? having the same exact problems
  • My 2001 Durango acts like the battery is low when starting the truck and then starts. The battery, alternator and charging system check out good at the autoparts store. One time the vehical would not start at all and the solenoid just clicked...i.e. like a dead/low battery, then an hour later started and had trouble running. Went straight to the auto parts store for a new battery and all checked out fine. Could it be a weak starter?
  • THIS IS THE THIRD TIME THIS HAS HAPPENED WHILE I WAS DRIVING IN THE PAST 4 MONTHS. THE AIR BAG LIGHTS WILL COME ON & OFF WHILE DRIVING. (BOTH THE PASSENGER & DRIVER SIDES LIGHTS SEEM TO ALTERNATE.) THIS TIME ALSO THE 4 WHEEL LOCK LIGHT BLINKED ON & OFF DURING THE 50 MILE TRIP GOING 70 MPH. WHEN I TURNED ON MY WIPERS THERE WAS A CHIME/DING. ONCE WHEN I ROLLED DOWN THE WINDOW THE WIPERS CAME ONE. ANOTHER TRIP TWO MONTHS AGO WHEN THE AIRBAG LIGHT WAS ACTING UP & I TURNED ON MY BLINKER TO CHANGE LANES THE WIPERS CAME ON. I ALSO JUST REALIZED THAT THE DOOR LOCKS NO LONGER UNLOCK WHEN I TURN THE VEHICLE OFF. I HAVE TO MANUALLY DO IT NOW. ALSO IT USED TO AUTOMATICALLY LOCK THE DOORS WHEN I PUT THE VEHICLE IN DRIVE AND THAT HAS
    BEEN ACTING UP PERIODICALLY. THE ICING ON THE CAKE WAS YESTERDAY WHEN I WENT TO PULL INTO A PARKING SPOT AND THE VEHICLE COMPLETELY SHUT OFF AND ALL THE WARNING LIGHTS ON THE DASH ILLUMINATED, I JUST TOOK IT TO BRIGGS DODGE IN TOPEKA, KS AND THEY CANNOT DUPLICATE THESE ISSUES AND SHOW NOTHING WHEN THEY HOOKED IT UP. THEY TOLD ME THAT DODGE HAS A "STAR CASE" ON FILE AND THAT STATES THAT DRIVERS ARE CAUSING THESE PROBLEMS TO OCCUR. (i totally disagree& think this is a cop out) THEY ARE TELLING ME I GENERATE TOO MUCH STATIC ELECTRICITY! HUH? I FIND THIS VERY HARD TO BELIEVE. I AM VERY DISCOURAGED AND FRUSTRATED. I GUESS WHEN SOMEONE IS KILLED IN AN ACCIDENT FROM ONE OF THESE FAILING, THEN MAYBE THEY WILL OWN UP TO THE PROBLEMS AND FIX THEM. PLEASE HELP! WHAT DOES ANYBODY ON HERE THINK? THERE ARE MANY OTHER PEOPLE WHO ARE HAVING THESE ISSUES WHEN I SEARCHED THE WEB. WHAT SHOULD I DO? JUST START LOOKING FOR A NEW VEHICLE OR IS THERE A FIX OUT THERE?
  • I have a 2000 Dodge durango and for some reason the engine will not shift correctly pass 40 mph...it feels like it is always pulling. I got a code reading from Advance Auto and it said that I need a speed sensor but when I took the SUV to a couple of transmission mechanics they said I need a whole new transmission!! Also, here lately I have a hard time trying to start my vehicle. It clicks for about 10- 15 mins before it turns over...again Advance showed that there was nothing wrong with the solenoid, starter, alternator or battery. Anyone having the same problems...if so, what has been your remedy? I am trying to see if the problems that I am having are worth fixing or should I just trade the darn thing in for something else before I have to spend any more major money!
  • Ok, so I have a 2004 dodge Durango. I keep up with the maintenance but I keep having this issue where my battery dies. At first it was the alternator. So I got that replaced. So I started to notice that my radio would stay on once I pulled the key out and lock the door. At first I didn't pay it any mind until I go to start my truck and it wouldn't turn over. So after I got a jump I ran the car for 15 minutes and drove it around. So I started to take the face off the radio. That seemed to work for a while. Now I am having the same issue and I don't know what to do. Can someone please help me???? I am beyond frustrated and I have put well over 6000 dollars into this vehicle. But now it seems to be for nothing..... Help please!!!!!!!
  • When I had a similar problem with my 1998 Durango, it turned out to be my rear wiper- even though it was off, it never actually shut itself off. We had to take apart the interior panel of the hatch, and just disconnected the wiper. So we don't have a rear wiper now, but we haven't had a battery problem since.
    Hope that helps.
  • Did you figure out the issue nikki I am having the same problem
  • You have an electrical short somewhere in the vehicle. Bring it to a shop that is skilled in diagnosing electrical problems. It should not cost you more than $100 ti diagnose (not repair) the problem. If they try to charge you more than that to diagnose go to another shop. Good Luck!
13»
Sign In or Register to comment.