Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Cavalier Check Engine Light

2»

Comments

  • I have a 1998 Chevy Cavalier, and when it gets hot out the check engine light comes on and while driving in town my temp gauge drops from normal to cold, and when it does that my trans shifts hard. But when the light come on and im driving on the highway nothing esle happen it drives fine. Any sugestions?
  • If you have the Trac Off light coming on at random times and the transmission jumping into low gear here is the answer:

    Replace the TPS (Throttle Position Sensor). $30 to $40 if you do it yourself or $70 to $95 if you have a service station do it. Of course you can pay a dealer to do it but they will charge you hundreds of dollars, (just my opinion).
    This will fix all of your problems related to the TRAC OFF light and transmission shifting into low gear.
  • Hi, I was just wondering if you, or anyone, has ever found out what this is about? I have a friend with a 2003 Cavalier with the trac off/check engine lights on. She has also recently had a problem with the coolant system, temp. gauge went way past red, but the car did not seem to actually be overheating. Then it did overheat and she had to have the thermostat and a hose replaced. Now the car only gets up to about 100 degrees and these lights are on. She is very frustrated and has been to two different shops already. All of these problems started after an emissions inspection while she was on a long drive to Ohio. Any suggestions would be greatly appreciated.
  • My 2004 cavalier has the check engine light blinking. It also idles rough, has a burning smell when the enging runs for a while, it sounds like its going to turn off after i take my foot off the gas pedal, when it first started i had to turn it three times before it finally kicked on. it sounds like it misfires and the car shakes while in idle. it wasn't able to go above 3000 rpms when i last drove it (the only time i drove it since these troubles). I changed the o2 sensor before the cat conv, the spark plugs, and the coil pack and it has the same things wrong with it. A local mechanic looked at it and said he seen milky oil on the dipstick and under the oil cap. he said it may be a blown head gasket. The following codes come up when i scan the vehicle:

    P1137 - Heated Oxygen Sensor (HO2S) Bank 1 Sensor 2 Lean System or Low Voltage
    P1138 - Heated Oxygen Sensor (HO2S) Bank 1 Sensor 2 Rich or High Voltage
    P1133 - Heated Oxygen Sensor (HO2S) Insufficient Switching Bank 1 Sensor 1
    P0137 - O2 Sensor Circuit Low Volts (Bank 1 Sensor 2)
    P0138 - O2 Sensor Circuit High Volts (Bank 1 Sensor 2)
    P0140 - O2 Sensor CKT No Activity (Bank 1 Sensor 2)
    P0136 - O2 Sensor Circuit Malfunction (Bank 1 Sensor 2)
    P0300 - Random/Multiple Cylinder Misfire Detected

    any help with be greatly appreciated, i need my vehicle for work....
  • austin21austin21 Posts: 1
    my check engine light and ets off lights are on. i replaced the tps sensor and it started shifting better. i hooked a code reader up to it but it wasnt any help. anyone have this same problem and if so any suggestions on fixing it
  • caveman55caveman55 Posts: 2
    Im working on an 03 cavalier with a 2.2 ecotec. It idles and runs rough at any speed. Codes were 171 bank 1 lean, 108 map hi input 128 coolant temp not in spec and random misfire. Map was replaced, new plugs, new coil unit. TPS seems to be ok. Pulled the new plugs and they are black seems rich to me not lean. All cylinders are at 205. Any suggestions where to look.

    Thanks
  • My abs light just came on all of a sudden and i had the brakes done a few months ago and the fluid level is full. Anyone know why it would do that? :confuse:
  • I know you posted this a while ago but did you figure out what was wrong with it? My cav is doing the same thing and I don't know what it is. If you do and you could let me know that would be great. Thank you.
  • I found excessive slack in the timing chain and it had jumped a couple of teeth. The timing chain guides were also broken. Check the timing chain ASAP because you can mess up the valves and you'll have to rebuild the head.

    Good luck
  • have 05 simliar trouble, replaced tps, plugs, crank sensor, coil packs etc, just kept throwing money at it, Found out that cavaliers are real sensative to poor grounds..the cable from battery (ground) down to the battery tray was not making a good connection at the tray (body ground) was very rusty, replaced it, the same
    cable goes to the right side of the engine (stud sticking out of engine block) also the 2 wires from the main harness also hook to this stud, they were corrected a little, snipped them off put ona new connector and HOLY CRAP this car never ran this good, no propblems or lights on since.
  • Don't listen to whoever replied to ur question I has the same problem it's the tempature control censor sum people call it coolant control censor and it's about 25
  • It's about $20 try that I'm almost positive
  • so i have 1998 chevy cavalier, the problem is when the weather its cold, when i turn on my car it won't start, so i decided to just turn to run position. And after a while (depend how cold the weather is, sometime it took 10minute,somtime 30minute,sometime 1hour, sometime i need to wait for the sun to sunrise first) then the all lights on the dashboard will on (they are blinking for a while, and needle it was like shaking). So after all the light on, and completely stop blinking, i start to turn on the engine. But it won't start, because the THEFT system light is blinking. And i wait about 10 minute, then the THEFT SYSTEM lights stop blinking. on that time it will start right away. But it's totally diffrent if the weather is warm. if the weather was warm, i just turn on to run position and all the lights on right away and i just turn on the engine and its working. I already change the iginition key for 200$ and 40$ for ignition starter switch . But i still have this problem. PLease kinda help me to fix this problem. i do really appreciated it.
  • fortyfordfortyford Posts: 1
    edited June 2013
    the engine light is off until a few miles down the road and over 40 miles an hour , but when you shut off the motor , and turn back on the light is gone until you are over 40 , does this over and over , the car seems to run just fine with no other issues , anyone have any ideas , taken to autozone , but when the go to check the code the light is gone and they get nothing :confuse:
  • mserymsery Posts: 1
    I have a 2000 cav 2.4 and all three lights were on when i bought it. I found out one of my abs sensors was getting a bad connection. got another plug in and spliced it on. all 3 lights turned off. not saying this is your problem for sure but is pretty easy and cheap solution worth taking a look at
  • loislane999loislane999 Posts: 2
    edited September 2013
    I had the same problem. just got the fuel pump fixed... it will go and sometimes when it stops it wil not hold and it will die. have to restart again. it has 130 miles... is somtehint wrong with it or does this particular vehicle have probs. its either a 1999 or 2000 cavalier..also my ets lights and chk engine lights are on. did not chk if gas cap was tightend
  • for a blown headgasket, try steal seel first at www.steelseal.com
    its like $90 bucks.

    its worth it. will repair a headgasket that is blown ( not fully blown but worth a try since theres a money bak guarantee. have a mechanic put it in. I did to mine. thanks
2»
Sign In or Register to comment.