Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Volkswagen Jetta Maintenance and Repair

1179180182184185218

Comments

  • I have a 99 Jetta 2.0 engine99K miles I had a shop install a new timing belt and now I have a large oil leak I have taken the car back twice and still have a leak the shop stated that the cam seal has no spring inside like the crank seal. Do any of you know of a fix for this

    Thanks Jerry jdavis790@carolina.rr.com
  • Just wanted to inform you that the brake light switch was the culprit and it was a recall item that the dealer replaced and now good to go.
    Thanks for your help, and all others who replyed with input.
  • bpeeblesbpeebles Posts: 4,085
    replace the seal
  • the seal has been replaced twice the shop said the seal has no spring inside
  • I have an 03 jetta with the same issues. The only difference is the wheel does not lock per se but I do smell what I thought was rubber burning from driver rear wheel. I got new tires on it and now the smell is worse. I looked at the rotor and pads and they appeared fine. Let me know what you find or how you fixed the problem if you can. Thank you.
  • bpeeblesbpeebles Posts: 4,085
    Ignore the spring (or lack therof) as long as the proper seal (from VW) is being installed, then the spring is of no cocnequence.

    If proper seal is being installed, then suspect there is a burr on the sealing surface which is damaging the seal causling leakage.

    Also, this may seem like a silly question..... are you aboslutely certain that the leakage is from the seal? (Perhaps the leak is from elsewhere)
  • Dear Forum,

    Occasionally my brakes seem to shudder or stutter when applied. It was pretty rare (I have owned it since March 2006) but seems to be happening more often (about three times in the last month). I think it might be affecting my breaking speed just a little bit.

    It is still under warranty but unfortunately the places authorized to do to warranty repair in my area (I just moved to San Francisco) have extremely bad and numerous customer reviews online. I found a couple of places that have great reviews but since they are not authorized, I would have to pay for repairs.

    Any information about this weird braking problem be much appreciated. I checked previous posts but did not find any information about this. I wish I could contribute back with some helpful answers to some of the other questions on this forum, but I don't know anything about cars.

    One last thing -- also, in the last month, antifreeze warning light has started to come on when I first turn on the car in the morning. If I turn off the car, then turn it on again, warning light does not come on again.

    Thanks!
    Janice
  • jeffyscottjeffyscott Posts: 3,855
    On the antifreeze, have you looked at the level in the resevoir under the hood? If not you should check that when it is cold. Do not add anything other than water (prefeably distilled) or the proper coolant, which should be G12 (unless you or a previous owner flushed the system and replaced it with a lesser coolant).

    The braking issue couldn't just be the ABS kicking in, could it?

    BTW, brakes may not be covered by warranty if it happens to be just worn pads/rotors.
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,615
    If this is happening under hard braking in the rain (which you've had a lot of lately) that could very well just be the ABS system doing its job. If it occurs during light braking on dry pavement, then you might have warped rotors IF you can feel it in the steering wheel.

    Visiting Host

    MODERATOR

  • Thanks for the replies JeffyScott and Mr. Shiftright. You are right that it was just the ABS kicking in, so hooray, no repairs. I just took it to a mechanic right now. It happens in dry weather. I do not feel it in the steering wheel. My experience is that it is happening in the front bottom of the car.

    I checked the coolant level a few times over the last month and it's always at the right level and the engine doesn't overheat. So I guess I will just ignore that light.

    For those of you in the San Francisco area, I had a good experience with Advanced Audi Volkswagen repair on Michigan. Owner is Aaron.

    Thanks again,
    Janice
  • Thanks for the replies JeffyScott and Mr. Shiftright. You are right that it was just the ABS kicking in, so hooray, no repairs. I just took it to a mechanic right now. It happens in dry weather. I do not feel it in the steering wheel. My experience is that it is happening in the front bottom of the car.

    I checked the coolant level a few times over the last month and it's always at the right level and the engine doesn't overheat. So I guess I will just ignore that light.

    For those of you in the San Francisco area, I had a good experience with Advanced Audi Volkswagen repair on Michigan. Owner is Aaron.

    Thanks again,
    Janice
  • bpeeblesbpeebles Posts: 4,085
    That sure sounds like the ABS system kicking in to me. If you apply the brakes too hard on slippery surface (snow/sand) then the brake-pedal will kinda "vibrate" as the ABS system does its thing.

    The antifreeze light is common when the coolant level is right on the cusp of being too low. When coolant is cold, it contracts and the sensor sees it as "too low".... as the coolant warms up, it expands and the level goes up so the antifreeze light extinguishes.

    To fix that problem, add about 1/4 cup of DISTILLED water. (If you need to add any more liquid than that... MUST use proper VW antifreeze.)
  • 2001 Jetta 1.8 is flashing engine light and running rough on acceleration. It also has a rotten egg smell. ???
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,615
    Something is overloading your catalytic converter. You need to take it in right away and have the codes read. I think you are running rich, or the catalytic is plugging up.

    Don't delay!

    MODERATOR

  • Thx so much for your speedy reply. Made a date with the man with a computer and program for this car. On another note, just finished doing a clutch change on this 2001 jetta. I must by into whips and chains and didn't even know it! Not wanting to do that job again!
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,615
    little tight in there ain't it? ;)

    MODERATOR

  • My 2001 Jetta with 51000 miles has been making power steering noise in the morning when it's cold. How do you check the fluid? and what's it cost to replace one. Any one else with this issue...Paul
  • Hi bpeebles, Thanks for writing back and explaining about the anti-freeze light. I have to take it in for 40,000 mile service soon, so hopefully, that will take care of it. Thanks again, Janice
  • I own a 1999 Jetta IV VR6 and I need to replace the ECM. Can I just get one from a used parts place? I understand that I might have to get it "reflashed". Does that meen that the car won't start with the replacement? It would seem to me that there must be a battery in the ECM to hold the memory or it is an EPROM chip, holding the info. I know that you would need to load the VIN number of the car, along with the milage.
    I am planning on getting rid of this car shortly but I won't get much with the check engine light on and the ABS light on, and the break light flashing, which is why I don't want to spend the $1500 for a new ECM at the dealer.
    Isn't there an easy way to solve this problem?
    It would seem to me that someone should have an adapter cable to plub your laptop into the ECM plug and redo your required information. Sure you could change the milage, but on other cars, you can change the speedo, so what's the biggie?
  • i have a 96 jetta the car shut off at the light after i was driving it for about a half hour didnt overheat and their is gas in the tank it turns over fine it but it seems that it isnt firing or no gas is getting to the plugs or something any help of what the problem may be
    :sick:
  • Buy an ignition coil from VW. An after market one may not last for more than about 5 months.
    Try spraying starting fluid after the MAF sensor and into the intake. If it runs for a short time then suspect fuel pump and/or fuel delivery issues. If it does not run even after that then the ignition coil.
  • that happened to my 2004 jetta and i had to get a new ignition coil, cam sensor and O2 sensor
  • I have a 99 Jetta VR6. Not sure if its my actual cigarette lighter that is broken or something else. I have plugged my GPS charger in. it charges for maaaybe 5 minutes, then stops working. very temperamental, sometimes works for a few minutes, sometime doesn't work at all. tried my cell phone charger..same thing. sometimes may work for a few minutes...sometimes doesn't work at all..same thing wil ipod charger, etc, etc. all work perfectly elsewhere.

    thought about just getting it replaced..(not really interested in spending the money though)

    someone said they got some sort of "sleeve' that goes over the plug or somethign that helps make these charger plugs fit better.???

    ..anyone heard of this or had this problem? id really appreciate it..i want to use my garmin!!! haha
  • askfl7askfl7 Posts: 2
    Can I reset the Service Now indicator on the computer on my 2006 Jetta TDI? I have done all of the service.
  • hpmuffinhpmuffin Posts: 1
    Hi all,
    My gf's jetta wont start... I replaced the battery. recently replaced timing belt, spark plugs, wires, by mechanic. Acts like there is no fuel, but disconected fuel intake into maifold and fuel was pumping when cranken over. What should I check next? Is there a good on-line trouble shooting site? I have limited knowlege and $ is tight.

    thx
  • jeffyscottjeffyscott Posts: 3,855
    You might check the coil pack, especially if the problem occurs with damp weather. My son had starting a problem with his 1996, he found a crack in plastic case of the coil pack when he took it off. His problem was intermittent and mostly occurred in wet or damp weather. I believe problem with coil packs are common on these cars.

    I think places like autozone may do free testing of several starting related components, but it's hard to get it there for them to test if it won't start at all.
  • I have a 2002 Jetter 1.8T. The check engine light keeps coming on. The code is P0171 running lean. One dealer had the car for three months replaced all kinds of parts. Carried to another VW dealer and they have replaced cat coverter, pulled the head and checked it (it was fine), have replaced several sensors and usually before we get home from the dealership the light is back on and with the same code. This time we drove the car for 166 miles before the light came back on, but it is back on again. I am getting really tired of it. It is getting very expensive. The car runs perfect, just the check engine light. Can you help me? :mad: :cry:
  • microjmicroj Posts: 10
    I have a 1998 Jetta GLS 5spd. manual Tran.
    The car has only 25,000 miles but is now 10 years old.
    I've been told timing belt is both mileage and Time sensitive.
    Do you think I should change the timing belt and water pump? this is about $900.00 thru dealer.
    Is there an affordable alternative(have mechanic look at it?) or is the expense in the labour getting to the belt?
    Thank-you
  • jeffyscottjeffyscott Posts: 3,855
    You can get that done a lot cheaper. IIRC, a VW specialist in our area quoted something like $200-300 for timing belt on a 4 cyl 1997 GL, not sure what water pump would add. Did not need the work done, I had just asked out of curiosity.

    As to whether you should get it done, I don't know. I have never heard of having a time interval for timing belt, but it kind of makes sense that a rubber belt might deteriorate with time as well as mileage. I do think that by the time they do the labor to look at it, you might as well just replace it.
Sign In or Register to comment.