Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Focus Engine Problems

1235

Comments

  • oldfordmecholdfordmech Posts: 124
    Need a bit more info, miles since air filter repl. tune up, fuel filter.? Does it idle ok with air on?
    Auto trans ?
  • mammawmammaw Posts: 1
    I have a 2003 ford focus that when in drive and it picks up speed, it has a hard surging feeling. I have had the trans fluid, and filter changed. It helped a bit, but the problem is still there. I was told to try the speed sensors. If that doesn't help, anyone have any suggestions.
  • markus5markus5 Posts: 102
    Several days ago when I went to fill up the tank, I noticed that the Fuel Cap was missing on on my 04 Focus (2.3 PZEV). The Check cap light was NOT on. It was a weekend and no Ford Dealers were open. I was also away from home so therefore decided to try for a generic cap. An auto parts store clerk was very helpful as we tried on 3 different parts which seemed to be applicable. We settled on one but I knew that it did not turn and close appropriately.
    This morning, I noticed that finally the Check gas cap light is on. I quickly secured the Motorcraft part and replaced the generic cap. The warning light has not yet gone off. Is there a built in "Buffer" or delay set into the electical warning light system.? I figure It took a number of days for the light to go on, will it be likewise when shutting off?
  • tim156tim156 Posts: 308
    edited July 2011
    Try pulling the fuse first to reset the function. You will find the fuse location in your Owner's Guide. If that doesn't do it, try disconnecting the negative battery cable, of course this will cut power to all your electrical systems.
  • markus5markus5 Posts: 102
    Tim,
    Thanks for the quick reply. I will not need to try any of these remedies, which seem to very logical ( first thing to do is re-boot, of course).
    This morning, very quietly, the sensors did their job and turned the warning light off. Quite symetrical, I must say. It took about the same time to activate the warning light as to de-activate.
    So I will attach the tether on this replacement Motor Craft cap, it is a keeper. $34 well spent. My next time in Benington the generic cap hopefully can be returned.
  • Hey,
    we reolaced the intake manifold (plastic) aqnd were left holding a suction hose that we don't know where to connect? the dealer has no clue,and so do local mechanics. the engine light is on and it calls for the oxygen senser to be changed but we feel that the vacuum hose needs to be connected first.
    anybody has an idea out there we would appreciate.
    thanks
    Z
  • markus5markus5 Posts: 102
    One of the boots was ripped while pulling the coil off the plug. These boots are non-electrical insulaters that slip down into the spark plug holes. Dealer wants $113 for a new coil and boot. The coil is good. Indeed the original plugs after 110,000 miles were absolutely text book perfect. I am using this old coil fitted with the damaged, less than perfect boot. It seems to be running just fine. However does any body have any ideas on either replacing or properly sealing up this opening without buying a new coil and boot assembly. ( 2.3 pzev )
  • I think the boot is avail by is't self from Ford, it also may be avail at NAPA.
    Cliff
  • markus5markus5 Posts: 102
    Thanks Cliff. Perhaps I did not ask the dealer the right question. I should have asked him to pull the Coil out of stock only to find that this boot is a separate part. I thought I had been clear to the parts person that I did not want to spend the money on a coil that was good.
    I will get back as soon as it dries out around here.
  • markus5markus5 Posts: 102
    Thanks Cliff, The people at NAPA knew exactly what I needed. $8 is a lot better than $113
  • cvjointcvjoint Posts: 4
    I bought my daughter a 2002 Ford Focus which was diagnosed as being in very good 95K condition. I put new hub bearings on it, new brakes and pads, had the transmission cleaned. She drove over something large that ruined the air conditioning compressor and the serpentine belt. I fixed that $1000. later. Today she was driving on a driveway at 10mph and the car just stopped. The engine turns over (RRR,rrr, rrr etc) but doesn't start. We will get it towed again. What are the likely problems? Should we dump this car and lose $4000? Thanks to everyone
  • I have a 2005 Ford Focus zx4 and the engine starts to buck when holding a steady speed. It used to do it once in a while now all the time.
  • just a guess, sounds like a plug or plug wire breaking down.

    Cliff
  • I changed the plugs I was wondering about the coils on top of the plugs.
  • Yes, Do you know someone with a good code reader ? It will tell you which of the 4 coil packs is breaking down. You can find coil packs at NAPA, Advance Auto, On-Line, Auto-Zone. They are NOT cheap.

    Cliff
  • Thanks I will try that.
  • orion2571orion2571 Posts: 1
    edited September 2011
    My 2001 ford focus was running rough and loud I raplaced the spark wire set yesterday and wat a difference smoothand quiet now.$20.00 fix. I got the car used, cleaned the engine at the car wash and later the car was running bad, the macanic said the coil was badand replaced it he said to replace the wires soon.I should have done sooner. try it
    PS If you hose down engin at the car wash cover coil save $75.00
  • Hey

    My 2003 ford focus SE has been jerking and not speeding up, ( stales) so I changed my spark plugs, and cords but it didn't help. I look at my car and notice that my crank case relief hose and valve is wearing, ( I took a picture to ford), could this be the problem.

    washington
  • newbie68newbie68 Posts: 1
    edited October 2011
    Today, as soon as I started my car, I could tell something was wrong. When I put the car in reverse, it stated to shake/shudder. When I put it in drive, it shook harder. I parked the car, waited about 10 minutes, and tried again, with the same results, and the engine light came on; when I tried to drive through my parking lot, no acceleration.
    I drove about 90 miles round trip yesterday, with no problems.
    Any thoughts?
  • I am not sure it could be the PVC valve, or a coil I have been dealing with a problem of bucking and lack of power. The best I can come up with is the PVC valve, coil, or it could be plugs. Did it do this when it was raining?
Sign In or Register to comment.